]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
- rel 1.1; A is unstable it seems :/
[packages/erlang.git] / erlang.spec
1 # NOTE: Building requires working DNS setup. Build may hang
2 #       even if _only_ first dns specified in resolv.conf
3 #       is unreachable.
4 # TODO
5 # - separate -devel (at least header files!)
6 # - modularize (odbc, etc)
7 # - manuals to %{_mandir}
8 # - investigate fPIC.patch
9 #
10 # Conditional build:
11 %bcond_with     java            # with Java support
12 %bcond_without  odbc            # without unixODBC support
13 #
14 Summary:        OpenSource Erlang/OTP
15 Summary(pl.UTF-8):      Erlang/OTP z otwartymi źródłami
16 Name:           erlang
17 # A - unstable, B - stable line, keep stable
18 Version:        R14A
19 Release:        1.1
20 Epoch:          1
21 %define         _version        %(echo %{version} | tr _ -)
22 License:        distributable
23 Group:          Development/Languages
24 Source0:        http://www.erlang.org/download/otp_src_%{_version}.tar.gz
25 # Source0-md5:  a24873bbace9ab3c307f3d2492d9e134
26 Source1:        http://www.erlang.org/download/otp_doc_man_%{_version}.tar.gz
27 # Source1-md5:  b57a7846818ad144b1b6ecc0a54de2ae
28 Patch0:         %{name}-fPIC.patch
29 Patch1:         %{name}-tinfo.patch
30 Patch2:         %{name}-link.patch
31 URL:            http://www.erlang.org/
32 %{?with_java:BuildRequires:     /usr/bin/jar}
33 BuildRequires:  xorg-lib-libX11-devel
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  flex
37 %{?with_java:BuildRequires:     jdk >= 1.2}
38 BuildRequires:  ncurses-devel
39 BuildRequires:  openssl-devel >= 0.9.7
40 BuildRequires:  openssl-tools
41 BuildRequires:  perl-base
42 %if %{with odbc}
43 BuildRequires:  unixODBC-devel
44 %else
45 BuildConflicts: unixODBC-devel
46 %endif
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define _erl_target %(echo %{_build}-gnu | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
50
51 %description
52 Erlang is a programming language designed at the Ericsson Computer
53 Science Laboratory. Open-source Erlang is being released to help
54 encourage the spread of Erlang outside Ericsson.
55
56 %description -l pl.UTF-8
57 Erlang to język programowania opracowany w Ericsson Computer Science
58 Laboratory. Open-source Erlang został wydany, aby pomóc w
59 rozpowszechnianiu Erlanga poza Ericssonem.
60
61 %prep
62 %setup -q -n otp_src_%{_version}
63 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
64 #%patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67
68 %build
69 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
70 %{__autoconf}
71 cd lib
72 %{__autoconf}
73 cd erl_interface
74 %{__autoconf}
75 cd ../gs
76 %{__autoconf}
77 cd ../megaco
78 %{__autoconf}
79 cd ../odbc
80 %{__autoconf}
81 cd ../snmp
82 %{__autoconf}
83 cd ../../erts/
84 %{__autoconf}
85 cd ..
86 %configure \
87 %ifarch sparc
88         CFLAGS="%{rpmcflags} -mv8plus" \
89 %endif
90         --with%{!?with_java:out}-javac
91 rm -f lib/ssl/SKIP
92 ERL_TOP=`pwd`; export ERL_TOP
93  %{__make} -j1 \
94         TARGET="%{_erl_target}" \
95         || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} -j1 install \
101         TARGET="%{_erl_target}" \
102         INSTALL_PREFIX=$RPM_BUILD_ROOT
103
104 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
105
106 sed -i -e"s#$RPM_BUILD_ROOT##" \
107         $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
108
109 for l in erl erlc escript dialyzer epmd run_erl to_erl typer; do
110         ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
111 done
112 ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
113 for l in epmd ; do
114         ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
115 done
116 ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
117
118 cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
119 find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
120
121 # some files in the library need +x, so we build the list here
122 echo "%%defattr(644,root,root,755)" > lib.list
123 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type d \
124         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%dir %%{_libdir}/%%{name}/#" >> lib.list
125 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
126         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%attr(755,root,root) %%{_libdir}/%%{name}/#" >> lib.list
127 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
128         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
129
130 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
131 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files -f lib.list
137 %defattr(644,root,root,755)
138 %doc AUTHORS EPLICENCE COPYRIGHT
139 %attr(755,root,root) %{_bindir}/*
140 %dir %{_libdir}/erlang
141 %dir %{_libdir}/%{name}/bin
142 %attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
143 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
144 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
145 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
146 %attr(755,root,root) %{_libdir}/%{name}/bin/escript
147 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
148 %attr(755,root,root) %{_libdir}/%{name}/bin/start
149 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
150 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
151 %attr(755,root,root) %{_libdir}/%{name}/bin/typer
152 %{_libdir}/%{name}/bin/start*.*
153 %dir %{_libdir}/%{name}/erts-*
154 %{_libdir}/%{name}/erts-*/doc
155 %{_libdir}/%{name}/erts-*/man
156 %{_libdir}/%{name}/erts-*/src
157 %{_libdir}/%{name}/erts-*/include
158 #%{_libdir}/%{name}/erts-*/*.ear
159 %dir %{_libdir}/%{name}/erts-*/bin
160 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
161 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
162 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
163 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dyn_erl
164 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
165 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
166 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
167 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
168 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
169 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
170 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
171 %{_libdir}/%{name}/erts-*/bin/start*.*
172 # (file list dynamically generated) %{_libdir}/%{name}/lib
173 %dir %{_libdir}/%{name}/misc
174 %attr(755,root,root) %{_libdir}/%{name}/misc/*
175 %{_libdir}/%{name}/releases
176 %{_libdir}/%{name}/usr
177 %doc %{_libdir}/%{name}/man
178 %attr(755,root,root) %{_libdir}/%{name}/Install
This page took 0.08863 seconds and 4 git commands to generate.