]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
- package renamed from "otp" to "erlang"
[packages/erlang.git] / erlang.spec
1 Summary:        OpenSource Erlang/OTP
2 Summary(pl):    Erlang/OTP z otwartymi ¼ród³ami
3 Name:           erlang
4 Version:        R9C_2
5 Release:        0.1
6 Epoch:          1
7 License:        distributable
8 Group:          Development/Languages
9 %define         _version        %(echo %{version} | tr _ -)
10 Source0:        http://www.erlang.org/download/otp_src_%{_version}.tar.gz
11 # Source0-md5:  3cdb1c58671995d6b334e0f8da414816
12 Source1:        http://www.erlang.org/download/otp_man_R9C-0.tar.gz
13 # Source1-md5:  80ab1a76fb2bf59cf83832096cf7f63b
14 URL:            http://www.erlang.org/
15 BuildRequires:  XFree86-devel
16 BuildRequires:  autoconf
17 BuildRequires:  flex
18 BuildRequires:  perl-base
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Erlang is a programming language designed at the Ericsson Computer
23 Science Laboratory. Open-source Erlang is being released to help
24 encourage the spread of Erlang outside Ericsson.
25
26 %description -l pl
27 Erlang to jêzyk programowania opracowany w Ericsson Computer Science
28 Laboratory. Open-source Erlang zosta³ wydany, aby pomóc w
29 rozpowszechnianiu Erlanga poza Ericssonem.
30
31 %prep
32 %setup -q -n otp_src_%{_version}
33 %{__tar} xf %{SOURCE1} man/ COPYRIGHT
34
35 %build
36 %{__autoconf}
37 cd lib
38 %{__autoconf}
39 cd erl_interface
40 %{__autoconf}
41 cd ../gs
42 %{__autoconf}
43 cd ../megaco
44 %{__autoconf}
45 cd ../snmp
46 %{__autoconf}
47 cd ../../erts/
48 %{__autoconf}
49 cd ..
50 %configure
51 ERL_TOP=`pwd`; export ERL_TOP
52 %{__make} \
53         TARGET="%{_build}"
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         TARGET="%{_build}" \
60         INSTALL_PREFIX=$RPM_BUILD_ROOT
61
62 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
63
64 sed -i -e"s#$RPM_BUILD_ROOT##" \
65         $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
66
67 for l in erl erlc ; do
68         ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
69 done
70 ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
71 for l in ear ecc elink escript ; do
72         ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
73 done
74 ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
75
76 cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
77 find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc AUTHORS EPLICENCE README erts/notes.html COPYRIGHT
85 %attr(755,root,root) %{_bindir}/*
86 %dir %{_libdir}/erlang
87 %dir %{_libdir}/%{name}/bin
88 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
89 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
90 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
91 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
92 %attr(755,root,root) %{_libdir}/%{name}/bin/start
93 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
94 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
95 %{_libdir}/%{name}/bin/start*.*
96 %dir %{_libdir}/%{name}/erts-*
97 %{_libdir}/%{name}/erts-*/doc
98 %{_libdir}/%{name}/erts-*/man
99 %{_libdir}/%{name}/erts-*/src
100 %{_libdir}/%{name}/erts-*/*.ear
101 %dir %{_libdir}/%{name}/erts-*/bin
102 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
103 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
104 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
105 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
106 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
107 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
108 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
109 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
110 %{_libdir}/%{name}/erts-*/bin/start*.*
111 %{_libdir}/%{name}/lib
112 %dir %{_libdir}/%{name}/misc
113 %attr(755,root,root) %{_libdir}/%{name}/misc/*
114 %{_libdir}/%{name}/releases
115 %{_libdir}/%{name}/usr
116 %doc %{_libdir}/%{name}/man
117 %attr(755,root,root) %{_libdir}/%{name}/Install
This page took 0.050757 seconds and 3 git commands to generate.