]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
- up to 17.3; add systemd scripts; enable smp support
[packages/erlang.git] / erlang.spec
1 # NOTE: Building requires working DNS setup. Build may hang
2 #       even if _only_ first dns specified in resolv.conf
3 #       is unreachable.
4 # TODO
5 # - separate -devel (at least header files!)
6 # - modularize (odbc, etc)
7 # - manuals to %{_mandir}
8 # - investigate fPIC.patch
9 #
10 # Conditional build:
11 %bcond_with     java            # with Java support
12 %bcond_without  odbc            # without unixODBC support
13 #
14 Summary:        OpenSource Erlang/OTP
15 Summary(pl.UTF-8):      Erlang/OTP z otwartymi źródłami
16 Name:           erlang
17 Version:        17.3
18 Release:        1
19 Epoch:          2
20 %define         _version        %(echo %{version} | tr _ -)
21 License:        distributable
22 Group:          Development/Languages
23 Source0:        http://www.erlang.org/download/otp_src_%{_version}.tar.gz
24 # Source0-md5:  1d0bb2d54dfe1bb6844756b99902ba20
25 Source1:        http://www.erlang.org/download/otp_doc_man_%{_version}.tar.gz
26 # Source1-md5:  6aa12c96d8d58ecc7be855c99286fc61
27 Source2:        epmd.service
28 Source3:        epmd.socket
29 Source4:        epmd@.service
30 Source5:        epmd@.socket
31 Patch0:         %{name}-fPIC.patch
32 Patch1:         otp-0007-Added-systemd-notify-support-to-EPMD.patch
33 URL:            http://www.erlang.org/
34 %{?with_java:BuildRequires:     /usr/bin/jar}
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  flex
38 %{?with_java:BuildRequires:     jdk >= 1.2}
39 BuildRequires:  ncurses-devel
40 BuildRequires:  openssl-devel >= 0.9.7
41 BuildRequires:  openssl-tools
42 BuildRequires:  perl-base
43 BuildRequires:  xorg-lib-libX11-devel
44 %if %{with odbc}
45 BuildRequires:  unixODBC-devel
46 %else
47 BuildConflicts: unixODBC-devel
48 %endif
49 Requires:       systemd-units >= 38
50 Requires(post,preun,postun):    systemd-units >= 38
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define _erl_target %(echo %{_build}-gnu | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
54
55 %description
56 Erlang is a programming language designed at the Ericsson Computer
57 Science Laboratory. Open-source Erlang is being released to help
58 encourage the spread of Erlang outside Ericsson.
59
60 %description -l pl.UTF-8
61 Erlang to język programowania opracowany w Ericsson Computer Science
62 Laboratory. Open-source Erlang został wydany, aby pomóc w
63 rozpowszechnianiu Erlanga poza Ericssonem.
64
65 %prep
66 %setup -q -n otp_src_%{_version}
67 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
68 #%patch0 -p1
69 %patch1 -p1
70
71 %build
72 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
73 curd=$(pwd)
74 for i in $(find . -type f -name configure.in); do
75         cd $(dirname $i)
76         %{__autoconf}
77         cd $curd
78 done
79 %configure \
80 %ifarch sparc
81         CFLAGS="%{rpmcflags} -mv8plus" \
82 %endif
83         --disable-silent-rules \
84         --enable-smp-support \
85         --with-javac%{!?with_java:=no}
86 rm -f lib/ssl/SKIP
87 ERL_TOP=`pwd`; export ERL_TOP
88  %{__make} -j1 \
89         TARGET="%{_erl_target}" \
90         || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
91
92 %install
93 rm -rf $RPM_BUILD_ROOT
94
95 %{__make} -j1 install \
96         TARGET="%{_erl_target}" \
97         INSTALL_PREFIX=$RPM_BUILD_ROOT
98
99 install -D -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdunitdir}/epmd.service
100 install -D -p %{SOURCE3} $RPM_BUILD_ROOT%{systemdunitdir}/epmd.socket
101 install -D -p %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/epmd@.service
102 install -D -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/epmd@.socket
103
104 sed -i -e"s#$RPM_BUILD_ROOT##" \
105         $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
106
107 cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
108 find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
109
110 # some files in the library need +x, so we build the list here
111 echo "%%defattr(644,root,root,755)" > lib.list
112 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type d \
113         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%dir %%{_libdir}/%%{name}/#" >> lib.list
114 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
115         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%attr(755,root,root) %%{_libdir}/%%{name}/#" >> lib.list
116 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
117         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
118
119 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
120 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post
126 %systemd_post epmd.service
127 %systemd_post epmd@.service
128
129 %preun
130 %systemd_preun epmd.service
131 %systemd_preun epmd@.service
132
133 %postun
134 %systemd_reload
135
136 %files -f lib.list
137 %defattr(644,root,root,755)
138 %doc AUTHORS EPLICENCE COPYRIGHT
139 %attr(755,root,root) %{_bindir}/ct_run
140 %attr(755,root,root) %{_bindir}/dialyzer
141 %attr(755,root,root) %{_bindir}/epmd
142 %attr(755,root,root) %{_bindir}/erl
143 %attr(755,root,root) %{_bindir}/erlc
144 %attr(755,root,root) %{_bindir}/escript
145 %attr(755,root,root) %{_bindir}/run_erl
146 %attr(755,root,root) %{_bindir}/to_erl
147 %attr(755,root,root) %{_bindir}/typer
148 %dir %{_libdir}/erlang
149 %dir %{_libdir}/%{name}/bin
150 %attr(755,root,root) %{_libdir}/%{name}/bin/ct_run
151 %attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
152 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
153 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
154 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
155 %attr(755,root,root) %{_libdir}/%{name}/bin/escript
156 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
157 %attr(755,root,root) %{_libdir}/%{name}/bin/start
158 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
159 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
160 %attr(755,root,root) %{_libdir}/%{name}/bin/typer
161 %{_libdir}/%{name}/bin/start*.*
162 %dir %{_libdir}/%{name}/erts-*
163 %{_libdir}/%{name}/erts-*/doc
164 %{_libdir}/%{name}/erts-*/man
165 %{_libdir}/%{name}/erts-*/src
166 %{_libdir}/%{name}/erts-*/include
167 #%{_libdir}/%{name}/erts-*/*.ear
168 %dir %{_libdir}/%{name}/erts-*/bin
169 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
170 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
171 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/ct_run
172 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
173 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dyn_erl
174 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
175 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
176 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
177 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
178 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
179 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
180 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
181 %{_libdir}/%{name}/erts-*/bin/start*.*
182 # (file list dynamically generated) %{_libdir}/%{name}/lib
183 %dir %{_libdir}/%{name}/misc
184 %attr(755,root,root) %{_libdir}/%{name}/misc/*
185 %{_libdir}/%{name}/releases
186 %{_libdir}/%{name}/usr
187 %doc %{_libdir}/%{name}/man
188 %attr(755,root,root) %{_libdir}/%{name}/Install
189
190 %{systemdunitdir}/epmd.service
191 %{systemdunitdir}/epmd.socket
192 %{systemdunitdir}/epmd@.service
193 %{systemdunitdir}/epmd@.socket
This page took 0.073625 seconds and 3 git commands to generate.