]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
- make distfiles happy (maybe) - use tr instead of sed.
[packages/erlang.git] / erlang.spec
1 Summary:        OpenSource Erlang/OTP
2 Name:           otp
3 Version:        R9C_2
4 Release:        0.1
5 Epoch:          1
6 License:        distributable
7 Group:          Development/Languages
8 %define         _version        %(echo %{version} | tr _ -) 
9 Source0:        http://www.erlang.org/download/%{name}_src_%{_version}.tar.gz
10 URL:            http://www.erlang.org/
11 BuildRequires:  perl-base
12 BuildRequires:  flex
13 BuildRequires:  XFree86-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Erlang is a programming language designed at the Ericsson Computer
18 Science Laboratory. Open-source Erlang is being released to help
19 encourage the spread of Erlang outside Ericsson.
20       
21 %prep
22 %setup -q -n %{name}_src_%{_version}
23
24 %build
25 %{__autoconf}
26 cd lib
27 %{__autoconf}
28 cd erl_interface
29 %{__autoconf}
30 cd ../gs
31 %{__autoconf}
32 cd ../megaco
33 %{__autoconf}
34 cd ../snmp
35 %{__autoconf}
36 cd ..
37 cd ../erts/
38 %{__autoconf}
39 cd ..
40 %configure
41 ERL_TOP=`pwd`; export ERL_TOP
42 %{__make}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %pre
54
55 %post
56
57 %preun
58
59 %postun
60
61 %files
62 %defattr(644,root,root,755)
63 %doc AUTHORS CREDITS ChangeLog NEWS README THANKS TODO
64 %attr(755,root,root) %{_bindir}/*
65 %{_datadir}/%{name}
This page took 0.029607 seconds and 3 git commands to generate.