]> git.pld-linux.org Git - packages/erlang.git/blob - erlang.spec
067b384633e14b7b0a9c9459f99c9c7587f204bf
[packages/erlang.git] / erlang.spec
1 # NOTE: Building requires working DNS setup. Build may hang
2 #       even if _only_ first dns specified in resolv.conf
3 #       is unreachable.
4 # TODO
5 # - separate -devel (at least header files!)
6 # - modularize (odbc, etc)
7 # - manuals to %{_mandir}
8 # - investigate fPIC.patch
9 #
10 # Conditional build:
11 %bcond_with     java            # with Java support
12 %bcond_without  odbc            # without unixODBC support
13 #
14 Summary:        OpenSource Erlang/OTP
15 Summary(pl.UTF-8):      Erlang/OTP z otwartymi źródłami
16 Name:           erlang
17 # A - unstable, B - stable line, keep stable
18 Version:        R16B03
19 Release:        1
20 Epoch:          1
21 %define         _version        %(echo %{version} | tr _ -)
22 License:        distributable
23 Group:          Development/Languages
24 Source0:        http://www.erlang.org/download/otp_src_%{_version}.tar.gz
25 # Source0-md5:  c330150913556a0fe73e57a441cb6375
26 Source1:        http://www.erlang.org/download/otp_doc_man_%{_version}.tar.gz
27 # Source1-md5:  099ed598feadc54e7efea908cc598f08
28 Patch0:         %{name}-fPIC.patch
29 Patch1:         %{name}-tinfo.patch
30 URL:            http://www.erlang.org/
31 %{?with_java:BuildRequires:     /usr/bin/jar}
32 BuildRequires:  xorg-lib-libX11-devel
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  flex
36 %{?with_java:BuildRequires:     jdk >= 1.2}
37 BuildRequires:  ncurses-devel
38 BuildRequires:  openssl-devel >= 0.9.7
39 BuildRequires:  openssl-tools
40 BuildRequires:  perl-base
41 %if %{with odbc}
42 BuildRequires:  unixODBC-devel
43 %else
44 BuildConflicts: unixODBC-devel
45 %endif
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %define _erl_target %(echo %{_build}-gnu | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
49
50 %description
51 Erlang is a programming language designed at the Ericsson Computer
52 Science Laboratory. Open-source Erlang is being released to help
53 encourage the spread of Erlang outside Ericsson.
54
55 %description -l pl.UTF-8
56 Erlang to język programowania opracowany w Ericsson Computer Science
57 Laboratory. Open-source Erlang został wydany, aby pomóc w
58 rozpowszechnianiu Erlanga poza Ericssonem.
59
60 %prep
61 %setup -q -n otp_src_%{_version}
62 %{__tar} xzf %{SOURCE1} man/ COPYRIGHT
63 #%patch0 -p1
64 %patch1 -p1
65
66 %build
67 find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
68 curd=$(pwd)
69 for i in $(find . -type f -name configure.in); do
70         cd $(dirname $i)
71         %{__autoconf}
72         cd $curd
73 done
74 %configure \
75 %ifarch sparc
76         CFLAGS="%{rpmcflags} -mv8plus" \
77 %endif
78         --with-javac%{!?with_java:=no}
79 rm -f lib/ssl/SKIP
80 ERL_TOP=`pwd`; export ERL_TOP
81  %{__make} -j1 \
82         TARGET="%{_erl_target}" \
83         || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} -j1 install \
89         TARGET="%{_erl_target}" \
90         INSTALL_PREFIX=$RPM_BUILD_ROOT
91
92 sed -i -e"s#$RPM_BUILD_ROOT##" \
93         $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
94
95 cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
96 find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
97
98 # some files in the library need +x, so we build the list here
99 echo "%%defattr(644,root,root,755)" > lib.list
100 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type d \
101         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%dir %%{_libdir}/%%{name}/#" >> lib.list
102 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
103         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%attr(755,root,root) %%{_libdir}/%%{name}/#" >> lib.list
104 find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
105         | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
106
107 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
108 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %files -f lib.list
114 %defattr(644,root,root,755)
115 %doc AUTHORS EPLICENCE COPYRIGHT
116 %attr(755,root,root) %{_bindir}/ct_run
117 %attr(755,root,root) %{_bindir}/dialyzer
118 %attr(755,root,root) %{_bindir}/epmd
119 %attr(755,root,root) %{_bindir}/erl
120 %attr(755,root,root) %{_bindir}/erlc
121 %attr(755,root,root) %{_bindir}/escript
122 %attr(755,root,root) %{_bindir}/run_erl
123 %attr(755,root,root) %{_bindir}/to_erl
124 %attr(755,root,root) %{_bindir}/typer
125 %dir %{_libdir}/erlang
126 %dir %{_libdir}/%{name}/bin
127 %attr(755,root,root) %{_libdir}/%{name}/bin/ct_run
128 %attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
129 %attr(755,root,root) %{_libdir}/%{name}/bin/epmd
130 %attr(755,root,root) %{_libdir}/%{name}/bin/erl
131 %attr(755,root,root) %{_libdir}/%{name}/bin/erlc
132 %attr(755,root,root) %{_libdir}/%{name}/bin/escript
133 %attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
134 %attr(755,root,root) %{_libdir}/%{name}/bin/start
135 %attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
136 %attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
137 %attr(755,root,root) %{_libdir}/%{name}/bin/typer
138 %{_libdir}/%{name}/bin/start*.*
139 %dir %{_libdir}/%{name}/erts-*
140 %{_libdir}/%{name}/erts-*/doc
141 %{_libdir}/%{name}/erts-*/man
142 %{_libdir}/%{name}/erts-*/src
143 %{_libdir}/%{name}/erts-*/include
144 #%{_libdir}/%{name}/erts-*/*.ear
145 %dir %{_libdir}/%{name}/erts-*/bin
146 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
147 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
148 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/ct_run
149 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
150 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dyn_erl
151 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
152 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
153 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
154 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
155 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
156 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
157 %attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
158 %{_libdir}/%{name}/erts-*/bin/start*.*
159 # (file list dynamically generated) %{_libdir}/%{name}/lib
160 %dir %{_libdir}/%{name}/misc
161 %attr(755,root,root) %{_libdir}/%{name}/misc/*
162 %{_libdir}/%{name}/releases
163 %{_libdir}/%{name}/usr
164 %doc %{_libdir}/%{name}/man
165 %attr(755,root,root) %{_libdir}/%{name}/Install
This page took 0.034821 seconds and 2 git commands to generate.