]> git.pld-linux.org Git - packages/erlang.git/blame - erlang.spec
- Patch for correct openssl-devel detection with --as-needed
[packages/erlang.git] / erlang.spec
CommitLineData
a57a4f81
AM
1# NOTE: Building requires working DNS setup. Build may hang
2# even if _only_ first dns specified in resolv.conf
3# is unreachable.
7863299b
ER
4# TODO
5# - separate -devel (at least header files!)
6# - modularize (odbc, etc)
1bfec8a4 7# - manuals to %{_mandir}
9dab2fdc 8# - investigate fPIC.patch
3bb4a699
JK
9#
10# Conditional build:
11%bcond_with java # with Java support
38af531e 12%bcond_without odbc # without unixODBC support
9a059664 13#
c7068bd4 14Summary: OpenSource Erlang/OTP
285f449f 15Summary(pl.UTF-8): Erlang/OTP z otwartymi źródłami
c6ed8a25 16Name: erlang
64f81501 17Version: R12B_2
37ff12ad 18Release: 2
c7068bd4 19Epoch: 1
9a059664 20%define _version %(echo %{version} | tr _ -)
c7068bd4
JK
21License: distributable
22Group: Development/Languages
c6ed8a25 23Source0: http://www.erlang.org/download/otp_src_%{_version}.tar.gz
64f81501 24# Source0-md5: 05861c7f75d7b2ed5af42c93cebe5801
462ee014 25Source1: http://www.erlang.org/download/otp_doc_man_%{_version}.tar.gz
26# Source1-md5: 645a4486f02338a5cf22be7563b862f9
d6d0a605 27Patch0: %{name}-fPIC.patch
de154c22 28Patch1: %{name}-optional_java.patch
e06bff62 29Patch2: %{name}-tinfo.patch
64f81501 30Patch3: %{name}-new_glibc.patch
37ff12ad 31Patch4: %{name}-as_needed.patch
c7068bd4 32URL: http://www.erlang.org/
9a059664 33%{?with_java:BuildRequires: /usr/bin/jar}
d5ce2f9c 34BuildRequires: xorg-lib-libX11-devel
5c54a479 35BuildRequires: autoconf
d6d0a605 36BuildRequires: automake
5c54a479 37BuildRequires: flex
9a059664 38%{?with_java:BuildRequires: jdk >= 1.2}
e6190289 39BuildRequires: ncurses-devel
52fa868e 40BuildRequires: openssl-devel >= 0.9.7
41Buildrequires: openssl-tools
5c54a479 42BuildRequires: perl-base
38af531e 43%if %{with odbc}
9a059664 44BuildRequires: unixODBC-devel
38af531e 45%else
9a059664 46BuildConflicts: unixODBC-devel
38af531e 47%endif
c7068bd4 48BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
9a059664 49
3bb4a699 50%define _erl_target %(echo %{_build} | sed -e's/amd64/x86_64/;s/athlon/i686/;s/ppc/powerpc/')
c7068bd4
JK
51
52%description
53Erlang is a programming language designed at the Ericsson Computer
54Science Laboratory. Open-source Erlang is being released to help
55encourage the spread of Erlang outside Ericsson.
5c54a479 56
9ac92939
JR
57%description -l pl.UTF-8
58Erlang to język programowania opracowany w Ericsson Computer Science
59Laboratory. Open-source Erlang został wydany, aby pomóc w
5c54a479
JB
60rozpowszechnianiu Erlanga poza Ericssonem.
61
c7068bd4 62%prep
c6ed8a25 63%setup -q -n otp_src_%{_version}
d709612b 64%{__tar} xzf %{SOURCE1} man/ COPYRIGHT
43071f9a 65#%patch0 -p1
de154c22 66%patch1 -p1
29122d5e 67%patch2 -p1
64f81501 68%patch3 -p1
37ff12ad 69%patch4 -p0
c7068bd4
JK
70
71%build
d6d0a605 72find . -name config.sub | xargs -n 1 cp -f /usr/share/automake/config.sub
c7068bd4
JK
73%{__autoconf}
74cd lib
75%{__autoconf}
76cd erl_interface
77%{__autoconf}
78cd ../gs
79%{__autoconf}
80cd ../megaco
81%{__autoconf}
5fe0b29c
AZ
82cd ../odbc
83%{__autoconf}
c7068bd4
JK
84cd ../snmp
85%{__autoconf}
5c54a479 86cd ../../erts/
c7068bd4
JK
87%{__autoconf}
88cd ..
3bb4a699 89%configure \
1485134d 90%ifarch sparc
91 CFLAGS="%{rpmcflags} -mv8plus" \
92%endif
3bb4a699 93 --with%{!?with_java:out}-java
a952def8 94rm -f lib/ssl/SKIP
c7068bd4 95ERL_TOP=`pwd`; export ERL_TOP
82844de3 96 %{__make} -j1 \
6cba5783 97 TARGET="%{_erl_target}" \
8738d875 98 || { find . -name erl_crash.dump | xargs cat ; exit 1 ; }
c7068bd4
JK
99
100%install
101rm -rf $RPM_BUILD_ROOT
102
64f81501 103%{__make} -j1 install \
e043a03d 104 TARGET="%{_erl_target}" \
3685cbd2
JK
105 INSTALL_PREFIX=$RPM_BUILD_ROOT
106
c6ed8a25 107rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/*.html
3685cbd2
JK
108
109sed -i -e"s#$RPM_BUILD_ROOT##" \
c6ed8a25 110 $RPM_BUILD_ROOT%{_libdir}/%{name}/bin/{erl,start,start_erl}
3685cbd2 111
82844de3 112for l in erl erlc escript dialyzer epmd run_erl to_erl typer; do
c6ed8a25 113 ln -sf %{_libdir}/%{name}/bin/$l $RPM_BUILD_ROOT%{_bindir}
3685cbd2 114done
c6ed8a25 115ERTSDIR=`echo $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-* | sed -e"s#^$RPM_BUILD_ROOT##"`
49d2322c 116for l in epmd ; do
3685cbd2
JK
117 ln -sf $ERTSDIR/bin/$l $RPM_BUILD_ROOT%{_bindir}
118done
c6ed8a25
JK
119ln -sf $ERTSDIR/bin/epmd $RPM_BUILD_ROOT%{_libdir}/%{name}/bin
120
121cp -r man $RPM_BUILD_ROOT%{_libdir}/%{name}
122find $RPM_BUILD_ROOT%{_libdir}/%{name}/man -type f | xargs gzip -9
c7068bd4 123
e043a03d
JK
124# some files in the library need +x, so we build the list here
125echo "%%defattr(644,root,root,755)" > lib.list
126find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type d \
127 | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%dir %%{_libdir}/%%{name}/#" >> lib.list
128find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f -perm -500 \
129 | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%attr(755,root,root) %%{_libdir}/%%{name}/#" >> lib.list
130find $RPM_BUILD_ROOT%{_libdir}/%{name}/lib -type f '!' -perm -500 \
131 | sed -e"s#^$RPM_BUILD_ROOT%{_libdir}/%{name}/#%%{_libdir}/%%{name}/#" >> lib.list
132
5482576a 133rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/lib
43071f9a
JK
134rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/erts-*/include/internal
135
c7068bd4
JK
136%clean
137rm -rf $RPM_BUILD_ROOT
138
e043a03d 139%files -f lib.list
c7068bd4 140%defattr(644,root,root,755)
43071f9a 141%doc AUTHORS EPLICENCE README COPYRIGHT
c7068bd4 142%attr(755,root,root) %{_bindir}/*
3685cbd2 143%dir %{_libdir}/erlang
c6ed8a25 144%dir %{_libdir}/%{name}/bin
5482576a 145%attr(755,root,root) %{_libdir}/%{name}/bin/dialyzer
c6ed8a25
JK
146%attr(755,root,root) %{_libdir}/%{name}/bin/epmd
147%attr(755,root,root) %{_libdir}/%{name}/bin/erl
148%attr(755,root,root) %{_libdir}/%{name}/bin/erlc
82844de3 149%attr(755,root,root) %{_libdir}/%{name}/bin/escript
c6ed8a25
JK
150%attr(755,root,root) %{_libdir}/%{name}/bin/run_erl
151%attr(755,root,root) %{_libdir}/%{name}/bin/start
152%attr(755,root,root) %{_libdir}/%{name}/bin/start_erl
153%attr(755,root,root) %{_libdir}/%{name}/bin/to_erl
82844de3 154%attr(755,root,root) %{_libdir}/%{name}/bin/typer
c6ed8a25
JK
155%{_libdir}/%{name}/bin/start*.*
156%dir %{_libdir}/%{name}/erts-*
157%{_libdir}/%{name}/erts-*/doc
158%{_libdir}/%{name}/erts-*/man
159%{_libdir}/%{name}/erts-*/src
43071f9a
JK
160%{_libdir}/%{name}/erts-*/include
161#%{_libdir}/%{name}/erts-*/*.ear
c6ed8a25
JK
162%dir %{_libdir}/%{name}/erts-*/bin
163%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/beam*
164%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/child*
5482576a 165%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/dialyzer
c6ed8a25
JK
166%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/e*
167%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/heart*
168%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/inet_gethost
169%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/run_erl
170%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/start
171%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/to_erl
49d2322c 172%attr(755,root,root) %{_libdir}/%{name}/erts-*/bin/typer
c6ed8a25 173%{_libdir}/%{name}/erts-*/bin/start*.*
e043a03d 174# (file list dynamically generated) %{_libdir}/%{name}/lib
c6ed8a25
JK
175%dir %{_libdir}/%{name}/misc
176%attr(755,root,root) %{_libdir}/%{name}/misc/*
177%{_libdir}/%{name}/releases
178%{_libdir}/%{name}/usr
179%doc %{_libdir}/%{name}/man
180%attr(755,root,root) %{_libdir}/%{name}/Install
This page took 0.048295 seconds and 4 git commands to generate.