]> git.pld-linux.org Git - packages/erlang-rebar.git/blame - erlang-rebar.spec
Release: 1
[packages/erlang-rebar.git] / erlang-rebar.spec
CommitLineData
b9ad0760
JK
1
2%bcond_with bootstrap # bootstrap build
de5af75d 3%bcond_with tests # build without tests
b9ad0760
JK
4
5Summary: Erlang Build Tools
6Name: erlang-rebar
7Version: 2.5.1
ab972175 8Release: 1
b9ad0760
JK
9License: MIT
10Group: Development/Tools
11Source0: https://github.com/rebar/rebar/tarball/%{version}/rebar-%{version}.tar.bz2
12# Source0-md5: b9b21756f56902b339559f3833d2c544
13Source1: rebar.escript
14URL: https://github.com/rebar/rebar
15%if %{with bootstrap}
16BuildRequires: erlang
17%else
18BuildRequires: erlang-rebar
19%endif
20Requires: erlang
21Provides: rebar = %{version}-%{release}
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24%description
25Erlang Build Tools.
26
27%prep
28%setup -qc
29mv rebar-rebar-*/* .
30%{__rm} -r rebar-rebar-*
31
32%build
33%if %{with bootstrap}
34./bootstrap
35./rebar compile -v
36%else
37rebar compile -v
38install %{SOURCE1} ./rebar
39%endif
40
ad275ce4
JK
41%if %{with tests}
42./rebar eunit -v
43%endif
44
b9ad0760
JK
45%install
46rm -rf $RPM_BUILD_ROOT
47install -d $RPM_BUILD_ROOT%{_bindir} \
48 $RPM_BUILD_ROOT%{_libdir}/erlang/lib/rebar-%{version}/{ebin,include}
49
50cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/rebar
51cp -p ebin/rebar.app $RPM_BUILD_ROOT%{_libdir}/erlang/lib/rebar-%{version}/ebin
52cp -p ebin/*.beam $RPM_BUILD_ROOT%{_libdir}/erlang/lib/rebar-%{version}/ebin
53cp -p include/*.hrl $RPM_BUILD_ROOT%{_libdir}/erlang/lib/rebar-%{version}/include
54cp -a priv $RPM_BUILD_ROOT%{_libdir}/erlang/lib/rebar-%{version}
55
b9ad0760
JK
56%files
57%defattr(644,root,root,755)
58%doc LICENSE NOTES.org README.md THANKS rebar.config.sample
59%defattr(644,root,root,755)
60%attr(755,root,root) %{_bindir}/rebar
61%{_libdir}/erlang/lib/rebar-%{version}
62
63%clean
64rm -rf $RPM_BUILD_ROOT
This page took 0.061174 seconds and 4 git commands to generate.