]> git.pld-linux.org Git - packages/eric6.git/blame - eric6.spec
- release 5 (by relup.sh)
[packages/eric6.git] / eric6.spec
CommitLineData
50968d52 1%bcond_with python2 # Use python2 (NOTE: as for 17.03.1 it has issuses in PLD)
e2cab009 2
845243b6
MK
3# NOTE: Detlev Offenbach <detlev@die-offenbachs.de> (author) 2017/04/13 wrote:
4# "eric6 can be used with Python2 or Python3 and with PyQt5 or PyQt4.
5# However, the recommended combination is PyQt5 on Python3.
6
e2cab009
MK
7%define module eric6
8Summary: Eric6 - a full featured Python IDE
9Summary(pl.UTF-8): Eric6 - pełnowartościowe IDE dla Pythona
e2cab009 10Name: eric6
845243b6 11Version: 17.07
bd76a655 12Release: 5
e2cab009
MK
13License: GPL v3
14Group: Libraries/Python
a9909cc0 15Source0: https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
845243b6 16# Source0-md5: c21c097bf36259ff61187e2698b7c50d
e2cab009
MK
17URL: http://eric-ide.python-projects.org/index.html
18BuildRequires: rpm-pythonprov
50968d52
MK
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
e2cab009
MK
21BuildRequires: python-modules
22BuildRequires: python-setuptools
23# NOTE: As for 6.1.8 eric6 still tries to import PyQt5 while having PyQt4 leading to crash
24# http://die-offenbachs.homelinux.org:48888/issues/issue204
25# for --pyqt=4
e2cab009 26# BuildRequires: python-PyQt4-qscintilla2
5c2f16b8 27# BuildRequires: python-PyQt4-uic
e2cab009
MK
28# for --pyqt=5
29BuildRequires: python-PyQt5-qscintilla2
30BuildRequires: python-PyQt5-uic
2758d547 31Requires: python-PyQt5-qscintilla2
a9909cc0 32Requires: python-modules
50968d52
MK
33Suggests: python-pylint
34%else
35BuildRequires: python3-PyQt5-qscintilla2
36BuildRequires: python3-PyQt5-uic
37BuildRequires: python3-modules
38BuildRequires: python3-setuptools
e585e44e
MK
39# NOTE: Not sure if Qt5Svg should be listed here or be R by other BRs.
40BuildRequires: Qt5Svg
50968d52
MK
41Requires: python3-PyQt5-qscintilla2
42Requires: python3-modules
43Suggests: python3-pylint
44%endif
45
e2cab009
MK
46BuildArch: noarch
47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49%description
5c2f16b8
MK
50Eric is a Python IDE written using PyQt and QScintilla. It provides
51various features such as any number of open editors, an integrated
52(remote) debugger, project management facilities, unit test,
53refactoring and much more.
e2cab009
MK
54
55%description -l pl.UTF-8
5c2f16b8
MK
56Eric jest pythonowym graficznym środowiskiem programistycznym
57używającym PyQt i QScintilla.
e2cab009
MK
58
59%prep
60%setup -q
61
62%build
63
64%install
65rm -rf $RPM_BUILD_ROOT
50968d52 66%if %{with python2}
e2cab009 67python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT --pyqt=5
50968d52
MK
68%else
69python3 install.py -z -c -b %{_bindir} -d %{py3_sitescriptdir} -i $RPM_BUILD_ROOT --pyqt=5
70%endif
a9909cc0
MK
71mkdir $RPM_BUILD_ROOT%{_datadir}/appdata
72mv $RPM_BUILD_ROOT%{_datadir}/metainfo/eric6.appdata.xml $RPM_BUILD_ROOT%{_datadir}/appdata
e2cab009
MK
73
74%clean
75rm -rf $RPM_BUILD_ROOT
76
e2cab009
MK
77%files
78%defattr(644,root,root,755)
79%doc README.rst
50968d52 80%if %{with python2}
e2cab009 81%{py_sitescriptdir}/%{module}
50968d52
MK
82%else
83%{py3_sitescriptdir}/%{module}
84%endif
85
e2cab009
MK
86%attr(755,root,root) %{_bindir}/eric6
87%attr(755,root,root) %{_bindir}/eric6_*
88# for --pyqt=4
5c2f16b8
MK
89# %{_datadir}/qt4/qsci/api/qss/
90# %{_datadir}/qt4/qsci/api/ruby/
d5275b1c 91# NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
5c2f16b8
MK
92# %{_datadir}/qt4/qsci/api/python/eric6.*
93# %{_datadir}/qt4/qsci/api/python/zope-*.api
e2cab009
MK
94
95# for --pyqt=5
5c2f16b8
MK
96%{_datadir}/qt5/qsci/api/qss/
97%{_datadir}/qt5/qsci/api/ruby/
98%{_datadir}/qt5/qsci/api/python/eric6.*
99%{_datadir}/qt5/qsci/api/python/zope-*.api
e2cab009 100
5c2f16b8
MK
101%{_pixmapsdir}/eric*.png
102%{_desktopdir}/eric6.desktop
103%{_desktopdir}/eric6_webbrowser.desktop
fd4f94e0 104%{_desktopdir}/eric6_browser.desktop
a9909cc0 105%{_datadir}/appdata/eric6.appdata.xml
50968d52 106%if %{with python2}
5c2f16b8
MK
107%{py_sitescriptdir}/eric6config.py
108%{py_sitescriptdir}/eric6plugins
50968d52
MK
109%else
110%{py3_sitescriptdir}/eric6config.py
111%{py3_sitescriptdir}/eric6plugins
112%endif
This page took 0.075125 seconds and 4 git commands to generate.