]> git.pld-linux.org Git - packages/epydoc.git/blobdiff - epydoc.spec
- mass commit: remove obsolete BR: rpm-pythonprov
[packages/epydoc.git] / epydoc.spec
index 89d72ca2b79f3fc4cb6b08e9f9dbe7695d8963d0..2c5dc9ea74a6920228c0e6c4e716dac56e16507b 100644 (file)
@@ -1,48 +1,71 @@
-%include       /usr/lib/rpm/macros.python
-
 Summary:       Tool for generating API documentation for Python modules
+Summary(pl):   Narzêdzie do generowania dokumentacji API modu³ów Pythona
 Name:          epydoc
-Version:       2.0
-Release:       1
+Version:       2.1
+Release:       2
 License:       MIT
 Group:         Development/Languages/Python
-Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
-# Source0-md5: fbb0bd482a872795c59f897b699f9549
+Source0:       http://dl.sourceforge.net/epydoc/%{name}-%{version}.tar.gz
+# Source0-md5: 94c494426c47496ee4d1ed26b580a5a7
+Patch0:                %{name}-failed_identifiers.patch
 URL:           http://epydoc.sourceforge.net/
 BuildRequires: python-modules >= 2.2.1
-BuildRequires: rpm-pythonprov
 %pyrequires_eq python-modules
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Epydoc is a tool for generating API documentation for Python modules, based
-on their docstrings. For an example of epydoc's output, see the API
-documentation for epydoc itself (html, pdf). A lightweight markup language
-called epytext can be used to format docstrings and to add information
-about specific fields, such as parameters and instance variables.  Epydoc
-also understands docstrings written in ReStructuredText, Javadoc and
-plaintext.
+epydoc is a tool for generating API documentation for Python modules,
+based on their docstrings. For an example of epydoc's output, see the
+API documentation for epydoc itself (html, pdf). A lightweight markup
+language called epytext can be used to format docstrings and to add
+information about specific fields, such as parameters and instance
+variables. epydoc also understands docstrings written in
+ReStructuredText, Javadoc and plaintext.
+
+%description -l pl
+epydoc jest narzêdziem do generowania dokumentacji API modu³ów Pythona
+w oparciu o ich wewnêtrzne opisy (docstrings). Jako przyk³ad wyniku
+jego dzia³ania mo¿na obejrzeæ jego w³asn± dokumentacjê (html, pdf).
+epytext wywo³ywany przez prosty jêzyk znaczników mo¿e s³u¿yæ do
+formatowania wewnêtrznych opisów oraz do dodawania informacji o
+konkretnych polach, takich jak parametry i zmienne instancji. epydoc
+rozumie równie¿ wewnêtrzne opisy stworzone w ReStructuredText, Javadoc
+i w postaci czystego tekstu.
 
 %package gui
-Summary:       GUI for Epydoc
+Summary:       GUI for epydoc
+Summary(pl):   Interfejs graficzny dla epydoc
 Group:         Development/Languages/Python
 Requires:      %{name} = %{version}
 %pyrequires_eq python-tkinter
 
 %description gui
-Epydoc is a tool for generating API documentation for Python modules, based
-on their docstrings. For an example of epydoc's output, see the API
-documentation for epydoc itself (html, pdf). A lightweight markup language
-called epytext can be used to format docstrings and to add information
-about specific fields, such as parameters and instance variables.  Epydoc
-also understands docstrings written in ReStructuredText, Javadoc and
-plaintext.
-
-This package contains GUI program for Epydoc.
+epydoc is a tool for generating API documentation for Python modules,
+based on their docstrings. For an example of epydoc's output, see the
+API documentation for epydoc itself (html, pdf). A lightweight markup
+language called epytext can be used to format docstrings and to add
+information about specific fields, such as parameters and instance
+variables. epydoc also understands docstrings written in
+ReStructuredText, Javadoc and plaintext.
+
+This package contains GUI program for epydoc.
+
+%description gui -l pl
+epydoc jest narzêdziem do generowania dokumentacji API modu³ów Pythona
+w oparciu o ich wewnêtrzne opisy (docstrings). Jako przyk³ad wyniku
+jego dzia³ania mo¿na obejrzeæ jego w³asn± dokumentacjê (html, pdf).
+epytext wywo³ywany przez prosty jêzyk znaczników mo¿e s³u¿yæ do
+formatowania wewnêtrznych opisów oraz do dodawania informacji o
+konkretnych polach, takich jak parametry i zmienne instancji. epydoc
+rozumie równie¿ wewnêtrzne opisy stworzone w ReStructuredText, Javadoc
+i w postaci czystego tekstu.
+
+Ten pakiet zawiera graficzny interfejs u¿ytkownika (GUI) dla epydoc.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 python setup.py build
@@ -55,6 +78,8 @@ python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
 
 install man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
+find $RPM_BUILD_ROOT%{py_sitescriptdir} -name "*.py" | xargs rm
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -63,18 +88,20 @@ rm -rf $RPM_BUILD_ROOT
 %doc doc/*
 %attr(755,root,root) %{_bindir}/epydoc
 
-%dir %{py_sitedir}/epydoc
-%{py_sitedir}/epydoc/*.py[co]
-%exclude %{py_sitedir}/epydoc/gui.py[co]
+%dir %{py_sitescriptdir}/epydoc
+%{py_sitescriptdir}/epydoc/*.py[co]
+%dir %{py_sitescriptdir}/epydoc/test
+%{py_sitescriptdir}/epydoc/test/*.py[co]
+%exclude %{py_sitescriptdir}/epydoc/gui.py[co]
 
-%dir %{py_sitedir}/epydoc/markup
-%{py_sitedir}/epydoc/markup/*.py[co]
+%dir %{py_sitescriptdir}/epydoc/markup
+%{py_sitescriptdir}/epydoc/markup/*.py[co]
 
 %{_mandir}/man1/epydoc.*
 
 %files gui
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/epydocgui
-%{py_sitedir}/epydoc/gui.py[co]
+%{py_sitescriptdir}/epydoc/gui.py[co]
 
 %{_mandir}/man1/epydocgui.*
This page took 0.072533 seconds and 4 git commands to generate.