up to 1.18.0 auto/th/eom-1.18.0-1
authorJan Palus <atler@pld-linux.org>
Wed, 15 Mar 2017 22:43:09 +0000 (23:43 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 15 Mar 2017 22:43:09 +0000 (23:43 +0100)
- upstream switched to gtk3 exclusively
- drop unsupported ku_IQ locale

eom-codegen.patch [deleted file]
eom.spec

diff --git a/eom-codegen.patch b/eom-codegen.patch
deleted file mode 100644 (file)
index 2f61501..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- eog-2.25.92/configure.ac~  2009-03-15 18:12:32.222616928 +0100
-+++ eog-2.25.92/configure.ac   2009-03-15 18:13:28.487391837 +0100
-@@ -361,11 +361,11 @@
-       AC_MSG_RESULT([$PYGTK_DEFSDIR])
-       AC_MSG_CHECKING([for pygobject codegen])
--      PYGOBJECT_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.py"
-+      PYGOBJECT_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/codegen.pyc"
-       AC_MSG_RESULT([$PYGOBJECT_CODEGEN])
-       AC_MSG_CHECKING([for pygobject h2def])
--      PYGOBJECT_H2DEF="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/h2def.py"
-+      PYGOBJECT_H2DEF="$PYTHON `$PKG_CONFIG --variable=codegendir pygobject-2.0`/h2def.pyc"
-       AC_MSG_RESULT([$PYGOBJECT_H2DEF])
-       AC_SUBST([PYGOBJECT_DEFSDIR])
index 1752456..ecc6077 100644 (file)
--- a/eom.spec
+++ b/eom.spec
@@ -1,19 +1,17 @@
 #
 # Conditional build:
 %bcond_without apidocs         # disable API documentation
-%bcond_with    gtk3            # use GTK+ 3.x instead of 2.x
 
 Summary:       The Eye of MATE image viewer
 Summary(pl.UTF-8):     Oko MATE - przeglądarka obrazków
 Summary(pt_BR.UTF-8):  Visualizador de imagem Eye of MATE
 Name:          eom
-Version:       1.16.1
+Version:       1.18.0
 Release:       1
 License:       GPL v2+
 Group:         X11/Applications/Graphics
-Source0:       http://pub.mate-desktop.org/releases/1.16/%{name}-%{version}.tar.xz
-# Source0-md5: d5fd10ad1b70c914b20502859c7e521c
-Patch0:                %{name}-codegen.patch
+Source0:       http://pub.mate-desktop.org/releases/1.18/%{name}-%{version}.tar.xz
+# Source0-md5: bb3ff5d5551d32c447275f78ffa7c3fe
 URL:           http://mate-desktop.org/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.9
@@ -24,18 +22,19 @@ BuildRequires:      gdk-pixbuf2-devel >= 2.30.0
 BuildRequires: gettext-tools >= 0.10.40
 BuildRequires: glib2-devel >= 1:2.36.0
 BuildRequires: gobject-introspection-devel >= 0.9.3
-%{!?with_gtk3:BuildRequires:   gtk+2-devel >= 2:2.18.0}
-%{?with_gtk3:BuildRequires:    gtk+3-devel >= 3.0.0}
+BuildRequires: gtk+3-devel >= 3.14
 %{?with_apidocs:BuildRequires: gtk-doc >= 1.9}
 BuildRequires: intltool >= 0.50.1
 BuildRequires: lcms2-devel >= 2
 BuildRequires: libexif-devel >= 1:0.6.14
 BuildRequires: libjpeg-devel
+BuildRequires: libpeas-devel >= 1.2.0
+BuildRequires: libpeas-gtk-devel >= 1.2.0
 BuildRequires: librsvg-devel >= 2.36.2
 BuildRequires: libtool >= 1:1.4.3
 BuildRequires: libxml2-devel >= 2.0
 BuildRequires: mate-common
-BuildRequires: mate-desktop-devel >= 1.9.1
+BuildRequires: mate-desktop-devel >= 1.17.0
 BuildRequires: pkgconfig >= 1:0.9.0
 BuildRequires: python-devel >= 1:2.3
 BuildRequires: python-pygobject-devel >= 2.16.0
@@ -56,11 +55,12 @@ Requires:   dbus-glib >= 0.71
 Requires:      exempi >= 1.99.5
 Requires:      gdk-pixbuf2 >= 2.30.0
 Requires:      glib2 >= 1:2.36.0
-%{!?with_gtk3:Requires:        gtk+2 >= 2:2.18.0}
-%{?with_gtk3:Requires: gtk+3 >= 3.0.0}
+Requires:      gtk+3 >= 3.14
 Requires:      libexif >= 1:0.6.14
+Requires:      libpeas >= 1.2.0
+Requires:      libpeas-gtk >= 1.2.0
 Requires:      librsvg >= 2.36.2
-Requires:      mate-desktop-libs >= 1.9.1
+Requires:      mate-desktop-libs >= 1.17.0
 Requires:      shared-mime-info >= 0.20
 Obsoletes:     mate-image-viewer
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -82,8 +82,7 @@ Summary(pl.UTF-8):    Pliki nagłówkowe dla wtyczek Eye of MATE
 Group:         X11/Development/Libraries
 # doesn't require base
 Requires:      glib2-devel >= 1:2.36.0
-%{!?with_gtk3:Requires:        gtk+2-devel >= 2:2.18.0}
-%{?with_gtk3:Requires: gtk+3-devel >= 3.0.0}
+Requires:      gtk+3-devel >= 3.14
 Obsoletes:     mate-image-viewer-devel
 
 %description devel
@@ -110,7 +109,6 @@ Dokumentacja API Eye of MATE.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %{?with_apidocs:%{__gtkdocize}}
@@ -123,7 +121,6 @@ Dokumentacja API Eye of MATE.
 %configure \
        --enable-gtk-doc%{!?with_apidocs:=no} \
        --disable-silent-rules \
-       %{?with_gtk:--with-gtk=3.0} \
        --with-html-dir=%{_gtkdocdir}
 %{__make}
 
@@ -136,7 +133,7 @@ rm -rf $RPM_BUILD_ROOT
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/eom/plugins/*.la
 
 # not supported by glibc yet
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{frp,jv,pms}
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{frp,ku_IQ,jv,pms}
 
 %find_lang eom --with-mate
 
@@ -161,11 +158,11 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/eom
 %dir %{_libdir}/eom/plugins
 %attr(755,root,root) %{_libdir}/eom/plugins/libfullscreen.so
-%{_libdir}/eom/plugins/fullscreen.eom-plugin
+%{_libdir}/eom/plugins/fullscreen.plugin
 %attr(755,root,root) %{_libdir}/eom/plugins/libreload.so
-%{_libdir}/eom/plugins/reload.eom-plugin
+%{_libdir}/eom/plugins/reload.plugin
 %attr(755,root,root) %{_libdir}/eom/plugins/libstatusbar-date.so
-%{_libdir}/eom/plugins/statusbar-date.eom-plugin
+%{_libdir}/eom/plugins/statusbar-date.plugin
 %{_datadir}/appdata/eom.appdata.xml
 %{_datadir}/glib-2.0/schemas/org.mate.eom.enums.xml
 %{_datadir}/glib-2.0/schemas/org.mate.eom.gschema.xml
This page took 0.297673 seconds and 4 git commands to generate.