]> git.pld-linux.org Git - packages/eom.git/blob - eom.spec
84de2d6ef59ddd28f57fc1f239be0b7a040a0c1d
[packages/eom.git] / eom.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable API documentation
4 %bcond_with     gtk3            # use GTK+ 3.x instead of 2.x
5
6 Summary:        The Eye of MATE image viewer
7 Summary(pl.UTF-8):      Oko MATE - przeglądarka obrazków
8 Summary(pt_BR.UTF-8):   Visualizador de imagem Eye of MATE
9 Name:           eom
10 Version:        1.10.0
11 Release:        1
12 License:        GPL v2+
13 Group:          X11/Applications/Graphics
14 Source0:        http://pub.mate-desktop.org/releases/1.10/%{name}-%{version}.tar.xz
15 # Source0-md5:  06da21f7f1b9b7c40561f127a549fa1e
16 Patch0:         %{name}-codegen.patch
17 URL:            http://mate-desktop.org/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake >= 1:1.9
20 BuildRequires:  dbus-glib-devel >= 0.71
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  exempi-devel >= 1.99.5
23 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
24 BuildRequires:  gettext-tools >= 0.10.40
25 BuildRequires:  glib2-devel >= 1:2.26.0
26 BuildRequires:  gobject-introspection-devel >= 0.9.3
27 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.18.0}
28 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
29 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
30 BuildRequires:  intltool >= 0.40.0
31 BuildRequires:  lcms2-devel >= 2
32 BuildRequires:  libexif-devel >= 1:0.6.14
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  librsvg-devel >= 2.36.2
35 BuildRequires:  libtool >= 1:1.4.3
36 BuildRequires:  libxml2-devel >= 2.0
37 BuildRequires:  mate-common
38 BuildRequires:  mate-desktop-devel >= 1.9.1
39 BuildRequires:  mate-icon-theme-devel >= 1.1.0
40 BuildRequires:  pkgconfig >= 1:0.9.0
41 BuildRequires:  python-devel >= 1:2.3
42 BuildRequires:  python-pygobject-devel >= 2.16.0
43 BuildRequires:  python-pygtk-devel >= 2:2.14.0
44 BuildRequires:  rpmbuild(find_lang) >= 1.36
45 BuildRequires:  rpmbuild(macros) >= 1.311
46 BuildRequires:  shared-mime-info >= 0.20
47 BuildRequires:  tar >= 1:1.22
48 BuildRequires:  xorg-lib-libX11-devel
49 BuildRequires:  xz
50 BuildRequires:  yelp-tools
51 BuildRequires:  zlib-devel
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  glib2 >= 1:2.26.0
54 Requires(post,postun):  gtk-update-icon-cache
55 Requires(post,postun):  hicolor-icon-theme
56 Requires:       dbus-glib >= 0.71
57 Requires:       exempi >= 1.99.5
58 Requires:       glib2 >= 1:2.26.0
59 %{!?with_gtk3:Requires: gtk+2 >= 2:2.18.0}
60 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
61 Requires:       libexif >= 1:0.6.14
62 Requires:       librsvg >= 2.36.2
63 Requires:       mate-desktop-libs >= 1.9.1
64 Requires:       mate-icon-theme >= 1.1.0
65 Requires:       shared-mime-info >= 0.20
66 Obsoletes:      mate-image-viewer
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 Eye of MATE is a tool for viewing/cataloging images. It's a fork of
71 Eye of GNOME.
72
73 %description -l pl.UTF-8
74 Eye of MATE (Oko MATE) jest narzędziem do oglądania i katalogowania
75 obrazków. Jest to odgałęzienie programu Eye of GNOME.
76
77 %description -l pt_BR.UTF-8
78 Aplicativo para visualizar imagens chamado Eye of MATE.
79
80 %package devel
81 Summary:        Header files for Eye of MATE plugins
82 Summary(pl.UTF-8):      Pliki nagłówkowe dla wtyczek Eye of MATE
83 Group:          X11/Development/Libraries
84 # doesn't require base
85 Requires:       glib2-devel >= 1:2.26.0
86 %{!?with_gtk3:Requires: gtk+2-devel >= 2:2.18.0}
87 %{?with_gtk3:Requires:  gtk+3-devel >= 3.0.0}
88 Obsoletes:      mate-image-viewer-devel
89
90 %description devel
91 Header files for Eye of MATE plugins.
92
93 %description devel -l pl.UTF-8
94 Pliki nagłówkowe dla wtyczek Eye of MATE.
95
96 %package apidocs
97 Summary:        Eye of MATE API documentation
98 Summary(pl.UTF-8):      Dokumentacja API Eye of MATE
99 Group:          Documentation
100 Requires:       gtk-doc-common
101 Obsoletes:      mate-image-viewer-apidocs
102 %if "%{_rpmversion}" >= "5"
103 BuildArch:      noarch
104 %endif
105
106 %description apidocs
107 Eye of MATE API documentation.
108
109 %description apidocs -l pl.UTF-8
110 Dokumentacja API Eye of MATE.
111
112 %prep
113 %setup -q
114 %patch0 -p1
115
116 %build
117 %{?with_apidocs:%{__gtkdocize}}
118 %{__intltoolize}
119 %{__libtoolize}
120 %{__aclocal}
121 %{__automake}
122 %{__autoheader}
123 %{__autoconf}
124 %configure \
125         --enable-gtk-doc%{!?with_apidocs:=no} \
126         --disable-silent-rules \
127         %{?with_gtk:--with-gtk=3.0} \
128         --with-html-dir=%{_gtkdocdir}
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/eom/plugins/*.la
138
139 # mate < 1.5 did not exist in PLD, avoid dependency on mate-conf
140 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/eom.convert
141
142 %find_lang eom --with-mate
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %post
148 %glib_compile_schemas
149 %update_desktop_database_post
150 %update_icon_cache hicolor
151
152 %postun
153 %glib_compile_schemas
154 %update_desktop_database_postun
155 %update_icon_cache hicolor
156
157 %files -f eom.lang
158 %defattr(644,root,root,755)
159 %doc AUTHORS ChangeLog NEWS README THANKS TODO
160 %attr(755,root,root) %{_bindir}/eom
161 %{_libdir}/girepository-1.0/Eom-1.0.typelib
162 %dir %{_libdir}/eom
163 %dir %{_libdir}/eom/plugins
164 %attr(755,root,root) %{_libdir}/eom/plugins/libfullscreen.so
165 %{_libdir}/eom/plugins/fullscreen.eom-plugin
166 %attr(755,root,root) %{_libdir}/eom/plugins/libreload.so
167 %{_libdir}/eom/plugins/reload.eom-plugin
168 %attr(755,root,root) %{_libdir}/eom/plugins/libstatusbar-date.so
169 %{_libdir}/eom/plugins/statusbar-date.eom-plugin
170 %{_datadir}/appdata/eom.appdata.xml
171 %{_datadir}/glib-2.0/schemas/org.mate.eom.enums.xml
172 %{_datadir}/glib-2.0/schemas/org.mate.eom.gschema.xml
173 %{_datadir}/eom
174 %{_desktopdir}/eom.desktop
175 %{_iconsdir}/hicolor/*/apps/eom.*
176 %{_mandir}/man1/eom.1*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %{_includedir}/eom-2.20
181 %{_datadir}/gir-1.0/Eom-1.0.gir
182 %{_pkgconfigdir}/eom.pc
183
184 %if %{with apidocs}
185 %files apidocs
186 %defattr(644,root,root,755)
187 %{_gtkdocdir}/eom
188 %endif
This page took 0.062358 seconds and 2 git commands to generate.