]> git.pld-linux.org Git - packages/eom.git/blob - eom.spec
- up to 1.8.1
[packages/eom.git] / eom.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable API documentation
4 %bcond_with     gtk3            # use GTK+ 3.x instead of 2.x
5
6 Summary:        The Eye of MATE image viewer
7 Summary(pl.UTF-8):      Oko MATE - przeglądarka obrazków
8 Summary(pt_BR.UTF-8):   Visualizador de imagem Eye of MATE
9 Name:           eom
10 Version:        1.8.1
11 Release:        1
12 License:        GPL v2+
13 Group:          X11/Applications/Graphics
14 Source0:        http://pub.mate-desktop.org/releases/1.8/%{name}-%{version}.tar.xz
15 # Source0-md5:  87dd1966dd9deeaaf95438a618353806
16 Patch0:         %{name}-codegen.patch
17 URL:            http://mate-desktop.org/
18 BuildRequires:  autoconf >= 2.59
19 BuildRequires:  automake >= 1:1.9
20 BuildRequires:  dbus-glib-devel >= 0.71
21 BuildRequires:  docbook-dtd412-xml
22 BuildRequires:  exempi-devel >= 1.99.5
23 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
24 BuildRequires:  gettext-devel >= 0.10.40
25 BuildRequires:  glib2-devel >= 1:2.26.0
26 %{!?with_gtk3:BuildRequires:    gtk+2-devel >= 2:2.18.0}
27 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
28 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
29 BuildRequires:  intltool >= 0.40.0
30 BuildRequires:  lcms2-devel >= 2
31 BuildRequires:  libexif-devel >= 1:0.6.14
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  librsvg-devel >= 2.26.0
34 BuildRequires:  libtool >= 1:1.4.3
35 BuildRequires:  libxml2-devel >= 2.0
36 BuildRequires:  mate-common
37 BuildRequires:  mate-desktop-devel >= 1.5.0
38 BuildRequires:  mate-icon-theme-devel >= 1.1.0
39 BuildRequires:  pkgconfig >= 1:0.9.0
40 BuildRequires:  python-devel >= 1:2.3
41 BuildRequires:  python-pygobject-devel >= 2.16.0
42 BuildRequires:  python-pygtk-devel >= 2:2.14.0
43 BuildRequires:  rpmbuild(find_lang) >= 1.36
44 BuildRequires:  rpmbuild(macros) >= 1.311
45 BuildRequires:  shared-mime-info >= 0.20
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xorg-lib-libX11-devel
48 BuildRequires:  xz
49 BuildRequires:  yelp-tools
50 BuildRequires:  zlib-devel
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  glib2 >= 1:2.26.0
53 Requires(post,postun):  gtk-update-icon-cache
54 Requires(post,postun):  hicolor-icon-theme
55 Requires:       dbus-glib >= 0.71
56 Requires:       exempi >= 1.99.5
57 Requires:       glib2 >= 1:2.26.0
58 %{!?with_gtk3:Requires: gtk+2 >= 2:2.18.0}
59 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
60 Requires:       libexif >= 1:0.6.14
61 Requires:       librsvg >= 2.26.0
62 Requires:       mate-icon-theme >= 1.1.0
63 Requires:       shared-mime-info >= 0.20
64 Obsoletes:      mate-image-viewer
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 Eye of MATE is a tool for viewing/cataloging images. It's a fork of
69 Eye of GNOME.
70
71 %description -l pl.UTF-8
72 Eye of MATE (Oko MATE) jest narzędziem do oglądania i katalogowania
73 obrazków. Jest to odgałęzienie programu Eye of GNOME.
74
75 %description -l pt_BR.UTF-8
76 Aplicativo para visualizar imagens chamado Eye of MATE.
77
78 %package devel
79 Summary:        Header files for Eye of MATE plugins
80 Summary(pl.UTF-8):      Pliki nagłówkowe dla wtyczek Eye of MATE
81 Group:          X11/Development/Libraries
82 # doesn't require base
83 Requires:       glib2-devel >= 1:2.26.0
84 Requires:       gtk+2-devel >= 2:2.18.0
85 Obsoletes:      mate-image-viewer-devel
86
87 %description devel
88 Header files for Eye of MATE plugins.
89
90 %description devel -l pl.UTF-8
91 Pliki nagłówkowe dla wtyczek Eye of MATE.
92
93 %package apidocs
94 Summary:        Eye of MATE API documentation
95 Summary(pl.UTF-8):      Dokumentacja API Eye of MATE
96 Group:          Documentation
97 Requires:       gtk-doc-common
98 Obsoletes:      mate-image-viewer-apidocs
99 %if "%{_rpmversion}" >= "5"
100 BuildArch:      noarch
101 %endif
102
103 %description apidocs
104 Eye of MATE API documentation.
105
106 %description apidocs -l pl.UTF-8
107 Dokumentacja API Eye of MATE.
108
109 %prep
110 %setup -q
111 %patch0 -p1
112
113 %build
114 %{?with_apidocs:%{__gtkdocize}}
115 %{__intltoolize}
116 %{__libtoolize}
117 %{__aclocal}
118 %{__automake}
119 %{__autoheader}
120 %{__autoconf}
121 %configure \
122         --enable-gtk-doc%{!?with_apidocs:=no} \
123         --disable-silent-rules \
124         %{?with_gtk:--with-gtk=3.0} \
125         --with-html-dir=%{_gtkdocdir}
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/eom/plugins/*.la
135
136 # mate < 1.5 did not exist in PLD, avoid dependency on mate-conf
137 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/eom.convert
138
139 %find_lang eom --with-mate
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 %glib_compile_schemas
146 %update_desktop_database_post
147 %update_icon_cache hicolor
148
149 %postun
150 %glib_compile_schemas
151 %update_desktop_database_postun
152 %update_icon_cache hicolor
153
154 %files -f eom.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS ChangeLog NEWS README THANKS TODO
157 %attr(755,root,root) %{_bindir}/eom
158 %dir %{_libdir}/eom
159 %dir %{_libdir}/eom/plugins
160 %attr(755,root,root) %{_libdir}/eom/plugins/libfullscreen.so
161 %{_libdir}/eom/plugins/fullscreen.eom-plugin
162 %attr(755,root,root) %{_libdir}/eom/plugins/libreload.so
163 %{_libdir}/eom/plugins/reload.eom-plugin
164 %attr(755,root,root) %{_libdir}/eom/plugins/libstatusbar-date.so
165 %{_libdir}/eom/plugins/statusbar-date.eom-plugin
166 %{_datadir}/glib-2.0/schemas/org.mate.eom.gschema.xml
167 %{_datadir}/eom
168 %{_desktopdir}/eom.desktop
169 %{_iconsdir}/hicolor/*/apps/eom.*
170 %{_mandir}/man1/eom.1*
171
172 %files devel
173 %defattr(644,root,root,755)
174 %{_includedir}/eom-2.20
175 %{_pkgconfigdir}/eom.pc
176
177 %if %{with apidocs}
178 %files apidocs
179 %defattr(644,root,root,755)
180 %{_gtkdocdir}/eom
181 %endif
This page took 0.120864 seconds and 3 git commands to generate.