- rename files mate-image-viewer -> eom
[packages/eom.git] / eom.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable API documentation
4 #
5 Summary:        The Eye of MATE image viewer
6 Summary(pl.UTF-8):      Oko MATE - przeglądarka obrazków
7 Summary(pt_BR.UTF-8):   Visualizador de imagem Eye of MATE
8 Name:           mate-image-viewer
9 Version:        1.6.2
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications/Graphics
13 Source0:        http://pub.mate-desktop.org/releases/1.6/%{name}-%{version}.tar.xz
14 # Source0-md5:  de728693721f1b35166f7687bba1f70d
15 Patch0:         %{name}-codegen.patch
16 URL:            http://mate-desktop.org/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1:1.9
19 BuildRequires:  dbus-glib-devel >= 0.71
20 BuildRequires:  docbook-dtd412-xml
21 BuildRequires:  exempi-devel >= 1.99.5
22 BuildRequires:  gdk-pixbuf2-devel >= 2.4.0
23 BuildRequires:  gettext-devel >= 0.10.40
24 BuildRequires:  glib2-devel >= 1:2.26.0
25 BuildRequires:  gtk+2-devel >= 2:2.18.0
26 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.9}
27 BuildRequires:  intltool >= 0.40.0
28 BuildRequires:  lcms-devel
29 BuildRequires:  libexif-devel >= 1:0.6.14
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  librsvg-devel >= 2.26.0
32 BuildRequires:  libtool >= 1:1.4.3
33 BuildRequires:  libxml2-devel >= 2.0
34 BuildRequires:  mate-common
35 BuildRequires:  mate-desktop-devel >= 1.5.0
36 BuildRequires:  mate-doc-utils
37 BuildRequires:  mate-icon-theme-devel >= 1.1.0
38 BuildRequires:  pkgconfig >= 1:0.9.0
39 BuildRequires:  python-devel >= 2.3
40 BuildRequires:  python-pygobject-devel >= 2.16.0
41 BuildRequires:  python-pygtk-devel >= 2:2.14.0
42 BuildRequires:  rpmbuild(find_lang) >= 1.36
43 BuildRequires:  rpmbuild(macros) >= 1.311
44 BuildRequires:  scrollkeeper
45 BuildRequires:  shared-mime-info >= 0.20
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xorg-lib-libX11-devel
48 BuildRequires:  xz
49 BuildRequires:  zlib-devel
50 Requires(post,postun):  desktop-file-utils
51 Requires(post,postun):  glib2 >= 1:2.26.0
52 Requires(post,postun):  gtk-update-icon-cache
53 Requires(post,postun):  hicolor-icon-theme
54 Requires(post,postun):  scrollkeeper
55 Requires:       dbus-glib >= 0.71
56 Requires:       exempi >= 1.99.5
57 Requires:       glib2 >= 1:2.26.0
58 Requires:       gtk+2 >= 2:2.18.0
59 Requires:       libexif >= 1:0.6.14
60 Requires:       librsvg >= 2.26.0
61 Requires:       mate-icon-theme >= 1.1.0
62 Requires:       shared-mime-info >= 0.20
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %description
66 Eye of MATE is a tool for viewing/cataloging images. It's a fork of
67 Eye of GNOME.
68
69 %description -l pl.UTF-8
70 Eye of MATE (Oko MATE) jest narzędziem do oglądania i katalogowania
71 obrazków. Jest to odgałęzienie programu Eye of GNOME.
72
73 %description -l pt_BR.UTF-8
74 Aplicativo para visualizar imagens chamado Eye of MATE.
75
76 %package devel
77 Summary:        Header files for Eye of MATE plugins
78 Summary(pl.UTF-8):      Pliki nagłówkowe dla wtyczek Eye of MATE
79 Group:          X11/Development/Libraries
80 # doesn't require base
81 Requires:       glib2-devel >= 1:2.26.0
82 Requires:       gtk+2-devel >= 2:2.18.0
83
84 %description devel
85 Header files for Eye of MATE plugins.
86
87 %description devel -l pl.UTF-8
88 Pliki nagłówkowe dla wtyczek Eye of MATE.
89
90 %package apidocs
91 Summary:        Eye of MATE API documentation
92 Summary(pl.UTF-8):      Dokumentacja API Eye of MATE
93 Group:          Documentation
94 Requires:       gtk-doc-common
95
96 %description apidocs
97 Eye of MATE API documentation.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API Eye of MATE.
101
102 %prep
103 %setup -q
104 %patch0 -p1
105
106 %build
107 mate-doc-prepare --copy --force
108 %{?with_apidocs:%{__gtkdocize}}
109 %{__intltoolize}
110 %{__libtoolize}
111 %{__aclocal}
112 %{__automake}
113 %{__autoheader}
114 %{__autoconf}
115 %configure \
116         --enable-gtk-doc%{!?with_apidocs:=no} \
117         --disable-scrollkeeper \
118         --disable-silent-rules \
119         --with-html-dir=%{_gtkdocdir}
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %{__rm} $RPM_BUILD_ROOT%{_libdir}/eom/plugins/*.la
129
130 # mate < 1.5 did not exist in PLD, avoid dependency on mate-conf
131 %{__rm} $RPM_BUILD_ROOT%{_datadir}/MateConf/gsettings/eom.convert
132
133 %find_lang eom --with-mate --with-omf
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 %glib_compile_schemas
140 %scrollkeeper_update_post
141 %update_desktop_database_post
142 %update_icon_cache hicolor
143
144 %postun
145 %glib_compile_schemas
146 %scrollkeeper_update_postun
147 %update_desktop_database_postun
148 %update_icon_cache hicolor
149
150 %files -f eom.lang
151 %defattr(644,root,root,755)
152 %doc AUTHORS ChangeLog NEWS README THANKS TODO
153 %attr(755,root,root) %{_bindir}/eom
154 %dir %{_libdir}/eom
155 %dir %{_libdir}/eom/plugins
156 %attr(755,root,root) %{_libdir}/eom/plugins/libfullscreen.so
157 %{_libdir}/eom/plugins/fullscreen.eom-plugin
158 %attr(755,root,root) %{_libdir}/eom/plugins/libreload.so
159 %{_libdir}/eom/plugins/reload.eom-plugin
160 %attr(755,root,root) %{_libdir}/eom/plugins/libstatusbar-date.so
161 %{_libdir}/eom/plugins/statusbar-date.eom-plugin
162 %{_datadir}/glib-2.0/schemas/org.mate.eom.gschema.xml
163 %{_datadir}/mate-image-viewer
164 %{_desktopdir}/eom.desktop
165 %{_iconsdir}/hicolor/*/apps/eom.*
166 %{_mandir}/man1/eom.1*
167
168 %files devel
169 %defattr(644,root,root,755)
170 %{_includedir}/eom-2.20
171 %{_pkgconfigdir}/eom.pc
172
173 %if %{with apidocs}
174 %files apidocs
175 %defattr(644,root,root,755)
176 %{_gtkdocdir}/eom
177 %endif
This page took 0.049862 seconds and 3 git commands to generate.