]> git.pld-linux.org Git - packages/enlightenment.git/commitdiff
- updated to 0.18.3
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 4 Feb 2014 15:02:07 +0000 (16:02 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 4 Feb 2014 15:02:07 +0000 (16:02 +0100)
- added missing wayland-specific files from git

e-module-wl_desktop_shell.edj [new file with mode: 0644]
e-module-wl_screenshot.edj [new file with mode: 0644]
enlightenment-missing.patch [new file with mode: 0644]
enlightenment.spec

diff --git a/e-module-wl_desktop_shell.edj b/e-module-wl_desktop_shell.edj
new file mode 100644 (file)
index 0000000..2c1f4d2
Binary files /dev/null and b/e-module-wl_desktop_shell.edj differ
diff --git a/e-module-wl_screenshot.edj b/e-module-wl_screenshot.edj
new file mode 100644 (file)
index 0000000..eaf667a
Binary files /dev/null and b/e-module-wl_screenshot.edj differ
diff --git a/enlightenment-missing.patch b/enlightenment-missing.patch
new file mode 100644 (file)
index 0000000..2f8d6f0
--- /dev/null
@@ -0,0 +1,134 @@
+--- enlightenment-0.18.3/src/modules/wl_desktop_shell/e_desktop_shell_protocol.h.orig  1970-01-01 01:00:00.000000000 +0100
++++ enlightenment-0.18.3/src/modules/wl_desktop_shell/e_desktop_shell_protocol.h       2014-02-03 19:04:06.967929065 +0100
+@@ -0,0 +1,131 @@
++#ifndef DESKTOP_SERVER_PROTOCOL_H
++#define DESKTOP_SERVER_PROTOCOL_H
++
++#ifdef  __cplusplus
++extern "C" {
++#endif
++
++#include <stdint.h>
++#include <stddef.h>
++#include "wayland-util.h"
++
++struct wl_client;
++struct wl_resource;
++
++/* struct e_desktop_shell; */
++/* struct screensaver; */
++
++extern const struct wl_interface e_desktop_shell_interface;
++extern const struct wl_interface screensaver_interface;
++
++#ifndef E_DESKTOP_SHELL_CURSOR_ENUM
++#define E_DESKTOP_SHELL_CURSOR_ENUM
++enum e_desktop_shell_cursor {
++      E_DESKTOP_SHELL_CURSOR_NONE = 0,
++      E_DESKTOP_SHELL_CURSOR_RESIZE_TOP = 1,
++      E_DESKTOP_SHELL_CURSOR_RESIZE_BOTTOM = 2,
++      E_DESKTOP_SHELL_CURSOR_ARROW = 3,
++      E_DESKTOP_SHELL_CURSOR_RESIZE_LEFT = 4,
++      E_DESKTOP_SHELL_CURSOR_RESIZE_TOP_LEFT = 5,
++      E_DESKTOP_SHELL_CURSOR_RESIZE_BOTTOM_LEFT = 6,
++      E_DESKTOP_SHELL_CURSOR_MOVE = 7,
++      E_DESKTOP_SHELL_CURSOR_RESIZE_RIGHT = 8,
++      E_DESKTOP_SHELL_CURSOR_RESIZE_TOP_RIGHT = 9,
++      E_DESKTOP_SHELL_CURSOR_RESIZE_BOTTOM_RIGHT = 10,
++      E_DESKTOP_SHELL_CURSOR_BUSY = 11,
++};
++#endif /* E_DESKTOP_SHELL_CURSOR_ENUM */
++
++struct e_desktop_shell_interface {
++      /**
++       * set_background - (none)
++       * @output: (none)
++       * @surface: (none)
++       */
++      void (*set_background)(struct wl_client *client,
++                             struct wl_resource *resource,
++                             struct wl_resource *output,
++                             struct wl_resource *surface);
++      /**
++       * set_panel - (none)
++       * @output: (none)
++       * @surface: (none)
++       */
++      void (*set_panel)(struct wl_client *client,
++                        struct wl_resource *resource,
++                        struct wl_resource *output,
++                        struct wl_resource *surface);
++      /**
++       * set_lock_surface - (none)
++       * @surface: (none)
++       */
++      void (*set_lock_surface)(struct wl_client *client,
++                               struct wl_resource *resource,
++                               struct wl_resource *surface);
++      /**
++       * unlock - (none)
++       */
++      void (*unlock)(struct wl_client *client,
++                     struct wl_resource *resource);
++      /**
++       * set_grab_surface - (none)
++       * @surface: (none)
++       */
++      void (*set_grab_surface)(struct wl_client *client,
++                               struct wl_resource *resource,
++                               struct wl_resource *surface);
++
++      /**
++       * desktop_ready - desktop is ready to be shown
++       *
++       * Tell the server, that enough desktop elements have been drawn
++       * to make the desktop look ready for use. During start-up, the
++       * server can wait for this request with a black screen before
++       * starting to fade in the desktop, for instance. If the client
++       * parts of a desktop take a long time to initialize, we avoid
++       * showing temporary garbage.
++       * @since: 2
++       */
++      void (*desktop_ready)(struct wl_client *client,
++                            struct wl_resource *resource);
++};
++
++#define E_DESKTOP_SHELL_CONFIGURE     0
++#define E_DESKTOP_SHELL_PREPARE_LOCK_SURFACE  1
++#define E_DESKTOP_SHELL_GRAB_CURSOR   2
++
++static inline void
++e_desktop_shell_send_configure(struct wl_resource *resource_, uint32_t edges, struct wl_resource *surface, int32_t width, int32_t height)
++{
++      wl_resource_post_event(resource_, E_DESKTOP_SHELL_CONFIGURE, edges, surface, width, height);
++}
++
++static inline void
++e_desktop_shell_send_prepare_lock_surface(struct wl_resource *resource_)
++{
++      wl_resource_post_event(resource_, E_DESKTOP_SHELL_PREPARE_LOCK_SURFACE);
++}
++
++static inline void
++e_desktop_shell_send_grab_cursor(struct wl_resource *resource_, uint32_t cursor)
++{
++      wl_resource_post_event(resource_, E_DESKTOP_SHELL_GRAB_CURSOR, cursor);
++}
++
++struct screensaver_interface {
++      /**
++       * set_surface - (none)
++       * @surface: (none)
++       * @output: (none)
++       */
++      void (*set_surface)(struct wl_client *client,
++                          struct wl_resource *resource,
++                          struct wl_resource *surface,
++                          struct wl_resource *output);
++};
++
++#ifdef  __cplusplus
++}
++#endif
++
++#endif
index 43e73de9b918eee2188df326b7147177270971e8..a13c1c9b28911e34a4f77fc8c0b04fba8adf3b48 100644 (file)
@@ -12,13 +12,16 @@ Summary:    Enlightenment Window Manager
 Summary(hu.UTF-8):     Enlightenment ablakkezelő
 Summary(pl.UTF-8):     Zarządca okien X - Enlightenment
 Name:          enlightenment
-Version:       0.18.2
+Version:       0.18.3
 Release:       1
 License:       BSD
 Group:         X11/Window Managers
 Source0:       http://download.enlightenment.org/rel/apps/enlightenment/%{name}-%{version}.tar.bz2
-# Source0-md5: af8baee80ad5285cef139aadcf5a0495
+# Source0-md5: 1ce67de50f48f49e4803023f2426d997
 Source1:       %{name}-xsession.desktop
+Source2:       e-module-wl_desktop_shell.edj
+Source3:       e-module-wl_screenshot.edj
+Patch0:                %{name}-missing.patch
 URL:           http://enlightenment.org/
 BuildRequires: alsa-lib-devel >= 1.0.8
 BuildRequires: autoconf >= 2.59-9
@@ -172,6 +175,10 @@ Pliki nagłówkowe dla Enlightenmenta.
 
 %prep
 %setup -q
+# missing files
+%patch0 -p1
+cp -p %{SOURCE2} src/modules/wl_desktop_shell
+cp -p %{SOURCE3} src/modules/wl_screenshot
 
 %build
 %{__gettextize}
@@ -576,6 +583,19 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/enlightenment/modules/wizard/def-ibar.txt
 %{_libdir}/enlightenment/modules/wizard/desktop
 #
+%if %{with wayland}
+%dir %{_libdir}/enlightenment/modules/wl_desktop_shell
+%dir %{_libdir}/enlightenment/modules/wl_desktop_shell/linux-gnu-*
+%attr(755,root,root) %{_libdir}/enlightenment/modules/wl_desktop_shell/linux-gnu-*/module.so
+%attr(755,root,root) %{_libdir}/enlightenment/modules/wl_desktop_shell/module.desktop
+%attr(755,root,root) %{_libdir}/enlightenment/modules/wl_desktop_shell/*.edj
+%dir %{_libdir}/enlightenment/modules/wl_screenshot
+%dir %{_libdir}/enlightenment/modules/wl_screenshot/linux-gnu-*
+%attr(755,root,root) %{_libdir}/enlightenment/modules/wl_screenshot/linux-gnu-*/module.so
+%attr(755,root,root) %{_libdir}/enlightenment/modules/wl_screenshot/module.desktop
+%attr(755,root,root) %{_libdir}/enlightenment/modules/wl_screenshot/*.edj
+%endif
+#
 %dir %{_libdir}/enlightenment/modules/xkbswitch
 %{_libdir}/enlightenment/modules/xkbswitch/e-module-xkbswitch.edj
 %dir %{_libdir}/enlightenment/modules/xkbswitch/linux-gnu-*
This page took 0.232056 seconds and 4 git commands to generate.