]> git.pld-linux.org Git - packages/enigma.git/commitdiff
- fix build issues with xerces-c 3.1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 23 Nov 2010 23:32:46 +0000 (23:32 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    enigma-xerces.patch -> 1.1
    enigma.spec -> 1.37

enigma-xerces.patch [new file with mode: 0644]
enigma.spec

diff --git a/enigma-xerces.patch b/enigma-xerces.patch
new file mode 100644 (file)
index 0000000..51f3f2b
--- /dev/null
@@ -0,0 +1,73 @@
+--- enigma-1.01/configure.ac~  2007-05-25 23:28:44.000000000 +0200
++++ enigma-1.01/configure.ac   2010-11-24 00:07:13.166423002 +0100
+@@ -179,7 +179,7 @@
+       xerces3exp="no")      
+   if test "x$xerces3exp" = xyes; then
+     AC_MSG_RESULT([found])
+-    AC_CHECK_LIB(xerces, main,,[AC_MSG_ERROR([xerces is required to compile Enigma])])
++    AC_CHECK_LIB(xerces-c, main,,[AC_MSG_ERROR([xerces is required to compile Enigma])])
+   else
+     AC_MSG_RESULT([not found])
+     AC_MSG_CHECKING([for Xerces >=2.4 released version])
+--- enigma-1.01/src/Utf8ToXML.cc~      2010-11-24 00:08:40.166982997 +0100
++++ enigma-1.01/src/Utf8ToXML.cc       2010-11-24 00:17:40.325982996 +0100
+@@ -40,11 +40,11 @@
+     }
+     void Utf8ToXML::init(const char * const toTranscode) {
+-        unsigned int srcLength = std::strlen(toTranscode) + 1;
++        XMLSize_t srcLength = std::strlen(toTranscode) + 1;
+         // make safe assumptions on utf-16 size
+-        unsigned int maxDestLength = srcLength;
+-        unsigned int charsEaten;
+-        unsigned int destLength;
++        XMLSize_t maxDestLength = srcLength;
++        XMLSize_t charsEaten;
++        XMLSize_t destLength;
+         unsigned char *charSizes = new unsigned char[maxDestLength]; // just junk
+         // make a buffer - size does not matter - the object is temporary 
+         xmlString = new XMLCh[maxDestLength];
+--- enigma-1.01/src/XMLtoUtf8.cc~      2006-01-20 12:12:12.000000000 +0100
++++ enigma-1.01/src/XMLtoUtf8.cc       2010-11-24 00:20:37.279982998 +0100
+@@ -27,11 +27,11 @@
+ namespace enigma
+ {
+     XMLtoUtf8::XMLtoUtf8(const XMLCh* const toTranscode) {
+-        unsigned int srcLength = XMLString::stringLen(toTranscode) + 1;
++        XMLSize_t srcLength = XMLString::stringLen(toTranscode) + 1;
+         // make safe assumptions on utf-8 size
+-        unsigned int maxDestLength = 3 * srcLength;
+-        unsigned int charsEaten;
+-        unsigned int destLength;
++        XMLSize_t maxDestLength = 3 * srcLength;
++        XMLSize_t charsEaten;
++        XMLSize_t destLength;
+         // make a buffer - size does not matter - the object is temporary 
+         utf8String = new char[maxDestLength];
+         // transcode to utf-8 -- there are no unrepresentable chars
+--- enigma-1.01/src/lev/ScoreManager.cc.orig   2007-04-10 23:52:50.000000000 +0200
++++ enigma-1.01/src/lev/ScoreManager.cc        2010-11-24 00:31:38.370982993 +0100
+@@ -61,18 +61,20 @@
+ namespace {
+ #if _XERCES_VERSION >= 30000
+     class ScoreDomSerFilter : public DOMLSSerializerFilter {
++      public:
++          virtual DOMNodeFilter::FilterAction acceptNode(const DOMNode *node) const;
+ #else
+     class ScoreDomSerFilter : public DOMWriterFilter {
+-#endif
+         public:
+             virtual short acceptNode(const DOMNode *node) const;
++#endif
+             virtual unsigned long getWhatToShow () const {
+                 return DOMNodeFilter::SHOW_ALL;
+             }
+             virtual void setWhatToShow (unsigned long toShow) {}
+     };
+-    
+-    short ScoreDomSerFilter::acceptNode(const DOMNode *node) const {
++   
++    DOMNodeFilter::FilterAction ScoreDomSerFilter::acceptNode(const DOMNode *node) const {
+         if (node->getNodeType () == DOMNode::ELEMENT_NODE &&
+                  std::string(XMLtoUtf8(node->getNodeName()).c_str()) == "level") {
+             const DOMElement *e = dynamic_cast<const DOMElement *>(node);
index 7e2442d9f02d64124ce9fb0034a28c704e3ac147..b83e0d9a2ef35ad60ddbc26df5af132d00afca41 100644 (file)
@@ -9,6 +9,7 @@ Source0:        http://download.berlios.de/enigma-game/%{name}-%{version}.tar.gz
 # Source0-md5: d3804534ac03425051ebfd383ed1b4ee
 Source1:       %{name}.desktop
 Patch0:                %{name}-gcc.patch
+Patch1:                %{name}-xerces.patch
 URL:           http://www.nongnu.org/enigma/
 BuildRequires: SDL_image-devel >= 1.2.0
 BuildRequires: SDL_mixer-devel >= 1.2.5
@@ -49,6 +50,7 @@ blokujących drogę do kamieni Oxyd.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 # hack: don't rebuild it, requires too new(?) version of texi2html
 # (doesn't work with texi2html 1.56k from tetex 2.0.2)
This page took 0.145928 seconds and 4 git commands to generate.