]> git.pld-linux.org Git - packages/endeavour.git/commitdiff
- fix libzip cflags auto/th/endeavour-3.1.4-4
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 10 Nov 2014 07:46:08 +0000 (08:46 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 10 Nov 2014 07:46:08 +0000 (08:46 +0100)
- fix building with giflib 5.1
- rel 4

endeavour-giflib51.patch [new file with mode: 0644]
endeavour.spec

diff --git a/endeavour-giflib51.patch b/endeavour-giflib51.patch
new file mode 100644 (file)
index 0000000..2e6dc3b
--- /dev/null
@@ -0,0 +1,56 @@
+--- endeavour-3.1.4/endeavour2/imgio_gif.c~    2014-11-10 08:41:48.000000000 +0100
++++ endeavour-3.1.4/endeavour2/imgio_gif.c     2014-11-10 08:43:54.590693857 +0100
+@@ -1465,7 +1465,7 @@
+  if(ctx != NULL) {                            \
+   /* Close the GIF file */                    \
+   if(ctx->gif_file != NULL)                   \
+-   (void)DGifCloseFile(ctx->gif_file);                \
++   (void)DGifCloseFile(ctx->gif_file, NULL);  \
+                                               \
+   /* Delete the GIF screen */                 \
+   if(ctx->gif_screen != NULL) {                       \
+@@ -1762,7 +1762,7 @@
+       }
+       /* End the GIF decoding */
+-      gif_status = DGifCloseFile(ctx->gif_file);
++      gif_status = DGifCloseFile(ctx->gif_file, NULL);
+       if(gif_status != GIF_OK)
+       {
+           ImgOpenSetError(DGIF_STR_ERROR(ctx->gif_file->Error));
+@@ -1973,7 +1973,7 @@
+  if(ctx != NULL) {                            \
+   /* Close the GIF file */                    \
+   if(ctx->gif_file != NULL)                   \
+-   (void)DGifCloseFile(ctx->gif_file);                \
++   (void)DGifCloseFile(ctx->gif_file, NULL);  \
+                                               \
+   /* Delete the GIF screen */                 \
+   if(ctx->gif_screen != NULL) {                       \
+@@ -2281,7 +2281,7 @@
+       }
+       /* End the GIF decoding */
+-      gif_status = DGifCloseFile(ctx->gif_file);
++      gif_status = DGifCloseFile(ctx->gif_file, NULL);
+       if(gif_status != GIF_OK)
+       {
+           ImgOpenSetError(DGIF_STR_ERROR(ctx->gif_file->Error));
+@@ -3994,7 +3994,7 @@
+  if(ctx != NULL) {                            \
+   /* Close the GIF file */                    \
+   if(ctx->gif_file != NULL)                   \
+-   (void)EGifCloseFile(ctx->gif_file);                \
++   (void)EGifCloseFile(ctx->gif_file, NULL);  \
+                                               \
+   free(ctx);                                  \
+  }                                            \
+@@ -4177,7 +4177,7 @@
+       }
+       /* End the GIF encoding */
+-      gif_status = EGifCloseFile(ctx->gif_file);
++      gif_status = EGifCloseFile(ctx->gif_file, NULL);
+       if(gif_status != GIF_OK)
+       {
+           ImgSaveSetError(EGIF_STR_ERROR(ctx->gif_file->Error));
index 1515cb5d908fd3cb6b5998ef872b3f5bec41b98b..9a3202d233c77773b1ca71b166c3908dc6877138 100644 (file)
@@ -7,7 +7,7 @@ Summary:        Endeavour Mark II file management suite
 Summary(pl.UTF-8):     Oprogramowanie do zarządzania plikami Endeavour Mark II
 Name:          endeavour
 Version:       3.1.4
-Release:       3
+Release:       4
 License:       GPL v2
 Group:         X11/Applications
 Source0:       http://wolfsinger.com/~wolfpack/packages/%{name}-%{version}.tar.bz2
@@ -22,9 +22,10 @@ Patch3:              %{name}-verbose.patch
 Patch4:                %{name}-libmng.patch
 Patch5:                %{name}-libpng.patch
 Patch6:                %{name}-PLD-polish.patch
+Patch7:                %{name}-giflib51.patch
 URL:           http://freecode.com/projects/endeavour2
 BuildRequires: bzip2-devel
-BuildRequires: giflib-devel
+BuildRequires: giflib-devel >= 5.1.0
 BuildRequires: glib-devel >= 1.2
 %{!?with_gtk2:BuildRequires:   gtk+-devel >= 1.2}
 %{?with_gtk2:BuildRequires:    gtk+2-devel >= 2.0}
@@ -37,7 +38,7 @@ BuildRequires:        libstdc++-devel
 BuildRequires: libtar-devel
 BuildRequires: libtiff-devel
 BuildRequires: libzip-devel
-%{?with_gtk2:BuildRequires:    pkgconfig}
+BuildRequires: pkgconfig
 BuildRequires: xar-devel
 BuildRequires: xorg-lib-libXpm-devel
 BuildRequires: xorg-lib-libXxf86vm-devel
@@ -97,6 +98,7 @@ Pliki nagłówkowe Endeavour2.
 %if %{with polish}
 %patch6 -p1
 %endif
+%patch7 -p1
 
 %build
 ./configure \
@@ -105,7 +107,7 @@ Pliki nagłówkowe Endeavour2.
 %{__make} \
        CC="%{__cc}"                    \
        CPP="%{__cxx}"                  \
-       OPTCFLAGS="%{rpmcflags} -fPIC"  \
+       OPTCFLAGS="%{rpmcflags} -fPIC `pkg-config --cflags libzip`"     \
        EDV_BIN_DIR=%{pkglibdir}/bin    \
        EDV_LIB_DIR=%{_libdir}
 
This page took 0.091258 seconds and 4 git commands to generate.