]> git.pld-linux.org Git - packages/encfs.git/commitdiff
- 1.5-2 auto/th/encfs-1_5-1
authorZsolt Udvari <uzsolt@pld-linux.org>
Tue, 27 Oct 2009 21:24:24 +0000 (21:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    encfs-const-char.patch -> 1.1
    encfs.spec -> 1.16

encfs-const-char.patch [new file with mode: 0644]
encfs.spec

diff --git a/encfs-const-char.patch b/encfs-const-char.patch
new file mode 100644 (file)
index 0000000..3991c2b
--- /dev/null
@@ -0,0 +1,11 @@
+--- encfs-1.5-orig/encfs/NameIO.cpp    2009-10-27 21:58:02.307752841 +0100
++++ encfs-1.5/encfs/NameIO.cpp 2009-10-27 21:59:52.115658074 +0100
+@@ -190,7 +190,7 @@
+       } else
+       {
+           bool isDotFile = (*path == '.');
+-          char *next = strchr( path, '/' );
++          const char *next = strchr( path, '/' );
+           int len = next ? next - path : strlen( path );
+           // at this point we know that len > 0
index 7fa2a7472638d26ee20d5fea07d05c46177de46d..18e1ea2f52e297eeb9b7caf01d9cfd3f586d6d99 100644 (file)
@@ -2,13 +2,14 @@
 Summary:       Encrypted pass-thru filesystem for Linux
 Summary(pl.UTF-8):     Zaszyfrowany system plików dla Linuksa
 Name:          encfs
-Version:       1.3.2
+Version:       1.5
 Release:       1
 License:       GPL v2
 Group:         Applications/System
-Source0:       http://arg0.net/users/vgough/download/%{name}-%{version}-1.tgz
-# Source0-md5: 71482dbe0e158ee9ba522ae637337230
-URL:           http://arg0.net/users/vgough/encfs.html
+Source0:       http://encfs.googlecode.com/files/encfs-1.5-2.tgz
+# Source0-md5: b07008545545b4a57cf2bf65f08a14ad
+Patch0:                %{name}-const-char.patch
+URL:           http://www.arg0.net/encfs
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: libfuse-devel >= 2.5
@@ -37,16 +38,20 @@ plików. Jest podobny do CFS-a, ale nie używa NFS-a.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
-#%{__libtoolize}
-#%{__aclocal}
-#%{__autoconf}
-#%{__autoheader}
-#%{__automake}
+# %{__libtoolize}
+# %{__aclocal}
+# %{__autoconf}
+# %{__autoheader}
+# %{__automake}
 %configure \
+  --with-boost-system=boost_system \
+  --with-boost-serialization=boost_serialization \
+  --with-boost-filesystem=boost_filesystem \
        --enable-debug=no
-%{__make}
+%{__make} -j1 LDFLAGS=-lboost_system
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -57,6 +62,8 @@ rm -rf $RPM_BUILD_ROOT
 # No public headers => no need for devel files
 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
 
+rm -rf $RPM_BUILD_ROOT/usr/share/locale/{fr_FR,pt_PT}
+
 %find_lang %{name}
 
 %clean
@@ -69,5 +76,5 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
 %attr(755,root,root) %{_bindir}/encfs*
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%attr(755,root,root) %{_libdir}/lib*.so*
 %{_mandir}/man1/*.1*
This page took 0.077524 seconds and 4 git commands to generate.