]> git.pld-linux.org Git - packages/enblend-enfuse.git/commitdiff
- fix building with gcc11 c++, rel 4 master auto/th/enblend-enfuse-4.2-4
authorJan Rękorajski <baggins@pld-linux.org>
Fri, 3 Dec 2021 20:44:31 +0000 (21:44 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Fri, 3 Dec 2021 20:44:31 +0000 (21:44 +0100)
enblend-enfuse.spec
gcc11.patch [new file with mode: 0644]

index 8358487250d2404b9e0d5acb14049fb8ef43332a..b5755b3714df58eee0ffc44d6ec74443ee9374cd 100644 (file)
@@ -8,11 +8,12 @@ Summary:      Image blending with multiresolution splines
 Summary(pl.UTF-8):     Łączenie zdjęć przy użyciu splajnów wielokrotnej rozdzielczości
 Name:          enblend-enfuse
 Version:       4.2
-Release:       3
+Release:       4
 License:       GPL v2+
 Group:         Applications/Graphics
 Source0:       http://downloads.sourceforge.net/enblend/%{name}-%{version}.tar.gz
 # Source0-md5: e26751f393862cecfd1a113003787001
+Patch0:                gcc11.patch
 URL:           http://enblend.sourceforge.net/
 BuildRequires: OpenEXR-devel >= 1.0
 BuildRequires: OpenGL-GLU-devel
@@ -61,8 +62,10 @@ przynajmniej bardzo trudne do zobaczenia. Enblend nie wyrównuje zdjęć
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
+export CXXFLAGS="%{rpmcxxflags} -std=gnu++14"
 %configure \
        %{?with_openmp:--enable-openmp --disable-image-cache}
        %{!?with_tcmalloc:--without-tcmalloc}
diff --git a/gcc11.patch b/gcc11.patch
new file mode 100644 (file)
index 0000000..cbb4251
--- /dev/null
@@ -0,0 +1,77 @@
+diff -r ef8470f9d682 src/anneal.h
+--- a/src/anneal.h     Sun Feb 12 15:25:10 2017 +0100
++++ b/src/anneal.h     Tue Jul 28 10:48:23 2020 +0100
+@@ -29,6 +29,7 @@
+ #include <algorithm>
+ #include <limits>
+ #include <vector>
++#include <limits>
+ #ifdef _WIN32
+ #include <cmath>
+diff -r ef8470f9d682 src/exposure_weight.cc
+--- a/src/exposure_weight.cc   Sun Feb 12 15:25:10 2017 +0100
++++ b/src/exposure_weight.cc   Tue Jul 28 10:48:23 2020 +0100
+@@ -21,6 +21,7 @@
+ #include <cassert>
+ #include <iostream>
++#include <limits>
+ #include "global.h"
+ #include "openmp_def.h"         // omp::atomic_t
+diff -r ef8470f9d682 src/fixmath.h
+--- a/src/fixmath.h    Sun Feb 12 15:25:10 2017 +0100
++++ b/src/fixmath.h    Tue Jul 28 10:48:23 2020 +0100
+@@ -27,6 +27,7 @@
+ #endif
+ #include <cmath>
++#include <limits>
+ #include <time.h>
+diff -r ef8470f9d682 src/minimizer.h
+--- a/src/minimizer.h  Sun Feb 12 15:25:10 2017 +0100
++++ b/src/minimizer.h  Tue Jul 28 10:48:23 2020 +0100
+@@ -26,6 +26,7 @@
+ #include <config.h>
+ #endif
++#include <limits>
+ #include <string>
+ #include <stdexcept>
+ #include <vector>
+diff -r ef8470f9d682 src/opencl.h
+--- a/src/opencl.h     Sun Feb 12 15:25:10 2017 +0100
++++ b/src/opencl.h     Tue Jul 28 10:48:23 2020 +0100
+@@ -37,6 +37,7 @@
+ #include <thread>
+ #include <type_traits>          // std::add_const
+ #include <vector>
++#include <limits>
+ #define __CL_ENABLE_EXCEPTIONS
+diff -r ef8470f9d682 src/openmp_vigra.h
+--- a/src/openmp_vigra.h       Sun Feb 12 15:25:10 2017 +0100
++++ b/src/openmp_vigra.h       Tue Jul 28 10:48:23 2020 +0100
+@@ -31,6 +31,7 @@
+ #include <vigra/combineimages.hxx>
+ #include <vigra/convolution.hxx>
+ #include <vigra/distancetransform.hxx>
++#include <limits>
+ #include "openmp_def.h"
+diff -r ef8470f9d682 src/self_test.cc
+--- a/src/self_test.cc Sun Feb 12 15:25:10 2017 +0100
++++ b/src/self_test.cc Tue Jul 28 10:48:23 2020 +0100
+@@ -34,6 +34,7 @@
+ #include <cmath>                // fabsf
+ #include <iostream>
+ #include <string>
++#include <limits>
+ #include "self_test.h"
This page took 0.08815 seconds and 4 git commands to generate.