]> git.pld-linux.org Git - packages/enblend-enfuse.git/blob - enblend-enfuse.spec
- fix building with gcc11 c++, rel 4
[packages/enblend-enfuse.git] / enblend-enfuse.spec
1 # NOTE: g++ eats 700+MB of memory
2 #
3 # Conditional build:
4 %bcond_with     openmp          # OpenMP support (incompatible with image-cache)
5 %bcond_without  tcmalloc        # use of Google TCMalloc library
6 #
7 Summary:        Image blending with multiresolution splines
8 Summary(pl.UTF-8):      Łączenie zdjęć przy użyciu splajnów wielokrotnej rozdzielczości
9 Name:           enblend-enfuse
10 Version:        4.2
11 Release:        2
12 License:        GPL v2+
13 Group:          Applications/Graphics
14 Source0:        http://downloads.sourceforge.net/enblend/%{name}-%{version}.tar.gz
15 # Source0-md5:  e26751f393862cecfd1a113003787001
16 URL:            http://enblend.sourceforge.net/
17 BuildRequires:  OpenEXR-devel >= 1.0
18 BuildRequires:  OpenGL-GLU-devel
19 BuildRequires:  OpenGL-glut-devel
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake
22 BuildRequires:  boost-devel >= 1.55
23 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
24 BuildRequires:  glew-devel
25 BuildRequires:  gnuplot
26 BuildRequires:  gsl-devel
27 BuildRequires:  help2man
28 BuildRequires:  lcms2-devel >= 2
29 %{?with_openmp:BuildRequires:   libgomp-devel}
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel
32 BuildRequires:  libstdc++-devel >= 5:4.3
33 %{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
34 BuildRequires:  libtiff-devel
35 BuildRequires:  perl-TimeDate
36 BuildRequires:  perl-base
37 BuildRequires:  pkgconfig
38 BuildRequires:  texinfo
39 BuildRequires:  tidy
40 BuildRequires:  transfig
41 BuildRequires:  vigra-devel >= 1.8
42 BuildRequires:  zlib-devel
43 Requires:       vigra >= 1.8
44 Provides:       enblend = %{version}
45 Obsoletes:      enblend
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 Enblend is a tool for compositing images. Given a set of images that
50 overlap in some irregular way, Enblend overlays them in such a way
51 that the seam between the images is invisible, or at least very
52 difficult to see. Enblend does not line up the images for you. Use a
53 tool like Hugin to do that.
54
55 %description -l pl.UTF-8
56 Enblend to narzędzie do łączenia zdjęć. Po przekazaniu zbioru zdjęć
57 nachodzących na siebie w jakiś nieregularny sposób Enblend nakłada je
58 w taki sposób, że połączenia między zdjęciami są niewidoczne, albo
59 przynajmniej bardzo trudne do zobaczenia. Enblend nie wyrównuje zdjęć
60 - do tego można użyć narzędzia takiego jak Hugin.
61
62 %prep
63 %setup -q
64
65 %build
66 %configure \
67         %{?with_openmp:--enable-openmp --disable-image-cache}
68         %{!?with_tcmalloc:--without-tcmalloc}
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/postshell
81 -/usr/sbin/fix-info-dir -c %{_infodir}
82
83 %postun -p /sbin/postshell
84 -/usr/sbin/fix-info-dir -c %{_infodir}
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS ChangeLog NEWS README
89 %attr(755,root,root) %{_bindir}/enblend
90 %attr(755,root,root) %{_bindir}/enfuse
91 %{_mandir}/man1/enblend.1*
92 %{_mandir}/man1/enfuse.1*
This page took 0.102308 seconds and 3 git commands to generate.