]> git.pld-linux.org Git - packages/empathy.git/commitdiff
- updated to 3.12.11 auto/th/empathy-3.12.11-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Jan 2016 22:54:59 +0000 (23:54 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 23 Jan 2016 22:54:59 +0000 (23:54 +0100)
- added uoa bcond

empathy.spec

index c6a710956d05d3c53da6af69b7cb24bfc8f1ed3e..580d01972b665c583609c7550bc68ecb89d7b66b 100644 (file)
@@ -1,12 +1,16 @@
+#
+# Conditional build:
+%bcond_with    uoa     # Ubuntu Online Accounts (single-signon)
+#
 Summary:       High-level library and user-interface for Telepathy
 Summary(pl.UTF-8):     Bardzo łatwy w użyciu klient Telepathy dla GNOME
 Name:          empathy
-Version:       3.12.10
+Version:       3.12.11
 Release:       1
 License:       GPL v2+
 Group:         Applications/Communications
 Source0:       https://download.gnome.org/sources/empathy/3.12/%{name}-%{version}.tar.xz
-# Source0-md5: 973441ea1db00d9c3b0e9bc90292601d
+# Source0-md5: 08636d1f04b94282f384ca5ed8482eab
 URL:           http://live.gnome.org/Empathy
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
@@ -20,7 +24,7 @@ BuildRequires:        enchant-devel >= 1.2.0
 BuildRequires: farstream-devel >= 0.2.0
 BuildRequires: folks-devel >= 0.9.5
 BuildRequires: gcr-devel >= 2.91.4
-BuildRequires: geoclue2-devel >= 1.99.3
+BuildRequires: geoclue2-devel >= 2.1.0
 BuildRequires: geocode-glib-devel >= 0.99.1
 BuildRequires: gettext-tools
 BuildRequires: glib2-devel >= 1:2.38.0
@@ -33,19 +37,22 @@ BuildRequires:      gtk+3-devel >= 3.10.0
 BuildRequires: gtk-webkit3-devel >= 1.10.0
 BuildRequires: intltool >= 0.50.0
 BuildRequires: iso-codes >= 0.35
+%{?with_uoa:BuildRequires:     libaccount-plugin-devel}
+%{?with_uoa:BuildRequires:     libaccounts-glib-devel >= 1.4}
 BuildRequires: libcanberra-gtk3-devel >= 0.25
 BuildRequires: libchamplain-devel >= 0.12.1
 BuildRequires: libgee-devel >= 0.8.0
 BuildRequires: libnotify-devel >= 0.7.0
 BuildRequires: libsecret-devel >= 0.5
+%{?with_uoa:BuildRequires:     libsignon-glib-devel >= 1.8}
 BuildRequires: libsoup-devel
 BuildRequires: libtool >= 2:2.2
 BuildRequires: libxml2-devel >= 1:2.6.28
 BuildRequires: libxslt-progs
-BuildRequires: pkgconfig
+BuildRequires: pkgconfig >= 1:0.25
 BuildRequires: pulseaudio-devel
-BuildRequires: python >= 2.3
-BuildRequires: python-modules >= 2.3
+BuildRequires: python >= 1:2.3
+BuildRequires: python-modules >= 1:2.3
 BuildRequires: rpmbuild(find_lang) >= 1.23
 BuildRequires: rpmbuild(macros) >= 1.592
 BuildRequires: tar >= 1:1.22
@@ -57,12 +64,33 @@ BuildRequires:      udev-glib-devel
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xz
 BuildRequires: yelp-tools
-Requires(post,postun): glib2 >= 1:2.26.0
+Requires(post,postun): glib2 >= 1:2.38.0
 Requires(post,postun): gtk-update-icon-cache
+Requires:      cheese >= 3.4.0
+Requires:      clutter >= 1.10.0
+Requires:      clutter-gst >= 1.9.92
+Requires:      clutter-gtk >= 1.2.0
+Requires:      cogl-devel >= 1.14.0
+Requires:      enchant >= 1.2.0
 Requires:      evolution-data-server
 Requires:      folks >= 0.9.5
+Requires:      gcr >= 2.91.4
+Requires:      geoclue2 >= 2.1.0
+Requires:      geocode-glib >= 0.99.1
+Requires:      glib2 >= 1:2.38.0
+Requires:      gnome-online-accounts >= 3.5.1
+Requires:      gnutls >= 2.8.5
 Requires:      gsettings-desktop-schemas
+Requires:      gtk+3 >= 3.10.0
+Requires:      gtk-webkit3 >= 1.10.0
 Requires:      hicolor-icon-theme
+%{?with_uoa:Requires:  libaccounts-glib >= 1.4}
+Requires:      libcanberra-gtk3 >= 0.25
+Requires:      libchamplain >= 0.12.1
+Requires:      libnotify >= 0.7.0
+Requires:      libsecret >= 0.5
+%{?with_uoa:Requires:  libsignon-glib >= 1.8}
+Requires:      telepathy-farstream >= 0.6.0
 Requires:      telepathy-glib >= 0.24.0
 Requires:      telepathy-logger >= 0.8.0
 Requires:      telepathy-mission-control >= 5.13.1
@@ -108,13 +136,13 @@ jak to tylko możliwe.
        --disable-silent-rules \
        --disable-static \
        --enable-goa \
+       --enable-gst-1.0 \
        --enable-gudev \
        --enable-location \
        --enable-map \
        --disable-nautilus-sendto \
        --enable-spell \
-       --enable-gst-1.0 \
-       --disable-ubuntu-online-accounts
+       --enable-ubuntu-online-accounts%{!?with_uoa:=no}
 
 %{__make} -j1
 
@@ -142,7 +170,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS CONTRIBUTORS ChangeLog NEWS README
+%doc AUTHORS CONTRIBUTORS ChangeLog NEWS README TODO
 %attr(755,root,root) %{_bindir}/empathy
 %attr(755,root,root) %{_bindir}/empathy-accounts
 %attr(755,root,root) %{_bindir}/empathy-debugger
This page took 0.095453 seconds and 4 git commands to generate.