]> git.pld-linux.org Git - packages/emby-server.git/blob - emby-server.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/emby-server.git] / emby-server.spec
1 # TODO
2 # - emby user
3 %include        /usr/lib/rpm/macros.mono
4 Summary:        Emby: home media server
5 Name:           emby-server
6 Version:        3.0.5607.2
7 Release:        0.1
8 License:        GPL
9 Group:          Applications/Multimedia
10 Source0:        https://github.com/MediaBrowser/MediaBrowser/archive/%{version}.tar.gz
11 # Source0-md5:  84f0e9a3ee083622562cae203583a65b
12 URL:            http://emby.media/
13 BuildRequires:  mono >= 3.2.7
14 BuildRequires:  rpmbuild(macros) >= 1.268
15 BuildRequires:  rpmbuild(monoautodeps)
16 Requires:       ImageMagick >= 6.8
17 Requires:       libmediainfo
18 Requires:       mono >= 3.2.7
19 Requires:       sqlite3 >= 3.8.2
20 Obsoletes:      MediaBrowserServer
21 Obsoletes:      MediaBrowserServer-dev
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _appdir %{_prefix}/lib/%{name}
26
27 %description
28 Emby (formely known as Media Browser) is a home media server built on
29 top of other popular open source technologies such as Service Stack,
30 jQuery, jQuery mobile, and Mono. It features a REST-based api with
31 built-in documention to facilitate client development. We also have
32 client libraries for our API to enable rapid development.
33
34 %prep
35 %setup -qc
36 mv MediaBrowser-%{version} src
37 install -d bin
38
39 %build
40 cd src
41 xbuild /p:Configuration="Release Mono" /p:Platform="Any CPU" /t:clean MediaBrowser.Mono.sln
42 xbuild /p:Configuration="Release Mono" /p:Platform="Any CPU" /t:build MediaBrowser.Mono.sln
43
44 mv MediaBrowser.Server.Mono/bin/Release\ Mono/* ../bin
45 cd ..
46
47 rm -v bin/lib*.dylib
48 rm -v bin/MediaInfo/osx/lib*.dylib
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_appdir}
53 cp -a bin/* $RPM_BUILD_ROOT%{_appdir}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %dir %{_appdir}
61 %{_appdir}/BDInfo.dll
62 %{_appdir}/DvdLib.dll
63 %{_appdir}/Emby.Drawing.dll
64 %{_appdir}/Emby.Drawing.dll.mdb
65 %{_appdir}/ImageMagickSharp.dll
66 %{_appdir}/ImageMagickSharp.dll.config
67 %{_appdir}/Interfaces.IO.dll
68 %{_appdir}/MediaBrowser.Api.dll
69 %{_appdir}/MediaBrowser.Common.Implementations.dll
70 %{_appdir}/MediaBrowser.Common.dll
71 %{_appdir}/MediaBrowser.Controller.dll
72 %{_appdir}/MediaBrowser.Dlna.dll
73 %{_appdir}/MediaBrowser.IsoMounting.Linux.dll
74 %{_appdir}/MediaBrowser.LocalMetadata.dll
75 %{_appdir}/MediaBrowser.MediaEncoding.dll
76 %{_appdir}/MediaBrowser.MediaInfo.dll
77 %{_appdir}/MediaBrowser.MediaInfo.dll.config
78 %{_appdir}/MediaBrowser.Model.dll
79 %{_appdir}/MediaBrowser.Model.dll.mdb
80 %{_appdir}/MediaBrowser.Naming.dll
81 %{_appdir}/MediaBrowser.Providers.dll
82 %{_appdir}/MediaBrowser.Server.Implementations.dll
83 %{_appdir}/MediaBrowser.Server.Mono.exe
84 %{_appdir}/MediaBrowser.Server.Mono.exe.config
85 %{_appdir}/MediaBrowser.Server.Startup.Common.dll
86 %{_appdir}/MediaBrowser.WebDashboard.dll
87 %{_appdir}/MediaBrowser.XbmcMetadata.dll
88 %{_appdir}/Mono.Nat.dll
89 %{_appdir}/Mono.Posix.dll
90 %{_appdir}/MoreLinq.dll
91 %{_appdir}/NLog.dll
92 %{_appdir}/OpenSubtitlesHandler.dll
93 %{_appdir}/Patterns.Logging.dll
94 %{_appdir}/ServiceStack.Api.Swagger.dll
95 %{_appdir}/ServiceStack.Client.dll
96 %{_appdir}/ServiceStack.Common.dll
97 %{_appdir}/ServiceStack.Interfaces.dll
98 %{_appdir}/ServiceStack.Text.dll
99 %{_appdir}/ServiceStack.dll
100 %{_appdir}/SharpCompress.dll
101 %{_appdir}/SimpleInjector.dll
102 %{_appdir}/SocketHttpListener.dll
103 %{_appdir}/System.Data.SQLite.dll
104 %{_appdir}/System.Data.SQLite.dll.config
105 %{_appdir}/UniversalDetector.dll
106 %{_appdir}/WebMarkupMin.Core.dll
107 %{_appdir}/taglib-sharp.dll
108
109 %{_appdir}/dashboard-ui
110 %{_appdir}/swagger-ui
This page took 0.125301 seconds and 3 git commands to generate.