]> git.pld-linux.org Git - packages/emacsen-ecb-pkg.git/blame - emacsen-ecb-pkg.spec
- use standard requires_eq macro, cleanups
[packages/emacsen-ecb-pkg.git] / emacsen-ecb-pkg.spec
CommitLineData
49c7f811
ER
1# TODO
2# - build for xemacs
5c116cf1
JB
3#
4# Conditional build:
637ed623 5%bcond_with xemacs # Build without XEmacs support
6%bcond_without emacs # Build without GNU Emacs support
5c116cf1 7#
637ed623 8%define _the_name ecb
9Summary: Emacs Code Browser IDE
c4e2cbee 10Summary(pl.UTF-8): Środowisko programistyczne dla Emacsa
637ed623 11Name: emacsen-%{_the_name}-pkg
d753fbf3 12Version: 2.26
637ed623 13Release: 0.1
14License: GPL
15Group: Applications/Editors/Emacs
5c116cf1 16Source0: http://dl.sourceforge.net/ecb/%{_the_name}-%{version}.tar.gz
d753fbf3 17# Source0-md5: 89bea4c856b96a943e83f14ef650e753
07bdc331 18URL: http://ecb.sourceforge.net/
637ed623 19BuildRequires: emacsen-cedet-pkg
20%if %{with emacs}
21BuildRequires: emacs
22%endif
23%if %{with xemacs}
24BuildRequires: xemacs
25%endif
26Requires: cedet-elisp-code = %{version}-%{release}
27Conflicts: xemacs-cedet-pkg
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32ECB is a global minor-mode which offers a couple of ECB-windows for
33browsing your sources comfortable with the mouse and the keyboard.
34
35This package contains files common to both GNU Emacs and XEmacs.
36
acc250e2
JR
37%description -l pl.UTF-8
38ECB jest globalnym minor mode wyświetlającym kilka własnych okienek
39ułatwiających przeglądanie kodu myszą i klawiaturą.
637ed623 40
acc250e2 41Ten pakiet zawiera pliki wspólne dla GNU Emacsa i XEmacsa.
637ed623 42
637ed623 43%package emacs
44Summary: ECB compiled elisp files for GNU Emacs
c4e2cbee 45Summary(pl.UTF-8): Skompilowany kod elisp ECB dla GNU Emacsa
637ed623 46Group: Applications/Editors/Emacs
47Requires: %{name} = %{version}-%{release}
637ed623 48Provides: cedet-elisp-code = %{version}-%{release}
49c7f811 49%requires_eq emacs
637ed623 50
51%description emacs
52This package contains compiled elisp files needed to run ECB on GNU Emacs
53
acc250e2 54%description emacs -l pl.UTF-8
637ed623 55Pakiet zawiera skompilowane pliki elisp z kodem ECB dla GNU Emacsa.
56
57%package emacs-el
58Summary: ECB elisp files for GNU Emacs
c4e2cbee 59Summary(pl.UTF-8): Kod elisp ECB dla GNU Emacsa
637ed623 60Group: Applications/Editors/Emacs
61Requires: %{name}-emacs = %{version}-%{release}
62
63%description emacs-el
64This package contains ECB source elisp files for GNU Emacs
65
acc250e2
JR
66%description emacs-el -l pl.UTF-8
67Pakiet zawiera źródłowe pliki elisp z kodem ECB dla GNU Emacsa.
637ed623 68
637ed623 69%package xemacs
70Summary: ECB elisp files for XEmacs
c4e2cbee 71Summary(pl.UTF-8): Kod elisp ECB dla XEmacsa
637ed623 72Group: Applications/Editors/Emacs
73Requires: %{name} = %{version}-%{release}
637ed623 74Provides: cedet-elisp-code = %{version}-%{release}
49c7f811 75%requires_eq xemacs
637ed623 76
77%description xemacs
78This package contains compiled elisp files needed to run ECB on XEmacs
79
acc250e2 80%description xemacs -l pl.UTF-8
637ed623 81Pakiet zawiera skompilowane pliki elisp z kodem ECB dla XEmacsa.
82
83%package xemacs-el
84Summary: ECB elisp source files for XEmacs
c4e2cbee 85Summary(pl.UTF-8): Kod źródłowy elisp ECB dla XEmacsa
637ed623 86Group: Applications/Editors/Emacs
87Requires: %{name}-xemacs = %{version}-%{release}
88
89%description xemacs-el
07bdc331 90This package contains source ECB elisp files for XEmacs
637ed623 91
acc250e2
JR
92%description xemacs-el -l pl.UTF-8
93Pakiet zawiera pliki źródłowe elisp z kodem ECB dla XEmacsa.
637ed623 94
95%prep
96%setup -q -n %{_the_name}-%{version}
97
637ed623 98%build
637ed623 99%if %{with xemacs}
100mkdir _xemacs
101%endif
102
103%if %{with emacs}
104mkdir _emacs
5c116cf1 105cp -a [!_]* _emacs
637ed623 106%{__make} -C _emacs \
107 EMACS=emacs \
108 CEDET=%{_datadir}/emacs/cedet
109%endif
110
111%install
07bdc331 112rm -rf $RPM_BUILD_ROOT
5c116cf1 113install -d $RPM_BUILD_ROOT%{_infodir}
637ed623 114
115%if %{with xemacs}
116%endif
117
118%if %{with emacs}
5c116cf1
JB
119install -d $RPM_BUILD_ROOT%{_emacs_lispdir}
120install _emacs/*.{el,elc} $RPM_BUILD_ROOT%{_emacs_lispdir}
d753fbf3 121rm _emacs/ecb-images/klaus.sh
122cp -a _emacs/ecb-images $RPM_BUILD_ROOT%{_emacs_lispdir}
637ed623 123%endif
124
5c116cf1 125install info-help/* $RPM_BUILD_ROOT%{_infodir}
637ed623 126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%files
131%defattr(644,root,root,755)
132%doc NEWS README RELEASE_NOTES html-help
5c116cf1 133%{_infodir}/*.info*
637ed623 134
135%if %{with emacs}
136%files emacs
137%defattr(644,root,root,755)
138%{_emacs_lispdir}/*.elc
d753fbf3 139%{_emacs_lispdir}/ecb-images
637ed623 140%{_emacs_lispdir}/ecb-autoloads.el
141
142%files emacs-el
143%defattr(644,root,root,755)
144# All except ecb-autoloads.el
5c116cf1
JB
145%{_emacs_lispdir}/[!e]*.el
146%{_emacs_lispdir}/ecb-[!a]*.el
637ed623 147%{_emacs_lispdir}/ecb-autogen.el
148%endif
149
150%if %{with xemacs}
151%files xemacs
152%defattr(644,root,root,755)
153%dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
154%{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
155%{_datadir}/xemacs-packages/etc/%{_the_name}
156
157%files xemacs-el
158%defattr(644,root,root,755)
159%{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
160%endif
This page took 0.116475 seconds and 4 git commands to generate.