]> git.pld-linux.org Git - packages/emacsen-cedet-pkg.git/blob - emacsen-cedet-pkg.spec
- unified, use subver macro
[packages/emacsen-cedet-pkg.git] / emacsen-cedet-pkg.spec
1 # TODO: build for xemacs
2 #
3 # Conditional build:
4 %bcond_with     xemacs  # Build without XEmacs support
5 %bcond_without  emacs   # Build without GNU Emacs support
6 #
7 %define         _the_name cedet
8 Summary:        Collection of Emacs development tools
9 Summary(pl.UTF-8):      Zbiór narzędzi programistycznych dla Emacsa
10 Name:           emacsen-cedet-pkg
11 Version:        1.0
12 %define subver  beta3b
13 Release:        0.%{subver}.1
14 License:        GPL
15 Group:          Applications/Editors/Emacs
16 Source0:        http://dl.sourceforge.net/cedet/%{_the_name}-%{version}%{subver}.tar.gz
17 # Source0-md5:  f24a07c8c934596fb33a81b653edaf73
18 URL:            http://cedet.sourceforge.net/
19 BuildRequires:  texinfo
20 %if %{with emacs}
21 BuildRequires:  emacs
22 %endif
23 %if %{with xemacs}
24 BuildRequires:  xemacs
25 %endif
26 Requires:       cedet-elisp-code = %{version}-%{release}
27 Conflicts:      xemacs-cedet-pkg
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 CEDET is a collection of tools written with the end goal of creating
33 an advanced development environment in Emacs.
34
35 This package contains files common to both GNU Emacs and XEmacs.
36
37 %description -l pl.UTF-8
38 CEDET jest zbiorem narzędzi stworzonych z myślą o utworzeniu
39 zaawansowanego środowiska programistycznego w Emacsie.
40
41 Ten pakiet zawiera pliki CEDET wspólne dla GNU Emacsa i XEmacsa.
42
43 %package emacs
44 Summary:        CEDET compiled elisp files for GNU Emacs
45 Summary(pl.UTF-8):      Skompilowany kod elisp CEDET dla GNU Emacsa
46 Group:          Applications/Editors/Emacs
47 Requires:       %{name} = %{version}-%{release}
48 %requires_eq    emacs
49 Provides:       cedet-elisp-code = %{version}-%{release}
50
51 %description emacs
52 This package contains compiled elisp files needed to run CEDET on GNU Emacs
53
54 %description emacs -l pl.UTF-8
55 Pakiet zawiera skompilowane pliki elisp z kodem CEDET dla GNU Emacsa.
56
57 %package emacs-el
58 Summary:        CEDET elisp files for GNU Emacs
59 Summary(pl.UTF-8):      Kod elisp CEDET dla GNU Emacsa
60 Group:          Applications/Editors/Emacs
61 Requires:       %{name}-emacs = %{version}-%{release}
62
63 %description emacs-el
64 This package contains CEDET source elisp files for GNU Emacs
65
66 %description emacs-el -l pl.UTF-8
67 Pakiet zawiera źródłowe pliki elisp z kodem CEDET dla GNU Emacsa.
68
69 %package xemacs
70 Summary:        CEDET elisp files for XEmacs
71 Summary(pl.UTF-8):      Kod elisp CEDET dla XEmacsa
72 Group:          Applications/Editors/Emacs
73 Requires:       %{name} = %{version}-%{release}
74 %requires_eq    xemacs
75 Provides:       cedet-elisp-code = %{version}-%{release}
76
77 %description xemacs
78 This package contains compiled elisp files needed to run CEDET on XEmacs
79
80 %description xemacs -l pl.UTF-8
81 Pakiet zawiera skompilowane pliki elisp z kodem CEDET dla XEmacsa.
82
83 %package xemacs-el
84 Summary:        CEDET elisp source files for XEmacs
85 Summary(pl.UTF-8):      Kod źródłowy elisp CEDET dla XEmacsa
86 Group:          Applications/Editors/Emacs
87 Requires:       %{name}-xemacs = %{version}-%{release}
88
89 %description xemacs-el
90 This package contains source CEDET elisp files for XEmacs
91
92 %description xemacs-el -l pl.UTF-8
93 Pakiet zawiera pliki źródłowe elisp z kodem CEDET dla XEmacsa.
94
95 %prep
96 %setup -q -n %{_the_name}-%{version}%{subver}
97
98 %build
99 # Move documentation
100 for F in */{INSTALL,README,ChangeLog,AUTHORS,NEWS,ONEWS}; do \
101         cp $F `echo $F | sed 's-\(.*\)/\(.*\)-\2.\1-'`; done
102
103 %if %{with xemacs}
104 mkdir _xemacs
105 %endif
106
107 %if %{with emacs}
108 mkdir _emacs
109 cp -a [!_]* _emacs
110 %{__make} -C _emacs \
111         EMACS=emacs
112 %endif
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT%{_infodir}
117
118 %if %{with xemacs}
119 %endif
120
121 %if %{with emacs}
122 install -d $RPM_BUILD_ROOT{%{_emacs_lispdir},%{_datadir}/emacs/cedet}
123 cp -a _emacs/* $RPM_BUILD_ROOT%{_datadir}/emacs/cedet/
124 cat > $RPM_BUILD_ROOT%{_emacs_lispdir}/cedet.el <<'EOF'
125 ;; Load CEDET
126 (load-file "%{_datadir}/emacs/cedet/common/cedet.elc")
127 ;; Enabling SEMANTIC minor modes.  See semantic/INSTALL for more ideas.
128 (semantic-load-enable-code-helpers)
129 EOF
130
131 cd _emacs \
132         && find . -name '*.info*' -print0 \
133         | xargs -0  sh -c 'install "$@" '$RPM_BUILD_ROOT%{_infodir}
134 %endif
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %files
140 %defattr(644,root,root,755)
141 %doc INSTALL* README* ChangeLog* AUTHORS* NEWS* ONEWS*
142 %{_infodir}/*.info*
143
144 %if %{with emacs}
145 %files emacs
146 %defattr(644,root,root,755)
147 %dir %{_datadir}/emacs/%{_the_name}
148 %dir %{_datadir}/emacs/%{_the_name}/[a-z]*
149 %dir %{_datadir}/emacs/%{_the_name}/semantic/wisent
150 %dir %{_datadir}/emacs/%{_the_name}/semantic/bovine
151 %{_datadir}/emacs/%{_the_name}/common/icons
152 %{_datadir}/emacs/%{_the_name}/*/Project.ede
153 %{_datadir}/emacs/%{_the_name}/*/*.elc
154 %{_datadir}/emacs/%{_the_name}/*/*.wy
155 %{_datadir}/emacs/%{_the_name}/semantic/*/Project.ede
156 %{_datadir}/emacs/%{_the_name}/semantic/*/*.elc
157 %{_datadir}/emacs/%{_the_name}/semantic/wisent/*.wy
158 %{_datadir}/emacs/%{_the_name}/semantic/bovine/*.by
159 %{_datadir}/emacs/%{_the_name}/speedbar/*.xpm
160 %{_emacs_lispdir}/cedet.el
161
162 %files emacs-el
163 %defattr(644,root,root,755)
164 %{_datadir}/emacs/%{_the_name}/*/*.el
165 %{_datadir}/emacs/%{_the_name}/*/*/*.el
166 %endif
167
168 %if %{with xemacs}
169 %files xemacs
170 %defattr(644,root,root,755)
171 %dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
172 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
173 %{_datadir}/xemacs-packages/etc/%{_the_name}
174
175 %files xemacs-el
176 %defattr(644,root,root,755)
177 %{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
178 %endif
This page took 0.092514 seconds and 3 git commands to generate.