]> git.pld-linux.org Git - packages/emacsen-cedet-pkg.git/blame - emacsen-cedet-pkg.spec
- unified, use subver macro
[packages/emacsen-cedet-pkg.git] / emacsen-cedet-pkg.spec
CommitLineData
70a67a5b 1# TODO: build for xemacs
b11f5db8
JB
2#
3# Conditional build:
70a67a5b 4%bcond_with xemacs # Build without XEmacs support
5%bcond_without emacs # Build without GNU Emacs support
b11f5db8 6#
70a67a5b 7%define _the_name cedet
70a67a5b 8Summary: Collection of Emacs development tools
c821aef7 9Summary(pl.UTF-8): Zbiór narzędzi programistycznych dla Emacsa
70a67a5b 10Name: emacsen-cedet-pkg
11Version: 1.0
ff97c521
JB
12%define subver beta3b
13Release: 0.%{subver}.1
70a67a5b 14License: GPL
15Group: Applications/Editors/Emacs
ff97c521 16Source0: http://dl.sourceforge.net/cedet/%{_the_name}-%{version}%{subver}.tar.gz
70a67a5b 17# Source0-md5: f24a07c8c934596fb33a81b653edaf73
2a2b236f 18URL: http://cedet.sourceforge.net/
70a67a5b 19BuildRequires: texinfo
20%if %{with emacs}
21BuildRequires: emacs
22%endif
23%if %{with xemacs}
24BuildRequires: xemacs
25%endif
26Requires: cedet-elisp-code = %{version}-%{release}
27Conflicts: xemacs-cedet-pkg
28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32CEDET is a collection of tools written with the end goal of creating
33an advanced development environment in Emacs.
34
35This package contains files common to both GNU Emacs and XEmacs.
36
0d6e8f42
JR
37%description -l pl.UTF-8
38CEDET jest zbiorem narzędzi stworzonych z myślą o utworzeniu
39zaawansowanego środowiska programistycznego w Emacsie.
70a67a5b 40
0d6e8f42 41Ten pakiet zawiera pliki CEDET wspólne dla GNU Emacsa i XEmacsa.
70a67a5b 42
70a67a5b 43%package emacs
44Summary: CEDET compiled elisp files for GNU Emacs
c821aef7 45Summary(pl.UTF-8): Skompilowany kod elisp CEDET dla GNU Emacsa
63ccacd8 46Group: Applications/Editors/Emacs
70a67a5b 47Requires: %{name} = %{version}-%{release}
ff97c521 48%requires_eq emacs
70a67a5b 49Provides: cedet-elisp-code = %{version}-%{release}
50
51%description emacs
52This package contains compiled elisp files needed to run CEDET on GNU Emacs
53
0d6e8f42 54%description emacs -l pl.UTF-8
70a67a5b 55Pakiet zawiera skompilowane pliki elisp z kodem CEDET dla GNU Emacsa.
56
57%package emacs-el
58Summary: CEDET elisp files for GNU Emacs
c821aef7 59Summary(pl.UTF-8): Kod elisp CEDET dla GNU Emacsa
63ccacd8 60Group: Applications/Editors/Emacs
70a67a5b 61Requires: %{name}-emacs = %{version}-%{release}
62
63%description emacs-el
64This package contains CEDET source elisp files for GNU Emacs
65
0d6e8f42
JR
66%description emacs-el -l pl.UTF-8
67Pakiet zawiera źródłowe pliki elisp z kodem CEDET dla GNU Emacsa.
70a67a5b 68
70a67a5b 69%package xemacs
70Summary: CEDET elisp files for XEmacs
c821aef7 71Summary(pl.UTF-8): Kod elisp CEDET dla XEmacsa
63ccacd8 72Group: Applications/Editors/Emacs
70a67a5b 73Requires: %{name} = %{version}-%{release}
ff97c521 74%requires_eq xemacs
70a67a5b 75Provides: cedet-elisp-code = %{version}-%{release}
76
77%description xemacs
78This package contains compiled elisp files needed to run CEDET on XEmacs
79
0d6e8f42 80%description xemacs -l pl.UTF-8
70a67a5b 81Pakiet zawiera skompilowane pliki elisp z kodem CEDET dla XEmacsa.
82
83%package xemacs-el
84Summary: CEDET elisp source files for XEmacs
c821aef7 85Summary(pl.UTF-8): Kod źródłowy elisp CEDET dla XEmacsa
63ccacd8 86Group: Applications/Editors/Emacs
70a67a5b 87Requires: %{name}-xemacs = %{version}-%{release}
88
89%description xemacs-el
2a2b236f 90This package contains source CEDET elisp files for XEmacs
70a67a5b 91
0d6e8f42
JR
92%description xemacs-el -l pl.UTF-8
93Pakiet zawiera pliki źródłowe elisp z kodem CEDET dla XEmacsa.
70a67a5b 94
95%prep
ff97c521 96%setup -q -n %{_the_name}-%{version}%{subver}
70a67a5b 97
70a67a5b 98%build
70a67a5b 99# Move documentation
100for F in */{INSTALL,README,ChangeLog,AUTHORS,NEWS,ONEWS}; do \
101 cp $F `echo $F | sed 's-\(.*\)/\(.*\)-\2.\1-'`; done
102
103%if %{with xemacs}
104mkdir _xemacs
105%endif
106
107%if %{with emacs}
108mkdir _emacs
5aeccc56 109cp -a [!_]* _emacs
70a67a5b 110%{__make} -C _emacs \
111 EMACS=emacs
112%endif
113
114%install
2a2b236f 115rm -rf $RPM_BUILD_ROOT
5aeccc56 116install -d $RPM_BUILD_ROOT%{_infodir}
70a67a5b 117
118%if %{with xemacs}
119%endif
120
121%if %{with emacs}
5aeccc56 122install -d $RPM_BUILD_ROOT{%{_emacs_lispdir},%{_datadir}/emacs/cedet}
70a67a5b 123cp -a _emacs/* $RPM_BUILD_ROOT%{_datadir}/emacs/cedet/
1f41c422 124cat > $RPM_BUILD_ROOT%{_emacs_lispdir}/cedet.el <<'EOF'
70a67a5b 125;; Load CEDET
126(load-file "%{_datadir}/emacs/cedet/common/cedet.elc")
127;; Enabling SEMANTIC minor modes. See semantic/INSTALL for more ideas.
128(semantic-load-enable-code-helpers)
129EOF
130
131cd _emacs \
132 && find . -name '*.info*' -print0 \
133 | xargs -0 sh -c 'install "$@" '$RPM_BUILD_ROOT%{_infodir}
134%endif
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%files
140%defattr(644,root,root,755)
141%doc INSTALL* README* ChangeLog* AUTHORS* NEWS* ONEWS*
5aeccc56 142%{_infodir}/*.info*
70a67a5b 143
144%if %{with emacs}
145%files emacs
146%defattr(644,root,root,755)
147%dir %{_datadir}/emacs/%{_the_name}
148%dir %{_datadir}/emacs/%{_the_name}/[a-z]*
149%dir %{_datadir}/emacs/%{_the_name}/semantic/wisent
150%dir %{_datadir}/emacs/%{_the_name}/semantic/bovine
151%{_datadir}/emacs/%{_the_name}/common/icons
152%{_datadir}/emacs/%{_the_name}/*/Project.ede
153%{_datadir}/emacs/%{_the_name}/*/*.elc
154%{_datadir}/emacs/%{_the_name}/*/*.wy
155%{_datadir}/emacs/%{_the_name}/semantic/*/Project.ede
156%{_datadir}/emacs/%{_the_name}/semantic/*/*.elc
157%{_datadir}/emacs/%{_the_name}/semantic/wisent/*.wy
158%{_datadir}/emacs/%{_the_name}/semantic/bovine/*.by
159%{_datadir}/emacs/%{_the_name}/speedbar/*.xpm
160%{_emacs_lispdir}/cedet.el
161
162%files emacs-el
163%defattr(644,root,root,755)
164%{_datadir}/emacs/%{_the_name}/*/*.el
165%{_datadir}/emacs/%{_the_name}/*/*/*.el
166%endif
167
168%if %{with xemacs}
169%files xemacs
170%defattr(644,root,root,755)
171%dir %{_datadir}/xemacs-packages/lisp/%{_the_name}
172%{_datadir}/xemacs-packages/lisp/%{_the_name}/*.elc
173%{_datadir}/xemacs-packages/etc/%{_the_name}
174
175%files xemacs-el
176%defattr(644,root,root,755)
177%{_datadir}/xemacs-packages/lisp/%{_the_name}/*.el
178%endif
This page took 0.12361 seconds and 4 git commands to generate.