]> git.pld-linux.org Git - packages/elinks.git/commitdiff
- added pre-0.10 typeahead match start and pre-0.12 double escape behaviour,
authorTomasz Pala <gotar@pld-linux.org>
Mon, 6 Jun 2011 01:00:33 +0000 (01:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  bconded among with pre-0.10.2 type-ahead null history; enabled 88/true color

Changed files:
    elinks-0.10.0-0.9.3-typeahead-beginning.patch -> 1.1
    elinks-double-esc.patch -> 1.1
    elinks.spec -> 1.177

elinks-0.10.0-0.9.3-typeahead-beginning.patch [new file with mode: 0644]
elinks-double-esc.patch [new file with mode: 0644]
elinks.spec

diff --git a/elinks-0.10.0-0.9.3-typeahead-beginning.patch b/elinks-0.10.0-0.9.3-typeahead-beginning.patch
new file mode 100644 (file)
index 0000000..b35d76e
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urp elinks-0.10.0/src/viewer/text/search.c elinks-0.10.0a/src/viewer/text/search.c
+--- elinks-0.10.0/src/viewer/text/search.c     2004-12-17 17:19:08.000000000 +0100
++++ elinks-0.10.0a/src/viewer/text/search.c    2011-06-06 00:42:15.000000000 +0200
+@@ -1107,7 +1107,7 @@ search_link_text(struct document *docume
+               int match_offset = match_link_text(link, text, textlen,
+                                                  case_sensitive);
+-              if (match_offset >= 0) {
++              if (match_offset == 0) {
+                       *offset = match_offset;
+                       return i;
+               }
diff --git a/elinks-double-esc.patch b/elinks-double-esc.patch
new file mode 100644 (file)
index 0000000..fb0c517
--- /dev/null
@@ -0,0 +1,25 @@
+diff -urp elinks-0.12pre5.orig/src/terminal/kbd.c elinks-0.12pre5/src/terminal/kbd.c
+--- elinks-0.12pre5.orig/src/terminal/kbd.c    2009-07-07 14:23:17.000000000 +0200
++++ elinks-0.12pre5/src/terminal/kbd.c 2011-06-06 02:29:58.000000000 +0200
+@@ -765,6 +765,11 @@ decode_terminal_escape_sequence(struct i
+       int v;
+       int el;
++      if (itrm->in.queue.len == 2 && itrm->in.queue.data[1] == ASCII_ESC) {
++              kbd.key = KBD_ESC;
++              set_kbd_interlink_event(ev, kbd.key, kbd.modifier);
++              return 2;
++      }
+       if (itrm->in.queue.len < 3) return -1;
+       if (itrm->in.queue.data[2] == '[') {
+@@ -1108,8 +1113,7 @@ process_queue(struct itrm *itrm)
+                        * beginning of e.g. ESC ESC 0x5B 0x41,
+                        * which we should parse as Esc Up.  */
+                       if (itrm->in.queue.len < 3) {
+-                              /* Need more data to figure it out.  */
+-                              el = -1;
++                              el = decode_terminal_escape_sequence(itrm, &ev);
+                       } else if (itrm->in.queue.data[2] == 0x5B
+                                  || itrm->in.queue.data[2] == 0x4F) {
+                               /* The first ESC appears to be followed
index c64981a527a05c20d58ff0275b63994c187ce346..eb488c2d23f70f9195ab51484e0745103c323b06 100644 (file)
@@ -21,6 +21,7 @@
 %bcond_without lua             # Disable Lua scripting
 %bcond_without openssl         # Disable OpenSSL support
 %bcond_without perl            # Disable Perl scripting
+%bcond_with    olderisbetter   # variuos pre-0.10.0 behaviour rules (typeahead and esc-esc)
 
 %if %{with gnutls}
 %undefine      with_openssl
@@ -45,18 +46,22 @@ Source2:    links.png
 Patch0:                %{name}-home_etc.patch
 Patch1:                %{name}-lua40.patch
 Patch2:                %{name}-date-format.patch
-Patch3:                %{name}-old_incremental.patch
-Patch4:                %{name}-fbterm.patch
+Patch3:                %{name}-fbterm.patch
+Patch4:                %{name}-old_incremental.patch
+Patch5:                %{name}-0.10.0-0.9.3-typeahead-beginning.patch
+Patch6:                %{name}-double-esc.patch
 URL:           http://www.elinks.cz/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
 %{?with_fsp:BuildRequires:     fsplib-devel}
+#BuildRequires:        gc-devel
 BuildRequires: gettext-devel
 %{?with_gnutls:BuildRequires:  gnutls-devel >= 1.2.5}
 BuildRequires: gpm-devel
 %{?with_guile:BuildRequires: guile-devel}
+#BuildRequires:        heimdal-devel
 %{?with_js:BuildRequires:      js-devel >= 1.5-0.rc6a.1}
 %{?with_idn:BuildRequires:     libidn-devel}
 %{?with_smb:BuildRequires:     libsmbclient-devel}
@@ -104,9 +109,12 @@ keepalive.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-# restores old behaviour of type-ahead search
-#%patch3 -p1
+%patch3 -p1
+%if %{with olderisbetter}
 %patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%endif
 
 %build
 %{__aclocal}
@@ -123,7 +131,9 @@ keepalive.
        --enable-finger \
        --enable-gopher \
        --enable-nntp \
+       --enable-88-colors \
        %{?with_256:--enable-256-colors} \
+       --enable-true-color \
        --enable-exmode \
        %{?with_fsp:--enable-fsp} \
        %{?with_leds:--enable-leds} \
This page took 0.185413 seconds and 4 git commands to generate.