]> git.pld-linux.org Git - packages/elinks.git/blobdiff - elinks.spec
- note to previous changelog entry
[packages/elinks.git] / elinks.spec
index d1130c0f4a5bbc16b9dc4079e66b04f043e45bb9..68748d73a3eb56d86e8ab91172a63559ab574ea7 100644 (file)
@@ -1,17 +1,19 @@
 #
 # Conditional build:
-%bcond_with    x       # Use the X Windows System
-%bcond_with    gnutls  # Enable GNUTLS SSL support (disables openssl)
-%bcond_without 256     # Disable 256 colors support
-%bcond_without cgi     # Disable Local CGI support
-%bcond_without guile   # Disable Guile scripting
-%bcond_without idn     # Disable Internation Domain Names support
-%bcond_without ipv6    # Disable IPv6 support
-%bcond_without js      # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
-%bcond_without led     # Disable LEDs
-%bcond_without lua     # Disable Lua scripting
-%bcond_without openssl # Disable OpenSSL support
-%bcond_without perl    # Disable Perl scripting
+%bcond_with    x               # Use the X Windows System
+%bcond_with    gnutls          # Enable GNUTLS SSL support (disables openssl)
+%bcond_with    ruby            # Enable (experimental) Ruby scripting support
+%bcond_without 256             # Disable 256 colors support
+%bcond_without bittorrent      # Disable BitTorrent support
+%bcond_without cgi             # Disable Local CGI support
+%bcond_without guile           # Disable Guile scripting
+%bcond_without idn             # Disable Internation Domain Names support
+%bcond_without ipv6            # Disable IPv6 support
+%bcond_without js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
+%bcond_without led             # Disable LEDs
+%bcond_without lua             # Disable Lua scripting
+%bcond_without openssl         # Disable OpenSSL support
+%bcond_without perl            # Disable Perl scripting
 # 
 %if %{with gnutls}
 %undefine      with_openssl
@@ -22,25 +24,25 @@ Summary(es):        El links es un browser para modo texto, similar a lynx
 Summary(pl):   Eksperymentalny Links (tekstowa przegl±darka WWW)
 Summary(pt_BR):        O links Ă© um browser para modo texto, similar ao lynx
 Name:          elinks
-Version:       0.10.6
+Version:       0.11.2
 Release:       1
 Epoch:         1
 License:       GPL
 Group:         Applications/Networking
-#Source0Download:      http://elinks.or.cz/download.html
-Source0:       http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
-# Source0-md5: f539c07a7b0e19e8f1c6f35f7d406841
+#Source0Download:      http://www.elinks.cz/download.html
+Source0:       http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 5a8f83afb527cf443f58b372136a81fc
 Source1:       %{name}.desktop
 Source2:       links.png
 Patch0:                %{name}-home_etc.patch
 Patch1:                %{name}-lua40.patch
-Patch2:                %{name}-locale_names.patch
-#Patch3:               %{name}-pl.po-update.patch
-URL:           http://elinks.or.cz/
+Patch2:                %{name}-pl.po-update.patch
+URL:           http://www.elinks.cz/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
+BuildRequires: fsplib-devel
 BuildRequires: gettext-devel
 BuildRequires: gpm-devel
 %{?with_guile:BuildRequires: guile-devel}
@@ -51,8 +53,8 @@ BuildRequires:        gpm-devel
 BuildRequires: ncurses-devel >= 5.1
 %{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
 %{?with_perl:BuildRequires:    perl-devel}
+%{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: zlib-devel
-BuildRequires: tetex
 Provides:      webclient
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -86,31 +88,32 @@ keepalive.
 %patch1 -p1
 %patch2 -p1
 
-mv -f po/{no,nb}.po
-
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
-%{__automake}
 %configure \
        --disable-no-root \
        HAVE_SMBCLIENT=yes \
        %{!?debug:--enable-fastmem} \
        %{?debug:--enable-debug} \
        %{!?with_ipv6:--disable-ipv6} \
+       %{?with_bittorrent:--enable-bittorrent} \
        %{?with_cgi:--enable-cgi} \
        --enable-finger \
        --enable-gopher \
        --enable-nntp \
        %{?with_256:--enable-256-colors} \
        --enable-exmode \
+       --enable-fsp \
        %{?with_leds:--enable-leds} \
+       --enable-marks \
        --enable-html-highlight \
        %{!?with_idn:--without-idn} \
        %{?with_guile:--with-guile} \
        %{?with_perl:--with-perl} \
        %{!?with_lua:--without-lua} \
+       %{?with_ruby:--with-ruby} \
        %{!?with_js:--without-spidermonkey} \
        %{?with_gnutls:--with-gnutls} \
        %{!?with_openssl:--without-openssl} \
@@ -119,11 +122,7 @@ mv -f po/{no,nb}.po
 # something else
 #      --with-xterm="xterm -e"
 
-%{__make}
-
-cd doc
-texi2html elinks-lua.texi
-cd ..
+%{__make} V=1
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -131,7 +130,7 @@ install -d $RPM_BUILD_ROOT%{_desktopdir} \
        $RPM_BUILD_ROOT%{_datadir}/%{name} \
        $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
 
-%{__make} install \
+%{__make} install V=1 \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
@@ -149,9 +148,9 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
 %doc contrib/conv/{*awk,*.pl,*.sh}
-%doc doc/{*.txt,*.html}
+%doc doc/html/*.html
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man*/*
-%{_desktopdir}/*
+%{_desktopdir}/*.desktop
 %{_pixmapsdir}/*
 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.083924 seconds and 4 git commands to generate.