]> git.pld-linux.org Git - packages/elinks.git/blobdiff - elinks.spec
- updated lua40 patch to use lua50 (as elinks no longer supports lua 4.0)
[packages/elinks.git] / elinks.spec
index f55a1996810a3a4df04aeffdf9272030621ae13b..502803fa25d607ed8291eba642f958bbb18d34b2 100644 (file)
@@ -1,17 +1,19 @@
 #
 # Conditional build:
-%bcond_with    x       # Use the X Windows System
-%bcond_with    gnutls  # Enable GNUTLS SSL support (disables openssl)
-%bcond_with    js      # Enable experimental JavaScript support (using SpiderMonkey)
-%bcond_without 256     # Disable 256 colors support
-%bcond_without cgi     # Disable Local CGI support
-%bcond_without guile   # Disable Guile scripting
-%bcond_without idn     # Disable Internation Domain Names support
-%bcond_without ipv6    # Disable IPv6 support
-%bcond_without led     # Disable LEDs
-%bcond_without lua     # Disable Lua scripting
-%bcond_without openssl # Disable OpenSSL support
-%bcond_without perl    # Disable Perl scripting
+%bcond_with    x               # Use the X Windows System
+%bcond_with    gnutls          # Enable GNUTLS SSL support (disables openssl)
+%bcond_with    ruby            # Enable (experimental) Ruby scripting support
+%bcond_without 256             # Disable 256 colors support
+%bcond_without bittorrent      # Disable BitTorrent support
+%bcond_without cgi             # Disable Local CGI support
+%bcond_without guile           # Disable Guile scripting
+%bcond_without idn             # Disable Internation Domain Names support
+%bcond_without ipv6            # Disable IPv6 support
+%bcond_without js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
+%bcond_without led             # Disable LEDs
+%bcond_without lua             # Disable Lua scripting
+%bcond_without openssl         # Disable OpenSSL support
+%bcond_without perl            # Disable Perl scripting
 # 
 %if %{with gnutls}
 %undefine      with_openssl
@@ -22,20 +24,21 @@ Summary(es):        El links es un browser para modo texto, similar a lynx
 Summary(pl):   Eksperymentalny Links (tekstowa przegl±darka WWW)
 Summary(pt_BR):        O links Ă© um browser para modo texto, similar ao lynx
 Name:          elinks
-Version:       0.10.1
+Version:       0.11.0
 Release:       1
 Epoch:         1
 License:       GPL
 Group:         Applications/Networking
-#Source0Download:      http://elinks.or.cz/download.html
-Source0:       http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
-# Source0-md5: ff730be29416dabdbbf2a2fa6ac8b298
+#Source0Download:      http://www.elinks.cz/download.html
+Source0:       http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 9154f493f544af31ae31ec1dd203d315
 Source1:       %{name}.desktop
 Source2:       links.png
 Patch0:                %{name}-home_etc.patch
 Patch1:                %{name}-lua40.patch
-Patch2:                %{name}-locale_names.patch
-URL:           http://elinks.or.cz/
+Patch2:                %{name}-pl.po-update.patch
+Patch3:                %{name}-srcdir.patch
+URL:           http://www.elinks.cz/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
@@ -43,13 +46,14 @@ BuildRequires:      expat-devel
 BuildRequires: gettext-devel
 BuildRequires: gpm-devel
 %{?with_guile:BuildRequires: guile-devel}
-%{?with_gnutls:BuildRequires: gnutls-devel}
+%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
 %{?with_js:BuildRequires:      js-devel >= 1.5-0.rc6a.1}
 %{?with_idn:BuildRequires:     libidn-devel}
-%{?with_lua:BuildRequires:     lua40-devel >= 4.0.1-9}
+%{?with_lua:BuildRequires:     lua50-devel}
 BuildRequires: ncurses-devel >= 5.1
 %{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
 %{?with_perl:BuildRequires:    perl-devel}
+%{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: zlib-devel
 BuildRequires: tetex
 Provides:      webclient
@@ -84,18 +88,19 @@ keepalive.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-
-mv -f po/{no,nb}.po
+%patch3 -p1
 
 %build
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
-%{__automake}
 %configure \
+       --disable-no-root \
+       HAVE_SMBCLIENT=yes \
        %{!?debug:--enable-fastmem} \
        %{?debug:--enable-debug} \
        %{!?with_ipv6:--disable-ipv6} \
+       %{?with_bittorrent:--enable-bittorrent} \
        %{?with_cgi:--enable-cgi} \
        --enable-finger \
        --enable-gopher \
@@ -103,18 +108,22 @@ mv -f po/{no,nb}.po
        %{?with_256:--enable-256-colors} \
        --enable-exmode \
        %{?with_leds:--enable-leds} \
+       --enable-marks \
        --enable-html-highlight \
-       --disable-no-root \
        %{!?with_idn:--without-idn} \
        %{?with_guile:--with-guile} \
        %{?with_perl:--with-perl} \
        %{!?with_lua:--without-lua} \
+       %{?with_ruby:--with-ruby} \
        %{!?with_js:--without-spidermonkey} \
        %{?with_gnutls:--with-gnutls} \
        %{!?with_openssl:--without-openssl} \
-       %{?with_x:--with-x} 
+       --with%{!?with_x:out}-x
+# xterm -e is default, one might want to change it to
+# something else
+#      --with-xterm="xterm -e"
 
-%{__make}
+%{__make} V=1
 
 cd doc
 texi2html elinks-lua.texi
@@ -126,7 +135,7 @@ install -d $RPM_BUILD_ROOT%{_desktopdir} \
        $RPM_BUILD_ROOT%{_datadir}/%{name} \
        $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
 
-%{__make} install \
+%{__make} install V=1 \
        DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
@@ -144,9 +153,9 @@ rm -rf $RPM_BUILD_ROOT
 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
 %doc contrib/conv/{*awk,*.pl,*.sh}
-%doc doc/{*.txt,*.html}
+%doc doc/{*.txt,html}
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man*/*
 %{_desktopdir}/*
 %{_pixmapsdir}/*
-%{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
+%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.087409 seconds and 4 git commands to generate.