]> git.pld-linux.org Git - packages/elinks.git/blobdiff - elinks.spec
- updated lua40 patch to use lua50 (as elinks no longer supports lua 4.0)
[packages/elinks.git] / elinks.spec
index 60908c199eda3ee6f057fa7c4c7ccf0a6008692d..502803fa25d607ed8291eba642f958bbb18d34b2 100644 (file)
@@ -1,37 +1,66 @@
+#
+# Conditional build:
+%bcond_with    x               # Use the X Windows System
+%bcond_with    gnutls          # Enable GNUTLS SSL support (disables openssl)
+%bcond_with    ruby            # Enable (experimental) Ruby scripting support
+%bcond_without 256             # Disable 256 colors support
+%bcond_without bittorrent      # Disable BitTorrent support
+%bcond_without cgi             # Disable Local CGI support
+%bcond_without guile           # Disable Guile scripting
+%bcond_without idn             # Disable Internation Domain Names support
+%bcond_without ipv6            # Disable IPv6 support
+%bcond_without js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
+%bcond_without led             # Disable LEDs
+%bcond_without lua             # Disable Lua scripting
+%bcond_without openssl         # Disable OpenSSL support
+%bcond_without perl            # Disable Perl scripting
+# 
+%if %{with gnutls}
+%undefine      with_openssl
+%endif
+#
 Summary:       Experimantal Links (text WWW browser)
 Summary(es):   El links es un browser para modo texto, similar a lynx
 Summary(pl):   Eksperymentalny Links (tekstowa przegl±darka WWW)
 Summary(pt_BR):        O links é um browser para modo texto, similar ao lynx
 Name:          elinks
-Version:       0.5
-%define        _pre    pre5
-Release:       0.%{_pre}.1
+Version:       0.11.0
+Release:       1
 Epoch:         1
 License:       GPL
 Group:         Applications/Networking
-#Source0Download:      http://elinks.or.cz/download.html
-Source0:       http://elinks.or.cz/download/%{name}-%{version}%{_pre}.tar.bz2
-# Source0-md5: 6445fdcd652709be3fb7401e9da019f7
+#Source0Download:      http://www.elinks.cz/download.html
+Source0:       http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 9154f493f544af31ae31ec1dd203d315
 Source1:       %{name}.desktop
 Source2:       links.png
-Patch0:                %{name}-pl.po.patch
-Patch1:                %{name}-http-host.patch
-URL:           http://elinks.or.cz/
+Patch0:                %{name}-home_etc.patch
+Patch1:                %{name}-lua40.patch
+Patch2:                %{name}-pl.po-update.patch
+Patch3:                %{name}-srcdir.patch
+URL:           http://www.elinks.cz/
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: expat-devel
+BuildRequires: gettext-devel
 BuildRequires: gpm-devel
-BuildRequires: lua40-devel
-BuildRequires: ncurses-devel => 5.1
-BuildRequires: openssl-devel >= 0.9.7c
+%{?with_guile:BuildRequires: guile-devel}
+%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
+%{?with_js:BuildRequires:      js-devel >= 1.5-0.rc6a.1}
+%{?with_idn:BuildRequires:     libidn-devel}
+%{?with_lua:BuildRequires:     lua50-devel}
+BuildRequires: ncurses-devel >= 5.1
+%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
+%{?with_perl:BuildRequires:    perl-devel}
+%{?with_ruby:BuildRequires:    ruby-devel}
 BuildRequires: zlib-devel
-BuildRequires: /usr/bin/texi2html
+BuildRequires: tetex
 Provides:      webclient
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sysconfdir     /etc/elinks
-%define                specflags_ia32  "-fomit-frame-pointer"
+%define                specflags_ia32  -fomit-frame-pointer 
 
 %description
 This is the elinks tree - intended to provide feature-rich version of
@@ -46,7 +75,7 @@ tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
 keepalive.
 
 %description -l pl
-Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki www - links.
+Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
 elinks jednak jest dedykowana g³ównie do testowania.
 
 %description -l pt_BR
@@ -55,19 +84,46 @@ tabelas, baixa arquivos em segundo plano, e usa as conex
 keepalive.
 
 %prep
-%setup -q -n %{name}-%{version}%{_pre}
+%setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %build
-rm -f missing
 %{__aclocal}
 %{__autoconf}
-%{__automake}
+%{__autoheader}
 %configure \
-       --enable-fastmem \
-       --without-x
-%{__make}
+       --disable-no-root \
+       HAVE_SMBCLIENT=yes \
+       %{!?debug:--enable-fastmem} \
+       %{?debug:--enable-debug} \
+       %{!?with_ipv6:--disable-ipv6} \
+       %{?with_bittorrent:--enable-bittorrent} \
+       %{?with_cgi:--enable-cgi} \
+       --enable-finger \
+       --enable-gopher \
+       --enable-nntp \
+       %{?with_256:--enable-256-colors} \
+       --enable-exmode \
+       %{?with_leds:--enable-leds} \
+       --enable-marks \
+       --enable-html-highlight \
+       %{!?with_idn:--without-idn} \
+       %{?with_guile:--with-guile} \
+       %{?with_perl:--with-perl} \
+       %{!?with_lua:--without-lua} \
+       %{?with_ruby:--with-ruby} \
+       %{!?with_js:--without-spidermonkey} \
+       %{?with_gnutls:--with-gnutls} \
+       %{!?with_openssl:--without-openssl} \
+       --with%{!?with_x:out}-x
+# xterm -e is default, one might want to change it to
+# something else
+#      --with-xterm="xterm -e"
+
+%{__make} V=1
 
 cd doc
 texi2html elinks-lua.texi
@@ -75,18 +131,17 @@ cd ..
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_applnkdir}/Network/WWW \
+install -d $RPM_BUILD_ROOT%{_desktopdir} \
        $RPM_BUILD_ROOT%{_datadir}/%{name} \
        $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
 
-%{__make} install \
+%{__make} install V=1 \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Network/WWW
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
 
-install contrib/lua/[bcmr]*.lua $RPM_BUILD_ROOT%{_sysconfdir}
-install contrib/lua/hooks.lua.in $RPM_BUILD_ROOT%{_sysconfdir}/hooks.lua
+%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
 
 %find_lang %{name}
 
@@ -96,11 +151,11 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
-%doc contrib/{completion.tcsh,keybind*,wipe-out-ssl*,lua/elinks-remote}
+%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
 %doc contrib/conv/{*awk,*.pl,*.sh}
-%doc doc/{*.txt,*.html}
+%doc doc/{*.txt,html}
 %attr(755,root,root) %{_bindir}/*
 %{_mandir}/man*/*
-%{_applnkdir}/Network/WWW/*
+%{_desktopdir}/*
 %{_pixmapsdir}/*
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}
+%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.0481 seconds and 4 git commands to generate.