]> git.pld-linux.org Git - packages/elinks.git/blame_incremental - elinks.spec
- updated to 0.15.1
[packages/elinks.git] / elinks.spec
... / ...
CommitLineData
1#
2# Conditional build:
3# - protocols
4%bcond_without bittorrent # BitTorrent protocol support
5%bcond_without fsp # FSP support
6%bcond_without idn # Internation Domain Names support
7%bcond_without ipv6 # IPv6 support
8%bcond_with smb # smb protocol support (non-distib: recent libsmbclient is GPL v3)
9%bcond_with gnutls # GNUTLS-based SSL support (instead of openssl)
10%bcond_without openssl # OpenSSL-based SSL support
11# - content
12%bcond_without cgi # Local CGI support
13%bcond_without brotli # Brotli compression support
14%bcond_without js # experimental (yet quite usable) JavaScript support (using quickjs)
15%bcond_with lzma # LZMA support (old API, incompatible with xz-libs)
16%bcond_without zstd # zstd compression support
17# - scripting
18%bcond_with guile # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
19%bcond_without lua # Lua scripting
20%bcond_with perl # Perl scripting
21%bcond_with python # Python scripting support
22%bcond_with ruby # (experimental) Ruby scripting support
23# - display and UI
24%bcond_without 256 # 256 colors support
25%bcond_without led # LEDs
26%bcond_without truecolor # true color
27%bcond_with x # Use the X Window System
28# - misc
29%bcond_without verbose # verbose build (V=1)
30%bcond_without libevent # build without libevent
31
32%if %{with gnutls}
33%undefine with_openssl
34%endif
35
36Summary: Experimantal Links (text WWW browser)
37Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
38Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
39Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
40Name: elinks
41Version: 0.15.1
42Release: 1
43Epoch: 1
44License: GPL v2
45Group: Applications/Networking
46Source0: https://github.com/rkd77/elinks/releases/download/v%{version}/%{name}-%{version}.tar.xz
47# Source0-md5: 9bf8aad8d480139b9420c19f18ae9a4e
48Source1: %{name}.desktop
49Source2: links.png
50URL: http://www.elinks.cz/
51BuildRequires: autoconf >= 2.61
52BuildRequires: automake
53BuildRequires: bzip2-devel
54BuildRequires: expat-devel
55%{?with_fsp:BuildRequires: fsplib-devel}
56BuildRequires: gettext-tools
57BuildRequires: git-core
58%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
59BuildRequires: gpm-devel
60%{?with_guile:BuildRequires: guile-devel}
61BuildRequires: libstdc++-devel
62%{?with_js:BuildRequires: libxml++5-devel >= 5.0.1-2}
63BuildRequires: rpmbuild(macros) >= 1.736
64%{?with_js:BuildRequires: sqlite3-devel}
65%{?with_brotli:BuildRequires: libbrotli-devel}
66%{?with_libevent:BuildRequires: libevent-devel}
67%{?with_idn:BuildRequires: libidn-devel}
68%{?with_smb:BuildRequires: libsmbclient-devel}
69%{?with_lua:BuildRequires: lua53-devel}
70%{?with_lzma:BuildRequires: lzma-devel}
71BuildRequires: meson
72BuildRequires: ncurses-devel >= 5.1
73BuildRequires: ninja >= 1.5
74%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
75%{?with_perl:BuildRequires: perl-devel}
76BuildRequires: pkgconfig
77%{?with_python:BuildRequires: python3-devel}
78%{?with_js:BuildRequires: quickjs-devel >= 20210327-4}
79%{?with_ruby:BuildRequires: ruby-devel}
80BuildRequires: sed
81BuildRequires: tar >= 1:1.22
82BuildRequires: tre-devel
83BuildRequires: which
84BuildRequires: xz
85BuildRequires: zlib-devel
86%{?with_zstd:BuildRequires: zstd-devel}
87Suggests: mailcap
88Provides: webclient
89BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
90
91%define _sysconfdir /etc/elinks
92%define specflags_ia32 -fomit-frame-pointer
93
94%description
95This is the elinks tree - intended to provide feature-rich version of
96links, however not rock-stable and dedicated mainly for testing. Its
97purpose is to make alternative to links, until Mikulas will have some
98time to maintain it, and to test and tune various patches for Mikulas
99to be able to include them in the official links releases.
100
101%description -l es.UTF-8
102Links es un browser WWW modo texto, similar al Lynx. El links muestra
103tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
104keepalive.
105
106%description -l pl.UTF-8
107Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
108elinks jednak jest dedykowana głównie do testowania.
109
110%description -l pt_BR.UTF-8
111Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
112tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
113keepalive.
114
115%prep
116%setup -q
117
118%build
119%meson build \
120 %{?with_bittorrent:-Dbittorrent=true} \
121 %{?with_cgi:-Dcgi=true} \
122 -D88-colors=true \
123 %{?with_256:-D256-colors=true} \
124 %{?with_truecolor:-Dtrue-color=true} \
125 -Dexmode=true \
126 %{?debug:-Ddebug=true} \
127 %{!?debug:-Dfastmem=true} \
128 -Dfinger=true \
129 -Dfsp=%{__true_false fsp} \
130 -Dgemini=true \
131 -Dgettext=true \
132 -Dgopher=true \
133 -Dhtml-highlight=true \
134 %{!?with_ipv6:-Dipv6=false} \
135 %{?with_leds:-Dleds=true} \
136 -Dmarks=true \
137 -Dnntp=true \
138 -Dno-root=false \
139 %{?with_smb:-Dsmb=true} \
140 %{?with_brotli:-Dbrotli=true} \
141 %{?with_zstd:-Dzstd=true} \
142 %{?with_gnutls:-Dgnutls=true} \
143 %{?with_guile:-Dguile=true} \
144 %{!?with_idn:-Didn=false} \
145 %{?with_lua:-Dluapkg=lua5.3} \
146 %{?with_lzma:-Dlzma=true} \
147 %{?with_openssl:-Dopenssl=true} \
148 %{?with_perl:-Dperl=true} \
149 %{?with_python:-Dpython=true} \
150 %{?with_ruby:-Druby=true} \
151 %{?with_js:-Dquickjs=true} \
152 %{?with_x:-Dx=true} \
153 %{?with_libevent:-Dlibevent=true}
154
155%ninja_build -C build
156
157%install
158rm -rf $RPM_BUILD_ROOT
159%ninja_install -C build
160
161install -d $RPM_BUILD_ROOT%{_desktopdir} \
162 $RPM_BUILD_ROOT%{_datadir}/%{name} \
163 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
164
165cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
166cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
167
168%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
169sed -i -e 's|bin/lua|bin/lua5.3|g' $RPM_BUILD_ROOT%{_sysconfdir}/*lua
170
171%find_lang %{name}
172
173%clean
174rm -rf $RPM_BUILD_ROOT
175
176%files -f %{name}.lang
177%defattr(644,root,root,755)
178%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
179%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh}
180%attr(755,root,root) %{_bindir}/elinks
181%{_mandir}/man1/elinks.1*
182%{_mandir}/man5/elinks.conf.5*
183%{_mandir}/man5/elinkskeys.5*
184%{_desktopdir}/elinks.desktop
185%{_pixmapsdir}/elinks.png
186%if %{with lua}
187%dir %{_sysconfdir}
188%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
189%endif
This page took 0.125595 seconds and 4 git commands to generate.