]> git.pld-linux.org Git - packages/elinks.git/blame_incremental - elinks.spec
- release ...4
[packages/elinks.git] / elinks.spec
... / ...
CommitLineData
1# TODO: consider lua51
2
3# Conditional build:
4%bcond_with gnutls # Enable GNUTLS SSL support (disables openssl)
5%bcond_with lzma # Enable lzma support
6%bcond_with python # Enable Python scripting support
7%bcond_with ruby # Enable (experimental) Ruby scripting support
8%bcond_with smb # Enable smb protocol support (smb requires libsmbclient)
9#The latest libsmbclient is GPLv3, while ELinks is GPL v2 only.
10%bcond_with verbose # verbose build (V=1)
11%bcond_with x # Use the X Windows System
12%bcond_without 256 # Disable 256 colors support
13%bcond_without bittorrent # Disable BitTorrent support
14%bcond_without cgi # Disable Local CGI support
15%bcond_without fsp # Disable FSP support
16%bcond_without guile # Disable Guile scripting
17%bcond_without idn # Disable Internation Domain Names support
18%bcond_without ipv6 # Disable IPv6 support
19%bcond_without js # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
20%bcond_without led # Disable LEDs
21%bcond_without lua # Disable Lua scripting
22%bcond_without openssl # Disable OpenSSL support
23%bcond_without perl # Disable Perl scripting
24#
25%if %{with gnutls}
26%undefine with_openssl
27%endif
28#
29%define pre pre5
30Summary: Experimantal Links (text WWW browser)
31Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
32Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
33Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
34Name: elinks
35Version: 0.12
36Release: 0.%{pre}.4
37Epoch: 1
38License: GPL v2
39Group: Applications/Networking
40Source0: http://www.elinks.cz/download/%{name}-%{version}%{pre}.tar.bz2
41# Source0-md5: 92790144290131ac5e63b44548b45e08
42Source1: %{name}.desktop
43Source2: links.png
44Patch0: %{name}-home_etc.patch
45Patch1: %{name}-lua40.patch
46Patch2: %{name}-date-format.patch
47Patch3: %{name}-old_incremental.patch
48Patch4: %{name}-fbterm.patch
49URL: http://www.elinks.cz/
50BuildRequires: autoconf
51BuildRequires: automake
52BuildRequires: bzip2-devel
53BuildRequires: expat-devel
54%{?with_fsp:BuildRequires: fsplib-devel}
55BuildRequires: gettext-devel
56BuildRequires: gpm-devel
57%{?with_guile:BuildRequires: guile-devel}
58%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
59%{?with_js:BuildRequires: js-devel >= 1.5-0.rc6a.1}
60%{?with_idn:BuildRequires: libidn-devel}
61%{?with_smb:BuildRequires: libsmbclient-devel}
62%{?with_lua:BuildRequires: lua50-devel}
63%{?with_lzma:BuildRequires: lzma-devel}
64BuildRequires: ncurses-devel >= 5.1
65%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
66%{?with_perl:BuildRequires: perl-devel}
67BuildRequires: pkgconfig
68%{?with_python:BuildRequires: python-devel}
69%{?with_ruby:BuildRequires: ruby-devel}
70BuildRequires: tre-devel
71BuildRequires: which
72BuildRequires: zlib-devel
73Suggests: mailcap
74Provides: webclient
75BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77%define _sysconfdir /etc/elinks
78%define specflags_ia32 -fomit-frame-pointer
79
80%description
81This is the elinks tree - intended to provide feature-rich version of
82links, however not rock-stable and dedicated mainly for testing. Its
83purpose is to make alternative to links, until Mikulas will have some
84time to maintain it, and to test and tune various patches for Mikulas
85to be able to include them in the official links releases.
86
87%description -l es.UTF-8
88Links es un browser WWW modo texto, similar al Lynx. El links muestra
89tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
90keepalive.
91
92%description -l pl.UTF-8
93Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
94elinks jednak jest dedykowana głównie do testowania.
95
96%description -l pt_BR.UTF-8
97Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
98tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
99keepalive.
100
101%prep
102%setup -q -n %{name}-%{version}%{pre}
103%patch0 -p1
104%patch1 -p1
105%patch2 -p1
106# restores old behaviour of type-ahead search
107#%patch3 -p1
108%patch4 -p1
109
110%build
111%{__aclocal}
112%{__autoconf}
113%{__autoheader}
114%configure \
115 %{?with_smb:--enable-smb} \
116 --disable-no-root \
117 %{!?debug:--enable-fastmem} \
118 %{?debug:--enable-debug} \
119 %{!?with_ipv6:--disable-ipv6} \
120 %{?with_bittorrent:--enable-bittorrent} \
121 %{?with_cgi:--enable-cgi} \
122 --enable-finger \
123 --enable-gopher \
124 --enable-nntp \
125 %{?with_256:--enable-256-colors} \
126 --enable-exmode \
127 %{?with_fsp:--enable-fsp} \
128 %{?with_leds:--enable-leds} \
129 --enable-marks \
130 --enable-html-highlight \
131 %{!?with_idn:--without-idn} \
132 %{?with_guile:--with-guile} \
133 %{?with_perl:--with-perl} \
134 %{!?with_lua:--without-lua} \
135 %{?with_python:--with-python} \
136 %{?with_ruby:--with-ruby} \
137 %{!?with_js:--without-spidermonkey} \
138 %{?with_gnutls:--with-gnutls} \
139 %{!?with_openssl:--without-openssl} \
140 --with%{!?with_x:out}-x \
141 %{!?with_lzma:--without-lzma}
142# xterm -e is default, one might want to change it to
143# something else
144# --with-xterm="xterm -e"
145
146%{__make} %{?with_verbose:V=1}
147
148%install
149rm -rf $RPM_BUILD_ROOT
150install -d $RPM_BUILD_ROOT%{_desktopdir} \
151 $RPM_BUILD_ROOT%{_datadir}/%{name} \
152 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
153
154%{__make} install %{?with_verbose:V=1} \
155 DESTDIR=$RPM_BUILD_ROOT
156
157install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
158install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
159
160%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
161
162%find_lang %{name}
163
164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%files -f %{name}.lang
168%defattr(644,root,root,755)
169%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
170%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
171%doc contrib/conv/{*awk,*.pl,*.sh}
172%doc doc/html/*.html
173%attr(755,root,root) %{_bindir}/*
174%{_mandir}/man*/*
175%{_desktopdir}/*.desktop
176%{_pixmapsdir}/*
177%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.0870840000000001 seconds and 4 git commands to generate.