]> git.pld-linux.org Git - packages/elinks.git/blame - elinks.spec
- added bug517.patch
[packages/elinks.git] / elinks.spec
CommitLineData
2e552f3e 1# TODO: consider lua51
1c33e430 2#
21bf3c6a 3# Conditional build:
b67326b7
JB
4%bcond_with x # Use the X Windows System
5%bcond_with gnutls # Enable GNUTLS SSL support (disables openssl)
6%bcond_with ruby # Enable (experimental) Ruby scripting support
7%bcond_without 256 # Disable 256 colors support
8%bcond_without bittorrent # Disable BitTorrent support
9%bcond_without cgi # Disable Local CGI support
b631af97 10%bcond_without fsp # Disable FSP support
b67326b7
JB
11%bcond_without guile # Disable Guile scripting
12%bcond_without idn # Disable Internation Domain Names support
13%bcond_without ipv6 # Disable IPv6 support
14%bcond_without js # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15%bcond_without led # Disable LEDs
16%bcond_without lua # Disable Lua scripting
17%bcond_without openssl # Disable OpenSSL support
18%bcond_without perl # Disable Perl scripting
3d4d38d9
AG
19#
20%if %{with gnutls}
21%undefine with_openssl
22%endif
21bf3c6a 23#
17631700 24Summary: Experimantal Links (text WWW browser)
f85cbf5d
ER
25Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
26Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
27Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
17631700 28Name: elinks
2e552f3e 29Version: 0.11.3
9136119b 30Release: 2
e2affc83 31Epoch: 1
17631700
AM
32License: GPL
33Group: Applications/Networking
8ca357a6 34Source0: http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
2e552f3e 35# Source0-md5: a0eb50e18a2ac8e77d6b0df8f94bb5a6
17631700 36Source1: %{name}.desktop
5a8f1bd1 37Source2: links.png
ef0f233a
AG
38Patch0: %{name}-home_etc.patch
39Patch1: %{name}-lua40.patch
9136119b 40Patch2: %{name}-bug517.patch
8ca357a6 41URL: http://www.elinks.cz/
17631700
AM
42BuildRequires: autoconf
43BuildRequires: automake
5a8f1bd1 44BuildRequires: bzip2-devel
fcffdc5b 45BuildRequires: expat-devel
b631af97 46%{?with_fsp:BuildRequires: fsplib-devel}
ab99996e 47BuildRequires: gettext-devel
17631700 48BuildRequires: gpm-devel
3d4d38d9 49%{?with_guile:BuildRequires: guile-devel}
69d969c4 50%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
3d4d38d9
AG
51%{?with_js:BuildRequires: js-devel >= 1.5-0.rc6a.1}
52%{?with_idn:BuildRequires: libidn-devel}
8eb57a4f 53%{?with_lua:BuildRequires: lua50-devel}
1c33e430 54BuildRequires: ncurses-devel >= 5.1
3d4d38d9
AG
55%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
56%{?with_perl:BuildRequires: perl-devel}
8ca357a6 57%{?with_ruby:BuildRequires: ruby-devel}
5a8f1bd1 58BuildRequires: zlib-devel
17631700
AM
59Provides: webclient
60BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
c4be24e9 62%define _sysconfdir /etc/elinks
ef0f233a 63%define specflags_ia32 -fomit-frame-pointer
4fc089e9 64
17631700 65%description
cd6ad879
JB
66This is the elinks tree - intended to provide feature-rich version of
67links, however not rock-stable and dedicated mainly for testing. Its
68purpose is to make alternative to links, until Mikulas will have some
69time to maintain it, and to test and tune various patches for Mikulas
70to be able to include them in the official links releases.
17631700 71
3328f371 72%description -l es.UTF-8
c15f1e53 73Links es un browser WWW modo texto, similar al Lynx. El links muestra
74tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
75keepalive.
76
3328f371
JR
77%description -l pl.UTF-8
78Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
79elinks jednak jest dedykowana głównie do testowania.
17631700 80
3328f371
JR
81%description -l pt_BR.UTF-8
82Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
83tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
c15f1e53 84keepalive.
85
17631700 86%prep
cdfd7eb6 87%setup -q
ef0f233a 88%patch0 -p1
1fa8ef0a 89%patch1 -p1
9136119b 90%patch2 -p1
0b57a582 91
17631700 92%build
663b78ce 93%{__aclocal}
285e9f62 94%{__autoconf}
115d3038 95%{__autoheader}
ad628403 96%configure \
eda372dc 97 HAVE_SMBCLIENT=yes \
2e552f3e 98 --disable-no-root \
3d4d38d9
AG
99 %{!?debug:--enable-fastmem} \
100 %{?debug:--enable-debug} \
cc7f804f 101 %{!?with_ipv6:--disable-ipv6} \
8ca357a6 102 %{?with_bittorrent:--enable-bittorrent} \
3d4d38d9
AG
103 %{?with_cgi:--enable-cgi} \
104 --enable-finger \
105 --enable-gopher \
106 --enable-nntp \
107 %{?with_256:--enable-256-colors} \
108 --enable-exmode \
b631af97 109 %{?with_fsp:--enable-fsp} \
3d4d38d9 110 %{?with_leds:--enable-leds} \
8ca357a6 111 --enable-marks \
3d4d38d9 112 --enable-html-highlight \
3d4d38d9
AG
113 %{!?with_idn:--without-idn} \
114 %{?with_guile:--with-guile} \
115 %{?with_perl:--with-perl} \
62c5be6a 116 %{!?with_lua:--without-lua} \
8ca357a6 117 %{?with_ruby:--with-ruby} \
3d4d38d9
AG
118 %{!?with_js:--without-spidermonkey} \
119 %{?with_gnutls:--with-gnutls} \
120 %{!?with_openssl:--without-openssl} \
82dd9b93
AG
121 --with%{!?with_x:out}-x
122# xterm -e is default, one might want to change it to
123# something else
124# --with-xterm="xterm -e"
3d4d38d9 125
1378c2d4 126%{__make} V=1
17631700
AM
127
128%install
129rm -rf $RPM_BUILD_ROOT
1568d5eb 130install -d $RPM_BUILD_ROOT%{_desktopdir} \
ad628403 131 $RPM_BUILD_ROOT%{_datadir}/%{name} \
c4be24e9 132 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
17631700 133
1378c2d4 134%{__make} install V=1 \
834d1634 135 DESTDIR=$RPM_BUILD_ROOT
17631700 136
1568d5eb 137install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
5a8f1bd1 138install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
139
ef0f233a 140%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
347f019c 141
269a2ef7 142%find_lang %{name}
143
17631700
AM
144%clean
145rm -rf $RPM_BUILD_ROOT
146
269a2ef7 147%files -f %{name}.lang
17631700 148%defattr(644,root,root,755)
bf7521cb 149%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
ab99996e 150%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
5a8f1bd1 151%doc contrib/conv/{*awk,*.pl,*.sh}
cf865ed3 152%doc doc/html/*.html
17631700 153%attr(755,root,root) %{_bindir}/*
17631700 154%{_mandir}/man*/*
1faa0547 155%{_desktopdir}/*.desktop
06096625 156%{_pixmapsdir}/*
a153230d 157%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.137351 seconds and 4 git commands to generate.