]> git.pld-linux.org Git - packages/elinks.git/blame - elinks.spec
- date format is locale-dependent - so allow to localize it
[packages/elinks.git] / elinks.spec
CommitLineData
2e552f3e 1# TODO: consider lua51
1c33e430 2#
21bf3c6a 3# Conditional build:
b67326b7
JB
4%bcond_with x # Use the X Windows System
5%bcond_with gnutls # Enable GNUTLS SSL support (disables openssl)
6%bcond_with ruby # Enable (experimental) Ruby scripting support
7%bcond_without 256 # Disable 256 colors support
8%bcond_without bittorrent # Disable BitTorrent support
9%bcond_without cgi # Disable Local CGI support
b631af97 10%bcond_without fsp # Disable FSP support
b67326b7
JB
11%bcond_without guile # Disable Guile scripting
12%bcond_without idn # Disable Internation Domain Names support
13%bcond_without ipv6 # Disable IPv6 support
14%bcond_without js # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15%bcond_without led # Disable LEDs
16%bcond_without lua # Disable Lua scripting
17%bcond_without openssl # Disable OpenSSL support
18%bcond_without perl # Disable Perl scripting
3d4d38d9
AG
19#
20%if %{with gnutls}
21%undefine with_openssl
22%endif
21bf3c6a 23#
17631700 24Summary: Experimantal Links (text WWW browser)
f85cbf5d
ER
25Summary(es.UTF-8): El links es un browser para modo texto, similar a lynx
26Summary(pl.UTF-8): Eksperymentalny Links (tekstowa przeglądarka WWW)
27Summary(pt_BR.UTF-8): O links é um browser para modo texto, similar ao lynx
17631700 28Name: elinks
2e552f3e 29Version: 0.11.3
bfae6673 30Release: 3
e2affc83 31Epoch: 1
17631700
AM
32License: GPL
33Group: Applications/Networking
8ca357a6 34Source0: http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
2e552f3e 35# Source0-md5: a0eb50e18a2ac8e77d6b0df8f94bb5a6
17631700 36Source1: %{name}.desktop
5a8f1bd1 37Source2: links.png
ef0f233a
AG
38Patch0: %{name}-home_etc.patch
39Patch1: %{name}-lua40.patch
9136119b 40Patch2: %{name}-bug517.patch
bfae6673 41Patch3: %{name}-cgi.patch
42Patch4: %{name}-justify_date.patch
8ca357a6 43URL: http://www.elinks.cz/
17631700
AM
44BuildRequires: autoconf
45BuildRequires: automake
5a8f1bd1 46BuildRequires: bzip2-devel
fcffdc5b 47BuildRequires: expat-devel
b631af97 48%{?with_fsp:BuildRequires: fsplib-devel}
ab99996e 49BuildRequires: gettext-devel
17631700 50BuildRequires: gpm-devel
3d4d38d9 51%{?with_guile:BuildRequires: guile-devel}
69d969c4 52%{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
3d4d38d9
AG
53%{?with_js:BuildRequires: js-devel >= 1.5-0.rc6a.1}
54%{?with_idn:BuildRequires: libidn-devel}
8eb57a4f 55%{?with_lua:BuildRequires: lua50-devel}
1c33e430 56BuildRequires: ncurses-devel >= 5.1
3d4d38d9
AG
57%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
58%{?with_perl:BuildRequires: perl-devel}
8ca357a6 59%{?with_ruby:BuildRequires: ruby-devel}
5a8f1bd1 60BuildRequires: zlib-devel
17631700
AM
61Provides: webclient
62BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
c4be24e9 64%define _sysconfdir /etc/elinks
ef0f233a 65%define specflags_ia32 -fomit-frame-pointer
4fc089e9 66
17631700 67%description
cd6ad879
JB
68This is the elinks tree - intended to provide feature-rich version of
69links, however not rock-stable and dedicated mainly for testing. Its
70purpose is to make alternative to links, until Mikulas will have some
71time to maintain it, and to test and tune various patches for Mikulas
72to be able to include them in the official links releases.
17631700 73
3328f371 74%description -l es.UTF-8
c15f1e53 75Links es un browser WWW modo texto, similar al Lynx. El links muestra
76tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
77keepalive.
78
3328f371
JR
79%description -l pl.UTF-8
80Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
81elinks jednak jest dedykowana głównie do testowania.
17631700 82
3328f371
JR
83%description -l pt_BR.UTF-8
84Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
85tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
c15f1e53 86keepalive.
87
17631700 88%prep
cdfd7eb6 89%setup -q
ef0f233a 90%patch0 -p1
1fa8ef0a 91%patch1 -p1
9136119b 92%patch2 -p1
bfae6673 93%patch3 -p1
94%patch4 -p1
0b57a582 95
17631700 96%build
663b78ce 97%{__aclocal}
285e9f62 98%{__autoconf}
115d3038 99%{__autoheader}
ad628403 100%configure \
eda372dc 101 HAVE_SMBCLIENT=yes \
2e552f3e 102 --disable-no-root \
3d4d38d9
AG
103 %{!?debug:--enable-fastmem} \
104 %{?debug:--enable-debug} \
cc7f804f 105 %{!?with_ipv6:--disable-ipv6} \
8ca357a6 106 %{?with_bittorrent:--enable-bittorrent} \
3d4d38d9
AG
107 %{?with_cgi:--enable-cgi} \
108 --enable-finger \
109 --enable-gopher \
110 --enable-nntp \
111 %{?with_256:--enable-256-colors} \
112 --enable-exmode \
b631af97 113 %{?with_fsp:--enable-fsp} \
3d4d38d9 114 %{?with_leds:--enable-leds} \
8ca357a6 115 --enable-marks \
3d4d38d9 116 --enable-html-highlight \
3d4d38d9
AG
117 %{!?with_idn:--without-idn} \
118 %{?with_guile:--with-guile} \
119 %{?with_perl:--with-perl} \
62c5be6a 120 %{!?with_lua:--without-lua} \
8ca357a6 121 %{?with_ruby:--with-ruby} \
3d4d38d9
AG
122 %{!?with_js:--without-spidermonkey} \
123 %{?with_gnutls:--with-gnutls} \
124 %{!?with_openssl:--without-openssl} \
82dd9b93
AG
125 --with%{!?with_x:out}-x
126# xterm -e is default, one might want to change it to
127# something else
128# --with-xterm="xterm -e"
3d4d38d9 129
1378c2d4 130%{__make} V=1
17631700
AM
131
132%install
133rm -rf $RPM_BUILD_ROOT
1568d5eb 134install -d $RPM_BUILD_ROOT%{_desktopdir} \
ad628403 135 $RPM_BUILD_ROOT%{_datadir}/%{name} \
c4be24e9 136 $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
17631700 137
1378c2d4 138%{__make} install V=1 \
834d1634 139 DESTDIR=$RPM_BUILD_ROOT
17631700 140
1568d5eb 141install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
5a8f1bd1 142install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
143
ef0f233a 144%{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
347f019c 145
269a2ef7 146%find_lang %{name}
147
17631700
AM
148%clean
149rm -rf $RPM_BUILD_ROOT
150
269a2ef7 151%files -f %{name}.lang
17631700 152%defattr(644,root,root,755)
bf7521cb 153%doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
ab99996e 154%doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
5a8f1bd1 155%doc contrib/conv/{*awk,*.pl,*.sh}
cf865ed3 156%doc doc/html/*.html
17631700 157%attr(755,root,root) %{_bindir}/*
17631700 158%{_mandir}/man*/*
1faa0547 159%{_desktopdir}/*.desktop
06096625 160%{_pixmapsdir}/*
a153230d 161%{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.134264 seconds and 4 git commands to generate.