]> git.pld-linux.org Git - packages/elilo.git/commitdiff
Config files added
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Wed, 31 Oct 2012 13:34:55 +0000 (14:34 +0100)
committerJacek Konieczny <jajcus@jajcus.net>
Wed, 31 Oct 2012 13:34:55 +0000 (14:34 +0100)
Config file for ELILO itself and for the efi-boot-update script

elilo.conf [new file with mode: 0644]
elilo.efi-boot-update [new file with mode: 0644]
elilo.spec

diff --git a/elilo.conf b/elilo.conf
new file mode 100644 (file)
index 0000000..2ffc71e
--- /dev/null
@@ -0,0 +1,12 @@
+delay=20
+prompt
+
+image=vmlinuz
+    label=pld-linux
+    read-only
+    initrd=initrd
+
+image=vmlinuz.old
+    label=pld-linux-old
+    read-only
+    initrd=initrd.old
diff --git a/elilo.efi-boot-update b/elilo.efi-boot-update
new file mode 100644 (file)
index 0000000..948cd2d
--- /dev/null
@@ -0,0 +1,17 @@
+ENABLED=yes
+LABEL="ELILO"
+ARCH=x64
+BINARY=elilo.efi
+ARGS=""
+
+install_files() {
+
+    update_file /lib/efi/$ARCH/elilo.efi elilo.efi
+    update_file /etc/efi-boot/elilo.conf elilo.conf
+
+    update_file /boot/initrd initrd
+    update_file /boot/vmlinuz vmlinuz
+
+    update_file --missingok initrd.old initrd.old
+    update_file --missingok vmlinuz.old vmlinuz.old
+}
index f1016913d4977150623fffdb99e35c90ccdada75..6efa56c97a4ea75616495284ccddf17cbb549808 100644 (file)
@@ -7,6 +7,8 @@ License:        GPL v2+
 Group:         Applications/System
 Source0:       http://downloads.sourceforge.net/elilo/%{name}-%{version}-all.tar.gz
 # Source0-md5: d16086bcb228d2c25e241d73c1bf36be
+Source1:       %{name}.conf
+Source2:       %{name}.efi-boot-update
 URL:           http://elilo.sourceforge.net/
 BuildRequires: gnu-efi >= 3.0d
 ExclusiveArch: %{ix86} %{x8664} ia64
@@ -46,11 +48,16 @@ tar xf elilo-%{version}-source.tar.gz
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sbindir},/lib/efi/%{efi_arch}}
+install -d $RPM_BUILD_ROOT{%{_sbindir},/lib/efi/%{efi_arch}} \
+               $RPM_BUILD_ROOT/etc/efi-boot/update.d
 
 install elilo/tools/eliloalt $RPM_BUILD_ROOT%{_sbindir}
 install elilo/elilo.efi $RPM_BUILD_ROOT/lib/efi/%{efi_arch}/elilo.efi
 
+install %{SOURCE1}  $RPM_BUILD_ROOT/etc/efi-boot/%{name}.conf
+sed -e's/ARCH=.*/ARCH=%{efi_arch}/' %{SOURCE2} \
+               > $RPM_BUILD_ROOT/etc/efi-boot/update.d/%{name}.conf
+
 %triggerpostun -- %{name} < 3.14-1.1
 # someone may have boot configured from this misplaced location
 # better put elilo.efi copy there too
@@ -65,4 +72,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc %{version}-release-notes.txt elilo/{ChangeLog,README*,TODO} elilo/docs/*.txt elilo/examples
 %attr(755,root,root) %{_sbindir}/eliloalt
+/etc/efi-boot/%{name}.conf
+/etc/efi-boot/update.d/%{name}.conf
 /lib/efi/%{efi_arch}/elilo.efi
This page took 0.093903 seconds and 4 git commands to generate.