]> git.pld-linux.org Git - packages/elfutils.git/commitdiff
- let it build using gcc 4.[12], not only 4.3.x
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 10 Sep 2008 05:16:21 +0000 (05:16 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    elfutils-scanf.patch -> 1.1

elfutils-scanf.patch [new file with mode: 0644]

diff --git a/elfutils-scanf.patch b/elfutils-scanf.patch
new file mode 100644 (file)
index 0000000..8a98743
--- /dev/null
@@ -0,0 +1,49 @@
+--- elfutils-0.137/src/addr2line.c.orig        2008-08-09 06:06:44.000000000 +0200
++++ elfutils-0.137/src/addr2line.c     2008-09-09 22:15:16.304992337 +0200
+@@ -374,8 +374,13 @@ handle_address (const char *string, Dwfl
+       bool parsed = false;
+       int n;
+       char *name = NULL;
++#if (__GLIBC__ >= 2) && (__GLIBC_MINOR__ >= 7) && (__GNUC__ >= 4) && (__GNUC_MINOR__ >= 3)
+       if (sscanf (string, "(%m[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
+         && string[n] == '\0')
++#else
++      if (sscanf (string, "(%a[^)])%" PRIiMAX "%n", &name, &addr, &n) == 2
++        && string[n] == '\0')
++#endif
+       {
+         /* It was (section)+offset.  This makes sense if there is
+            only one module to look in for a section.  */
+@@ -415,8 +420,13 @@ handle_address (const char *string, Dwfl
+               }
+           }
+       }
++#if (__GLIBC__ >= 2) && (__GLIBC_MINOR__ >= 7) && (__GNUC__ >= 4) && (__GNUC_MINOR__ >= 3)
+       else if (sscanf (string, "%m[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
+              && string[n] == '\0')
++#else
++      else if (sscanf (string, "%a[^-+]%" PRIiMAX "%n", &name, &addr, &n) == 2
++             && string[n] == '\0')
++#endif
+       {
+         /* It was symbol+offset.  */
+         GElf_Sym sym;
+--- elfutils-0.137/src/Makefile.am.orig        2008-09-09 21:30:37.592989823 +0200
++++ elfutils-0.137/src/Makefile.am     2008-09-09 22:36:04.380988147 +0200
+@@ -35,7 +35,7 @@
+ AM_CFLAGS += -Wall -Wshadow -std=gnu99 $(native_ld_cflags) \
+            $(if $($(*F)_no_Werror),,-Werror) \
+            $(if $($(*F)_no_Wunused),,-Wunused $(WEXTRA)) \
+-           $(if $($(*F)_no_Wformat),,-Wformat=2) $(CFLAGS_$(*F))
++           $(if $($(*F)_no_Wformat),-Wno-format,-Wformat=2) $(CFLAGS_$(*F))
+ INCLUDES = -I$(srcdir) -I$(srcdir)/../libelf -I$(srcdir)/../libebl \
+          -I$(srcdir)/../libdw -I$(srcdir)/../libdwfl \
+@@ -109,6 +109,7 @@
+ nm_no_Wformat = yes
+ size_no_Wformat = yes
+ strings_no_Wformat = yes
++addr2line_no_Wformat = yes
+ # XXX While the file is not finished, don't warn about this
+ ldgeneric_no_Wunused = yes
This page took 0.175754 seconds and 4 git commands to generate.