]> git.pld-linux.org Git - packages/elfutils.git/commitdiff
- updated to 0.166 auto/th/elfutils-0.166-1
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 5 Apr 2016 14:55:28 +0000 (16:55 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 5 Apr 2016 14:55:28 +0000 (16:55 +0200)
- updated pl.po-update patch
- removed obsolete inline patch

elfutils-inline.patch [deleted file]
elfutils-pl.po.patch
elfutils.spec

diff --git a/elfutils-inline.patch b/elfutils-inline.patch
deleted file mode 100644 (file)
index a8a1d02..0000000
+++ /dev/null
@@ -1,221 +0,0 @@
---- elfutils-0.127/src/ld.h.orig       2006-07-12 01:20:42.000000000 +0200
-+++ elfutils-0.127/src/ld.h    2007-05-19 16:13:40.015849251 +0200
-@@ -1090,7 +1090,7 @@
- #ifdef __GNUC_STDC_INLINE__
- __attribute__ ((__gnu_inline__))
- #endif
--extern inline bool
-+extern __libdw_gnu_inline bool
- linked_from_dso_p (struct scninfo *scninfo, size_t symidx)
- {
-   struct usedfiles *file = scninfo->fileinfo;
---- elfutils-0.127/libdwfl/dwfl_module_getsrc_file.c.orig      2006-04-11 22:52:05.000000000 +0200
-+++ elfutils-0.127/libdwfl/dwfl_module_getsrc_file.c   2007-05-19 16:09:31.910875393 +0200
-@@ -79,15 +79,15 @@
-        && cu != NULL
-        && (error = __libdwfl_cu_getsrclines (cu)) == DWFL_E_NOERROR)
-     {
--      inline const char *INTUSE(dwarf_line_file) (const Dwarf_Line *line)
-+      __libdw_gnu_inline const char *INTUSE(dwarf_line_file) (const Dwarf_Line *line)
-       {
-         return line->files->info[line->file].name;
-       }
--      inline Dwarf_Line *dwfl_line (const Dwfl_Line *line)
-+      __libdw_gnu_inline Dwarf_Line *dwfl_line (const Dwfl_Line *line)
-       {
-         return &dwfl_linecu (line)->die.cu->lines->info[line->idx];
-       }
--      inline const char *dwfl_line_file (const Dwfl_Line *line)
-+      __libdw_gnu_inline const char *dwfl_line_file (const Dwfl_Line *line)
-       {
-         return INTUSE(dwarf_line_file) (dwfl_line (line));
-       }
---- elfutils-0.164/libdwfl/elf-from-memory.c.orig      2015-10-12 12:22:58.000000000 +0200
-+++ elfutils-0.164/libdwfl/elf-from-memory.c   2015-10-24 13:03:45.371641718 +0200
-@@ -223,7 +223,7 @@
-        segments_end, segments_end_mem and loadbase (if not
-        found_base yet).  Returns true if sanity checking failed,
-        false otherwise.  */
--      inline bool handle_segment (GElf_Addr vaddr, GElf_Off offset,
-+      __libdw_gnu_inline bool handle_segment (GElf_Addr vaddr, GElf_Off offset,
-                                 GElf_Xword filesz, GElf_Xword memsz)
-       {
-         /* Sanity check the segment load aligns with the pagesize.  */
-@@ -303,7 +303,7 @@
-     {
-       /* Reads the given segment.  Returns true if reading fails,
-        false otherwise.  */
--      inline bool handle_segment (GElf_Addr vaddr, GElf_Off offset,
-+      __libdw_gnu_inline bool handle_segment (GElf_Addr vaddr, GElf_Off offset,
-                                 GElf_Xword filesz)
-       {
-         GElf_Off start = offset & -pagesize;
---- elfutils-0.127/libdwfl/argp-std.c.orig     2007-04-05 11:12:36.000000000 +0200
-+++ elfutils-0.127/libdwfl/argp-std.c  2007-05-19 16:08:04.209055832 +0200
-@@ -106,7 +106,7 @@
- static error_t
- parse_opt (int key, char *arg, struct argp_state *state)
- {
--  inline void failure (Dwfl *dwfl, int errnum, const char *msg)
-+  __libdw_gnu_inline void failure (Dwfl *dwfl, int errnum, const char *msg)
-     {
-       if (errnum == -1)
-       argp_failure (state, EXIT_FAILURE, 0, "%s: %s",
-@@ -116,7 +116,7 @@
-       if (dwfl != NULL)
-       dwfl_end (dwfl);
-     }
--  inline error_t fail (Dwfl *dwfl, int errnum, const char *msg)
-+  __libdw_gnu_inline error_t fail (Dwfl *dwfl, int errnum, const char *msg)
-     {
-       failure (dwfl, errnum, msg);
-       return errnum == -1 ? EIO : errnum;
---- elfutils-0.127/libdwfl/linux-proc-maps.c.orig      2007-04-05 11:12:36.000000000 +0200
-+++ elfutils-0.127/libdwfl/linux-proc-maps.c   2007-05-19 16:09:02.093611158 +0200
-@@ -134,7 +134,7 @@
-   char *last_file = NULL;
-   Dwarf_Addr low = 0, high = 0;
--  inline bool report (void)
-+  __libdw_gnu_inline bool report (void)
-     {
-       if (last_file != NULL)
-       {
---- elfutils-0.159/libdwfl/dwfl_module_addrsym.c.orig  2014-06-14 14:36:48.425126218 +0200
-+++ elfutils-0.159/libdwfl/dwfl_module_addrsym.c       2014-06-14 14:42:22.541785921 +0200
-@@ -44,7 +44,7 @@ __libdwfl_addrsym (Dwfl_Module *mod, GEl
-   /* Return true iff we consider ADDR to lie in the same section as SYM.  */
-   GElf_Word addr_shndx = SHN_UNDEF;
-   Elf *addr_symelf = NULL;
--  inline bool same_section (GElf_Addr value, Elf *symelf, GElf_Word shndx)
-+  __libdw_gnu_inline bool same_section (GElf_Addr value, Elf *symelf, GElf_Word shndx)
-     {
-       /* For absolute symbols and the like, only match exactly.  */
-       if (shndx >= SHN_LORESERVE)
---- elfutils-0.127/backends/ia64_retval.c.orig 2006-07-21 13:28:28.000000000 +0200
-+++ elfutils-0.127/backends/ia64_retval.c      2007-05-19 16:13:08.295213177 +0200
-@@ -96,7 +96,7 @@
-      If we find a datum that's not the same FP type as the first datum, punt.
-      If we count more than eight total homogeneous FP data, punt.  */
--  inline int hfa (const Dwarf_Op *loc, int nregs)
-+  __libdw_gnu_inline int hfa (const Dwarf_Op *loc, int nregs)
-     {
-       if (fpregs_used == 0)
-       *locp = loc;
---- elfutils-0.130/libdw/libdw.h.orig  2007-10-16 07:21:41.000000000 +0200
-+++ elfutils-0.130/libdw/libdw.h       2007-11-03 16:02:19.906831295 +0100
-@@ -61,10 +61,12 @@
- # define __nonnull_attribute__(args...)
- #endif
--#ifdef __GNUC_STDC_INLINE__
-+#if defined(__GNUC_STDC_INLINE__) || defined(__GNUC_GNU_INLINE__)
- # define __libdw_extern_inline extern __inline __attribute__ ((__gnu_inline__))
-+# define __libdw_gnu_inline __inline __attribute__ ((__gnu_inline__))
- #else
- # define __libdw_extern_inline extern __inline
-+# define __libdw_gnu_inline __inline
- #endif
---- elfutils-0.127/libdw/dwarf_getscopevar.c.orig      2006-04-11 22:52:05.000000000 +0200
-+++ elfutils-0.127/libdw/dwarf_getscopevar.c   2007-05-19 16:11:06.586106385 +0200
-@@ -93,7 +93,7 @@
-   size_t match_file_len = match_file == NULL ? 0 : strlen (match_file);
-   bool lastfile_matches = false;
-   const char *lastfile = NULL;
--  inline bool file_matches (Dwarf_Files *files, size_t idx)
-+  __libdw_gnu_inline bool file_matches (Dwarf_Files *files, size_t idx)
-     {
-       if (idx >= files->nfiles)
-       return false;
---- elfutils-0.127/libdw/libdw_visit_scopes.c.orig     2006-04-11 22:52:05.000000000 +0200
-+++ elfutils-0.127/libdw/libdw_visit_scopes.c  2007-05-19 16:11:28.309875205 +0200
-@@ -107,7 +107,7 @@
-   if (INTUSE(dwarf_child) (&root->die, &child.die) != 0)
-     return -1;
--  inline int recurse (void)
-+  __libdw_gnu_inline int recurse (void)
-     {
-       return __libdw_visit_scopes (depth + 1, &child,
-                                  previsit, postvisit, arg);
---- elfutils-0.127/libdw/dwarf_entry_breakpoints.c.orig        2006-04-11 22:52:05.000000000 +0200
-+++ elfutils-0.127/libdw/dwarf_entry_breakpoints.c     2007-05-19 16:12:17.807534209 +0200
-@@ -64,7 +64,7 @@
-   *bkpts = NULL;
-   /* Add one breakpoint location to the result vector.  */
--  inline int add_bkpt (Dwarf_Addr pc)
-+  __libdw_gnu_inline int add_bkpt (Dwarf_Addr pc)
-     {
-       Dwarf_Addr *newlist = realloc (*bkpts, ++nbkpts * sizeof newlist[0]);
-       if (newlist == NULL)
-@@ -80,7 +80,7 @@
-     }
-   /* Fallback result, break at the entrypc/lowpc value.  */
--  inline int entrypc_bkpt (void)
-+  __libdw_gnu_inline int entrypc_bkpt (void)
-     {
-       Dwarf_Addr pc;
-       return INTUSE(dwarf_entrypc) (die, &pc) < 0 ? -1 : add_bkpt (pc);
-@@ -107,7 +107,7 @@
-   /* Search a contiguous PC range for prologue-end markers.
-      If DWARF, look for proper markers.
-      Failing that, if ADHOC, look for the ad hoc convention.  */
--  inline int search_range (Dwarf_Addr low, Dwarf_Addr high,
-+  __libdw_gnu_inline int search_range (Dwarf_Addr low, Dwarf_Addr high,
-                          bool dwarf, bool adhoc)
-     {
-       size_t l = 0, u = nlines;
---- elfutils-0.135/src/strip.c.orig    2008-05-31 10:15:02.975418315 +0200
-+++ elfutils-0.135/src/strip.c 2008-05-31 10:28:10.216279777 +0200
-@@ -1335,7 +1335,7 @@
-       /* Update section headers when the data size has changed.
-          We also update the SHT_NOBITS section in the debug
-          file so that the section headers match in sh_size.  */
--      inline void update_section_size (const Elf_Data *newdata)
-+      __libdw_gnu_inline void update_section_size (const Elf_Data *newdata)
-       {
-         GElf_Shdr shdr_mem;
-         GElf_Shdr *shdr = gelf_getshdr (scn, &shdr_mem);
---- elfutils-0.128/src/unstrip.c.orig  2007-06-06 01:44:33.000000000 +0200
-+++ elfutils-0.128/src/unstrip.c       2007-06-12 18:51:03.570085226 +0200
-@@ -371,7 +371,7 @@
- {
-   Elf_Data *data = elf_getdata (outscn, NULL);
--  inline void adjust_reloc (GElf_Xword *info)
-+  __libdw_gnu_inline void adjust_reloc (GElf_Xword *info)
-     {
-       size_t ndx = GELF_R_SYM (*info);
-       if (ndx != STN_UNDEF)
-@@ -988,7 +988,7 @@
-     }
-   bool fail = false;
--  inline void check_match (bool match, Elf_Scn *scn, const char *name)
-+  __libdw_gnu_inline void check_match (bool match, Elf_Scn *scn, const char *name)
-     {
-       if (!match)
-       {
-@@ -1147,7 +1147,7 @@
-     }
-   /* Locate a matching unallocated section in SECTIONS.  */
--  inline struct section *find_unalloc_section (const GElf_Shdr *shdr,
-+  __libdw_gnu_inline struct section *find_unalloc_section (const GElf_Shdr *shdr,
-                                              const char *name)
-     {
-       size_t l = nalloc, u = stripped_shnum - 1;
-@@ -1983,7 +1983,7 @@
- handle_implicit_modules (const struct arg_info *info)
- {
-   struct match_module_info mmi = { info->args, NULL, info->match_files };
--  inline ptrdiff_t next (ptrdiff_t offset)
-+  __libdw_gnu_inline ptrdiff_t next (ptrdiff_t offset)
-     {
-       return dwfl_getmodules (info->dwfl, &match_module, &mmi, offset);
-     }
index dee082bca1e53f246e7ad10526195cfb00551c74..71b1b8859a73a297b27dc0d205720bbe79047c34 100644 (file)
---- elfutils-0.164/po/pl.po.orig       2015-10-16 13:26:11.000000000 +0200
-+++ elfutils-0.164/po/pl.po    2015-10-24 12:55:01.951652622 +0200
-@@ -1635,13 +1635,12 @@
"programu\n"
+--- elfutils-0.166/po/pl.po.orig       2016-04-05 16:15:29.546180944 +0200
++++ elfutils-0.166/po/pl.po    2016-04-05 16:17:52.312841621 +0200
+@@ -4292,9 +4292,9 @@
msgstr "%s: rozmiar sekcji %zd „%s” nie jest wielokrotnością rozmiaru wpisu"
  
- #: src/elflint.c:863
+ #: src/nm.c:1316
 -#, fuzzy, c-format
 +#, c-format
- msgid ""
- "section [%2d] '%s': symbol %zu: TLS symbol but couldn't get TLS program "
- "header entry\n"
- msgstr ""
--"sekcja [%2d] \"%s\": symbol %zu: symbol TLS, ale brak wpisu TLS nagłówka "
--"programu\n"
-+"sekcja [%2d] \"%s\": symbol %zu: symbol TLS, ale nie udało się pobrać wpisu TLS nagłówka programu\n"
+ msgid "%s: entries (%zd) in section %zd `%s' is too large"
+-msgstr "%s: rozmiar wpisu w sekcji %zd „%s” nie jest tym, czego oczekiwano"
++msgstr "%s: liczba wpisów (%zd) w sekcji %zd „%s” jest zbyt duża"
  
- #: src/elflint.c:871
+ #: src/nm.c:1542
  #, c-format
-@@ -1806,10 +1805,10 @@
- msgstr "sekcja [%2d] \"%s\": sh_info powinno wynosić zero\n"
+@@ -4926,9 +4926,9 @@
+ msgstr "Nie można dekompresować sekcji"
  
- #: src/elflint.c:1259
+ #: src/readelf.c:1534 src/readelf.c:2248 src/readelf.c:3331
 -#, fuzzy, c-format
 +#, c-format
- msgid ""
- "section [%2d] '%s': no relocations for merge-able string sections possible\n"
--msgstr "sekcja [%2d] \"%s\": relokacje dla sekcji złączalnych są niemożliwe\n"
-+msgstr "sekcja [%2d] \"%s\": relokacje dla sekcji złączalnych łańcuchów są niemożliwe\n"
+ msgid "cannot get section [%zd] header: %s"
+-msgstr "nie można uzyskać nagłówka sekcji: %s"
++msgstr "nie można uzyskać nagłówka sekcji [%zd]: %s"
  
- #: src/elflint.c:1267
- #, c-format
-@@ -2377,9 +2376,9 @@
- msgstr "sekcja [%2d] \"%s\": nieznane flagi grupy sekcji\n"
- #: src/elflint.c:2689
--#, fuzzy, c-format
-+#, c-format
- msgid "section [%2d] '%s': section index %zu out of range\n"
--msgstr "sekcja [%2d] \"%s\": indeks sekcji %Zu jest spoza zakresu\n"
-+msgstr "sekcja [%2d] \"%s\": indeks sekcji %zu jest spoza zakresu\n"
- #: src/elflint.c:2698
- #, c-format
-@@ -2393,12 +2392,12 @@
- msgstr "sekcja [%2d] \"%s\": grupa sekcji zawiera inną grupę [%2d] \"%s\"\n"
- #: src/elflint.c:2711
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "section [%2d] '%s': element %zu references section [%2d] '%s' without "
- "SHF_GROUP flag set\n"
- msgstr ""
--"sekcja [%2d] \"%s\": element %Zu odwołuje się do sekcji [%2d] \"%s\" bez "
-+"sekcja [%2d] \"%s\": element %zu odwołuje się do sekcji [%2d] \"%s\" bez "
- "flagi SHF_GROUP\n"
- #: src/elflint.c:2718
-@@ -2906,9 +2905,9 @@
- "sekcja [%2zu] \"%s\" posiada nieoczekiwany typ %d dla sekcji wykonywalnej\n"
- #: src/elflint.c:3945
--#, fuzzy, c-format
-+#, c-format
- msgid "section [%2zu] '%s' must be of type NOBITS in debuginfo files\n"
--msgstr "sekcja [%2zu] \"%s\" nie może być zapisywalna\n"
-+msgstr "sekcja [%2zu] \"%s\" musi być typu NOBITS w plikach debuginfo\n"
- #: src/elflint.c:3952
- #, c-format
-@@ -2934,13 +2933,13 @@
- "segmencie wpisu %d nagłówka programu\n"
- #: src/elflint.c:4018
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "section [%2zu] '%s' has type NOBITS but is read from the file in segment of "
- "program header entry %d and file contents is non-zero\n"
- msgstr ""
- "sekcja [%2zu] \"%s\" posiada typ NOBITS, a jest odczytywana z pliku w "
--"segmencie wpisu %d nagłówka programu\n"
-+"segmencie wpisu %d nagłówka programu i plik jest niepusty\n"
- #: src/elflint.c:4029
- #, c-format
-@@ -3037,26 +3036,26 @@
- "phdr[%d]: nieznany typ notatki pliku core %<PRIu32> pod offsetem %<PRIu64>\n"
- #: src/elflint.c:4256
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "section [%2d] '%s': unknown core file note type %<PRIu32> at offset %zu\n"
- msgstr ""
--"phdr[%2d]: \"%s\": nieznany typ notatki pliku core %<PRIu32> pod offsetem "
--"%Zu\n"
-+"sekcja [%2d] \"%s\": nieznany typ notatki pliku core %<PRIu32> pod offsetem "
-+"%zu\n"
- #: src/elflint.c:4279
--#, fuzzy, c-format
-+#, c-format
- msgid "phdr[%d]: unknown object file note type %<PRIu32> at offset %zu\n"
- msgstr ""
--"phdr[%d]: nieznany typ notatki pliku obiektu %<PRIu32> pod offsetem %Zu\n"
-+"phdr[%d]: nieznany typ notatki pliku obiektu %<PRIu32> pod offsetem %zu\n"
- #: src/elflint.c:4283
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "section [%2d] '%s': unknown object file note type %<PRIu32> at offset %zu\n"
- msgstr ""
- "sekcja [%2d] \"%s\": nieznany typ notatki pliku obiektu %<PRIu32> pod "
--"offsetem %Zu\n"
-+"offsetem %zu\n"
- #: src/elflint.c:4300
- #, c-format
-@@ -3153,6 +3152,7 @@
- msgid ""
- "GNU_RELRO [%u] flags are not a subset of the loadable segment [%u] flags\n"
- msgstr ""
-+"Flagi GNU_RELRO [%u] nie są podzbiorem flag segmentu wczytywalnego [%u]\n"
- #: src/elflint.c:4496 src/elflint.c:4519
- #, c-format
-@@ -4061,11 +4061,11 @@
- msgstr "podczas odczytywania skryptu konsolidatora \"%s\": %s w wierszu %d"
- #: src/ldscript.y:737
--#, fuzzy, c-format
-+#, c-format
- msgid "symbol '%s' is declared both local and global for unnamed version '%s'"
- msgstr ""
- "symbol \"%s\" jest zadeklarowany jednocześnie lokalny i globalny dla "
--"nienazwanej wersji"
-+"nienazwanej wersji '%s'"
- #: src/ldscript.y:739
- #, c-format
-@@ -4861,9 +4861,9 @@
- #: src/readelf.c:1585 src/readelf.c:2208 src/readelf.c:2466 src/readelf.c:2542
- #: src/readelf.c:2846 src/readelf.c:2920 src/readelf.c:4608
--#, fuzzy, c-format
-+#, c-format
- msgid "invalid sh_link value in section %zu"
--msgstr "nieprawidłowa wartość sh_link w sekcji %Zu"
-+msgstr "nieprawidłowa wartość sh_link w sekcji %zu"
- #: src/readelf.c:1588
- #, c-format
-@@ -5495,13 +5495,13 @@
- "Sekcja DWARF [%2zu] \"%s\" pod offsetem %#<PRIx64>:\n"
- #: src/readelf.c:4689 src/readelf.c:6386
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "\n"
- "Table at offset %zu:\n"
- msgstr ""
- "\n"
--"Tabela pod offsetem %Zu:\n"
-+"Tabela pod offsetem %zu:\n"
- #: src/readelf.c:4693 src/readelf.c:5430 src/readelf.c:6397
- #, c-format
-@@ -5567,9 +5567,9 @@
- msgstr "   %s..%s\n"
- #: src/readelf.c:4807
--#, fuzzy, c-format
-+#, c-format
- msgid "   %zu padding bytes\n"
--msgstr "   bajty wypełnienia: %Zu\n"
-+msgstr "   bajty wypełnienia: %zu\n"
- #: src/readelf.c:4825
- #, c-format
-@@ -6233,46 +6233,46 @@
- "Segment notatki o długości %<PRIu64> bajtów pod offsetem %#0<PRIx64>:\n"
- #: src/readelf.c:9395
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "\n"
- "Section [%zu] '%s' has no data to dump.\n"
- msgstr ""
- "\n"
--"Sekcja [%Zu] \"%s\" nie posiada danych do zrzucenia.\n"
-+"Sekcja [%zu] \"%s\" nie posiada danych do zrzucenia.\n"
- #: src/readelf.c:9401 src/readelf.c:9424
--#, fuzzy, c-format
-+#, c-format
- msgid "cannot get data for section [%zu] '%s': %s"
--msgstr "nie można uzyskać danych dla sekcji [%Zu] \"%s\": %s"
-+msgstr "nie można uzyskać danych dla sekcji [%zu] \"%s\": %s"
- #: src/readelf.c:9405
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "\n"
- "Hex dump of section [%zu] '%s', %<PRIu64> bytes at offset %#0<PRIx64>:\n"
- msgstr ""
- "\n"
--"Segment zrzutu szesnastkowego [%Zu] \"%s\", %<PRIu64> bajtów pod offsetem "
-+"Zrzut szesnastkowy sekcji [%zu] \"%s\", %<PRIu64> bajtów pod offsetem "
- "%#0<PRIx64>:\n"
- #: src/readelf.c:9418
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "\n"
- "Section [%zu] '%s' has no strings to dump.\n"
- msgstr ""
- "\n"
--"Sekcja [%Zu] \"%s\" nie posiada ciągów do zrzucenia.\n"
-+"Sekcja [%zu] \"%s\" nie posiada ciągów do zrzucenia.\n"
- #: src/readelf.c:9428
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "\n"
- "String section [%zu] '%s' contains %<PRIu64> bytes at offset %#0<PRIx64>:\n"
- msgstr ""
- "\n"
--"Sekcja ciągów [%Zu] \"%s\" zawiera %<PRIu64> bajtów pod offsetem "
-+"Sekcja ciągów [%zu] \"%s\" zawiera %<PRIu64> bajtów pod offsetem "
- "%#0<PRIx64>:\n"
- #: src/readelf.c:9476
-@@ -6308,18 +6308,18 @@
- "Archiwum \"%s\" nie posiada indeksu symboli\n"
- #: src/readelf.c:9569
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "\n"
- "Index of archive '%s' has %zu entries:\n"
- msgstr ""
- "\n"
--"Indeks archiwum \"%s\" posiada %Zu wpisów:\n"
-+"Indeks archiwum \"%s\" posiada %zu wpisów:\n"
- #: src/readelf.c:9587
--#, fuzzy, c-format
-+#, c-format
- msgid "cannot extract member at offset %zu in '%s': %s"
--msgstr "nie można wydobyć elementów pod offsetem %Zu w \"%s\": %s"
-+msgstr "nie można wydobyć elementów pod offsetem %zu w \"%s\": %s"
- #: src/readelf.c:9592
- #, c-format
-@@ -6573,9 +6573,9 @@
- msgstr "nieprawidłowa minimalna długość dopasowanego rozmiaru ciągu"
- #: src/strings.c:600
--#, fuzzy, c-format
-+#, c-format
- msgid "lseek failed"
--msgstr "lseek64 się nie powiodło"
-+msgstr "lseek nie powiodło się"
- #: src/strings.c:617 src/strings.c:681
- #, c-format
-@@ -6924,19 +6924,19 @@
- msgstr "nie można uzyskać wersji symbolu: %s"
- #: src/unstrip.c:526
--#, fuzzy, c-format
-+#, c-format
- msgid "unexpected section type in [%zu] with sh_link to symtab"
--msgstr "nieoczekiwany typ sekcji w [%Zu] z sh_link do tabeli symboli"
-+msgstr "nieoczekiwany typ sekcji w [%zu] z sh_link do tabeli symboli"
- #: src/unstrip.c:774
--#, fuzzy, c-format
-+#, c-format
- msgid "invalid string offset in symbol [%zu]"
--msgstr "nieprawidłowy offset ciągu w symbolu [%Zu]"
-+msgstr "nieprawidłowy offset ciągu w symbolu [%zu]"
- #: src/unstrip.c:932 src/unstrip.c:1278
--#, fuzzy, c-format
-+#, c-format
- msgid "cannot read section [%zu] name: %s"
--msgstr "nie można odczytać nazwy sekcji [%Zu]: %s"
-+msgstr "nie można odczytać nazwy sekcji [%zu]: %s"
- #: src/unstrip.c:973 src/unstrip.c:992 src/unstrip.c:1027
- #, c-format
-@@ -6951,12 +6951,12 @@
- #: src/unstrip.c:1019
- #, c-format
- msgid "overflow with shnum = %zu in '%s' section"
--msgstr ""
-+msgstr "przepełnienie z shnum = %zu w sekcji '%s'"
- #: src/unstrip.c:1073 src/unstrip.c:1398
--#, fuzzy, c-format
-+#, c-format
- msgid "cannot find matching section for [%zu] '%s'"
--msgstr "nie można odnaleźć pasującej sekcji dla [%Zu] \"%s\""
-+msgstr "nie można odnaleźć pasującej sekcji dla [%zu] \"%s\""
- #: src/unstrip.c:1198 src/unstrip.c:1213 src/unstrip.c:1479 src/unstrip.c:1731
- #, c-format
-@@ -6996,9 +6996,9 @@
- msgstr "nie można dodać nowej sekcji: %s"
- #: src/unstrip.c:1583
--#, fuzzy, c-format
-+#, c-format
- msgid "symbol [%zu] has invalid section index"
--msgstr "symbol [%Zu] posiada nieprawidłowy indeks sekcji"
-+msgstr "symbol [%zu] posiada nieprawidłowy indeks sekcji"
- #: src/unstrip.c:1864
- #, c-format
-@@ -7177,6 +7177,3 @@
- #: tests/dwflmodtest.c:214
- msgid "Show instances of inlined functions"
- msgstr "Wyświetla wystąpienia wstawionych funkcji"
--
--#~ msgid "cannot get section header of section %Zu: %s"
--#~ msgstr "nie można uzyskać nagłówka sekcji dla sekcji %Zu: %s"
+ #: src/readelf.c:1678 src/readelf.c:2315 src/readelf.c:2573 src/readelf.c:2649
+ #: src/readelf.c:2953 src/readelf.c:3027 src/readelf.c:4729
index 989bc0d2ffe30a8fcb1580f9a34929ca92ad877d..14499b92535279d55e108ce120fe70a2d5922246 100644 (file)
@@ -5,20 +5,19 @@
 Summary:       A collection of utilities and DSOs to handle compiled objects
 Summary(pl.UTF-8):     Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
 Name:          elfutils
-Version:       0.164
+Version:       0.166
 Release:       1
 License:       GPL v2+ or LGPL v3+ (libraries), GPL v3+ (programs)
 Group:         Development/Tools
 Source0:       https://fedorahosted.org/releases/e/l/elfutils/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 2e4536c1c48034f188a80789a59114d8
+# Source0-md5: d4e462b7891915dc5326bccefa2024ff
 Patch0:                %{name}-pl.po.patch
 Patch1:                %{name}-debian-manpages.patch
 Patch2:                %{name}-awk.patch
 Patch3:                %{name}-align.patch
 Patch4:                %{name}-paxflags.patch
 Patch5:                %{name}-sparc.patch
-Patch6:                %{name}-inline.patch
-Patch7:                %{name}-maps.patch
+Patch6:                %{name}-maps.patch
 URL:           https://fedorahosted.org/elfutils/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.8
@@ -68,6 +67,9 @@ Summary:      Development part of libraries to handle compiled objects
 Summary(pl.UTF-8):     Część programistyczna bibliotek do obsługi skompilowanych obiektów
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      bzip2-devel
+Requires:      xz-devel
+Requires:      zlib-devel
 Obsoletes:     libelf-devel
 
 %description devel
@@ -140,7 +142,6 @@ programowalny interfejs asemblera.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch7 -p1
 
 %{__rm} po/stamp-po
 
@@ -219,6 +220,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/gelf.h
 %{_includedir}/libelf.h
 %{_includedir}/nlist.h
+%{_pkgconfigdir}/libdw.pc
+%{_pkgconfigdir}/libelf.pc
 
 %files libelf -f %{name}.lang
 %defattr(644,root,root,755)
This page took 0.206351 seconds and 4 git commands to generate.