]> git.pld-linux.org Git - packages/elfutils.git/commitdiff
- added tests patch from git (fix strip-nothing test with unstripped libc_nonshared... auto/th/elfutils-0.170-2
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 Nov 2017 18:26:51 +0000 (19:26 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 23 Nov 2017 18:26:51 +0000 (19:26 +0100)
elfutils-tests.patch [new file with mode: 0644]
elfutils.spec

diff --git a/elfutils-tests.patch b/elfutils-tests.patch
new file mode 100644 (file)
index 0000000..18b6630
--- /dev/null
@@ -0,0 +1,45 @@
+From 8f0140ace401197beaed1df6a48f259756d8bbd9 Mon Sep 17 00:00:00 2001
+From: "Dmitry V. Levin" <ldv@altlinux.org>
+Date: Tue, 8 Aug 2017 19:06:16 +0300
+Subject: [PATCH] tests: robustify run-strip-nothing.sh against unstripped
+ libc_nonshared.a
+
+When glibc's libc_nonshared.a contains objects with debug info,
+this debug info is leaked into every output file produced by gcc.
+Change run-strip-nothing.sh to use "gcc -s" instead of plain "gcc"
+for producing objects without debug info.
+
+Signed-off-by: Dmitry V. Levin <ldv@altlinux.org>
+---
+ tests/ChangeLog            | 4 ++++
+ tests/run-strip-nothing.sh | 2 +-
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/tests/ChangeLog b/tests/ChangeLog
+index 04efdc8..94f4cf2 100644
+--- a/tests/ChangeLog
++++ b/tests/ChangeLog
+@@ -1,3 +1,7 @@
++2017-08-08  Dmitry V. Levin <ldv@altlinux.org>
++
++      * run-strip-nothing.sh: Add -s.
++
+ 2017-07-26  Mark Wielaard  <mark@klomp.org>
+       * dwarf-getmacros.c (mac): Use DW_MACRO names instead of DW_MACRO_GNU.
+diff --git a/tests/run-strip-nothing.sh b/tests/run-strip-nothing.sh
+index e80bd90..914fdfb 100755
+--- a/tests/run-strip-nothing.sh
++++ b/tests/run-strip-nothing.sh
+@@ -23,7 +23,7 @@
+ tempfiles a.out strip.out debug.out
+ # Create no-debug a.out.
+-echo "int main() { return 1; }" | gcc -xc -
++echo "int main() { return 1; }" | gcc -s -xc -
+ # strip to file
+ testrun ${abs_top_builddir}/src/strip -g -o strip.out ||
+-- 
+2.9.3
+
index 4c02df7129a26723ab60d8ab2cbc373424c8f691..e561e693b91877fb6fcca406e16b3f446b5cf42b 100644 (file)
@@ -6,7 +6,7 @@ Summary:        A collection of utilities and DSOs to handle compiled objects
 Summary(pl.UTF-8):     Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
 Name:          elfutils
 Version:       0.170
-Release:       1
+Release:       2
 License:       GPL v2+ or LGPL v3+ (libraries), GPL v3+ (programs)
 Group:         Development/Tools
 Source0:       https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
@@ -18,6 +18,8 @@ Patch3:               %{name}-align.patch
 Patch4:                %{name}-paxflags.patch
 Patch5:                %{name}-sparc.patch
 Patch6:                %{name}-maps.patch
+# https://sourceware.org/git/?p=elfutils.git;a=patch;h=8f0140ace401197beaed1df6a48f259756d8bbd9
+Patch7:                %{name}-tests.patch
 URL:           https://sourceware.org/elfutils/
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
@@ -146,6 +148,7 @@ programowalny interfejs asemblera.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
+%patch7 -p1
 
 %{__rm} po/stamp-po
 
This page took 0.042836 seconds and 4 git commands to generate.