]> git.pld-linux.org Git - packages/elfutils.git/blobdiff - elfutils.spec
- added maps patch (fixes backtrace selftest reading /proc/PID/maps:
[packages/elfutils.git] / elfutils.spec
index 87472a8a805a7eefc5b41775b522f9df65a6406f..b731be39361689c847c1bc439440e2e79bac9ada 100644 (file)
@@ -5,32 +5,27 @@
 Summary:       A collection of utilities and DSOs to handle compiled objects
 Summary(pl.UTF-8):     Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
 Name:          elfutils
-Version:       0.135
+Version:       0.164
 Release:       1
-License:       GPL v2 with OSL linking exception
+License:       GPL v2+ or LGPL v3+ (libraries), GPL v3+ (programs)
 Group:         Development/Tools
-# http://ftp.fi.muni.cz/pub/linux/fedora/linux/development/source/SRPMS/
-Source0:       %{name}-%{version}.tar.gz
-# Source0-md5: 2fb0d3d9cdb22f71ad0df91d676bb2eb
+Source0:       https://fedorahosted.org/releases/e/l/elfutils/%{version}/%{name}-%{version}.tar.bz2
+# Source0-md5: 2e4536c1c48034f188a80789a59114d8
 Patch0:                %{name}-pl.po.patch
 Patch1:                %{name}-debian-manpages.patch
-Patch2:                %{name}-portability.patch
-Patch3:                %{name}-robustify.patch
-Patch4:                %{name}-align.patch
-Patch5:                %{name}-paxflags.patch
-Patch6:                %{name}-sparc.patch
-Patch7:                %{name}-inline.patch
-Patch8:                %{name}-Werror.patch
-#URL:          file://home/devel/drepper
-BuildRequires: autoconf >= 2.59
-BuildRequires: automake >= 1:1.7
-BuildRequires: gcc >= 3.2
-BuildRequires: gettext-devel
-%ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
-# PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
-# also needed for nanosecond timestamps on alpha
-BuildRequires: glibc-devel >= 6:2.3.4
-%endif
+Patch2:                %{name}-awk.patch
+Patch3:                %{name}-align.patch
+Patch4:                %{name}-paxflags.patch
+Patch5:                %{name}-sparc.patch
+Patch6:                %{name}-inline.patch
+Patch7:                %{name}-maps.patch
+URL:           https://fedorahosted.org/elfutils/
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake >= 1:1.8
+BuildRequires: gawk
+BuildRequires: gcc >= 6:4.3
+BuildRequires: gettext-tools
+BuildRequires: glibc-devel >= 6:2.7
 BuildRequires: perl-tools-pod
 BuildRequires: rpmbuild(macros) >= 1.315
 BuildRequires: sharutils
@@ -43,6 +38,10 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # fails to build with -Wl,-s
 %define                filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
+%if %{with tests} && 0%(echo %{rpmcflags} | grep -q '\<-g' ; echo $?)
+# tests require debug symbols
+%define                specflags       -g
+%endif
 
 %define                programprefix   eu-
 
@@ -142,24 +141,22 @@ programowalny interfejs asemblera.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
 
-rm -f po/stamp-po
+%{__rm} po/stamp-po
 
-# temporarily disable test failing on specific archs
-%ifarch alpha sparc sparc64
-%{__perl} -pi -e 's/run-elflint-self.sh//' tests/Makefile
-%endif
+# temporarily disable failing tests (depending or arch)
+#%{__sed} -i -e 's/run-elflint-self.sh//' tests/Makefile.am
 
 %build
 #%%{__gettextize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
-       --program-prefix=%{programprefix} \
-       --enable-shared
+       --disable-silent-rules \
+       --disable-werror \
+       --program-prefix=%{programprefix}
 
 # make check depends on test-nlist not stripped
 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
@@ -182,9 +179,9 @@ install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
 
 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
-mv $RPM_BUILD_ROOT%{_libdir}/{libelf-*.so,libelf.so.*} $RPM_BUILD_ROOT/%{_lib}
+%{__mv} $RPM_BUILD_ROOT%{_libdir}/{libelf-*.so,libelf.so.*} $RPM_BUILD_ROOT/%{_lib}
 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libelf-*.so) \
-        $RPM_BUILD_ROOT%{_libdir}/libelf.so
+       $RPM_BUILD_ROOT%{_libdir}/libelf.so
 
 %find_lang %{name}
 
@@ -199,12 +196,12 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS EXCEPTION NEWS NOTES README THANKS TODO
+%doc AUTHORS CONTRIBUTING ChangeLog NEWS NOTES README THANKS TODO
 %attr(755,root,root) %{_bindir}/eu-*
 %attr(755,root,root) %{_libdir}/libasm-*.so
-%ghost %attr(755,root,root) %{_libdir}/libasm.so.*
+%attr(755,root,root) %ghost %{_libdir}/libasm.so.1
 %attr(755,root,root) %{_libdir}/libdw-*.so
-%ghost %attr(755,root,root) %{_libdir}/libdw.so.*
+%attr(755,root,root) %ghost %{_libdir}/libdw.so.1
 %dir %{_libdir}/elfutils
 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
 %{_mandir}/man1/eu-*.1*
@@ -224,7 +221,7 @@ rm -rf $RPM_BUILD_ROOT
 %files libelf -f %{name}.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libelf-*.so
-%ghost %attr(755,root,root) /%{_lib}/libelf.so.*
+%attr(755,root,root) %ghost /%{_lib}/libelf.so.1
 
 %files static
 %defattr(644,root,root,755)
This page took 0.057605 seconds and 4 git commands to generate.