]> git.pld-linux.org Git - packages/elfutils.git/blobdiff - elfutils.spec
- updated to 0.151
[packages/elfutils.git] / elfutils.spec
index 3e4621303f5bdb8df83284fce886357cac3eb12f..92334a4305ac336cc67f00db4bbeeaf4b0bd296f 100644 (file)
@@ -5,35 +5,32 @@
 Summary:       A collection of utilities and DSOs to handle compiled objects
 Summary(pl.UTF-8):     Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
 Name:          elfutils
-Version:       0.125
+Version:       0.151
 Release:       1
 License:       GPL v2 with OSL linking exception
 Group:         Development/Tools
-# http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/
-# abuse systemtap to get .tar.gz directly
-Source0:       ftp://sources.redhat.com/pub/systemtap/elfutils/%{name}-%{version}.tar.gz
-# Source0-md5: b489f937b41e41e23a2e580c8bfd9e08
+Source0:       https://fedorahosted.org/releases/e/l/elfutils/%{version}/%{name}-%{version}.tar.bz2
+# Source0-md5: 9bc04e409a5510ba379afc3f853a59ae
 Patch0:                %{name}-pl.po.patch
 Patch1:                %{name}-debian-manpages.patch
 Patch2:                %{name}-portability.patch
 Patch3:                %{name}-robustify.patch
 Patch4:                %{name}-align.patch
 Patch5:                %{name}-paxflags.patch
-Patch6:                %{name}-alpha.patch
-Patch7:                %{name}-sparc.patch
-Patch8:                %{name}-strip-copy-symtab.patch
-Patch9:                %{name}-gcc4.patch
-#URL:          file://home/devel/drepper
+Patch6:                %{name}-sparc.patch
+Patch7:                %{name}-inline.patch
+Patch8:                %{name}-scanf.patch
+Patch9:                %{name}-strings_c.patch
+URL:           https://fedorahosted.org/elfutils/
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake >= 1:1.7
-BuildRequires: gcc >= 3.2
+BuildRequires: gcc >= 5:3.4
 BuildRequires: gettext-devel
 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
 # PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
 # also needed for nanosecond timestamps on alpha
 BuildRequires: glibc-devel >= 6:2.3.4
 %endif
-BuildRequires: libltdl-devel
 BuildRequires: perl-tools-pod
 BuildRequires: rpmbuild(macros) >= 1.315
 BuildRequires: sharutils
@@ -47,7 +44,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # fails to build with -Wl,-s
 %define                filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
 
-%define                _programprefix  eu-
+%define                programprefix   eu-
 
 %description
 Elfutils is a collection of utilities, including ld (a linker), nm
@@ -146,28 +143,30 @@ programowalny interfejs asemblera.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
-%patch9 -p1
+%patch9 -p0
 
-# strip-test5 needs adjusting for strip-copy-symtab patch (already in FC, but not worth bothering)
-# dwfl-bug-addr-overflow sources are missing in tar
-sed -i -e 's/ run-strip-test5\.sh / /;s/dwfl-bug-addr-overflow/$(nil)/' tests/Makefile.am
+%{__rm} po/stamp-po
+
+# temporarily disable test failing on specific archs
+%ifarch alpha
+%{__perl} -pi -e 's/run-elflint-self.sh//' tests/Makefile
+%endif
 
 %build
 #%%{__gettextize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoheader}
-%{__automake}
 %{__autoconf}
-
+%{__automake}
 %configure \
-       --program-prefix=%{_programprefix} \
-       --enable-shared
+       --program-prefix=%{programprefix}
 
 # make check depends on test-nlist not stripped
 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
 
 %{__make}
 %{__make} -C debian/man
+
 %if %{with tests}
 # some tests rely on English messages
 LC_ALL=C \
@@ -178,24 +177,15 @@ LC_ALL=C \
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
 
-# *OBJEXT must be passed to workaround problem with messed gettext,
-# which doesn't like *-po dir names
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       MKINSTALLDIRS=$(pwd)/config/mkinstalldirs \
-       CATOBJEXT=.gmo \
-       INSTOBJEXT=.mo
+       DESTDIR=$RPM_BUILD_ROOT
 
 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
 
-mv $RPM_BUILD_ROOT%{_libdir}/libelf-*.so $RPM_BUILD_ROOT/%{_lib}
-ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libelf-*.so) \
+mv $RPM_BUILD_ROOT%{_libdir}/{libelf-*.so,libelf.so.*} $RPM_BUILD_ROOT/%{_lib}
+ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libelf-*.so) \
         $RPM_BUILD_ROOT%{_libdir}/libelf.so
 
-/sbin/ldconfig -n -N $RPM_BUILD_ROOT%{_libdir}
-/sbin/ldconfig -n -N $RPM_BUILD_ROOT/%{_lib}
-
-%find_lang libelf
 %find_lang %{name}
 
 %clean
@@ -207,17 +197,17 @@ rm -rf $RPM_BUILD_ROOT
 %post  libelf -p /sbin/ldconfig
 %postun        libelf -p /sbin/ldconfig
 
-%files -f %{name}.lang
+%files
 %defattr(644,root,root,755)
-%doc AUTHORS COPYING NEWS NOTES README THANKS TODO
-%attr(755,root,root) %{_bindir}/*
+%doc AUTHORS EXCEPTION NEWS NOTES README THANKS TODO
+%attr(755,root,root) %{_bindir}/eu-*
 %attr(755,root,root) %{_libdir}/libasm-*.so
-%ghost %attr(755,root,root) %{_libdir}/libasm.so.*
+%attr(755,root,root) %ghost %{_libdir}/libasm.so.1
 %attr(755,root,root) %{_libdir}/libdw-*.so
-%ghost %attr(755,root,root) %{_libdir}/libdw.so.*
+%attr(755,root,root) %ghost %{_libdir}/libdw.so.1
 %dir %{_libdir}/elfutils
 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
-%{_mandir}/man1/*.1*
+%{_mandir}/man1/eu-*.1*
 
 %files devel
 %defattr(644,root,root,755)
@@ -225,12 +215,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libdw.so
 %attr(755,root,root) %{_libdir}/libelf.so
 %{_libdir}/libebl.a
-%{_includedir}/*
+%{_includedir}/elfutils
+%{_includedir}/dwarf.h
+%{_includedir}/gelf.h
+%{_includedir}/libelf.h
+%{_includedir}/nlist.h
 
-%files libelf -f libelf.lang
+%files libelf -f %{name}.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libelf-*.so
-%ghost %attr(755,root,root) /%{_lib}/libelf.so.*
+%attr(755,root,root) %ghost /%{_lib}/libelf.so.1
 
 %files static
 %defattr(644,root,root,755)
This page took 0.133214 seconds and 4 git commands to generate.