]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
separate libs and tools; rel 2
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl.UTF-8):      Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.168
9 Release:        1
10 License:        GPL v2+ or LGPL v3+ (libraries), GPL v3+ (programs)
11 Group:          Development/Tools
12 Source0:        https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
13 # Source0-md5:  52adfa40758d0d39e5d5c57689bf38d6
14 Patch0:         %{name}-pl.po.patch
15 Patch1:         %{name}-debian-manpages.patch
16 Patch2:         %{name}-awk.patch
17 Patch3:         %{name}-align.patch
18 Patch4:         %{name}-paxflags.patch
19 Patch5:         %{name}-sparc.patch
20 Patch6:         %{name}-maps.patch
21 URL:            https://sourceware.org/elfutils/
22 BuildRequires:  autoconf >= 2.63
23 BuildRequires:  automake >= 1:1.11
24 BuildRequires:  bzip2-devel
25 BuildRequires:  gawk
26 BuildRequires:  gcc >= 6:4.3
27 BuildRequires:  gettext-tools
28 BuildRequires:  glibc-devel >= 6:2.7
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  perl-tools-pod
31 BuildRequires:  rpmbuild(macros) >= 1.315
32 BuildRequires:  sharutils
33 BuildRequires:  xz-devel
34 BuildRequires:  zlib-devel
35 %if %{with tests} && %(test -d /proc/self ; echo $?)
36 # native test needs proc (for libdwfl -p PID to work)
37 BuildRequires:  MOUNTED_PROC
38 %endif
39 Requires:       %{name}-libelf = %{version}-%{release}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # fails to build with -Wl,-s
43 %define         filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
44 %if %{with tests} && 0%(echo %{rpmcflags} | grep -q '\<-g' ; echo $?)
45 # tests require debug symbols
46 %define         specflags       -g
47 %endif
48
49 %define         programprefix   eu-
50
51 %description
52 Elfutils is a collection of utilities, including ld (a linker), nm
53 (for listing symbols from object files), size (for listing the section
54 sizes of an object or archive file), strip (for discarding symbols),
55 readline (the see the raw ELF file structures), and elflint (to check
56 for well-formed ELF files). Also included are numerous helper
57 libraries which implement DWARF, ELF, and machine-specific ELF
58 handling.
59
60 %description -l pl.UTF-8
61 Elfutils to zestaw narzędzi, składający się z ld (linkera), nm (do
62 listowania symboli z plików obiektów), size (do listowania rozmiarów
63 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
64 readline (do oglądania surowych struktur plików ELF) oraz elflint (do
65 sprawdzania poprawności plików ELF). Dołączone są także liczne
66 biblioteki pomocnicze z zaimplementowaną obsługą DWARF, ELF i ELF
67 specyficznych dla architektury.
68
69 %package devel
70 Summary:        Development part of libraries to handle compiled objects
71 Summary(pl.UTF-8):      Część programistyczna bibliotek do obsługi skompilowanych obiektów
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Requires:       bzip2-devel
75 Requires:       xz-devel
76 Requires:       zlib-devel
77 Obsoletes:      libelf-devel
78
79 %description devel
80 The elfutils-devel package contains the development part of libraries
81 to create applications for handling compiled objects. libelf allows
82 you to access the internals of the ELF object file format, so you can
83 see the different sections of an ELF file. libebl provides some
84 higher-level ELF access functionality. libdwarf provides access to the
85 DWARF debugging information. libasm provides a programmable assembler
86 interface.
87
88 %description devel -l pl.UTF-8
89 Pakiet elfutils-devel zawiera część programistyczną bibliotek do
90 tworzenia aplikacji obsługujących skompilowane obiekty. libelf pozwala
91 na dostęp do wnętrzności formatu pliku obiektowego ELF, co pozwala na
92 oglądanie różnych sekcji pliku ELF. libebl udostępnia funkcjonalność
93 dostępu do plików ELF trochę wyższego poziomu. libdwarf pozwala na
94 dostęp do informacji DWARF służących do odpluskwiania. libasm
95 udostępnia programowalny interfejs asemblera.
96
97 %package libelf
98 Summary:        Library to read and write ELF files
99 Summary(pl.UTF-8):      Biblioteki do odczytu i zapisu plików ELF
100 Group:          Libraries
101 #Obsoletes:     libelf
102
103 %description libelf
104 The elfutils-libelf package provides a DSO which allows reading and
105 writing ELF files on a high level. Third party programs depend on this
106 package to read internals of ELF files. The programs of the elfutils
107 package use it also to generate new ELF files.
108
109 %description libelf -l pl.UTF-8
110 Pakiet elfutils-libelf udostępnia bibliotekę dzieloną, która pozwala
111 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
112 wymagają tego pakietu, aby odczytywać zawartość plików ELF. Programy z
113 pakietu elfutils używają jej także do generowania nowych plików ELF.
114
115 %package static
116 Summary:        Static libraries to handle compiled objects
117 Summary(pl.UTF-8):      Statyczne biblioteki do obsługi skompilowanych obiektów
118 Group:          Development/Libraries
119 Requires:       %{name}-devel = %{version}-%{release}
120 Obsoletes:      libelf-static
121
122 %description static
123 The elfutils-static package contains the static libraries to create
124 applications for handling compiled objects. libelf allows you to
125 access the internals of the ELF object file format, so you can see the
126 different sections of an ELF file. libebl provides some higher-level
127 ELF access functionality. libdwarf provides access to the DWARF
128 debugging information. libasm provides a programmable assembler
129 interface.
130
131 %description static -l pl.UTF-8
132 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
133 aplikacji obsługujących skompilowane obiekty. libelf pozwala na dostęp
134 do wnętrzności formatu pliku obiektowego ELF, co pozwala na oglądanie
135 różnych sekcji pliku ELF. libebl udostępnia funkcjonalność dostępu do
136 plików ELF trochę wyższego poziomu. libdwarf pozwala na dostęp do
137 informacji DWARF służących do odpluskwiania. libasm udostępnia
138 programowalny interfejs asemblera.
139
140 %prep
141 %setup -q
142 %patch0 -p1
143 %patch1 -p1
144 %patch2 -p1
145 %patch3 -p1
146 %patch4 -p1
147 %patch5 -p1
148 %patch6 -p1
149
150 %{__rm} po/stamp-po
151
152 # temporarily disable failing tests (depending or arch)
153 %ifarch x32
154 %{__sed} -i -e 's/run-backtrace-native-biarch.sh//' tests/Makefile.am
155 %endif
156
157 %build
158 #%%{__gettextize}
159 %{__aclocal} -I m4
160 %{__autoheader}
161 %{__autoconf}
162 %{__automake}
163 %configure \
164         --disable-silent-rules \
165         --disable-werror \
166         --program-prefix=%{programprefix}
167
168 # make check depends on test-nlist not stripped
169 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
170
171 %{__make}
172 %{__make} -C debian/man
173
174 %if %{with tests}
175 # some tests rely on English messages
176 LC_ALL=C \
177 %{__make} -C tests check
178 %endif
179
180 %install
181 rm -rf $RPM_BUILD_ROOT
182 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
183
184 %{__make} install \
185         DESTDIR=$RPM_BUILD_ROOT
186
187 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
188
189 %{__mv} $RPM_BUILD_ROOT%{_libdir}/{libelf-*.so,libelf.so.*} $RPM_BUILD_ROOT/%{_lib}
190 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libelf-*.so) \
191         $RPM_BUILD_ROOT%{_libdir}/libelf.so
192
193 %find_lang %{name}
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %post   -p /sbin/ldconfig
199 %postun -p /sbin/ldconfig
200
201 %post   libelf -p /sbin/ldconfig
202 %postun libelf -p /sbin/ldconfig
203
204 %files
205 %defattr(644,root,root,755)
206 %doc AUTHORS CONTRIBUTING ChangeLog NEWS NOTES README THANKS TODO
207 %attr(755,root,root) %{_bindir}/eu-*
208 %attr(755,root,root) %{_libdir}/libasm-*.so
209 %attr(755,root,root) %ghost %{_libdir}/libasm.so.1
210 %attr(755,root,root) %{_libdir}/libdw-*.so
211 %attr(755,root,root) %ghost %{_libdir}/libdw.so.1
212 %dir %{_libdir}/elfutils
213 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
214 %{_mandir}/man1/eu-*.1*
215
216 %files devel
217 %defattr(644,root,root,755)
218 %attr(755,root,root) %{_libdir}/libasm.so
219 %attr(755,root,root) %{_libdir}/libdw.so
220 %attr(755,root,root) %{_libdir}/libelf.so
221 %{_libdir}/libebl.a
222 %{_includedir}/elfutils
223 %{_includedir}/dwarf.h
224 %{_includedir}/gelf.h
225 %{_includedir}/libelf.h
226 %{_includedir}/nlist.h
227 %{_pkgconfigdir}/libdw.pc
228 %{_pkgconfigdir}/libelf.pc
229
230 %files libelf -f %{name}.lang
231 %defattr(644,root,root,755)
232 %attr(755,root,root) /%{_lib}/libelf-*.so
233 %attr(755,root,root) %ghost /%{_lib}/libelf.so.1
234
235 %files static
236 %defattr(644,root,root,755)
237 %{_libdir}/libasm.a
238 %{_libdir}/libdw.a
239 %{_libdir}/libelf.a
This page took 0.15236 seconds and 3 git commands to generate.