]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
8a8d84b1a3f007717d848d6f3f788d405c412c04
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl.UTF-8):      Zestaw narzędzi i bibliotek do obsługi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.177
9 Release:        0.1
10 License:        GPL v2+ or LGPL v3+ (libraries), GPL v3+ (programs)
11 Group:          Development/Tools
12 Source0:        https://sourceware.org/elfutils/ftp/%{version}/%{name}-%{version}.tar.bz2
13 # Source0-md5:  0b583722f911e1632544718d502aab87
14 Patch0:         %{name}-pl.po.patch
15 Patch1:         %{name}-debian-manpages.patch
16 Patch2:         %{name}-awk.patch
17 Patch3:         %{name}-align.patch
18 Patch4:         %{name}-paxflags.patch
19 Patch5:         %{name}-sparc.patch
20 URL:            https://sourceware.org/elfutils/
21 BuildRequires:  autoconf >= 2.63
22 BuildRequires:  automake >= 1:1.11
23 BuildRequires:  bzip2-devel
24 BuildRequires:  gawk
25 BuildRequires:  gcc >= 6:4.3
26 BuildRequires:  gettext-tools
27 BuildRequires:  glibc-devel >= 6:2.7
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  perl-tools-pod
30 BuildRequires:  rpmbuild(macros) >= 1.315
31 BuildRequires:  sharutils
32 BuildRequires:  xz-devel
33 BuildRequires:  zlib-devel
34 %if %{with tests} && %(test -d /proc/self ; echo $?)
35 # native test needs proc (for libdwfl -p PID to work)
36 BuildRequires:  MOUNTED_PROC
37 %endif
38 Requires:       %{name}-libelf = %{version}-%{release}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 # fails to build with -Wl,-s
42 %define         filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
43 %if %{with tests} && 0%(echo %{rpmcflags} | grep -q '\<-g' ; echo $?)
44 # tests require debug symbols
45 %define         specflags       -g
46 %endif
47
48 %define         programprefix   eu-
49
50 %description
51 Elfutils is a collection of utilities, including ld (a linker), nm
52 (for listing symbols from object files), size (for listing the section
53 sizes of an object or archive file), strip (for discarding symbols),
54 readline (the see the raw ELF file structures), and elflint (to check
55 for well-formed ELF files). Also included are numerous helper
56 libraries which implement DWARF, ELF, and machine-specific ELF
57 handling.
58
59 %description -l pl.UTF-8
60 Elfutils to zestaw narzędzi, składający się z ld (linkera), nm (do
61 listowania symboli z plików obiektów), size (do listowania rozmiarów
62 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
63 readline (do oglądania surowych struktur plików ELF) oraz elflint (do
64 sprawdzania poprawności plików ELF). Dołączone są także liczne
65 biblioteki pomocnicze z zaimplementowaną obsługą DWARF, ELF i ELF
66 specyficznych dla architektury.
67
68 %package devel
69 Summary:        Development part of libraries to handle compiled objects
70 Summary(pl.UTF-8):      Część programistyczna bibliotek do obsługi skompilowanych obiektów
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73 Requires:       bzip2-devel
74 Requires:       xz-devel
75 Requires:       zlib-devel
76 Obsoletes:      libelf-devel
77
78 %description devel
79 The elfutils-devel package contains the development part of libraries
80 to create applications for handling compiled objects. libelf allows
81 you to access the internals of the ELF object file format, so you can
82 see the different sections of an ELF file. libebl provides some
83 higher-level ELF access functionality. libdwarf provides access to the
84 DWARF debugging information. libasm provides a programmable assembler
85 interface.
86
87 %description devel -l pl.UTF-8
88 Pakiet elfutils-devel zawiera część programistyczną bibliotek do
89 tworzenia aplikacji obsługujących skompilowane obiekty. libelf pozwala
90 na dostęp do wnętrzności formatu pliku obiektowego ELF, co pozwala na
91 oglądanie różnych sekcji pliku ELF. libebl udostępnia funkcjonalność
92 dostępu do plików ELF trochę wyższego poziomu. libdwarf pozwala na
93 dostęp do informacji DWARF służących do odpluskwiania. libasm
94 udostępnia programowalny interfejs asemblera.
95
96 %package libelf
97 Summary:        Library to read and write ELF files
98 Summary(pl.UTF-8):      Biblioteki do odczytu i zapisu plików ELF
99 Group:          Libraries
100 #Obsoletes:     libelf
101
102 %description libelf
103 The elfutils-libelf package provides a DSO which allows reading and
104 writing ELF files on a high level. Third party programs depend on this
105 package to read internals of ELF files. The programs of the elfutils
106 package use it also to generate new ELF files.
107
108 %description libelf -l pl.UTF-8
109 Pakiet elfutils-libelf udostępnia bibliotekę dzieloną, która pozwala
110 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
111 wymagają tego pakietu, aby odczytywać zawartość plików ELF. Programy z
112 pakietu elfutils używają jej także do generowania nowych plików ELF.
113
114 %package static
115 Summary:        Static libraries to handle compiled objects
116 Summary(pl.UTF-8):      Statyczne biblioteki do obsługi skompilowanych obiektów
117 Group:          Development/Libraries
118 Requires:       %{name}-devel = %{version}-%{release}
119 Obsoletes:      libelf-static
120
121 %description static
122 The elfutils-static package contains the static libraries to create
123 applications for handling compiled objects. libelf allows you to
124 access the internals of the ELF object file format, so you can see the
125 different sections of an ELF file. libebl provides some higher-level
126 ELF access functionality. libdwarf provides access to the DWARF
127 debugging information. libasm provides a programmable assembler
128 interface.
129
130 %description static -l pl.UTF-8
131 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
132 aplikacji obsługujących skompilowane obiekty. libelf pozwala na dostęp
133 do wnętrzności formatu pliku obiektowego ELF, co pozwala na oglądanie
134 różnych sekcji pliku ELF. libebl udostępnia funkcjonalność dostępu do
135 plików ELF trochę wyższego poziomu. libdwarf pozwala na dostęp do
136 informacji DWARF służących do odpluskwiania. libasm udostępnia
137 programowalny interfejs asemblera.
138
139 %prep
140 %setup -q
141 %patch0 -p1
142 %patch1 -p1
143 %patch2 -p1
144 %patch3 -p1
145 %patch4 -p1
146 %patch5 -p1
147
148 %{__rm} po/stamp-po
149
150 # temporarily disable failing tests (depending on arch)
151 %ifarch x32
152 %{__sed} -i -e 's/run-backtrace-native-biarch.sh//' tests/Makefile.am
153 %endif
154
155 # make sure this is not even tried on arch it has no chance to run
156 %ifarch %{ix86}
157 %{__sed} -i -e 's/run-disasm-x86-64.sh//' tests/Makefile.am
158 %endif
159
160 %build
161 #%%{__gettextize}
162 %{__aclocal} -I m4
163 %{__autoheader}
164 %{__autoconf}
165 %{__automake}
166 %configure \
167         --disable-silent-rules \
168         --disable-werror \
169         --program-prefix=%{programprefix}
170
171 # make check depends on test-nlist not stripped
172 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
173
174 %{__make}
175 %{__make} -C debian/man
176
177 %if %{with tests}
178 # some tests rely on English messages
179 LC_ALL=C \
180 %{__make} -C tests check
181 %endif
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
186
187 %{__make} install \
188         DESTDIR=$RPM_BUILD_ROOT
189
190 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
191
192 %{__mv} $RPM_BUILD_ROOT%{_libdir}/{libelf-*.so,libelf.so.*} $RPM_BUILD_ROOT/%{_lib}
193 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libelf-*.so) \
194         $RPM_BUILD_ROOT%{_libdir}/libelf.so
195
196 %find_lang %{name}
197
198 %clean
199 rm -rf $RPM_BUILD_ROOT
200
201 %post   -p /sbin/ldconfig
202 %postun -p /sbin/ldconfig
203
204 %post   libelf -p /sbin/ldconfig
205 %postun libelf -p /sbin/ldconfig
206
207 %files
208 %defattr(644,root,root,755)
209 %doc AUTHORS CONTRIBUTING ChangeLog NEWS NOTES README THANKS TODO
210 %attr(755,root,root) %{_bindir}/eu-*
211 %attr(755,root,root) %{_libdir}/libasm-*.so
212 %attr(755,root,root) %ghost %{_libdir}/libasm.so.1
213 %attr(755,root,root) %{_libdir}/libdw-*.so
214 %attr(755,root,root) %ghost %{_libdir}/libdw.so.1
215 %dir %{_libdir}/elfutils
216 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
217 %{_mandir}/man1/eu-*.1*
218
219 %files devel
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libasm.so
222 %attr(755,root,root) %{_libdir}/libdw.so
223 %attr(755,root,root) %{_libdir}/libelf.so
224 %{_libdir}/libebl.a
225 %{_includedir}/elfutils
226 %{_includedir}/dwarf.h
227 %{_includedir}/gelf.h
228 %{_includedir}/libelf.h
229 %{_includedir}/nlist.h
230 %{_pkgconfigdir}/libdw.pc
231 %{_pkgconfigdir}/libelf.pc
232
233 %files libelf -f %{name}.lang
234 %defattr(644,root,root,755)
235 %attr(755,root,root) /%{_lib}/libelf-*.so
236 %attr(755,root,root) %ghost /%{_lib}/libelf.so.1
237
238 %files static
239 %defattr(644,root,root,755)
240 %{_libdir}/libasm.a
241 %{_libdir}/libdw.a
242 %{_libdir}/libelf.a
This page took 0.084775 seconds and 2 git commands to generate.