]> git.pld-linux.org Git - packages/elfutils.git/blob - elfutils.spec
- updated for 0.124
[packages/elfutils.git] / elfutils.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform tests
4 #
5 Summary:        A collection of utilities and DSOs to handle compiled objects
6 Summary(pl):    Zestaw narzêdzi i bibliotek do obs³ugi skompilowanych obiektów
7 Name:           elfutils
8 Version:        0.123
9 Release:        1
10 License:        GPL v2 with OSL linking exception
11 Group:          Development/Tools
12 # http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/
13 # abuse systemtap to get .tar.gz directly
14 Source0:        ftp://sources.redhat.com/pub/systemtap/elfutils/%{name}-%{version}.tar.gz
15 # Source0-md5:  dd2bf7bc0f63adc82def4ca0e6c2519e
16 Patch0:         %{name}-pl.po.patch
17 Patch1:         %{name}-debian-manpages.patch
18 Patch2:         %{name}-portability.patch
19 Patch3:         %{name}-robustify.patch
20 Patch4:         %{name}-align.patch
21 Patch5:         %{name}-paxflags.patch
22 Patch6:         %{name}-alpha.patch
23 Patch7:         %{name}-sparc.patch
24 Patch8:         %{name}-kill-native.patch
25 #URL:           file://home/devel/drepper
26 BuildRequires:  autoconf >= 2.59
27 BuildRequires:  automake >= 1:1.7
28 BuildRequires:  gcc >= 3.2
29 BuildRequires:  gettext-devel
30 %ifarch %{x8664} alpha ia64 ppc64 s390x sparc64
31 # PR*FAST{8,16} in <inttypes.h> were broken for 64-bit archs in older versions
32 # also needed for nanosecond timestamps on alpha
33 BuildRequires:  glibc-devel >= 6:2.3.4
34 %endif
35 BuildRequires:  libltdl-devel
36 BuildRequires:  perl-tools-pod
37 BuildRequires:  rpmbuild(macros) >= 1.315
38 BuildRequires:  sharutils
39 %if %{with tests} && %(test -d /proc/self ; echo $?)
40 # native test needs proc (for libdwfl -p PID to work)
41 BuildRequires:  MOUNTED_PROC
42 %endif
43 Requires:       %{name}-libelf = %{version}-%{release}
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 # fails to build with -Wl,-s
47 %define         filterout_ld    (-Wl,)?-[sS] (-Wl,)?--strip.*
48
49 %define         _programprefix  eu-
50
51 %description
52 Elfutils is a collection of utilities, including ld (a linker), nm
53 (for listing symbols from object files), size (for listing the section
54 sizes of an object or archive file), strip (for discarding symbols),
55 readline (the see the raw ELF file structures), and elflint (to check
56 for well-formed ELF files). Also included are numerous helper
57 libraries which implement DWARF, ELF, and machine-specific ELF
58 handling.
59
60 %description -l pl
61 Elfutils to zestaw narzêdzi, sk³adaj±cy siê z ld (linkera), nm (do
62 listowania symboli z plików obiektów), size (do listowania rozmiarów
63 sekcji plików obiektów lub archiwów), strip (do usuwania symboli),
64 readline (do ogl±dania surowych struktur plików ELF) oraz elflint (do
65 sprawdzania poprawno¶ci plików ELF). Do³±czone s± tak¿e liczne
66 biblioteki pomocnicze z zaimplementowan± obs³ug± DWARF, ELF i ELF
67 specyficznych dla architektury.
68
69 %package devel
70 Summary:        Development part of libraries to handle compiled objects
71 Summary(pl):    Czê¶æ programistyczna bibliotek do obs³ugi skompilowanych obiektów
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}-%{release}
74 Obsoletes:      libelf-devel
75
76 %description devel
77 The elfutils-devel package contains the development part of libraries
78 to create applications for handling compiled objects. libelf allows
79 you to access the internals of the ELF object file format, so you can
80 see the different sections of an ELF file. libebl provides some
81 higher-level ELF access functionality. libdwarf provides access to the
82 DWARF debugging information. libasm provides a programmable assembler
83 interface.
84
85 %description devel -l pl
86 Pakiet elfutils-devel zawiera czê¶æ programistyczn± bibliotek do
87 tworzenia aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala
88 na dostêp do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na
89 ogl±danie ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ
90 dostêpu do plików ELF trochê wy¿szego poziomu. libdwarf pozwala na
91 dostêp do informacji DWARF s³u¿±cych do odpluskwiania. libasm
92 udostêpnia programowalny interfejs asemblera.
93
94 %package libelf
95 Summary:        Library to read and write ELF files
96 Summary(pl):    Biblioteki do odczytu i zapisu plików ELF
97 Group:          Libraries
98 #Obsoletes:     libelf
99
100 %description libelf
101 The elfutils-libelf package provides a DSO which allows reading and
102 writing ELF files on a high level. Third party programs depend on this
103 package to read internals of ELF files. The programs of the elfutils
104 package use it also to generate new ELF files.
105
106 %description libelf -l pl
107 Pakiet elfutils-libelf udostêpnia bibliotekê dzielon±, która pozwala
108 na wysokopoziomowe czytanie i zapisywanie plików ELF. Inne programy
109 wymagaj± tego pakietu, aby odczytywaæ zawarto¶æ plików ELF. Programy z
110 pakietu elfutils u¿ywaj± jej tak¿e do generowania nowych plików ELF.
111
112 %package static
113 Summary:        Static libraries to handle compiled objects
114 Summary(pl):    Statyczne biblioteki do obs³ugi skompilowanych obiektów
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{version}-%{release}
117 Obsoletes:      libelf-static
118
119 %description static
120 The elfutils-static package contains the static libraries to create
121 applications for handling compiled objects. libelf allows you to
122 access the internals of the ELF object file format, so you can see the
123 different sections of an ELF file. libebl provides some higher-level
124 ELF access functionality. libdwarf provides access to the DWARF
125 debugging information. libasm provides a programmable assembler
126 interface.
127
128 %description static -l pl
129 Pakiet elfutils-static zawiera statyczne biblioteki do tworzenia
130 aplikacji obs³uguj±cych skompilowane obiekty. libelf pozwala na dostêp
131 do wnêtrzno¶ci formatu pliku obiektowego ELF, co pozwala na ogl±danie
132 ró¿nych sekcji pliku ELF. libebl udostêpnia funkcjonalno¶æ dostêpu do
133 plików ELF trochê wy¿szego poziomu. libdwarf pozwala na dostêp do
134 informacji DWARF s³u¿±cych do odpluskwiania. libasm udostêpnia
135 programowalny interfejs asemblera.
136
137 %prep
138 %setup -q
139 %patch0 -p1
140 %patch1 -p1
141 %patch2 -p1
142 %patch3 -p1
143 %patch4 -p1
144 %patch5 -p1
145 %patch6 -p1
146 %patch7 -p1
147 %patch8 -p1
148
149 %build
150 #%%{__gettextize}
151 %{__aclocal}
152 %{__autoheader}
153 %{__automake}
154 %{__autoconf}
155
156 %configure \
157         --program-prefix=%{_programprefix} \
158         --enable-shared
159
160 # make check depends on test-nlist not stripped
161 %{__perl} -pi -e 's/^(LDFLAGS =.*)-s/$1/' tests/Makefile
162
163 %{__make}
164 %{__make} -C debian/man
165 %if %{with tests}
166 %{__make} -C tests check
167 %endif
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171 install -d $RPM_BUILD_ROOT{%{_mandir}/man1,/%{_lib}}
172
173 # *OBJEXT must be passed to workaround problem with messed gettext,
174 # which doesn't like *-po dir names
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT \
177         MKINSTALLDIRS=$(pwd)/config/mkinstalldirs \
178         CATOBJEXT=.gmo \
179         INSTOBJEXT=.mo
180
181 install debian/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
182
183 mv $RPM_BUILD_ROOT%{_libdir}/libelf-*.so $RPM_BUILD_ROOT/%{_lib}
184 ln -sf /%{_lib}/$(cd $RPM_BUILD_ROOT/%{_lib} ; echo libelf-*.so) \
185         $RPM_BUILD_ROOT%{_libdir}/libelf.so
186
187 %find_lang libelf
188 %find_lang %{name}
189
190 %clean
191 rm -rf $RPM_BUILD_ROOT
192
193 %post   -p /sbin/ldconfig
194 %postun -p /sbin/ldconfig
195
196 %post   libelf -p /sbin/ldconfig
197 %postun libelf -p /sbin/ldconfig
198
199 %files -f %{name}.lang
200 %defattr(644,root,root,755)
201 %doc AUTHORS COPYING NEWS NOTES README THANKS TODO
202 %attr(755,root,root) %{_bindir}/*
203 %attr(755,root,root) %{_libdir}/libasm-*.so
204 %attr(755,root,root) %{_libdir}/libdw-*.so
205 %dir %{_libdir}/elfutils
206 %attr(755,root,root) %{_libdir}/elfutils/lib*.so
207 %{_mandir}/man1/*.1*
208
209 %files devel
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/libasm.so
212 %attr(755,root,root) %{_libdir}/libdw.so
213 %attr(755,root,root) %{_libdir}/libelf.so
214 %{_libdir}/libebl.a
215 %{_includedir}/*
216
217 %files libelf -f libelf.lang
218 %defattr(644,root,root,755)
219 %attr(755,root,root) /%{_lib}/libelf-*.so
220
221 %files static
222 %defattr(644,root,root,755)
223 %{_libdir}/libasm.a
224 %{_libdir}/libdw.a
225 %{_libdir}/libelf.a
This page took 0.060543 seconds and 3 git commands to generate.