]> git.pld-linux.org Git - packages/elektra.git/blobdiff - elektra.spec
- remove inconsistent man page (doesn't get created randomly)
[packages/elektra.git] / elektra.spec
index 90af9ee06073245fcdd4951e35e99c8e91dd86f9..939b43ebe422e528f10ae9fff76208c732bc80f0 100644 (file)
@@ -1,5 +1,5 @@
 # TODO:
-# - force maven to work without network, enable java
+# - force maven to work without network, enable java_mvn
 # - haskell plugin (BR: ghc >= 8.0.0, cabal)
 # - rest-backend (BR: cppcms boost >= 1.45 libjwt openssl)
 # - rest-frontend, web (BR: npm)
@@ -10,7 +10,8 @@
 %bcond_without gen             # gen tool packaging
 %bcond_without glib            # GLib/GObject/GSetttings (+ GI) bindings
 %bcond_without gsettings       # GSetttings module
-%bcond_with    java            # Java support: JNA binding and JNI plugin (needs Java 8)
+%bcond_without java            # Java support: JNA binding and JNI plugin (needs Java 8)
+%bcond_with    java_mvn        # Java JNA binding (needs Java 8 and maven)
 %bcond_without lua             # Lua (5.2) support: bindings and plugin
 %bcond_without python2         # Python 2 support: bindings and plugin
 %bcond_without python3         # Python 3 support: bindings and plugin
 %if %{without glib}
 %undefine      with_gsettings
 %endif
+%if %{without java}
+%undefine      with_java_mvn
+%endif
 Summary:       A key/value pair database to store software configurations
 Summary(pl.UTF-8):     Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
 Name:          elektra
 Version:       0.8.23
-Release:       1
+Release:       13
 License:       BSD
 Group:         Applications/System
 Source0:       https://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
 # Source0-md5: 0a065ed381a59b6213bd46fd3c82ba83
 Patch0:                %{name}-zsh.patch
 Patch1:                %{name}-no-markdown.patch
+Patch2:                disable-broken-tests.patch
 URL:           https://www.libelektra.org/
 %if %{with qt}
 BuildRequires: Qt5Core-devel >= 5.3
@@ -53,8 +58,8 @@ BuildRequires:        gettext-tools
 %{?with_gsettings:BuildRequires:       glib2-devel >= 1:2.42}
 %{?with_glib:BuildRequires:    gobject-introspection-devel >= 1.38}
 # for binding
-%{?with_java:BuildRequires:    java-jna >= 4.5.0}
-%{?with_java:BuildRequires:    java-junit >= 4.12}
+%{?with_java_mvn:BuildRequires:        java-jna >= 4.5.0}
+%{?with_java_mvn:BuildRequires:        java-junit >= 4.12}
 %{?with_java:BuildRequires:    jdk >= 1.8}
 # jawt for plugin
 %{?with_java:BuildRequires:    jre-X11 >= 1.8}
@@ -66,9 +71,9 @@ BuildRequires:        libuv-devel
 BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libxslt-progs
 %{?with_lua:BuildRequires:     lua52-devel >= 5.2}
-%{?with_java:BuildRequires:    maven}
-%{?with_java:BuildRequires:    maven-plugin-compiler >= 3.6.0}
-%{?with_java:BuildRequires:    maven-plugin-surefire >= 2.19.1}
+%{?with_java_mvn:BuildRequires:        maven}
+%{?with_java_mvn:BuildRequires:        maven-plugin-compiler >= 3.6.0}
+%{?with_java_mvn:BuildRequires:        maven-plugin-surefire >= 2.19.1}
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig
 %{?with_python2:BuildRequires: python-devel >= 1:2.7}
@@ -219,9 +224,7 @@ Summary(pl.UTF-8):  Bashowe uzupełnianie parametrów dla poleceń z pakietu Elek
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      bash-completion >= 2
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description -n bash-completion-elektra
 Bash completion for Elektra kdb command.
@@ -235,9 +238,7 @@ Summary(pl.UTF-8):  Uzupełnianie parametrów w fish dla poleceń z pakietu Elekt
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      fish
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description -n fish-completion-elektra
 Fish completion for Elektra kdb command.
@@ -251,9 +252,7 @@ Summary(pl.UTF-8):  Uzupełnianie parametrów dla poleceń z pakietu Elektra w po
 Group:         Applications/Shells
 Requires:      %{name} = %{version}-%{release}
 Requires:      zsh
-%if "%{_rpmversion}" >= "5"
 BuildArch:     noarch
-%endif
 
 %description -n zsh-completion-elektra
 ZSH completion for Elektra kdb command.
@@ -400,7 +399,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 %description io-uv
 Elektra I/O binding using uv.
 
-%description io-glib -l pl.UTF-8
+%description io-uv -l pl.UTF-8
 Wiązanie we/wy Elektry wykorzystujące uv.
 
 %package io-uv-devel
@@ -422,7 +421,7 @@ Summary:    Java binding for Elektra
 Summary(pl.UTF-8):     Wiązanie języka Java dla Elektry
 Group:         Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      java-jna
+Requires:      java-jna >= 4.5.0
 Requires:      jre >= 1.8
 
 %description -n java-elektra
@@ -518,15 +517,20 @@ Wiązanie języka Ruby dla Elektry.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %{__sed} -i -e '1s,/usr/bin/env bash,/bin/bash,' $(grep -l '/usr/bin/env bash' -r scripts)
 %{__sed} -i -e '1s,/usr/bin/env python,%{__python},' scripts/{find-tools,update-infos-status}
 
+%{__rm} -r src/bindings/io/test
+%{__rm} src/bindings/io/uv/testio_uv.c
+%{__rm} src/bindings/io/glib/testio_glib.c
+
 %build
 install -d build
 cd build
 %cmake .. \
-       -DBINDINGS="INTERCEPT;cpp;io_uv%{?with_glib:;glib;io_glib%{?with_gsettings:;gsettings}%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}%{?with_ruby:;swig_ruby}" \
+       -DBINDINGS="INTERCEPT;cpp;io_uv%{?with_glib:;glib;io_glib%{?with_gsettings:;gsettings}%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java_mvn:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}%{?with_ruby:;swig_ruby}" \
        %{!?with_full:-DBUILD_FULL=OFF} \
        -DINSTALL_TESTING=FALSE \
        -DPLUGINS=ALL \
@@ -534,7 +538,7 @@ cd build
        -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}" \
        -DBUILD_STATIC=ON
 
-%{__make} -j1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -578,7 +582,7 @@ install -d installed-doc
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{benchmark_crypto_comparison,benchmark_plugins,examples_backend}.cpp.3elektra
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/std_hash_*_.3elektra
 
-%if %{without java}
+%if %{without java_mvn}
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/org_libelektra_*.3elektra
 %endif
 
@@ -801,6 +805,7 @@ rm -rf $RPM_BUILD_ROOT
 %{py_sitedir}/elektra_gen-%{version}-py*.egg-info
 # FIXME: should be in elektra_gen subdir
 %{py_sitedir}/support
+%dir %{_datadir}/elektra
 %{_datadir}/elektra/templates
 %{_mandir}/man1/kdb-gen.1*
 %endif
@@ -951,7 +956,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/dbus.c.3elektra*
 %{_mandir}/man3/deprecated.3elektra*
 %{_mandir}/man3/global.c.3elektra*
-%{_mandir}/man3/invoke.3elektra*
 %{_mandir}/man3/invoke.c.3elektra*
 %{_mandir}/man3/io.c.3elektra*
 %{_mandir}/man3/io_doc.c.3elektra*
@@ -1091,7 +1095,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/elektra/kdbio_uv.h
 %{_pkgconfigdir}/elektra-io-uv.pc
 
-%if %{with java}
+%if %{with java_mvn}
 %files -n java-elektra
 %defattr(644,root,root,755)
 %doc src/bindings/jna/README.md
This page took 0.098192 seconds and 4 git commands to generate.