]> git.pld-linux.org Git - packages/elektra.git/blob - elektra.spec
- man pages cleanup
[packages/elektra.git] / elektra.spec
1 # TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
2 #
3 # Conditonal build:
4 %bcond_with     full    # "full" variant (libelektra-full with all plugins linked in)
5 %bcond_without  java    # Java support: JNA binding and JNI plugin (needs Java 8)
6 %bcond_without  glib    # GLib/GObject binding
7 %bcond_without  lua     # Lua (5.2) support: binding and plugin
8 %bcond_without  python2 # Python 2 support: binding and plugin
9 %bcond_without  python3 # Python 3 support: binding and plugin
10 %bcond_without  qt      # Qt GUI
11
12 Summary:        A key/value pair database to store software configurations
13 Summary(pl.UTF-8):      Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
14 Name:           elektra
15 Version:        0.8.19
16 Release:        3
17 License:        BSD
18 Group:          Applications/System
19 Source0:        http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  6669e765c834e259fb7570f126b85d7e
21 Patch1:         %{name}-no-markdown.patch
22 Patch2:         %{name}-no-deb.patch
23 URL:            http://www.libelektra.org/
24 %if %{with qt}
25 BuildRequires:  Qt5Core-devel >= 5
26 BuildRequires:  Qt5Gui-devel >= 5
27 BuildRequires:  Qt5Qml-devel >= 5
28 BuildRequires:  Qt5Quick-devel >= 5
29 BuildRequires:  Qt5Test-devel >= 5
30 BuildRequires:  Qt5Widgets-devel >= 5
31 %endif
32 BuildRequires:  augeas-devel >= 1.0
33 BuildRequires:  boost-devel
34 BuildRequires:  cmake >= 2.8.8
35 BuildRequires:  dbus-devel
36 BuildRequires:  doxygen
37 BuildRequires:  gettext-tools
38 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.36}
39 %{?with_glib:BuildRequires:     gobject-introspection-devel >= 1.38}
40 # for binding
41 %{?with_java:BuildRequires:     java-jna}
42 %{?with_java:BuildRequires:     jdk >= 1.8}
43 # jawt for plugin
44 %{?with_java:BuildRequires:     jre-X11 >= 1.8}
45 BuildRequires:  libgcrypt-devel
46 %{?with_qt:BuildRequires:       libmarkdown-devel}
47 BuildRequires:  libstdc++-devel
48 BuildRequires:  libxml2-devel >= 2.0
49 BuildRequires:  libxslt-progs
50 %{?with_lua:BuildRequires:      lua52-devel >= 5.2}
51 BuildRequires:  pkgconfig
52 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
53 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
54 BuildRequires:  ronn
55 BuildRequires:  rpm-pythonprov
56 BuildRequires:  rpmbuild(macros) >= 1.612
57 BuildRequires:  swig >= 2
58 %if %{with python2} || %{with python3}
59 BuildRequires:  swig-python >= 2
60 %endif
61 BuildRequires:  systemd-devel
62 BuildRequires:  tcl-devel
63 BuildRequires:  yajl-devel
64 Requires:       %{name}-libs = %{version}-%{release}
65 Requires:       mktemp
66 Obsoletes:      registry
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %description
70 The Elektra Project provides a framework to store generic
71 configuration data in an hierarchical key-value pair database, instead
72 of a human-readable only text file.
73
74 This way any software can read/save his configuration using a
75 consistent API. Also, applications can be aware of other applications
76 configurations, leveraging easy application integration.
77
78 %description -l pl.UTF-8
79 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
80 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
81 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
82
83 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
84 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
85 konfiguracji innych aplikacji, ułatwiając ich integrację.
86
87 %package gui
88 Summary:        Qt based GUI for Elektra
89 Summary(pl.UTF-8):      Oparty na Qt graficzny interfejs do Elektry
90 Group:          X11/Applications
91 Requires:       %{name} = %{version}-%{release}
92
93 %description gui
94 Qt based GUI for Elektra.
95
96 %description gui -l pl.UTF-8
97 Oparty na Qt graficzny interfejs do Elektry.
98
99 %package plugin-jni
100 Summary:        Java JNI plugin for Elektra
101 Summary(pl.UTF-8):      Wtyczka Java JNI dla Elektry
102 Group:          Libraries
103 Requires:       %{name} = %{version}-%{release}
104 # jawt
105 Requires:       jre-X11 >= 1.8
106
107 %description plugin-jni
108 Java JNI plugin for Elektra. It allows to use plugins written in Java.
109
110 %description plugin-jni -l pl.UTF-8
111 Wtyczka Java JNI dla Elektry. Pozwala na używanie wtyczek napisanych w
112 Javie.
113
114 %package plugin-lua
115 Summary:        Lua plugin for Elektra
116 Summary(pl.UTF-8):      Wtyczka Lua dla Elektry
117 Group:          Libraries
118 Requires:       %{name} = %{version}-%{release}
119 Requires:       lua52-libs >= 5.2
120
121 %description plugin-lua
122 Lua plugin for Elektra. It allows to use plugins written in Lua.
123
124 %description plugin-lua -l pl.UTF-8
125 Wtyczka Lua dla Elektry. Pozwala na używanie wtyczek napisanych w Lua.
126
127 %package plugin-python2
128 Summary:        Python 2 plugin for Elektra
129 Summary(pl.UTF-8):      Wtyczka Python 2 dla Elektry
130 Group:          Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       python-libs >= 1:2.7
133
134 %description plugin-python2
135 Python 2 plugin for Elektra. It allows to use plugins written in
136 Python 2.
137
138 %description plugin-python2 -l pl.UTF-8
139 Wtyczka 2 Python dla Elektry. Pozwala na używanie wtyczek napisanych w
140 Pythonie 2.
141
142 %package plugin-python3
143 Summary:        Python plugin for Elektra
144 Summary(pl.UTF-8):      Wtyczka Python dla Elektry
145 Group:          Libraries
146 Requires:       %{name} = %{version}-%{release}
147 Requires:       python3-libs >= 1:3.2
148
149 %description plugin-python3
150 Python 3 plugin for Elektra. It allows to use plugins written in
151 Python 3.
152
153 %description plugin-python3 -l pl.UTF-8
154 Wtyczka Python 3 dla Elektry. Pozwala na używanie wtyczek napisanych w
155 Pythonie 3.
156
157 %package -n bash-completion-elektra
158 Summary:        Bash completion for Elektra commands
159 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
160 Group:          Applications/Shells
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       bash-completion
163 %if "%{_rpmversion}" >= "5"
164 BuildArch:      noarch
165 %endif
166
167 %description -n bash-completion-elektra
168 Bash completion for Elektra kdb command.
169
170 %description -n bash-completion-elektra -l pl.UTF-8
171 Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
172
173 %package libs
174 Summary:        Elektra Project libraries
175 Summary(pl.UTF-8):      Biblioteki projektu Elektra
176 Group:          Libraries
177 Obsoletes:      elektra-cpp < 0.8
178 Conflicts:      elektra < 0.7
179
180 %description libs
181 The Elektra Project provides a framework to store generic
182 configuration data in an hierarchical key-value pair database, instead
183 of a human-readable only text file.
184
185 This way any software can read/save his configuration using a
186 consistent API. Also, applications can be aware of other applications
187 configurations, leveraging easy application integration.
188
189 This package contains Elektra shared libraries.
190
191 %description libs -l pl.UTF-8
192 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
193 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
194 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
195
196 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
197 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
198 konfiguracji innych aplikacji, ułatwiając ich integrację.
199
200 Ten pakiet zawiera biblioteki współdzielone Elektry.
201
202 %package devel
203 Summary:        Include files and API documentation for Elektra Project
204 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API projektu Elektra
205 Group:          Development/Libraries
206 Requires:       %{name}-libs = %{version}-%{release}
207
208 %description devel
209 This package contains the include files and API manual pages to use
210 the Elektra API in C.
211
212 %description devel -l pl.UTF-8
213 Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
214 systemowego opisującego sposób użycia API Elektry w C.
215
216 %package static
217 Summary:        Static libraries for Elektra Project
218 Summary(pl.UTF-8):      Statyczne biblioteki projektu Elektra
219 Group:          Development/Libraries
220 Requires:       %{name}-devel = %{version}-%{release}
221
222 %description static
223 This package contains static libraries for Elektra Project.
224
225 %description static -l pl.UTF-8
226 Ten pakiet zawiera statyczne biblioteki projektu Elektra.
227
228 %package cpp-devel
229 Summary:        Header files of C++ interface for Elektra library
230 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
231 Group:          Development/Libraries
232 Requires:       %{name}-devel = %{version}-%{release}
233 Requires:       libstdc++-devel
234 Obsoletes:      elektra-cpp-static < 0.8
235
236 %description cpp-devel
237 Header files of C++ interface for Elektra library.
238
239 %description cpp-devel -l pl.UTF-8
240 Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
241
242 %package glib
243 Summary:        GLib/GObject binding for Elektra
244 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry
245 Group:          Libraries
246 Requires:       %{name}-libs = %{version}-%{release}
247 Requires:       glib2 >= 1:2.36
248
249 %description glib
250 GLib/GObject binding for Elektra.
251
252 %description glib -l pl.UTF-8
253 Wiązanie GLib/GObject do Elektry.
254
255 %package glib-devel
256 Summary:        GLib/GObject binding for Elektra - development files
257 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry - pliki programistyczne
258 Group:          Libraries
259 Requires:       %{name}-devel = %{version}-%{release}
260 Requires:       glib2-devel >= 1:2.36
261
262 %description glib-devel
263 GLib/GObject binding for Elektra - development files.
264
265 %description glib-devel -l pl.UTF-8
266 Wiązanie GLib/GObject do Elektry - pliki programistyczne.
267
268 %package -n java-elektra
269 Summary:        Java binding for Elektra
270 Summary(pl.UTF-8):      Wiązanie języka Java dla Elektry
271 Group:          Libraries
272 Requires:       %{name}-libs = %{version}-%{release}
273 Requires:       java-jna
274 Requires:       jre
275
276 %description -n java-elektra
277 Java binding for Elektra.
278
279 %description -n java-elektra -l pl.UTF-8
280 Wiązanie języka Java dla Elektry.
281
282 %package -n lua-elektra
283 Summary:        Lua binding for Elektra
284 Summary(pl.UTF-8):      Wiązanie języka Lua dla Elektry
285 Group:          Libraries
286 Requires:       %{name}-libs = %{version}-%{release}
287 Requires:       lua52-libs >= 5.2
288
289 %description -n lua-elektra
290 Lua binding for Elektra.
291
292 %description -n lua-elektra -l pl.UTF-8
293 Wiązanie języka Lua dla Elektry.
294
295 %package -n lua-elektra-glib
296 Summary:        Lua/GI binding for Elektra
297 Summary(pl.UTF-8):      Wiązanie Lua/GI dla Elektry
298 Group:          Libraries
299 Requires:       %{name}-glib = %{version}-%{release}
300 Requires:       lua52-libs >= 5.2
301 #R: lua52-lgi ?
302
303 %description -n lua-elektra-glib
304 Lua/GI binding for Elektra.
305
306 %description -n lua-elektra-glib -l pl.UTF-8
307 Wiązanie Lua/GI dla Elektry.
308
309 %package -n python-elektra
310 Summary:        Python 2 binding for Elektra
311 Summary(pl.UTF-8):      Wiązanie Pythona 2 dla Elektry
312 Group:          Libraries
313 Requires:       %{name}-libs = %{version}-%{release}
314 Requires:       python-libs >= 1:2.7
315
316 %description -n python-elektra
317 Python 2 binding for Elektra.
318
319 %description -n python-elektra -l pl.UTF-8
320 Wiązanie Pythona 2 dla Elektry.
321
322 %package -n python3-elektra
323 Summary:        Python 3 binding for Elektra
324 Summary(pl.UTF-8):      Wiązanie Pythona 3 dla Elektry
325 Group:          Libraries
326 Requires:       %{name}-libs = %{version}-%{release}
327 Requires:       python3-libs >= 1:3.2
328
329 %description -n python3-elektra
330 Python 3 binding for Elektra.
331
332 %description -n python3-elektra -l pl.UTF-8
333 Wiązanie Pythona 3 dla Elektry.
334
335 %package -n python3-elektra-glib
336 Summary:        Python 3 GI binding for Elektra
337 Summary(pl.UTF-8):      Wiązanie Pythona 3 GI dla Elektry
338 Group:          Libraries
339 Requires:       %{name}-glib = %{version}-%{release}
340 Requires:       python3-pygobject3 >= 3
341
342 %description -n python3-elektra-glib
343 Python 3 GI binding for Elektra.
344
345 %description -n python3-elektra-glib -l pl.UTF-8
346 Wiązanie Pythona 3 GI dla Elektry.
347
348 %prep
349 %setup -q
350 %patch1 -p1
351 %patch2 -p1
352
353 %build
354 install -d build
355 cd build
356 %cmake .. \
357         -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
358         %{!?with_full:-DBUILD_FULL=OFF} \
359         -DINSTALL_TESTING=FALSE \
360         -DPLUGINS=ALL \
361         -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
362         -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}" \
363         -DBUILD_STATIC=ON
364
365 %{__make} -j1
366
367 %install
368 rm -rf $RPM_BUILD_ROOT
369
370 %{__make} -C build install \
371         DESTDIR=$RPM_BUILD_ROOT
372
373 install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
374
375 install -d $RPM_BUILD_ROOT/etc/bash_completion.d
376 %{__mv} $RPM_BUILD_ROOT{%{bash_compdir}/kdb,/etc/bash_completion.d/kdb}
377
378 %if %{with python2}
379 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
380 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
381 %py_postclean
382 %endif
383
384 %if %{with python3}
385 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
386 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
387 %endif
388
389 # "static" variant (with libelektra-static and thus all plugins linked in);
390 # we don't need it
391 %{__rm} $RPM_BUILD_ROOT%{_bindir}/kdb-static
392
393 # prepare docs
394 %{__rm} -rf installed-doc
395 install -d installed-doc
396 %{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
397
398 # these don't belong to man3
399 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*,md_scripts_README,src_libs_getenv_README_md}.3elektra
400 # internal, not part of API
401 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/doc.h.3elektra
402 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{array,backend,dl,doc,ease_keyname,elektra_{keyname,plugin,proposal},exportsymbols,functional,internal,kdbenum,log,markdownlinkconverter,meta,mount,nolog,owner,plugin_plugin,proposal_proposal,split,static,trie}.c.3elektra
403 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{benchmark_plugins,examples_backend}.cpp.3elektra
404 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{internaldatastructs,std_hash_*_,trie,vheap,vstack}.3elektra
405
406 %clean
407 rm -rf $RPM_BUILD_ROOT
408
409 %post   libs -p /sbin/ldconfig
410 %postun libs -p /sbin/ldconfig
411
412 %post   glib -p /sbin/ldconfig
413 %postun glib -p /sbin/ldconfig
414
415 %files
416 %defattr(644,root,root,755)
417 %doc doc/{AUTHORS,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
418 # doc/standards installed-doc/scripts
419 %attr(755,root,root) %{_bindir}/kdb
420 %if %{with full}
421 %attr(755,root,root) %{_bindir}/kdb-full
422 %endif
423 %dir %{_libdir}/elektra
424 # R: augeas-libs
425 %attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
426 %attr(755,root,root) %{_libdir}/elektra/libelektra-base64.so
427 %attr(755,root,root) %{_libdir}/elektra/libelektra-blockresolver.so
428 %attr(755,root,root) %{_libdir}/elektra/libelektra-boolean.so
429 %attr(755,root,root) %{_libdir}/elektra/libelektra-c.so
430 %attr(755,root,root) %{_libdir}/elektra/libelektra-cachefilter.so
431 %attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
432 %attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
433 %attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
434 %attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
435 # R: libgcrypt
436 %attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_gcrypt.so
437 %attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_openssl.so
438 %attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
439 %attr(755,root,root) %{_libdir}/elektra/libelektra-curlget.so
440 # R: dbus
441 %attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
442 %attr(755,root,root) %{_libdir}/elektra/libelektra-desktop.so
443 %attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
444 %attr(755,root,root) %{_libdir}/elektra/libelektra-dpkg.so
445 %attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
446 %attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
447 %attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
448 %attr(755,root,root) %{_libdir}/elektra/libelektra-fcrypt.so
449 %attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
450 %attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
451 %attr(755,root,root) %{_libdir}/elektra/libelektra-gitresolver.so
452 %attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
453 %attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
454 %attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
455 %attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
456 %attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
457 # uses internal inih library
458 %attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
459 %attr(755,root,root) %{_libdir}/elektra/libelektra-iterate.so
460 # R: systemd-libs
461 %attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
462 %attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
463 %attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
464 %attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
465 %attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
466 %attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
467 %attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
468 %attr(755,root,root) %{_libdir}/elektra/libelektra-mozprefs.so
469 %attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
470 %attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
471 # uses internal nickel library
472 %attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
473 %attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
474 %attr(755,root,root) %{_libdir}/elektra/libelektra-passwd.so
475 %attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
476 %attr(755,root,root) %{_libdir}/elektra/libelektra-profile.so
477 %attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
478 %attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
479 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
480 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
481 %attr(755,root,root) %{_libdir}/elektra/libelektra-required.so
482 %attr(755,root,root) %{_libdir}/elektra/libelektra-semlock.so
483 %attr(755,root,root) %{_libdir}/elektra/libelektra-shell.so
484 %attr(755,root,root) %{_libdir}/elektra/libelektra-simplespeclang.so
485 %attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
486 %attr(755,root,root) %{_libdir}/elektra/libelektra-spec.so
487 %attr(755,root,root) %{_libdir}/elektra/libelektra-storage.so
488 %attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
489 %attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
490 %attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
491 %attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
492 %attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
493 %attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
494 %attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
495 %attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
496 %attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
497 %attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
498 %attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
499 # R: libxml2
500 %attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
501 # R: yajl
502 %attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
503 %dir %{_libdir}/elektra/tool_exec
504 %attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
505 %attr(755,root,root) %{_libdir}/elektra/tool_exec/configure-firefox
506 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
507 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
508 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
509 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
510 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
511 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
512 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
513 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-open
514 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
515 %attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
516 %dir %{_libdir}/elektra/tool_exec/ffconfig
517 %attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupConfig
518 %attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupHomepage
519 %attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupProxy
520 %attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/writeConfigFiles
521 %attr(755,root,root) %{_libdir}/elektra/tool_exec/find-tools
522 %attr(755,root,root) %{_libdir}/elektra/tool_exec/install-sh-completion
523 %attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
524 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
525 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
526 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
527 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
528 %attr(755,root,root) %{_libdir}/elektra/tool_exec/race
529 %attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
530 %attr(755,root,root) %{_libdir}/elektra/tool_exec/upgrade-bootstrap
531 %{_datadir}/sgml/elektra
532 %{_mandir}/man1/kdb.1*
533 %{_mandir}/man1/kdb-check.1*
534 %{_mandir}/man1/kdb-convert.1*
535 %{_mandir}/man1/kdb-cp.1*
536 %{_mandir}/man1/kdb-editor.1*
537 %{_mandir}/man1/kdb-export.1*
538 %{_mandir}/man1/kdb-file.1*
539 %{_mandir}/man1/kdb-find-tools.1*
540 %{_mandir}/man1/kdb-fstab.1*
541 %{_mandir}/man1/kdb-get.1*
542 %{_mandir}/man1/kdb-getmeta.1*
543 %{_mandir}/man1/kdb-global-mount.1*
544 %{_mandir}/man1/kdb-help.1*
545 %{_mandir}/man1/kdb-import.1*
546 %{_mandir}/man1/kdb-info.1*
547 %{_mandir}/man1/kdb-introduction.1*
548 %{_mandir}/man1/kdb-list.1*
549 %{_mandir}/man1/kdb-list-tools.1*
550 %{_mandir}/man1/kdb-ls.1*
551 %{_mandir}/man1/kdb-lsmeta.1*
552 %{_mandir}/man1/kdb-merge.1*
553 %{_mandir}/man1/kdb-mount.1*
554 %{_mandir}/man1/kdb-mv.1*
555 %{_mandir}/man1/kdb-remount.1*
556 %{_mandir}/man1/kdb-rm.1*
557 %{_mandir}/man1/kdb-set.1*
558 %{_mandir}/man1/kdb-setmeta.1*
559 %{_mandir}/man1/kdb-sget.1*
560 %{_mandir}/man1/kdb-shell.1*
561 %{_mandir}/man1/kdb-spec-mount.1*
562 %{_mandir}/man1/kdb-test.1*
563 %{_mandir}/man1/kdb-umount.1*
564 %{_mandir}/man1/kdb-vset.1*
565 %{_mandir}/man7/elektra-*.7*
566
567 %if 0
568 %files gen ?
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
571 %{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
572 # FIXME: should be in elektra_gen subdir
573 %{py_sitescriptdir}/support
574 %{_datadir}/elektra/templates
575 %endif
576
577 %files gui
578 %defattr(644,root,root,755)
579 %attr(755,root,root) %{_bindir}/elektra-qt-editor
580 %attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
581 %{_datadir}/appdata/org.libelektra.elektra-qt-editor.appdata.xml
582 %{_desktopdir}/org.libelektra.elektra-qt-editor.desktop
583 %{_iconsdir}/hicolor/scalable/apps/elektra-symbolic.svg
584 %{_iconsdir}/hicolor/scalable/apps/elektra.svg
585 %{_mandir}/man1/kdb-qt-gui.1*
586
587 %if %{with java}
588 %files plugin-jni
589 %defattr(644,root,root,755)
590 # R: jre with jawt
591 %attr(755,root,root) %{_libdir}/elektra/libelektra-jni.so
592 %endif
593
594 %if %{with lua}
595 %files plugin-lua
596 %defattr(644,root,root,755)
597 # R: lua52-libs
598 %attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
599 %endif
600
601 %if %{with python2}
602 %files plugin-python2
603 %defattr(644,root,root,755)
604 # R: python-libs
605 %attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
606 %endif
607
608 %if %{with python3}
609 %files plugin-python3
610 %defattr(644,root,root,755)
611 # R: python3-libs
612 %attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
613 %endif
614
615 %files -n bash-completion-elektra
616 %defattr(644,root,root,755)
617 /etc/bash_completion.d/kdb
618
619 %files libs
620 %defattr(644,root,root,755)
621 %attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
622 %attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
623 %attr(755,root,root) %{_libdir}/libelektra-core.so.*.*.*
624 %attr(755,root,root) %ghost %{_libdir}/libelektra-core.so.4
625 %attr(755,root,root) %{_libdir}/libelektra-ease.so.*.*.*
626 %attr(755,root,root) %ghost %{_libdir}/libelektra-ease.so.4
627 %attr(755,root,root) %{_libdir}/libelektra-kdb.so.*.*.*
628 %attr(755,root,root) %ghost %{_libdir}/libelektra-kdb.so.4
629 %attr(755,root,root) %{_libdir}/libelektra-meta.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libelektra-meta.so.4
631 %attr(755,root,root) %{_libdir}/libelektra-plugin.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libelektra-plugin.so.4
633 %attr(755,root,root) %{_libdir}/libelektra-proposal.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libelektra-proposal.so.4
635 %attr(755,root,root) %{_libdir}/libelektratools.so.*.*.*
636 %attr(755,root,root) %ghost %{_libdir}/libelektratools.so.2
637 %if %{with full}
638 %attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
640 %endif
641
642 %files devel
643 %defattr(644,root,root,755)
644 %doc doc/API.md installed-doc/elektra-api/html
645 %attr(755,root,root) %{_libdir}/libelektra.so
646 %attr(755,root,root) %{_libdir}/libelektra-core.so
647 %attr(755,root,root) %{_libdir}/libelektra-ease.so
648 %attr(755,root,root) %{_libdir}/libelektra-kdb.so
649 %attr(755,root,root) %{_libdir}/libelektra-meta.so
650 %attr(755,root,root) %{_libdir}/libelektra-plugin.so
651 %attr(755,root,root) %{_libdir}/libelektra-proposal.so
652 %attr(755,root,root) %{_libdir}/libelektratools.so
653 %if %{with full}
654 %attr(755,root,root) %{_libdir}/libelektra-full.so
655 %endif
656 %dir %{_includedir}/elektra
657 %{_includedir}/elektra/kdb*.h
658 %{_pkgconfigdir}/elektra.pc
659 %{_datadir}/cmake/Modules/ElektraConfig*.cmake
660 %{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
661 %{_mandir}/man3/api.3elektra*
662 %{_mandir}/man3/deprecated.3elektra*
663 %{_mandir}/man3/kdb.3elektra*
664 %{_mandir}/man3/kdb.c.3elektra*
665 %{_mandir}/man3/kdb_*.3elektra*
666 %{_mandir}/man3/kdb*.h.3elektra*
667 %{_mandir}/man3/key.3elektra*
668 %{_mandir}/man3/keymeta.3elektra*
669 %{_mandir}/man3/keyname.3elektra*
670 %{_mandir}/man3/keyset.3elektra*
671 %{_mandir}/man3/keytest.3elektra*
672 %{_mandir}/man3/keyvalue.3elektra*
673 %{_mandir}/man3/key.c.3elektra*
674 %{_mandir}/man3/keyhelpers.c.3elektra*
675 %{_mandir}/man3/keymeta.c.3elektra*
676 %{_mandir}/man3/keyset.c.3elektra*
677 %{_mandir}/man3/keytest.c.3elektra*
678 %{_mandir}/man3/keyvalue.c.3elektra*
679 %{_mandir}/man3/meta.3elektra*
680 %{_mandir}/man3/plugin.3elektra*
681 %{_mandir}/man3/proposal.3elektra*
682
683 %files static
684 %defattr(644,root,root,755)
685 %{_libdir}/libelektra-static.a
686 %{_libdir}/libelektratools-static.a
687
688 %files cpp-devel
689 %defattr(644,root,root,755)
690 %{_includedir}/elektra/*.hpp
691 %{_includedir}/elektra/helper
692 %{_includedir}/elektra/merging
693 # libelektratools API man pages
694 %{_mandir}/man3/automergeconfiguration.cpp.3elektra*
695 %{_mandir}/man3/automergeconfiguration.hpp.3elektra*
696 %{_mandir}/man3/automergestrategy.cpp.3elektra*
697 %{_mandir}/man3/automergestrategy.hpp.3elektra*
698 %{_mandir}/man3/backend.hpp.3elektra*
699 %{_mandir}/man3/backendbuilder.cpp.3elektra*
700 %{_mandir}/man3/backendbuilder.hpp.3elektra*
701 %{_mandir}/man3/backendparser.cpp.3elektra*
702 %{_mandir}/man3/backendparser.hpp.3elektra*
703 %{_mandir}/man3/backends.cpp.3elektra*
704 %{_mandir}/man3/backends.hpp.3elektra*
705 %{_mandir}/man3/comparison.cpp.3elektra*
706 %{_mandir}/man3/comparison.hpp.3elektra*
707 %{_mandir}/man3/importmergeconfiguration.cpp.3elektra*
708 %{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
709 %{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
710 %{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
711 %{_mandir}/man3/kdb*.hpp.3elektra*
712 %{_mandir}/man3/key*.hpp.3elektra*
713 %{_mandir}/man3/keyhelper.cpp.3elektra*
714 %{_mandir}/man3/mergeconfiguration.hpp.3elektra*
715 %{_mandir}/man3/mergeconflict.hpp.3elektra*
716 %{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
717 %{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
718 %{_mandir}/man3/mergeresult.cpp.3elektra*
719 %{_mandir}/man3/mergeresult.hpp.3elektra*
720 %{_mandir}/man3/mergetask.hpp.3elektra*
721 %{_mandir}/man3/mergetestutils.cpp.3elektra*
722 %{_mandir}/man3/merging.cpp.3elektra*
723 %{_mandir}/man3/mergingkdb.cpp.3elektra*
724 %{_mandir}/man3/mergingkdb.hpp.3elektra*
725 %{_mandir}/man3/metamergestrategy.cpp.3elektra*
726 %{_mandir}/man3/metamergestrategy.hpp.3elektra*
727 %{_mandir}/man3/newkeystrategy.cpp.3elektra*
728 %{_mandir}/man3/newkeystrategy.hpp.3elektra*
729 %{_mandir}/man3/onesidemergeconfiguration.cpp.3elektra*
730 %{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
731 %{_mandir}/man3/onesidestrategy.cpp.3elektra*
732 %{_mandir}/man3/onesidestrategy.hpp.3elektra*
733 %{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
734 %{_mandir}/man3/onesidevaluestrategy.hpp.3elektra*
735 %{_mandir}/man3/overwritemergeconfiguration.cpp.3elektra*
736 %{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
737 %{_mandir}/man3/modules.cpp.3elektra*
738 %{_mandir}/man3/modules.hpp.3elektra*
739 %{_mandir}/man3/plugin.cpp.3elektra*
740 %{_mandir}/man3/plugin.hpp.3elektra*
741 %{_mandir}/man3/plugindatabase.cpp.3elektra*
742 %{_mandir}/man3/plugindatabase.hpp.3elektra*
743 %{_mandir}/man3/plugins.cpp.3elektra*
744 %{_mandir}/man3/plugins.hpp.3elektra*
745 %{_mandir}/man3/pluginspec.cpp.3elektra*
746 %{_mandir}/man3/pluginspec.hpp.3elektra*
747 %{_mandir}/man3/specreader.hpp.3elektra*
748 %{_mandir}/man3/src_backend.cpp.3elektra*
749 %{_mandir}/man3/testtool_*.cpp.3elektra*
750 %{_mandir}/man3/threewaymerge.cpp.3elektra*
751 %{_mandir}/man3/threewaymerge.hpp.3elektra*
752 %{_mandir}/man3/toolexcept.hpp.3elektra*
753
754 %if %{with glib}
755 %files glib
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_libdir}/libgelektra-4.0.so
758 %{_libdir}/girepository-1.0/GElektra-4.0.typelib
759
760 %files glib-devel
761 %defattr(644,root,root,755)
762 %{_datadir}/gir-1.0/GElektra-4.0.gir
763 %{_includedir}/elektra/gelektra-*.h
764 %{_pkgconfigdir}/gelektra-4.0.pc
765 %endif
766
767 %if %{with java}
768 %files -n java-elektra
769 %defattr(644,root,root,755)
770 %{_javadir}/libelektra-1.jar
771 %{_javadir}/libelektra.jar
772 %endif
773
774 %if %{with lua}
775 %files -n lua-elektra
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
778
779 %if %{with glib}
780 %files -n lua-elektra-glib
781 %defattr(644,root,root,755)
782 %dir %{_datadir}/lua/5.2/lgi
783 %dir %{_datadir}/lua/5.2/lgi/override
784 %{_datadir}/lua/5.2/lgi/override/GElektra.lua
785 %endif
786 %endif
787
788 %if %{with python2}
789 %files -n python-elektra
790 %defattr(644,root,root,755)
791 %attr(755,root,root) %{py_sitedir}/_kdb.so
792 %{py_sitedir}/kdb.py[co]
793 %endif
794
795 %if %{with python3}
796 %files -n python3-elektra
797 %defattr(644,root,root,755)
798 %attr(755,root,root) %{py3_sitedir}/_kdb.so
799 %{py3_sitedir}/kdb.py
800 %{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
801
802 %if %{with glib}
803 %files -n python3-elektra-glib
804 %defattr(644,root,root,755)
805 %{py3_sitedir}/gi/overrides/GElektra.py
806 %{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
807 %endif
808 %endif
This page took 0.11709 seconds and 4 git commands to generate.