]> git.pld-linux.org Git - packages/elektra.git/blob - elektra.spec
- package ronn-generated man pages
[packages/elektra.git] / elektra.spec
1 # TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
2 #
3 # Conditonal build:
4 %bcond_with     full    # "full" variant (libelektra-full with all plugins linked in)
5 %bcond_with     java    # Java support: JNA binding and JNI plugin (needs Java 8)
6 %bcond_without  glib    # GLib/GObject binding
7 %bcond_without  lua     # Lua (5.2) support: binding and plugin
8 %bcond_without  python2 # Python 2 support: binding and plugin
9 %bcond_without  python3 # Python 3 support: binding and plugin
10 %bcond_without  qt      # Qt GUI
11 #
12 Summary:        A key/value pair database to store software configurations
13 Summary(pl.UTF-8):      Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
14 Name:           elektra
15 Version:        0.8.14
16 Release:        1
17 License:        BSD
18 Group:          Applications/System
19 Source0:        http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  a87cd3845e590bf413959dfd555e3704
21 Patch0:         %{name}-elektraenv.patch
22 Patch1:         %{name}-no-markdown.patch
23 Patch2:         %{name}-no-deb.patch
24 URL:            http://www.libelektra.org/
25 %if %{with qt}
26 BuildRequires:  Qt5Core-devel >= 5
27 BuildRequires:  Qt5Gui-devel >= 5
28 BuildRequires:  Qt5Qml-devel >= 5
29 BuildRequires:  Qt5Quick-devel >= 5
30 BuildRequires:  Qt5Widgets-devel >= 5
31 BuildRequires:  Qt5Test-devel >= 5
32 %endif
33 BuildRequires:  augeas-devel >= 1.0
34 BuildRequires:  boost-devel
35 BuildRequires:  cmake >= 2.8.8
36 BuildRequires:  dbus-devel
37 BuildRequires:  doxygen
38 BuildRequires:  gettext-tools
39 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.36}
40 %{?with_glib:BuildRequires:     gobject-introspection-devel >= 1.38}
41 %{?with_java:BuildRequires:     java-jna}
42 %{?with_java:BuildRequires:     jdk >= 1.8}
43 BuildRequires:  libgcrypt-devel
44 %{?with_qt:BuildRequires:       libmarkdown-devel}
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libxml2-devel >= 2.0
47 BuildRequires:  libxslt-progs
48 %{?with_lua:BuildRequires:      lua52-devel >= 5.2}
49 BuildRequires:  pkgconfig
50 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
51 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
52 BuildRequires:  ronn
53 BuildRequires:  rpm-pythonprov
54 BuildRequires:  rpmbuild(macros) >= 1.612
55 BuildRequires:  swig >= 2
56 %if %{with python2} || %{with python3}
57 BuildRequires:  swig-python >= 2
58 %endif
59 BuildRequires:  systemd-devel
60 BuildRequires:  tcl-devel
61 BuildRequires:  yajl-devel
62 Requires:       %{name}-libs = %{version}-%{release}
63 Requires:       mktemp
64 Obsoletes:      registry
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %description
68 The Elektra Project provides a framework to store generic
69 configuration data in an hierarchical key-value pair database, instead
70 of a human-readable only text file.
71
72 This way any software can read/save his configuration using a
73 consistent API. Also, applications can be aware of other applications
74 configurations, leveraging easy application integration.
75
76 %description -l pl.UTF-8
77 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
78 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
79 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
80
81 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
82 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
83 konfiguracji innych aplikacji, ułatwiając ich integrację.
84
85 %package gui
86 Summary:        Qt based GUI for Elektra
87 Summary(pl.UTF-8):      Oparty na Qt graficzny interfejs do Elektry
88 Group:          X11/Applications
89 Requires:       %{name} = %{version}-%{release}
90
91 %description gui
92 Qt based GUI for Elektra.
93
94 %description gui -l pl.UTF-8
95 Oparty na Qt graficzny interfejs do Elektry.
96
97 %package -n bash-completion-elektra
98 Summary:        Bash completion for Elektra commands
99 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
100 Group:          Applications/Shells
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       bash-completion
103
104 %description -n bash-completion-elektra
105 Bash completion for Elektra kdb command.
106
107 %description -n bash-completion-elektra -l pl.UTF-8
108 Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
109
110 %package libs
111 Summary:        Elektra Project libraries
112 Summary(pl.UTF-8):      Biblioteki projektu Elektra
113 Group:          Libraries
114 Obsoletes:      elektra-cpp < 0.8
115 Conflicts:      elektra < 0.7
116
117 %description libs
118 The Elektra Project provides a framework to store generic
119 configuration data in an hierarchical key-value pair database, instead
120 of a human-readable only text file.
121
122 This way any software can read/save his configuration using a
123 consistent API. Also, applications can be aware of other applications
124 configurations, leveraging easy application integration.
125
126 This package contains Elektra shared libraries.
127
128 %description libs -l pl.UTF-8
129 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
130 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
131 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
132
133 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
134 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
135 konfiguracji innych aplikacji, ułatwiając ich integrację.
136
137 Ten pakiet zawiera biblioteki współdzielone Elektry.
138
139 %package devel
140 Summary:        Include files and API documentation for Elektra Project
141 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API projektu Elektra
142 Group:          Development/Libraries
143 Requires:       %{name}-libs = %{version}-%{release}
144
145 %description devel
146 This package contains the include files and API manual pages to use
147 the Elektra API in C.
148
149 %description devel -l pl.UTF-8
150 Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
151 systemowego opisującego sposób użycia API Elektry w C.
152
153 %package static
154 Summary:        Static libraries for Elektra Project
155 Summary(pl.UTF-8):      Statyczne biblioteki projektu Elektra
156 Group:          Development/Libraries
157 Requires:       %{name}-devel = %{version}-%{release}
158
159 %description static
160 This package contains static libraries for Elektra Project.
161
162 %description static -l pl.UTF-8
163 Ten pakiet zawiera statyczne biblioteki projektu Elektra.
164
165 %package cpp-devel
166 Summary:        Header files of C++ interface for Elektra library
167 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
168 Group:          Development/Libraries
169 Requires:       %{name}-devel = %{version}-%{release}
170 Requires:       libstdc++-devel
171 Obsoletes:      elektra-cpp-static < 0.8
172
173 %description cpp-devel
174 Header files of C++ interface for Elektra library.
175
176 %description cpp-devel -l pl.UTF-8
177 Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
178
179 %package glib
180 Summary:        GLib/GObject binding for Elektra
181 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry
182 Group:          Libraries
183 Requires:       %{name}-libs = %{version}-%{release}
184 Requires:       glib2 >= 1:2.36
185
186 %description glib
187 GLib/GObject binding for Elektra.
188
189 %description glib -l pl.UTF-8
190 Wiązanie GLib/GObject do Elektry.
191
192 %package glib-devel
193 Summary:        GLib/GObject binding for Elektra - development files
194 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry - pliki programistyczne
195 Group:          Libraries
196 Requires:       %{name}-devel = %{version}-%{release}
197 Requires:       glib2-devel >= 1:2.36
198
199 %description glib-devel
200 GLib/GObject binding for Elektra - development files.
201
202 %description glib-devel -l pl.UTF-8
203 Wiązanie GLib/GObject do Elektry - pliki programistyczne.
204
205 %package -n lua-elektra
206 Summary:        Lua binding for Elektra
207 Summary(pl.UTF-8):      Wiązanie języka Lua dla Elektry
208 Group:          Libraries
209 Requires:       %{name}-libs = %{version}-%{release}
210 Requires:       lua52-libs >= 5.2
211
212 %description -n lua-elektra
213 Lua binding for Elektra.
214
215 %description -n lua-elektra -l pl.UTF-8
216 Wiązanie języka Lua dla Elektry.
217
218 %package -n lua-elektra-glib
219 Summary:        Lua/GI binding for Elektra
220 Summary(pl.UTF-8):      Wiązanie Lua/GI dla Elektry
221 Group:          Libraries
222 Requires:       %{name}-glib = %{version}-%{release}
223 Requires:       lua52-libs >= 5.2
224 #R: lua52-lgi ?
225
226 %description -n lua-elektra-glib
227 Lua/GI binding for Elektra.
228
229 %description -n lua-elektra-glib -l pl.UTF-8
230 Wiązanie Lua/GI dla Elektry.
231
232 %package -n python-elektra
233 Summary:        Python 2 binding for Elektra
234 Summary(pl.UTF-8):      Wiązanie Pythona 2 dla Elektry
235 Group:          Libraries
236 Requires:       %{name}-libs = %{version}-%{release}
237 Requires:       python-libs >= 1:2.7
238
239 %description -n python-elektra
240 Python 2 binding for Elektra.
241
242 %description -n python-elektra -l pl.UTF-8
243 Wiązanie Pythona 2 dla Elektry.
244
245 %package -n python3-elektra
246 Summary:        Python 3 binding for Elektra
247 Summary(pl.UTF-8):      Wiązanie Pythona 3 dla Elektry
248 Group:          Libraries
249 Requires:       %{name}-libs = %{version}-%{release}
250 Requires:       python3-libs >= 1:3.2
251
252 %description -n python3-elektra
253 Python 3 binding for Elektra.
254
255 %description -n python3-elektra -l pl.UTF-8
256 Wiązanie Pythona 3 dla Elektry.
257
258 %package -n python3-elektra-glib
259 Summary:        Python 3 GI binding for Elektra
260 Summary(pl.UTF-8):      Wiązanie Pythona 3 GI dla Elektry
261 Group:          Libraries
262 Requires:       %{name}-glib = %{version}-%{release}
263 Requires:       python3-pygobject3 >= 3
264
265 %description -n python3-elektra-glib
266 Python 3 GI binding for Elektra.
267
268 %description -n python3-elektra-glib -l pl.UTF-8
269 Wiązanie Pythona 3 GI dla Elektry.
270
271 %prep
272 %setup -q
273 %patch0 -p1
274 %patch1 -p1
275 %patch2 -p1
276
277 %build
278 install -d build
279 cd build
280 %cmake .. \
281         -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
282         %{!?with_full:-DBUILD_FULL=OFF} \
283         -DINSTALL_TESTING=FALSE \
284         -DPLUGINS=ALL \
285         -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
286         -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}"
287
288 %{__make} -j1
289
290 %install
291 rm -rf $RPM_BUILD_ROOT
292 install -d $RPM_BUILD_ROOT/etc/sysconfig
293
294 %{__make} -C build install \
295         DESTDIR=$RPM_BUILD_ROOT
296
297 %{__mv} $RPM_BUILD_ROOT/etc/profile.d/{kdb,kdb.sh}
298 echo 'RUN="no"' > $RPM_BUILD_ROOT/etc/sysconfig/elektra
299 install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
300
301 %if %{with python2}
302 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
303 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
304 %py_postclean
305 %endif
306
307 %if %{with python3}
308 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
309 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
310 %endif
311
312 # "static" variant (with libelektra-static and thus all plugins linked in);
313 # we don't need it
314 %{__rm} $RPM_BUILD_ROOT%{_bindir}/kdb-static
315
316 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/elektra/test_data
317
318 # prepare docs
319 %{__rm} -rf installed-doc
320 install -d installed-doc
321 %{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
322
323 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*,src_plugins_*_md}.3elektra
324
325 %clean
326 rm -rf $RPM_BUILD_ROOT
327
328 %post   libs -p /sbin/ldconfig
329 %postun libs -p /sbin/ldconfig
330
331 %post   glib -p /sbin/ldconfig
332 %postun glib -p /sbin/ldconfig
333
334 %files
335 %defattr(644,root,root,755)
336 %doc doc/{AUTHORS,COPYING,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
337 # doc/standards installed-doc/scripts
338 %attr(755,root,root) %{_bindir}/kdb
339 %if %{with full}
340 %attr(755,root,root) %{_bindir}/kdb-full
341 %endif
342 %dir %{_libdir}/elektra
343 # R: augeas-libs
344 %attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
345 %attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
346 %attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
347 %attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
348 %attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
349 # R: libgcrypt
350 %attr(755,root,root) %{_libdir}/elektra/libelektra-crypto.so
351 %attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
352 # R: dbus
353 %attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
354 %attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
355 %attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
356 %attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
357 %attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
358 %attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
359 %attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
360 %attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
361 %attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
362 %attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
363 %attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
364 %attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
365 # uses internal inih library
366 %attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
367 # R: systemd-libs
368 %attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
369 %attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
370 %attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
371 %attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
372 %attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
373 %attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
374 %if %{with lua}
375 # R: lua52-libs
376 %attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
377 %endif
378 %attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
379 %attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
380 %attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
381 # uses internal nickel library
382 %attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
383 %attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
384 %attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
385 %if %{with python2}
386 # R: python-libs
387 %attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
388 %endif
389 %if %{with python3}
390 # R: python3-libs
391 %attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
392 %endif
393 %attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
394 %attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
395 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
396 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
397 %attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
398 %attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
399 %attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
400 %attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
401 %attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
402 %attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
403 %attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
404 %attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
405 %attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
406 %attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
407 %attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
408 %attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
409 # R: libxml2
410 %attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
411 # R: yajl
412 %attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
413 %dir %{_libdir}/elektra/tool_exec
414 %attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
415 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
416 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
417 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
418 %attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
419 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
420 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
421 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
422 %attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
423 %attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
424 %attr(755,root,root) %{_libdir}/elektra/tool_exec/getenv
425 %attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
426 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
427 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
428 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
429 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
430 %attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-spec
431 %attr(755,root,root) %{_libdir}/elektra/tool_exec/race
432 %attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
433 %attr(755,root,root) /etc/profile.d/kdb.sh
434 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/elektra
435 %{_datadir}/sgml/elektra
436 %{_mandir}/man1/kdb.1*
437 %{_mandir}/man1/kdb-check.1*
438 %{_mandir}/man1/kdb-convert.1*
439 %{_mandir}/man1/kdb-cp.1*
440 %{_mandir}/man1/kdb-elektrify-getenv.1*
441 %{_mandir}/man1/kdb-export.1*
442 %{_mandir}/man1/kdb-file.1*
443 %{_mandir}/man1/kdb-fstab.1*
444 %{_mandir}/man1/kdb-get.1*
445 %{_mandir}/man1/kdb-getmeta.1*
446 %{_mandir}/man1/kdb-help.1*
447 %{_mandir}/man1/kdb-import.1*
448 %{_mandir}/man1/kdb-info.1*
449 %{_mandir}/man1/kdb-introduction.1*
450 %{_mandir}/man1/kdb-list.1*
451 %{_mandir}/man1/kdb-list-tools.1*
452 %{_mandir}/man1/kdb-ls.1*
453 %{_mandir}/man1/kdb-lsmeta.1*
454 %{_mandir}/man1/kdb-merge.1*
455 %{_mandir}/man1/kdb-mount.1*
456 %{_mandir}/man1/kdb-mv.1*
457 %{_mandir}/man1/kdb-remount.1*
458 %{_mandir}/man1/kdb-rm.1*
459 %{_mandir}/man1/kdb-set.1*
460 %{_mandir}/man1/kdb-setmeta.1*
461 %{_mandir}/man1/kdb-sget.1*
462 %{_mandir}/man1/kdb-shell.1*
463 %{_mandir}/man1/kdb-test.1*
464 %{_mandir}/man1/kdb-umount.1*
465 %{_mandir}/man1/kdb-vset.1*
466 %{_mandir}/man7/elektra-*.7*
467
468 %if 0
469 %files gen ?
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
472 %{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
473 # FIXME: should be in elektra_gen subdir
474 %{py_sitescriptdir}/support
475 %{_datadir}/elektra/templates
476 %endif
477
478 %files gui
479 %defattr(644,root,root,755)
480 %attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
481 %{_mandir}/man1/kdb-qt-gui.1*
482
483 %files -n bash-completion-elektra
484 %defattr(644,root,root,755)
485 /etc/bash_completion.d/kdb
486
487 %files libs
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
490 %attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
491 %attr(755,root,root) %{_libdir}/libelektragetenv.so
492 %attr(755,root,root) %{_libdir}/libelektratools.so
493 %if %{with full}
494 %attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
495 %attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
496 %endif
497
498 %files devel
499 %defattr(644,root,root,755)
500 %doc doc/API.md installed-doc/elektra-api/html
501 %attr(755,root,root) %{_libdir}/libelektra.so
502 %if %{with full}
503 %attr(755,root,root) %{_libdir}/libelektra-full.so
504 %endif
505 %dir %{_includedir}/elektra
506 %{_includedir}/elektra/crypto_internal.h
507 %{_includedir}/elektra/kdb*.h
508 %{_pkgconfigdir}/elektra.pc
509 %{_datadir}/cmake/Modules/ElektraConfig*.cmake
510 %{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
511 %{_mandir}/man3/api.3elektra*
512 %{_mandir}/man3/deprecated.3elektra*
513 %{_mandir}/man3/kdb*.3elektra*
514 %{_mandir}/man3/key*.3elektra*
515 %{_mandir}/man3/meta.3elektra*
516 %{_mandir}/man3/plugin.3elektra*
517 %{_mandir}/man3/proposal.3elektra*
518 %{_mandir}/man3/proposal.c.3elektra*
519
520 %files static
521 %defattr(644,root,root,755)
522 %{_libdir}/libelektra-static.a
523 %{_libdir}/libelektratools-static.a
524
525 %files cpp-devel
526 %defattr(644,root,root,755)
527 %{_includedir}/elektra/*.hpp
528 %{_includedir}/elektra/helper
529 %{_includedir}/elektra/merging
530 # libelektratools API man pages
531 %{_mandir}/man3/automergeconfiguration.hpp.3elektra*
532 %{_mandir}/man3/automergestrategy.cpp.3elektra*
533 %{_mandir}/man3/automergestrategy.hpp.3elektra*
534 %{_mandir}/man3/comparison.cpp.3elektra*
535 %{_mandir}/man3/comparison.hpp.3elektra*
536 %{_mandir}/man3/backend.hpp.3elektra*
537 %{_mandir}/man3/backends.hpp.3elektra*
538 %{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
539 %{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
540 %{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
541 %{_mandir}/man3/mergeconfiguration.hpp.3elektra*
542 %{_mandir}/man3/mergeconflict.hpp.3elektra*
543 %{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
544 %{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
545 %{_mandir}/man3/mergeresult.cpp.3elektra*
546 %{_mandir}/man3/mergeresult.hpp.3elektra*
547 %{_mandir}/man3/mergetask.hpp.3elektra*
548 %{_mandir}/man3/mergetestutils.cpp.3elektra*
549 %{_mandir}/man3/metamergestrategy.cpp.3elektra*
550 %{_mandir}/man3/metamergestrategy.hpp.3elektra*
551 %{_mandir}/man3/newkeystrategy.cpp.3elektra*
552 %{_mandir}/man3/newkeystrategy.hpp.3elektra*
553 %{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
554 %{_mandir}/man3/onesidestrategy.cpp.3elektra*
555 %{_mandir}/man3/onesidestrategy.hpp.3elektra*
556 %{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
557 %{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
558 %{_mandir}/man3/modules.cpp.3elektra*
559 %{_mandir}/man3/modules.hpp.3elektra*
560 %{_mandir}/man3/plugin.cpp.3elektra*
561 %{_mandir}/man3/plugin.hpp.3elektra*
562 %{_mandir}/man3/plugins.cpp.3elektra*
563 %{_mandir}/man3/plugins.hpp.3elektra*
564 %{_mandir}/man3/src_backend.cpp.3elektra*
565 %{_mandir}/man3/testtool_*.cpp.3elektra*
566 %{_mandir}/man3/threewaymerge.cpp.3elektra*
567 %{_mandir}/man3/threewaymerge.hpp.3elektra*
568 %{_mandir}/man3/toolexcept.hpp.3elektra*
569
570 %if %{with glib}
571 %files glib
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/libgelektra-4.0.so
574 %{_libdir}/girepository-1.0/GElektra-4.0.typelib
575
576 %files glib-devel
577 %defattr(644,root,root,755)
578 %{_datadir}/gir-1.0/GElektra-4.0.gir
579 %{_includedir}/elektra/gelektra-*.h
580 %{_pkgconfigdir}/gelektra-4.0.pc
581 %endif
582
583 %if %{with lua}
584 %files -n lua-elektra
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
587
588 %if %{with glib}
589 %files -n lua-elektra-glib
590 %defattr(644,root,root,755)
591 %dir %{_datadir}/lua/5.2/lgi
592 %dir %{_datadir}/lua/5.2/lgi/override
593 %{_datadir}/lua/5.2/lgi/override/GElektra.lua
594 %endif
595 %endif
596
597 %if %{with python2}
598 %files -n python-elektra
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{py_sitedir}/_kdb.so
601 %{py_sitedir}/kdb.py[co]
602 %endif
603
604 %if %{with python3}
605 %files -n python3-elektra
606 %defattr(644,root,root,755)
607 %attr(755,root,root) %{py3_sitedir}/_kdb.so
608 %{py3_sitedir}/kdb.py
609 %{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
610
611 %if %{with glib}
612 %files -n python3-elektra-glib
613 %defattr(644,root,root,755)
614 %{py3_sitedir}/gi/overrides/GElektra.py
615 %{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
616 %endif
617 %endif
This page took 0.07594 seconds and 4 git commands to generate.