]> git.pld-linux.org Git - packages/elektra.git/blob - elektra.spec
- updated to 0.8.14
[packages/elektra.git] / elektra.spec
1 # TODO: use system nickel (in src/plugins/ni), inih (src/plugins/ini)
2 #
3 # Conditonal build:
4 %bcond_with     full    # "full" variant (libelektra-full with all plugins linked in)
5 %bcond_with     java    # Java support: JNA binding and JNI plugin (needs Java 8)
6 %bcond_without  glib    # GLib/GObject binding
7 %bcond_without  lua     # Lua (5.2) support: binding and plugin
8 %bcond_without  python2 # Python 2 support: binding and plugin
9 %bcond_without  python3 # Python 3 support: binding and plugin
10 %bcond_without  qt      # Qt GUI
11 #
12 Summary:        A key/value pair database to store software configurations
13 Summary(pl.UTF-8):      Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
14 Name:           elektra
15 Version:        0.8.14
16 Release:        1
17 License:        BSD
18 Group:          Applications/System
19 Source0:        http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
20 # Source0-md5:  a87cd3845e590bf413959dfd555e3704
21 Patch0:         %{name}-elektraenv.patch
22 Patch1:         %{name}-no-markdown.patch
23 Patch2:         %{name}-no-deb.patch
24 URL:            http://www.libelektra.org/
25 %if %{with qt}
26 BuildRequires:  Qt5Core-devel >= 5
27 BuildRequires:  Qt5Gui-devel >= 5
28 BuildRequires:  Qt5Qml-devel >= 5
29 BuildRequires:  Qt5Quick-devel >= 5
30 BuildRequires:  Qt5Widgets-devel >= 5
31 BuildRequires:  Qt5Test-devel >= 5
32 %endif
33 BuildRequires:  augeas-devel >= 1.0
34 BuildRequires:  boost-devel
35 BuildRequires:  cmake >= 2.8.8
36 BuildRequires:  dbus-devel
37 BuildRequires:  doxygen
38 BuildRequires:  gettext-tools
39 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.36}
40 %{?with_glib:BuildRequires:     gobject-introspection-devel >= 1.38}
41 %{?with_java:BuildRequires:     java-jna}
42 %{?with_java:BuildRequires:     jdk >= 1.8}
43 BuildRequires:  libgcrypt-devel
44 %{?with_qt:BuildRequires:       libmarkdown-devel}
45 BuildRequires:  libstdc++-devel
46 BuildRequires:  libxml2-devel >= 2.0
47 BuildRequires:  libxslt-progs
48 %{?with_lua:BuildRequires:      lua52-devel >= 5.2}
49 BuildRequires:  pkgconfig
50 %{?with_python2:BuildRequires:  python-devel >= 1:2.7}
51 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
52 BuildRequires:  rpm-pythonprov
53 BuildRequires:  rpmbuild(macros) >= 1.612
54 BuildRequires:  swig >= 2
55 %if %{with python2} || %{with python3}
56 BuildRequires:  swig-python >= 2
57 %endif
58 BuildRequires:  systemd-devel
59 BuildRequires:  tcl-devel
60 BuildRequires:  yajl-devel
61 Requires:       %{name}-libs = %{version}-%{release}
62 Requires:       mktemp
63 Obsoletes:      registry
64 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
65
66 %description
67 The Elektra Project provides a framework to store generic
68 configuration data in an hierarchical key-value pair database, instead
69 of a human-readable only text file.
70
71 This way any software can read/save his configuration using a
72 consistent API. Also, applications can be aware of other applications
73 configurations, leveraging easy application integration.
74
75 %description -l pl.UTF-8
76 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
77 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
78 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
79
80 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
81 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
82 konfiguracji innych aplikacji, ułatwiając ich integrację.
83
84 %package gui
85 Summary:        Qt based GUI for Elektra
86 Summary(pl.UTF-8):      Oparty na Qt graficzny interfejs do Elektry
87 Group:          X11/Applications
88 Requires:       %{name} = %{version}-%{release}
89
90 %description gui
91 Qt based GUI for Elektra.
92
93 %description gui -l pl.UTF-8
94 Oparty na Qt graficzny interfejs do Elektry.
95
96 %package -n bash-completion-elektra
97 Summary:        Bash completion for Elektra commands
98 Summary(pl.UTF-8):      Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
99 Group:          Applications/Shells
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       bash-completion
102
103 %description -n bash-completion-elektra
104 Bash completion for Elektra kdb command.
105
106 %description -n bash-completion-elektra -l pl.UTF-8
107 Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
108
109 %package libs
110 Summary:        Elektra Project libraries
111 Summary(pl.UTF-8):      Biblioteki projektu Elektra
112 Group:          Libraries
113 Obsoletes:      elektra-cpp < 0.8
114 Conflicts:      elektra < 0.7
115
116 %description libs
117 The Elektra Project provides a framework to store generic
118 configuration data in an hierarchical key-value pair database, instead
119 of a human-readable only text file.
120
121 This way any software can read/save his configuration using a
122 consistent API. Also, applications can be aware of other applications
123 configurations, leveraging easy application integration.
124
125 This package contains Elektra shared libraries.
126
127 %description libs -l pl.UTF-8
128 Projekt Elektra dostarcza szkielet do przechowywania typowych danych
129 konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
130 danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
131
132 W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
133 pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
134 konfiguracji innych aplikacji, ułatwiając ich integrację.
135
136 Ten pakiet zawiera biblioteki współdzielone Elektry.
137
138 %package devel
139 Summary:        Include files and API documentation for Elektra Project
140 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja API projektu Elektra
141 Group:          Development/Libraries
142 Requires:       %{name}-libs = %{version}-%{release}
143
144 %description devel
145 This package contains the include files and API manual pages to use
146 the Elektra API in C.
147
148 %description devel -l pl.UTF-8
149 Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
150 systemowego opisującego sposób użycia API Elektry w C.
151
152 %package static
153 Summary:        Static libraries for Elektra Project
154 Summary(pl.UTF-8):      Statyczne biblioteki projektu Elektra
155 Group:          Development/Libraries
156 Requires:       %{name}-devel = %{version}-%{release}
157
158 %description static
159 This package contains static libraries for Elektra Project.
160
161 %description static -l pl.UTF-8
162 Ten pakiet zawiera statyczne biblioteki projektu Elektra.
163
164 %package cpp-devel
165 Summary:        Header files of C++ interface for Elektra library
166 Summary(pl.UTF-8):      Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
167 Group:          Development/Libraries
168 Requires:       %{name}-devel = %{version}-%{release}
169 Requires:       libstdc++-devel
170 Obsoletes:      elektra-cpp-static < 0.8
171
172 %description cpp-devel
173 Header files of C++ interface for Elektra library.
174
175 %description cpp-devel -l pl.UTF-8
176 Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
177
178 %package glib
179 Summary:        GLib/GObject binding for Elektra
180 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry
181 Group:          Libraries
182 Requires:       %{name}-libs = %{version}-%{release}
183 Requires:       glib2 >= 1:2.36
184
185 %description glib
186 GLib/GObject binding for Elektra.
187
188 %description glib -l pl.UTF-8
189 Wiązanie GLib/GObject do Elektry.
190
191 %package glib-devel
192 Summary:        GLib/GObject binding for Elektra - development files
193 Summary(pl.UTF-8):      Wiązanie GLib/GObject do Elektry - pliki programistyczne
194 Group:          Libraries
195 Requires:       %{name}-devel = %{version}-%{release}
196 Requires:       glib2-devel >= 1:2.36
197
198 %description glib-devel
199 GLib/GObject binding for Elektra - development files.
200
201 %description glib-devel -l pl.UTF-8
202 Wiązanie GLib/GObject do Elektry - pliki programistyczne.
203
204 %package -n lua-elektra
205 Summary:        Lua binding for Elektra
206 Summary(pl.UTF-8):      Wiązanie języka Lua dla Elektry
207 Group:          Libraries
208 Requires:       %{name}-libs = %{version}-%{release}
209 Requires:       lua52-libs >= 5.2
210
211 %description -n lua-elektra
212 Lua binding for Elektra.
213
214 %description -n lua-elektra -l pl.UTF-8
215 Wiązanie języka Lua dla Elektry.
216
217 %package -n lua-elektra-glib
218 Summary:        Lua/GI binding for Elektra
219 Summary(pl.UTF-8):      Wiązanie Lua/GI dla Elektry
220 Group:          Libraries
221 Requires:       %{name}-glib = %{version}-%{release}
222 Requires:       lua52-libs >= 5.2
223 #R: lua52-lgi ?
224
225 %description -n lua-elektra-glib
226 Lua/GI binding for Elektra.
227
228 %description -n lua-elektra-glib -l pl.UTF-8
229 Wiązanie Lua/GI dla Elektry.
230
231 %package -n python-elektra
232 Summary:        Python 2 binding for Elektra
233 Summary(pl.UTF-8):      Wiązanie Pythona 2 dla Elektry
234 Group:          Libraries
235 Requires:       %{name}-libs = %{version}-%{release}
236 Requires:       python-libs >= 1:2.7
237
238 %description -n python-elektra
239 Python 2 binding for Elektra.
240
241 %description -n python-elektra -l pl.UTF-8
242 Wiązanie Pythona 2 dla Elektry.
243
244 %package -n python3-elektra
245 Summary:        Python 3 binding for Elektra
246 Summary(pl.UTF-8):      Wiązanie Pythona 3 dla Elektry
247 Group:          Libraries
248 Requires:       %{name}-libs = %{version}-%{release}
249 Requires:       python3-libs >= 1:3.2
250
251 %description -n python3-elektra
252 Python 3 binding for Elektra.
253
254 %description -n python3-elektra -l pl.UTF-8
255 Wiązanie Pythona 3 dla Elektry.
256
257 %package -n python3-elektra-glib
258 Summary:        Python 3 GI binding for Elektra
259 Summary(pl.UTF-8):      Wiązanie Pythona 3 GI dla Elektry
260 Group:          Libraries
261 Requires:       %{name}-glib = %{version}-%{release}
262 Requires:       python3-pygobject3 >= 3
263
264 %description -n python3-elektra-glib
265 Python 3 GI binding for Elektra.
266
267 %description -n python3-elektra-glib -l pl.UTF-8
268 Wiązanie Pythona 3 GI dla Elektry.
269
270 %prep
271 %setup -q
272 %patch0 -p1
273 %patch1 -p1
274 %patch2 -p1
275
276 %build
277 install -d build
278 cd build
279 %cmake .. \
280         -DBINDINGS="cpp%{?with_glib:;glib%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}" \
281         %{!?with_full:-DBUILD_FULL=OFF} \
282         -DINSTALL_TESTING=FALSE \
283         -DPLUGINS=ALL \
284         -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
285         -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}"
286
287 %{__make} -j1
288
289 %install
290 rm -rf $RPM_BUILD_ROOT
291 install -d $RPM_BUILD_ROOT/etc/sysconfig
292
293 %{__make} -C build install \
294         DESTDIR=$RPM_BUILD_ROOT
295
296 %{__mv} $RPM_BUILD_ROOT/etc/profile.d/{kdb,kdb.sh}
297 echo 'RUN="no"' > $RPM_BUILD_ROOT/etc/sysconfig/elektra
298 install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
299
300 %if %{with python2}
301 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
302 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
303 %py_postclean
304 %endif
305
306 %if %{with python3}
307 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
308 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
309 %endif
310
311 # "static" variant (with libelektra-static and thus all plugins linked in);
312 # we don't need it
313 %{__rm} $RPM_BUILD_ROOT%{_bindir}/kdb-static
314
315 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/elektra/test_data
316
317 # prepare docs
318 %{__rm} -rf installed-doc
319 install -d installed-doc
320 %{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
321
322 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*,src_plugins_*_md}.3elektra
323
324 %clean
325 rm -rf $RPM_BUILD_ROOT
326
327 %post   libs -p /sbin/ldconfig
328 %postun libs -p /sbin/ldconfig
329
330 %post   glib -p /sbin/ldconfig
331 %postun glib -p /sbin/ldconfig
332
333 %files
334 %defattr(644,root,root,755)
335 %doc doc/{AUTHORS,COPYING,DESIGN.md,GOALS.md,NEWS.md,SECURITY.md,todo}
336 # doc/standards installed-doc/scripts
337 %attr(755,root,root) %{_bindir}/kdb
338 %if %{with full}
339 %attr(755,root,root) %{_bindir}/kdb-full
340 %endif
341 %dir %{_libdir}/elektra
342 # R: augeas-libs
343 %attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
344 %attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
345 %attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
346 %attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
347 %attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
348 # R: libgcrypt
349 %attr(755,root,root) %{_libdir}/elektra/libelektra-crypto.so
350 %attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
351 # R: dbus
352 %attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
353 %attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
354 %attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
355 %attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
356 %attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
357 %attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
358 %attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
359 %attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
360 %attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
361 %attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
362 %attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
363 %attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
364 # uses internal inih library
365 %attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
366 # R: systemd-libs
367 %attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
368 %attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
369 %attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
370 %attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
371 %attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
372 %attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
373 %if %{with lua}
374 # R: lua52-libs
375 %attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
376 %endif
377 %attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
378 %attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
379 %attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
380 # uses internal nickel library
381 %attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
382 %attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
383 %attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
384 %if %{with python2}
385 # R: python-libs
386 %attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
387 %endif
388 %if %{with python3}
389 # R: python3-libs
390 %attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
391 %endif
392 %attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
393 %attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
394 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
395 %attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
396 %attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
397 %attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
398 %attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
399 %attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
400 %attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
401 %attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
402 %attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
403 %attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
404 %attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
405 %attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
406 %attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
407 %attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
408 # R: libxml2
409 %attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
410 # R: yajl
411 %attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
412 %if "%{_libdir}" != "%{_prefix}/lib"
413 %dir %{_prefix}/lib/elektra
414 %endif
415 %dir %{_prefix}/lib/elektra/tool_exec
416 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/benchmark-createtree
417 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/convert-fstab
418 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/convert-hosts
419 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/convert-inittab
420 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/convert-users
421 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/elektra-merge
422 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/elektra-mount
423 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/elektra-umount
424 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/elektrify-getenv
425 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/example-xorg
426 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/getenv
427 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/list-tools
428 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-augeas
429 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-info
430 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-kde
431 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-openicc
432 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/mount-spec
433 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/race
434 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/umount-all
435
436 %attr(755,root,root) /etc/profile.d/kdb.sh
437 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/elektra
438 %{_datadir}/sgml/elektra
439
440 %if 0
441 %files gen ?
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/gen
444 %{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
445 # FIXME: should be in elektra_gen subdir
446 %{py_sitescriptdir}/support
447 %{_datadir}/elektra/templates
448 %endif
449
450 %files gui
451 %defattr(644,root,root,755)
452 %attr(755,root,root) %{_prefix}/lib/elektra/tool_exec/qt-gui
453
454 %files -n bash-completion-elektra
455 %defattr(644,root,root,755)
456 /etc/bash_completion.d/kdb
457
458 %files libs
459 %defattr(644,root,root,755)
460 %attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
461 %attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
462 %attr(755,root,root) %{_libdir}/libelektragetenv.so
463 %attr(755,root,root) %{_libdir}/libelektratools.so
464 %if %{with full}
465 %attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
466 %attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
467 %endif
468
469 %files devel
470 %defattr(644,root,root,755)
471 %doc doc/API.md installed-doc/elektra-api/html
472 %attr(755,root,root) %{_libdir}/libelektra.so
473 %if %{with full}
474 %attr(755,root,root) %{_libdir}/libelektra-full.so
475 %endif
476 %dir %{_includedir}/elektra
477 %{_includedir}/elektra/crypto_internal.h
478 %{_includedir}/elektra/kdb*.h
479 %{_pkgconfigdir}/elektra.pc
480 %{_datadir}/cmake/Modules/ElektraConfig*.cmake
481 %{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
482 %{_mandir}/man3/api.3elektra*
483 %{_mandir}/man3/deprecated.3elektra*
484 %{_mandir}/man3/kdb*.3elektra*
485 %{_mandir}/man3/key*.3elektra*
486 %{_mandir}/man3/meta.3elektra*
487 %{_mandir}/man3/plugin.3elektra*
488 %{_mandir}/man3/proposal.3elektra*
489 %{_mandir}/man3/proposal.c.3elektra*
490
491 %files static
492 %defattr(644,root,root,755)
493 %{_libdir}/libelektra-static.a
494 %{_libdir}/libelektratools-static.a
495
496 %files cpp-devel
497 %defattr(644,root,root,755)
498 %{_includedir}/elektra/*.hpp
499 %{_includedir}/elektra/helper
500 %{_includedir}/elektra/merging
501 # libelektratools API man pages
502 %{_mandir}/man3/automergeconfiguration.hpp.3elektra*
503 %{_mandir}/man3/automergestrategy.cpp.3elektra*
504 %{_mandir}/man3/automergestrategy.hpp.3elektra*
505 %{_mandir}/man3/comparison.cpp.3elektra*
506 %{_mandir}/man3/comparison.hpp.3elektra*
507 %{_mandir}/man3/backend.hpp.3elektra*
508 %{_mandir}/man3/backends.hpp.3elektra*
509 %{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
510 %{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
511 %{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
512 %{_mandir}/man3/mergeconfiguration.hpp.3elektra*
513 %{_mandir}/man3/mergeconflict.hpp.3elektra*
514 %{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
515 %{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
516 %{_mandir}/man3/mergeresult.cpp.3elektra*
517 %{_mandir}/man3/mergeresult.hpp.3elektra*
518 %{_mandir}/man3/mergetask.hpp.3elektra*
519 %{_mandir}/man3/mergetestutils.cpp.3elektra*
520 %{_mandir}/man3/metamergestrategy.cpp.3elektra*
521 %{_mandir}/man3/metamergestrategy.hpp.3elektra*
522 %{_mandir}/man3/newkeystrategy.cpp.3elektra*
523 %{_mandir}/man3/newkeystrategy.hpp.3elektra*
524 %{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
525 %{_mandir}/man3/onesidestrategy.cpp.3elektra*
526 %{_mandir}/man3/onesidestrategy.hpp.3elektra*
527 %{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
528 %{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
529 %{_mandir}/man3/modules.cpp.3elektra*
530 %{_mandir}/man3/modules.hpp.3elektra*
531 %{_mandir}/man3/plugin.cpp.3elektra*
532 %{_mandir}/man3/plugin.hpp.3elektra*
533 %{_mandir}/man3/plugins.cpp.3elektra*
534 %{_mandir}/man3/plugins.hpp.3elektra*
535 %{_mandir}/man3/src_backend.cpp.3elektra*
536 %{_mandir}/man3/testtool_*.cpp.3elektra*
537 %{_mandir}/man3/threewaymerge.cpp.3elektra*
538 %{_mandir}/man3/threewaymerge.hpp.3elektra*
539 %{_mandir}/man3/toolexcept.hpp.3elektra*
540
541 %if %{with glib}
542 %files glib
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/libgelektra-4.0.so
545 %{_libdir}/girepository-1.0/GElektra-4.0.typelib
546
547 %files glib-devel
548 %defattr(644,root,root,755)
549 %{_datadir}/gir-1.0/GElektra-4.0.gir
550 %{_includedir}/elektra/gelektra-*.h
551 %{_pkgconfigdir}/gelektra-4.0.pc
552 %endif
553
554 %if %{with lua}
555 %files -n lua-elektra
556 %defattr(644,root,root,755)
557 %attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
558
559 %if %{with glib}
560 %files -n lua-elektra-glib
561 %defattr(644,root,root,755)
562 %dir %{_datadir}/lua/5.2/lgi
563 %dir %{_datadir}/lua/5.2/lgi/override
564 %{_datadir}/lua/5.2/lgi/override/GElektra.lua
565 %endif
566 %endif
567
568 %if %{with python2}
569 %files -n python-elektra
570 %defattr(644,root,root,755)
571 %attr(755,root,root) %{py_sitedir}/_kdb.so
572 %{py_sitedir}/kdb.py[co]
573 %endif
574
575 %if %{with python3}
576 %files -n python3-elektra
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{py3_sitedir}/_kdb.so
579 %{py3_sitedir}/kdb.py
580 %{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
581
582 %if %{with glib}
583 %files -n python3-elektra-glib
584 %defattr(644,root,root,755)
585 %{py3_sitedir}/gi/overrides/GElektra.py
586 %{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
587 %endif
588 %endif
This page took 0.147017 seconds and 3 git commands to generate.