]> git.pld-linux.org Git - packages/elektra.git/blame_incremental - elektra.spec
- rebuild with ruby 2.3
[packages/elektra.git] / elektra.spec
... / ...
CommitLineData
1# TODO: use system nickel (1.1.0, in src/plugins/ni), inih (r29, src/plugins/ini)
2#
3# Conditonal build:
4%bcond_with full # "full" variant (libelektra-full with all plugins linked in)
5%bcond_without glib # GLib/GObject/GSetttings (+ GI) bindings
6%bcond_with gsettings # GSetttings module (experimental)
7%bcond_without java # Java support: JNA binding and JNI plugin (needs Java 8)
8%bcond_without lua # Lua (5.2) support: bindings and plugin
9%bcond_without python2 # Python 2 support: bindings and plugin
10%bcond_without python3 # Python 3 support: bindings and plugin
11%bcond_without qt # Qt GUI
12%bcond_without ruby # Ruby binding
13
14Summary: A key/value pair database to store software configurations
15Summary(pl.UTF-8): Baza kluczy/wartości do przechowywania konfiguracji oprogramowania
16Name: elektra
17Version: 0.8.19
18Release: 5
19License: BSD
20Group: Applications/System
21Source0: http://www.libelektra.org/ftp/elektra/releases/%{name}-%{version}.tar.gz
22# Source0-md5: 6669e765c834e259fb7570f126b85d7e
23Patch0: %{name}-zsh.patch
24Patch1: %{name}-no-markdown.patch
25Patch2: %{name}-no-deb.patch
26URL: http://www.libelektra.org/
27%if %{with qt}
28BuildRequires: Qt5Core-devel >= 5.3
29BuildRequires: Qt5Gui-devel >= 5.3
30BuildRequires: Qt5Qml-devel >= 5.3
31BuildRequires: Qt5Quick-devel >= 5.3
32BuildRequires: Qt5Svg-devel >= 5.3
33BuildRequires: Qt5Test-devel >= 5.3
34BuildRequires: Qt5Widgets-devel >= 5.3
35%endif
36BuildRequires: augeas-devel >= 1.0
37BuildRequires: boost-devel
38BuildRequires: cmake >= 2.8.11
39BuildRequires: curl-devel
40BuildRequires: dbus-devel
41BuildRequires: doxygen
42BuildRequires: gettext-tools
43%{?with_glib:BuildRequires: glib2-devel >= 1:2.36}
44%{?with_glib:BuildRequires: gobject-introspection-devel >= 1.38}
45# for binding
46%{?with_java:BuildRequires: java-jna}
47%{?with_java:BuildRequires: jdk >= 1.8}
48# jawt for plugin
49%{?with_java:BuildRequires: jre-X11 >= 1.8}
50BuildRequires: libgcrypt-devel
51BuildRequires: libgit2-devel >= 0.24.1
52%{?with_qt:BuildRequires: libmarkdown-devel}
53BuildRequires: libstdc++-devel
54BuildRequires: libxml2-devel >= 2.0
55BuildRequires: libxslt-progs
56%{?with_lua:BuildRequires: lua52-devel >= 5.2}
57BuildRequires: openssl-devel
58BuildRequires: pkgconfig
59%{?with_python2:BuildRequires: python-devel >= 1:2.7}
60%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
61BuildRequires: ronn
62BuildRequires: rpm-pythonprov
63BuildRequires: rpmbuild(macros) >= 1.612
64%{?with_ruby:BuildRequires: ruby-devel}
65BuildRequires: swig >= 2
66%if %{with python2} || %{with python3}
67BuildRequires: swig-python >= 2
68%endif
69%{?with_ruby:BuildRequires: swig-ruby}
70BuildRequires: systemd-devel
71BuildRequires: tcl-devel
72BuildRequires: yajl-devel
73Requires: %{name}-libs = %{version}-%{release}
74Requires: mktemp
75Obsoletes: registry
76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78%description
79The Elektra Project provides a framework to store generic
80configuration data in an hierarchical key-value pair database, instead
81of a human-readable only text file.
82
83This way any software can read/save his configuration using a
84consistent API. Also, applications can be aware of other applications
85configurations, leveraging easy application integration.
86
87%description -l pl.UTF-8
88Projekt Elektra dostarcza szkielet do przechowywania typowych danych
89konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
90danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
91
92W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
93pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
94konfiguracji innych aplikacji, ułatwiając ich integrację.
95
96%package gui
97Summary: Qt based GUI for Elektra
98Summary(pl.UTF-8): Oparty na Qt graficzny interfejs do Elektry
99Group: X11/Applications
100Requires: %{name} = %{version}-%{release}
101
102%description gui
103Qt based GUI for Elektra.
104
105%description gui -l pl.UTF-8
106Oparty na Qt graficzny interfejs do Elektry.
107
108%package plugin-jni
109Summary: Java JNI plugin for Elektra
110Summary(pl.UTF-8): Wtyczka Java JNI dla Elektry
111Group: Libraries
112Requires: %{name} = %{version}-%{release}
113# jawt
114Requires: jre-X11 >= 1.8
115
116%description plugin-jni
117Java JNI plugin for Elektra. It allows to use plugins written in Java.
118
119%description plugin-jni -l pl.UTF-8
120Wtyczka Java JNI dla Elektry. Pozwala na używanie wtyczek napisanych w
121Javie.
122
123%package plugin-lua
124Summary: Lua plugin for Elektra
125Summary(pl.UTF-8): Wtyczka Lua dla Elektry
126Group: Libraries
127Requires: %{name} = %{version}-%{release}
128Requires: lua52-libs >= 5.2
129
130%description plugin-lua
131Lua plugin for Elektra. It allows to use plugins written in Lua.
132
133%description plugin-lua -l pl.UTF-8
134Wtyczka Lua dla Elektry. Pozwala na używanie wtyczek napisanych w Lua.
135
136%package plugin-python2
137Summary: Python 2 plugin for Elektra
138Summary(pl.UTF-8): Wtyczka Python 2 dla Elektry
139Group: Libraries
140Requires: %{name} = %{version}-%{release}
141Requires: python-libs >= 1:2.7
142
143%description plugin-python2
144Python 2 plugin for Elektra. It allows to use plugins written in
145Python 2.
146
147%description plugin-python2 -l pl.UTF-8
148Wtyczka 2 Python dla Elektry. Pozwala na używanie wtyczek napisanych w
149Pythonie 2.
150
151%package plugin-python3
152Summary: Python 3 plugin for Elektra
153Summary(pl.UTF-8): Wtyczka Python 3 dla Elektry
154Group: Libraries
155Requires: %{name} = %{version}-%{release}
156Requires: python3-libs >= 1:3.2
157
158%description plugin-python3
159Python 3 plugin for Elektra. It allows to use plugins written in
160Python 3.
161
162%description plugin-python3 -l pl.UTF-8
163Wtyczka Python 3 dla Elektry. Pozwala na używanie wtyczek napisanych w
164Pythonie 3.
165
166%package -n bash-completion-elektra
167Summary: Bash completion for Elektra commands
168Summary(pl.UTF-8): Bashowe uzupełnianie parametrów dla poleceń z pakietu Elektra
169Group: Applications/Shells
170Requires: %{name} = %{version}-%{release}
171Requires: bash-completion >= 2
172%if "%{_rpmversion}" >= "5"
173BuildArch: noarch
174%endif
175
176%description -n bash-completion-elektra
177Bash completion for Elektra kdb command.
178
179%description -n bash-completion-elektra -l pl.UTF-8
180Bashowe uzupełnianie parametrów dla polecenai kdb z pakietu Elektra.
181
182%package -n zsh-completion-elektra
183Summary: ZSH completion for Elektra commands
184Summary(pl.UTF-8): Uzupełnianie parametrów dla poleceń z pakietu Elektra w powłoce ZSH
185Group: Applications/Shells
186Requires: %{name} = %{version}-%{release}
187Requires: zsh
188%if "%{_rpmversion}" >= "5"
189BuildArch: noarch
190%endif
191
192%description -n zsh-completion-elektra
193ZSH completion for Elektra kdb command.
194
195%description -n zsh-completion-elektra -l pl.UTF-8
196Uzupełnianie parametrów dla polecenai kdb z pakietu Elektra w powłoce
197ZSH.
198
199%package libs
200Summary: Elektra Project libraries
201Summary(pl.UTF-8): Biblioteki projektu Elektra
202Group: Libraries
203Obsoletes: elektra-cpp < 0.8
204Conflicts: elektra < 0.7
205
206%description libs
207The Elektra Project provides a framework to store generic
208configuration data in an hierarchical key-value pair database, instead
209of a human-readable only text file.
210
211This way any software can read/save his configuration using a
212consistent API. Also, applications can be aware of other applications
213configurations, leveraging easy application integration.
214
215This package contains Elektra shared libraries.
216
217%description libs -l pl.UTF-8
218Projekt Elektra dostarcza szkielet do przechowywania typowych danych
219konfiguracyjnych w postaci klucz-wartość w hierarchicznej bazie
220danych, zamiast w pliku tekstowym czytelnym tylko dla człowieka.
221
222W ten sposób oprogramowanie może odczytywać/zapisywać konfigurację za
223pomocą spójnego API. Dodatkowo aplikacje mogą być zorientowane w
224konfiguracji innych aplikacji, ułatwiając ich integrację.
225
226Ten pakiet zawiera biblioteki współdzielone Elektry.
227
228%package devel
229Summary: Include files and API documentation for Elektra Project
230Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja API projektu Elektra
231Group: Development/Libraries
232Requires: %{name}-libs = %{version}-%{release}
233
234%description devel
235This package contains the include files and API manual pages to use
236the Elektra API in C.
237
238%description devel -l pl.UTF-8
239Ten pakiet zawiera pliki nagłówkowe oraz strony podręcznika
240systemowego opisującego sposób użycia API Elektry w C.
241
242%package static
243Summary: Static libraries for Elektra Project
244Summary(pl.UTF-8): Statyczne biblioteki projektu Elektra
245Group: Development/Libraries
246Requires: %{name}-devel = %{version}-%{release}
247
248%description static
249This package contains static libraries for Elektra Project.
250
251%description static -l pl.UTF-8
252Ten pakiet zawiera statyczne biblioteki projektu Elektra.
253
254%package cpp-devel
255Summary: Header files of C++ interface for Elektra library
256Summary(pl.UTF-8): Pliki nagłówkowe interfejsu C++ do biblioteki Elektra
257Group: Development/Libraries
258Requires: %{name}-devel = %{version}-%{release}
259Requires: libstdc++-devel
260Obsoletes: elektra-cpp-static < 0.8
261
262%description cpp-devel
263Header files of C++ interface for Elektra library.
264
265%description cpp-devel -l pl.UTF-8
266Pliki nagłówkowe interfejsu C++ do biblioteki Elektra.
267
268%package glib
269Summary: GLib/GObject binding for Elektra
270Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry
271Group: Libraries
272Requires: %{name}-libs = %{version}-%{release}
273Requires: glib2 >= 1:2.36
274
275%description glib
276GLib/GObject binding for Elektra.
277
278%description glib -l pl.UTF-8
279Wiązanie GLib/GObject do Elektry.
280
281%package glib-devel
282Summary: GLib/GObject binding for Elektra - development files
283Summary(pl.UTF-8): Wiązanie GLib/GObject do Elektry - pliki programistyczne
284Group: Libraries
285Requires: %{name}-devel = %{version}-%{release}
286Requires: glib2-devel >= 1:2.36
287
288%description glib-devel
289GLib/GObject binding for Elektra - development files.
290
291%description glib-devel -l pl.UTF-8
292Wiązanie GLib/GObject do Elektry - pliki programistyczne.
293
294%package -n java-elektra
295Summary: Java binding for Elektra
296Summary(pl.UTF-8): Wiązanie języka Java dla Elektry
297Group: Libraries
298Requires: %{name}-libs = %{version}-%{release}
299Requires: java-jna
300Requires: jre >= 1.8
301
302%description -n java-elektra
303Java binding for Elektra.
304
305%description -n java-elektra -l pl.UTF-8
306Wiązanie języka Java dla Elektry.
307
308%package -n lua-elektra
309Summary: Lua binding for Elektra
310Summary(pl.UTF-8): Wiązanie języka Lua dla Elektry
311Group: Libraries
312Requires: %{name}-libs = %{version}-%{release}
313Requires: lua52-libs >= 5.2
314
315%description -n lua-elektra
316Lua binding for Elektra.
317
318%description -n lua-elektra -l pl.UTF-8
319Wiązanie języka Lua dla Elektry.
320
321%package -n lua-elektra-glib
322Summary: Lua/GI binding for Elektra
323Summary(pl.UTF-8): Wiązanie Lua/GI dla Elektry
324Group: Libraries
325Requires: %{name}-glib = %{version}-%{release}
326Requires: lua52-libs >= 5.2
327#R: lua52-lgi ?
328
329%description -n lua-elektra-glib
330Lua/GI binding for Elektra. Note: this bindings is deprecated, it's
331better to use SWIG (lua-elektra) binding.
332
333%description -n lua-elektra-glib -l pl.UTF-8
334Wiązanie Lua/GI dla Elektry. Uwaga: to wiązanie jest przestarzałe,
335lepiej używać wiązania SWIG (lua-elektra).
336
337%package -n python-elektra
338Summary: Python 2 binding for Elektra
339Summary(pl.UTF-8): Wiązanie Pythona 2 dla Elektry
340Group: Libraries
341Requires: %{name}-libs = %{version}-%{release}
342Requires: python-libs >= 1:2.7
343
344%description -n python-elektra
345Python 2 binding for Elektra.
346
347%description -n python-elektra -l pl.UTF-8
348Wiązanie Pythona 2 dla Elektry.
349
350%package -n python3-elektra
351Summary: Python 3 binding for Elektra
352Summary(pl.UTF-8): Wiązanie Pythona 3 dla Elektry
353Group: Libraries
354Requires: %{name}-libs = %{version}-%{release}
355Requires: python3-libs >= 1:3.2
356
357%description -n python3-elektra
358Python 3 binding for Elektra.
359
360%description -n python3-elektra -l pl.UTF-8
361Wiązanie Pythona 3 dla Elektry.
362
363%package -n python3-elektra-glib
364Summary: Python 3 GI binding for Elektra
365Summary(pl.UTF-8): Wiązanie Pythona 3 GI dla Elektry
366Group: Libraries
367Requires: %{name}-glib = %{version}-%{release}
368Requires: python3-pygobject3 >= 3
369
370%description -n python3-elektra-glib
371Python 3 GI binding for Elektra. Note: this bindings is deprecated,
372it's better to use SWIG (python*-elektra) binding.
373
374
375%description -n python3-elektra-glib -l pl.UTF-8
376Wiązanie Pythona 3 GI dla Elektry. Uwaga: to wiązanie jest
377przestarzałe, lepiej używać wiązania SWIG (python*-elektra).
378
379%package -n ruby-elektra
380Summary: Ruby binding for Elektra
381Summary(pl.UTF-8): Wiązanie języka Ruby dla Elektry
382Group: Libraries
383Requires: %{name}-libs = %{version}-%{release}
384
385%description -n ruby-elektra
386Ruby binding for Elektra.
387
388%description -n ruby-elektra -l pl.UTF-8
389Wiązanie języka Ruby dla Elektry.
390
391%prep
392%setup -q
393%patch0 -p1
394%patch1 -p1
395%patch2 -p1
396
397%build
398install -d build
399cd build
400%cmake .. \
401 -DBINDINGS="INTERCEPT;cpp%{?with_glib:;glib%{?with_gsettings:;gsettings}%{?with_lua:;gi_lua}%{?with_python3:;gi_python}}%{?with_java:;jna}%{?with_lua:;swig_lua}%{?with_python2:;swig_python2}%{?with_python3:;swig_python}%{?with_ruby:;swig_ruby}" \
402 %{!?with_full:-DBUILD_FULL=OFF} \
403 -DINSTALL_TESTING=FALSE \
404 -DPLUGINS=ALL \
405 -DTARGET_CMAKE_FOLDER=%{_datadir}/cmake/Modules \
406 -DTOOLS="kdb;race%{?with_gen:;gen}%{?with_qt:;qt-gui}" \
407 -DBUILD_STATIC=ON
408
409%{__make} -j1
410
411%install
412rm -rf $RPM_BUILD_ROOT
413
414%{__make} -C build install \
415 DESTDIR=$RPM_BUILD_ROOT
416
417# unneeded compat symlink
418%{__rm} $RPM_BUILD_ROOT%{_libdir}/libelektragetenv.so.0
419
420install -D src/plugins/xmltool/xmlschema/elektra.xsd $RPM_BUILD_ROOT%{_datadir}/sgml/elektra/elektra.xsd
421
422%if %{with python2}
423%py_comp $RPM_BUILD_ROOT%{py_sitedir}
424%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
425%py_postclean
426%endif
427
428%if %{with python3}
429%py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
430%py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
431%endif
432
433# "static" variant (with libelektra-static and thus all plugins linked in);
434# we don't need it
435%{__rm} $RPM_BUILD_ROOT%{_bindir}/kdb-static
436
437# prepare docs
438%{__rm} -rf installed-doc
439install -d installed-doc
440%{__mv} $RPM_BUILD_ROOT%{_docdir}/%{name}-api installed-doc/elektra-api
441
442# these don't belong to man3
443%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{README_md,doc_*_md,md_doc_*,md_src_*,md_scripts_README,src_libs_getenv_README_md}.3elektra
444# internal, not part of API
445%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/doc.h.3elektra
446%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{array,backend,dl,doc,ease_keyname,elektra_{keyname,plugin,proposal},exportsymbols,functional,internal,kdbenum,log,markdownlinkconverter,meta,mount,nolog,owner,plugin_plugin,proposal_proposal,split,static,trie}.c.3elektra
447%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{benchmark_plugins,examples_backend}.cpp.3elektra
448%{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/{internaldatastructs,std_hash_*_,trie,vheap,vstack}.3elektra
449
450%clean
451rm -rf $RPM_BUILD_ROOT
452
453%post libs -p /sbin/ldconfig
454%postun libs -p /sbin/ldconfig
455
456%post glib -p /sbin/ldconfig
457%postun glib -p /sbin/ldconfig
458
459%files
460%defattr(644,root,root,755)
461%doc doc/{AUTHORS,BIGPICTURE.md,DESIGN.md,GOALS.md,LICENSE.md,NEWS.md,SECURITY.md,WHY.md,todo}
462# doc/standards installed-doc/scripts
463%attr(755,root,root) %{_bindir}/kdb
464%if %{with full}
465%attr(755,root,root) %{_bindir}/kdb-full
466%endif
467%dir %{_libdir}/elektra
468# R: augeas-libs libxml2
469%attr(755,root,root) %{_libdir}/elektra/libelektra-augeas.so
470%attr(755,root,root) %{_libdir}/elektra/libelektra-base64.so
471%attr(755,root,root) %{_libdir}/elektra/libelektra-blockresolver.so
472%attr(755,root,root) %{_libdir}/elektra/libelektra-boolean.so
473%attr(755,root,root) %{_libdir}/elektra/libelektra-c.so
474%attr(755,root,root) %{_libdir}/elektra/libelektra-cachefilter.so
475%attr(755,root,root) %{_libdir}/elektra/libelektra-ccode.so
476%attr(755,root,root) %{_libdir}/elektra/libelektra-conditionals.so
477%attr(755,root,root) %{_libdir}/elektra/libelektra-constants.so
478%attr(755,root,root) %{_libdir}/elektra/libelektra-counter.so
479# TODO: R: botan
480#%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_botan.so
481# R: libgcrypt
482%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_gcrypt.so
483# R: openssl
484%attr(755,root,root) %{_libdir}/elektra/libelektra-crypto_openssl.so
485%attr(755,root,root) %{_libdir}/elektra/libelektra-csvstorage.so
486# R: curl-libs
487%attr(755,root,root) %{_libdir}/elektra/libelektra-curlget.so
488# R: dbus
489%attr(755,root,root) %{_libdir}/elektra/libelektra-dbus.so
490%attr(755,root,root) %{_libdir}/elektra/libelektra-desktop.so
491%attr(755,root,root) %{_libdir}/elektra/libelektra-doc.so
492%attr(755,root,root) %{_libdir}/elektra/libelektra-dpkg.so
493%attr(755,root,root) %{_libdir}/elektra/libelektra-dump.so
494%attr(755,root,root) %{_libdir}/elektra/libelektra-enum.so
495%attr(755,root,root) %{_libdir}/elektra/libelektra-error.so
496%attr(755,root,root) %{_libdir}/elektra/libelektra-fcrypt.so
497%attr(755,root,root) %{_libdir}/elektra/libelektra-filecheck.so
498%attr(755,root,root) %{_libdir}/elektra/libelektra-fstab.so
499# R: libgit2 >= 0.24.1
500%attr(755,root,root) %{_libdir}/elektra/libelektra-gitresolver.so
501%attr(755,root,root) %{_libdir}/elektra/libelektra-glob.so
502%attr(755,root,root) %{_libdir}/elektra/libelektra-hexcode.so
503%attr(755,root,root) %{_libdir}/elektra/libelektra-hidden.so
504%attr(755,root,root) %{_libdir}/elektra/libelektra-hosts.so
505%attr(755,root,root) %{_libdir}/elektra/libelektra-iconv.so
506# uses internal inih library
507%attr(755,root,root) %{_libdir}/elektra/libelektra-ini.so
508%attr(755,root,root) %{_libdir}/elektra/libelektra-iterate.so
509# R: systemd-libs
510%attr(755,root,root) %{_libdir}/elektra/libelektra-journald.so
511%attr(755,root,root) %{_libdir}/elektra/libelektra-keytometa.so
512%attr(755,root,root) %{_libdir}/elektra/libelektra-line.so
513%attr(755,root,root) %{_libdir}/elektra/libelektra-lineendings.so
514%attr(755,root,root) %{_libdir}/elektra/libelektra-list.so
515%attr(755,root,root) %{_libdir}/elektra/libelektra-logchange.so
516%attr(755,root,root) %{_libdir}/elektra/libelektra-mathcheck.so
517%attr(755,root,root) %{_libdir}/elektra/libelektra-mozprefs.so
518%attr(755,root,root) %{_libdir}/elektra/libelektra-network.so
519%attr(755,root,root) %{_libdir}/elektra/libelektra-noresolver.so
520# uses internal nickel library
521%attr(755,root,root) %{_libdir}/elektra/libelektra-ni.so
522%attr(755,root,root) %{_libdir}/elektra/libelektra-null.so
523%attr(755,root,root) %{_libdir}/elektra/libelektra-passwd.so
524%attr(755,root,root) %{_libdir}/elektra/libelektra-path.so
525%attr(755,root,root) %{_libdir}/elektra/libelektra-profile.so
526%attr(755,root,root) %{_libdir}/elektra/libelektra-regexstore.so
527%attr(755,root,root) %{_libdir}/elektra/libelektra-rename.so
528%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver.so
529%attr(755,root,root) %{_libdir}/elektra/libelektra-resolver_fm_*.so
530%attr(755,root,root) %{_libdir}/elektra/libelektra-required.so
531%attr(755,root,root) %{_libdir}/elektra/libelektra-semlock.so
532%attr(755,root,root) %{_libdir}/elektra/libelektra-shell.so
533%attr(755,root,root) %{_libdir}/elektra/libelektra-simplespeclang.so
534%attr(755,root,root) %{_libdir}/elektra/libelektra-simpleini.so
535%attr(755,root,root) %{_libdir}/elektra/libelektra-spec.so
536%attr(755,root,root) %{_libdir}/elektra/libelektra-storage.so
537%attr(755,root,root) %{_libdir}/elektra/libelektra-struct.so
538%attr(755,root,root) %{_libdir}/elektra/libelektra-sync.so
539%attr(755,root,root) %{_libdir}/elektra/libelektra-syslog.so
540%attr(755,root,root) %{_libdir}/elektra/libelektra-tcl.so
541%attr(755,root,root) %{_libdir}/elektra/libelektra-template.so
542%attr(755,root,root) %{_libdir}/elektra/libelektra-timeofday.so
543%attr(755,root,root) %{_libdir}/elektra/libelektra-tracer.so
544%attr(755,root,root) %{_libdir}/elektra/libelektra-type.so
545%attr(755,root,root) %{_libdir}/elektra/libelektra-uname.so
546%attr(755,root,root) %{_libdir}/elektra/libelektra-validation.so
547%attr(755,root,root) %{_libdir}/elektra/libelektra-wresolver.so
548# R: libxml2
549%attr(755,root,root) %{_libdir}/elektra/libelektra-xmltool.so
550# R: yajl
551%attr(755,root,root) %{_libdir}/elektra/libelektra-yajl.so
552%dir %{_libdir}/elektra/tool_exec
553%attr(755,root,root) %{_libdir}/elektra/tool_exec/benchmark-createtree
554%attr(755,root,root) %{_libdir}/elektra/tool_exec/configure-firefox
555%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-fstab
556%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-hosts
557%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-inittab
558%attr(755,root,root) %{_libdir}/elektra/tool_exec/convert-users
559%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-merge
560%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-mount
561%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektra-umount
562%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-open
563%attr(755,root,root) %{_libdir}/elektra/tool_exec/elektrify-getenv
564%attr(755,root,root) %{_libdir}/elektra/tool_exec/example-xorg
565%dir %{_libdir}/elektra/tool_exec/ffconfig
566%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupConfig
567%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupHomepage
568%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/setupProxy
569%attr(755,root,root) %{_libdir}/elektra/tool_exec/ffconfig/writeConfigFiles
570%attr(755,root,root) %{_libdir}/elektra/tool_exec/find-tools
571%attr(755,root,root) %{_libdir}/elektra/tool_exec/getenv
572%attr(755,root,root) %{_libdir}/elektra/tool_exec/install-sh-completion
573%attr(755,root,root) %{_libdir}/elektra/tool_exec/list-tools
574%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-augeas
575%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-info
576%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-kde
577%attr(755,root,root) %{_libdir}/elektra/tool_exec/mount-openicc
578%attr(755,root,root) %{_libdir}/elektra/tool_exec/race
579%attr(755,root,root) %{_libdir}/elektra/tool_exec/umount-all
580%attr(755,root,root) %{_libdir}/elektra/tool_exec/upgrade-bootstrap
581%{_datadir}/sgml/elektra
582%{_mandir}/man1/kdb.1*
583%{_mandir}/man1/kdb-check.1*
584%{_mandir}/man1/kdb-convert.1*
585%{_mandir}/man1/kdb-cp.1*
586%{_mandir}/man1/kdb-editor.1*
587%{_mandir}/man1/kdb-elektrify-getenv.1*
588%{_mandir}/man1/kdb-export.1*
589%{_mandir}/man1/kdb-file.1*
590%{_mandir}/man1/kdb-find-tools.1*
591%{_mandir}/man1/kdb-fstab.1*
592%{_mandir}/man1/kdb-get.1*
593%{_mandir}/man1/kdb-getmeta.1*
594%{_mandir}/man1/kdb-global-mount.1*
595%{_mandir}/man1/kdb-help.1*
596%{_mandir}/man1/kdb-import.1*
597%{_mandir}/man1/kdb-info.1*
598%{_mandir}/man1/kdb-introduction.1*
599%{_mandir}/man1/kdb-list.1*
600%{_mandir}/man1/kdb-list-tools.1*
601%{_mandir}/man1/kdb-ls.1*
602%{_mandir}/man1/kdb-lsmeta.1*
603%{_mandir}/man1/kdb-merge.1*
604%{_mandir}/man1/kdb-mount.1*
605%{_mandir}/man1/kdb-mv.1*
606%{_mandir}/man1/kdb-remount.1*
607%{_mandir}/man1/kdb-rm.1*
608%{_mandir}/man1/kdb-set.1*
609%{_mandir}/man1/kdb-setmeta.1*
610%{_mandir}/man1/kdb-sget.1*
611%{_mandir}/man1/kdb-shell.1*
612%{_mandir}/man1/kdb-spec-mount.1*
613%{_mandir}/man1/kdb-test.1*
614%{_mandir}/man1/kdb-umount.1*
615%{_mandir}/man1/kdb-vset.1*
616%{_mandir}/man7/elektra-*.7*
617
618%if 0
619%files gen ?
620%defattr(644,root,root,755)
621%attr(755,root,root) %{_libdir}/elektra/tool_exec/gen
622%{py_sitescriptdir}/elektra_gen-%{version}-py*.egg-info
623# FIXME: should be in elektra_gen subdir
624%{py_sitescriptdir}/support
625%{_datadir}/elektra/templates
626%endif
627
628%files gui
629%defattr(644,root,root,755)
630%doc src/tools/qt-gui/README.md
631%attr(755,root,root) %{_bindir}/elektra-qt-editor
632%attr(755,root,root) %{_libdir}/elektra/tool_exec/qt-gui
633%{_datadir}/appdata/org.libelektra.elektra-qt-editor.appdata.xml
634%{_desktopdir}/org.libelektra.elektra-qt-editor.desktop
635%{_iconsdir}/hicolor/scalable/apps/elektra-symbolic.svg
636%{_iconsdir}/hicolor/scalable/apps/elektra.svg
637%{_mandir}/man1/kdb-qt-gui.1*
638
639%if %{with java}
640%files plugin-jni
641%defattr(644,root,root,755)
642# R: jre with jawt
643%attr(755,root,root) %{_libdir}/elektra/libelektra-jni.so
644%endif
645
646%if %{with lua}
647%files plugin-lua
648%defattr(644,root,root,755)
649# R: lua52-libs
650%attr(755,root,root) %{_libdir}/elektra/libelektra-lua.so
651%endif
652
653%if %{with python2}
654%files plugin-python2
655%defattr(644,root,root,755)
656# R: python-libs
657%attr(755,root,root) %{_libdir}/elektra/libelektra-python2.so
658%endif
659
660%if %{with python3}
661%files plugin-python3
662%defattr(644,root,root,755)
663# R: python3-libs
664%attr(755,root,root) %{_libdir}/elektra/libelektra-python.so
665%endif
666
667%files -n bash-completion-elektra
668%defattr(644,root,root,755)
669%{bash_compdir}/kdb
670
671%files -n zsh-completion-elektra
672%defattr(644,root,root,755)
673%{_datadir}/zsh/site-functions/_kdb
674
675%files libs
676%defattr(644,root,root,755)
677%attr(755,root,root) %{_libdir}/libelektra.so.*.*.*
678%attr(755,root,root) %ghost %{_libdir}/libelektra.so.4
679%attr(755,root,root) %{_libdir}/libelektra-core.so.*.*.*
680%attr(755,root,root) %ghost %{_libdir}/libelektra-core.so.4
681%attr(755,root,root) %{_libdir}/libelektra-ease.so.*.*.*
682%attr(755,root,root) %ghost %{_libdir}/libelektra-ease.so.4
683%attr(755,root,root) %{_libdir}/libelektra-kdb.so.*.*.*
684%attr(755,root,root) %ghost %{_libdir}/libelektra-kdb.so.4
685%attr(755,root,root) %{_libdir}/libelektra-meta.so.*.*.*
686%attr(755,root,root) %ghost %{_libdir}/libelektra-meta.so.4
687%attr(755,root,root) %{_libdir}/libelektra-plugin.so.*.*.*
688%attr(755,root,root) %ghost %{_libdir}/libelektra-plugin.so.4
689%attr(755,root,root) %{_libdir}/libelektra-proposal.so.*.*.*
690%attr(755,root,root) %ghost %{_libdir}/libelektra-proposal.so.4
691%attr(755,root,root) %{_libdir}/libelektraintercept-env.so.*.*.*
692%attr(755,root,root) %ghost %{_libdir}/libelektraintercept-env.so.0
693%attr(755,root,root) %{_libdir}/libelektraintercept-fs.so
694%attr(755,root,root) %{_libdir}/libelektratools.so.*.*.*
695%attr(755,root,root) %ghost %{_libdir}/libelektratools.so.2
696%if %{with full}
697%attr(755,root,root) %{_libdir}/libelektra-full.so.*.*.*
698%attr(755,root,root) %ghost %{_libdir}/libelektra-full.so.4
699%endif
700
701%files devel
702%defattr(644,root,root,755)
703%doc doc/API.md installed-doc/elektra-api/html
704%attr(755,root,root) %{_libdir}/libelektra.so
705%attr(755,root,root) %{_libdir}/libelektra-core.so
706%attr(755,root,root) %{_libdir}/libelektra-ease.so
707%attr(755,root,root) %{_libdir}/libelektra-kdb.so
708%attr(755,root,root) %{_libdir}/libelektra-meta.so
709%attr(755,root,root) %{_libdir}/libelektra-plugin.so
710%attr(755,root,root) %{_libdir}/libelektra-proposal.so
711%attr(755,root,root) %{_libdir}/libelektragetenv.so
712%attr(755,root,root) %{_libdir}/libelektraintercept-env.so
713%attr(755,root,root) %{_libdir}/libelektraintercept.so
714%attr(755,root,root) %{_libdir}/libelektratools.so
715%if %{with full}
716%attr(755,root,root) %{_libdir}/libelektra-full.so
717%endif
718%dir %{_includedir}/elektra
719%{_includedir}/elektra/kdb*.h
720%{_pkgconfigdir}/elektra.pc
721%{_datadir}/cmake/Modules/ElektraConfig*.cmake
722%{_datadir}/cmake/Modules/ElektraTargetsLibelektra*.cmake
723%{_mandir}/man3/api.3elektra*
724%{_mandir}/man3/deprecated.3elektra*
725%{_mandir}/man3/kdb.3elektra*
726%{_mandir}/man3/kdb.c.3elektra*
727%{_mandir}/man3/kdb_*.3elektra*
728%{_mandir}/man3/kdb*.h.3elektra*
729%{_mandir}/man3/key.3elektra*
730%{_mandir}/man3/keymeta.3elektra*
731%{_mandir}/man3/keyname.3elektra*
732%{_mandir}/man3/keyset.3elektra*
733%{_mandir}/man3/keytest.3elektra*
734%{_mandir}/man3/keyvalue.3elektra*
735%{_mandir}/man3/key.c.3elektra*
736%{_mandir}/man3/keyhelpers.c.3elektra*
737%{_mandir}/man3/keymeta.c.3elektra*
738%{_mandir}/man3/keyset.c.3elektra*
739%{_mandir}/man3/keytest.c.3elektra*
740%{_mandir}/man3/keyvalue.c.3elektra*
741%{_mandir}/man3/meta.3elektra*
742%{_mandir}/man3/plugin.3elektra*
743%{_mandir}/man3/proposal.3elektra*
744
745%files static
746%defattr(644,root,root,755)
747%{_libdir}/libelektra-static.a
748%{_libdir}/libelektratools-static.a
749
750%files cpp-devel
751%defattr(644,root,root,755)
752%doc src/bindings/cpp/README.md
753%{_includedir}/elektra/*.hpp
754%{_includedir}/elektra/helper
755%{_includedir}/elektra/merging
756# libelektratools API man pages
757%{_mandir}/man3/automergeconfiguration.cpp.3elektra*
758%{_mandir}/man3/automergeconfiguration.hpp.3elektra*
759%{_mandir}/man3/automergestrategy.cpp.3elektra*
760%{_mandir}/man3/automergestrategy.hpp.3elektra*
761%{_mandir}/man3/backend.hpp.3elektra*
762%{_mandir}/man3/backendbuilder.cpp.3elektra*
763%{_mandir}/man3/backendbuilder.hpp.3elektra*
764%{_mandir}/man3/backendparser.cpp.3elektra*
765%{_mandir}/man3/backendparser.hpp.3elektra*
766%{_mandir}/man3/backends.cpp.3elektra*
767%{_mandir}/man3/backends.hpp.3elektra*
768%{_mandir}/man3/comparison.cpp.3elektra*
769%{_mandir}/man3/comparison.hpp.3elektra*
770%{_mandir}/man3/importmergeconfiguration.cpp.3elektra*
771%{_mandir}/man3/importmergeconfiguration.hpp.3elektra*
772%{_mandir}/man3/interactivemergestrategy.cpp.3elektra*
773%{_mandir}/man3/interactivemergestrategy.hpp.3elektra*
774%{_mandir}/man3/kdb*.hpp.3elektra*
775%{_mandir}/man3/key*.hpp.3elektra*
776%{_mandir}/man3/keyhelper.cpp.3elektra*
777%{_mandir}/man3/mergeconfiguration.hpp.3elektra*
778%{_mandir}/man3/mergeconflict.hpp.3elektra*
779%{_mandir}/man3/mergeconflictstrategy.cpp.3elektra*
780%{_mandir}/man3/mergeconflictstrategy.hpp.3elektra*
781%{_mandir}/man3/mergeresult.cpp.3elektra*
782%{_mandir}/man3/mergeresult.hpp.3elektra*
783%{_mandir}/man3/mergetask.hpp.3elektra*
784%{_mandir}/man3/mergetestutils.cpp.3elektra*
785%{_mandir}/man3/merging.cpp.3elektra*
786%{_mandir}/man3/mergingkdb.cpp.3elektra*
787%{_mandir}/man3/mergingkdb.hpp.3elektra*
788%{_mandir}/man3/metamergestrategy.cpp.3elektra*
789%{_mandir}/man3/metamergestrategy.hpp.3elektra*
790%{_mandir}/man3/newkeystrategy.cpp.3elektra*
791%{_mandir}/man3/newkeystrategy.hpp.3elektra*
792%{_mandir}/man3/onesidemergeconfiguration.cpp.3elektra*
793%{_mandir}/man3/onesidemergeconfiguration.hpp.3elektra*
794%{_mandir}/man3/onesidestrategy.cpp.3elektra*
795%{_mandir}/man3/onesidestrategy.hpp.3elektra*
796%{_mandir}/man3/onesidevaluestrategy.cpp.3elektra*
797%{_mandir}/man3/onesidevaluestrategy.hpp.3elektra*
798%{_mandir}/man3/overwritemergeconfiguration.cpp.3elektra*
799%{_mandir}/man3/overwritemergeconfiguration.hpp.3elektra*
800%{_mandir}/man3/modules.cpp.3elektra*
801%{_mandir}/man3/modules.hpp.3elektra*
802%{_mandir}/man3/plugin.cpp.3elektra*
803%{_mandir}/man3/plugin.hpp.3elektra*
804%{_mandir}/man3/plugindatabase.cpp.3elektra*
805%{_mandir}/man3/plugindatabase.hpp.3elektra*
806%{_mandir}/man3/plugins.cpp.3elektra*
807%{_mandir}/man3/plugins.hpp.3elektra*
808%{_mandir}/man3/pluginspec.cpp.3elektra*
809%{_mandir}/man3/pluginspec.hpp.3elektra*
810%{_mandir}/man3/specreader.hpp.3elektra*
811%{_mandir}/man3/src_backend.cpp.3elektra*
812%{_mandir}/man3/testtool_*.cpp.3elektra*
813%{_mandir}/man3/threewaymerge.cpp.3elektra*
814%{_mandir}/man3/threewaymerge.hpp.3elektra*
815%{_mandir}/man3/toolexcept.hpp.3elektra*
816
817%if %{with glib}
818%files glib
819%defattr(644,root,root,755)
820%doc src/bindings/glib/README.md
821%attr(755,root,root) %{_libdir}/libgelektra-4.0.so
822%if %{with gsettings}
823%attr(755,root,root) %{_libdir}/gio/modules/libelektrasettings.so
824%endif
825%{_libdir}/girepository-1.0/GElektra-4.0.typelib
826
827%files glib-devel
828%defattr(644,root,root,755)
829%{_datadir}/gir-1.0/GElektra-4.0.gir
830%{_includedir}/elektra/gelektra-*.h
831%{_pkgconfigdir}/gelektra-4.0.pc
832%endif
833
834%if %{with java}
835%files -n java-elektra
836%defattr(644,root,root,755)
837%doc src/bindings/jna/README.md
838%{_javadir}/libelektra-1.jar
839%{_javadir}/libelektra.jar
840%endif
841
842%if %{with lua}
843%files -n lua-elektra
844%defattr(644,root,root,755)
845%doc src/bindings/swig/lua/README.md
846%attr(755,root,root) %{_libdir}/lua/5.2/kdb.so
847
848%if %{with glib}
849%files -n lua-elektra-glib
850%defattr(644,root,root,755)
851%doc src/bindings/gi/lua/README.md
852%dir %{_datadir}/lua/5.2/lgi
853%dir %{_datadir}/lua/5.2/lgi/override
854%{_datadir}/lua/5.2/lgi/override/GElektra.lua
855%endif
856%endif
857
858%if %{with python2}
859%files -n python-elektra
860%defattr(644,root,root,755)
861%doc src/bindings/swig/python2/README.md
862%attr(755,root,root) %{py_sitedir}/_kdb.so
863%{py_sitedir}/kdb.py[co]
864%endif
865
866%if %{with python3}
867%files -n python3-elektra
868%defattr(644,root,root,755)
869%doc src/bindings/swig/python/README.md
870%attr(755,root,root) %{py3_sitedir}/_kdb.so
871%{py3_sitedir}/kdb.py
872%{py3_sitedir}/__pycache__/kdb.cpython-*.py[co]
873
874%if %{with glib}
875%files -n python3-elektra-glib
876%defattr(644,root,root,755)
877%doc src/bindings/gi/python/README.md
878%{py3_sitedir}/gi/overrides/GElektra.py
879%{py3_sitedir}/gi/overrides/__pycache__/GElektra.cpython-*.py[co]
880%endif
881%endif
882
883%if %{with ruby}
884%files -n ruby-elektra
885%defattr(644,root,root,755)
886%doc src/bindings/swig/ruby/README.md
887%attr(755,root,root) %{ruby_vendorarchdir}/_kdb.so
888%{ruby_vendorlibdir}/kdb.rb
889%endif
This page took 0.039039 seconds and 4 git commands to generate.