]> git.pld-linux.org Git - packages/ekiga.git/commitdiff
- fix build with libnotify 0.7
authorlisu <lisu@pld-linux.org>
Thu, 7 Apr 2011 11:25:45 +0000 (11:25 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ekiga-libnotify.patch -> 1.1
    ekiga.spec -> 1.48

ekiga-libnotify.patch [new file with mode: 0644]
ekiga.spec

diff --git a/ekiga-libnotify.patch b/ekiga-libnotify.patch
new file mode 100644 (file)
index 0000000..226d8dd
--- /dev/null
@@ -0,0 +1,30 @@
+--- ekiga-3.2.7/lib/engine/components/libnotify/libnotify-main.cpp~    2010-05-30 23:58:01.000000000 +0200
++++ ekiga-3.2.7/lib/engine/components/libnotify/libnotify-main.cpp     2011-04-07 13:22:56.466190747 +0200
+@@ -158,7 +158,11 @@
+   notif = notify_notification_new (notification->get_title ().c_str (),
+                                  notification->get_body ().c_str (),
+-                                 urgency, NULL);
++                                 urgency
++#if !defined(NOTIFY_VERSION_MINOR) || (NOTIFY_VERSION_MAJOR == 0 && NOTIFY_VERSION_MINOR < 7)
++                                 , NULL
++#endif
++                                 );
+   g_signal_connect (notif, "closed",
+                   G_CALLBACK (on_notif_closed), notification.get ());
+--- ekiga-3.2.7/src/gui/main.cpp~      2010-05-30 23:58:01.000000000 +0200
++++ ekiga-3.2.7/src/gui/main.cpp       2011-04-07 13:23:45.542858431 +0200
+@@ -2820,7 +2820,11 @@
+   body = g_strdup_printf ("%s\n%s\n%s", uri, app, account);
+   
+-  notify = notify_notification_new (title, body, GM_ICON_LOGO, NULL);
++  notify = notify_notification_new (title, body, GM_ICON_LOGO
++#if !defined(NOTIFY_VERSION_MINOR) || (NOTIFY_VERSION_MAJOR == 0 && NOTIFY_VERSION_MINOR < 7)
++                , NULL
++#endif
++                );
+   notify_notification_add_action (notify, "accept", _("Accept"), notify_action_cb, mw, NULL);
+   notify_notification_add_action (notify, "reject", _("Reject"), notify_action_cb, mw, NULL);
+   notify_notification_set_timeout (notify, NOTIFY_EXPIRES_NEVER);
index 0ef1911242ad463ec325e6c53b0f10f2d49088c5..66c751b01b7f897ebfad38a82f53dd19bcbad4cb 100644 (file)
@@ -8,6 +8,7 @@ Group:          Applications/Communications
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/ekiga/3.2/%{name}-%{version}.tar.gz
 # Source0-md5: bdc787550c4cf5acf873788f5ea153ba
 Patch0:                %{name}-shell.patch
+Patch1:                %{name}-libnotify.patch
 URL:           http://www.ekiga.org/
 BuildRequires: GConf2-devel >= 2.14.0
 BuildRequires: SDL-devel
@@ -70,6 +71,7 @@ obrazem. Ekiga była poprzednio znana jako GnomeMeeting.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 sed -i -e 's|Categories=GNOME;GTK;Network;Telephony;|Categories=GTK;GNOME;Network;InstantMessaging;|' ekiga.desktop.in.in
 
 %build
This page took 0.06603 seconds and 4 git commands to generate.