]> git.pld-linux.org Git - packages/ekiga.git/commitdiff
- updated to 3.9.90
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 16 Oct 2012 21:35:24 +0000 (23:35 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 16 Oct 2012 21:35:24 +0000 (23:35 +0200)
ekiga-gcc47.patch [deleted file]
ekiga-libnotify.patch [deleted file]
ekiga.spec
format-security.patch [new file with mode: 0644]

diff --git a/ekiga-gcc47.patch b/ekiga-gcc47.patch
deleted file mode 100644 (file)
index 64232cd..0000000
+++ /dev/null
@@ -1,91 +0,0 @@
-diff --git a/lib/engine/account/bank-impl.h b/lib/engine/account/bank-impl.h
-index e16848e..b0a8775 100644
---- a/lib/engine/account/bank-impl.h
-+++ b/lib/engine/account/bank-impl.h
-@@ -203,7 +203,7 @@ template<typename AccountType>
- void
- Ekiga::BankImpl<AccountType>::add_account (boost::shared_ptr<AccountType> account)
- {
--  add_object (account);
-+  this->add_object (account);
-   account->questions.connect (boost::ref (questions));
- }
-@@ -213,7 +213,7 @@ template<typename AccountType>
- void
- Ekiga::BankImpl<AccountType>::remove_account (boost::shared_ptr<AccountType> account)
- {
--  remove_object (account);
-+  this->remove_object (account);
- }
- #endif
-diff --git a/lib/engine/addressbook/book-impl.h b/lib/engine/addressbook/book-impl.h
-index 711d8d9..4fea7d5 100644
---- a/lib/engine/addressbook/book-impl.h
-+++ b/lib/engine/addressbook/book-impl.h
-@@ -204,7 +204,7 @@ void
- Ekiga::BookImpl<ContactType>::add_contact (gmref_ptr<ContactType> contact)
- {
-   contact->questions.add_handler (questions.make_slot ());
--  add_object (contact);
-+  this->add_object (contact);
- }
-@@ -212,7 +212,7 @@ template<typename ContactType>
- void
- Ekiga::BookImpl<ContactType>::remove_contact (gmref_ptr<ContactType> contact)
- {
--  remove_object (contact);
-+  this->remove_object (contact);
- }
- #endif
-diff --git a/lib/engine/addressbook/source-impl.h b/lib/engine/addressbook/source-impl.h
-index a30cd03..630236f 100644
---- a/lib/engine/addressbook/source-impl.h
-+++ b/lib/engine/addressbook/source-impl.h
-@@ -206,7 +206,7 @@ template<typename BookType>
- void
- Ekiga::SourceImpl<BookType>::add_book (boost::shared_ptr<BookType> book)
- {
--  add_object (book);
-+  this->add_object (book);
-   add_connection (book, book->contact_added.connect (boost::bind (boost::ref (contact_added), book, _1)));
-diff --git a/lib/engine/presence/cluster-impl.h b/lib/engine/presence/cluster-impl.h
-index 245a7c6..92074a8 100644
---- a/lib/engine/presence/cluster-impl.h
-+++ b/lib/engine/presence/cluster-impl.h
-@@ -147,7 +147,7 @@ Ekiga::ClusterImpl<HeapType>::add_heap (boost::shared_ptr<HeapType> heap)
-   add_connection (heap, heap->questions.connect (boost::ref (questions)));
--  add_object (heap);
-+  this->add_object (heap);
- }
- template<typename HeapType>
-diff --git a/lib/engine/presence/heap-impl.h b/lib/engine/presence/heap-impl.h
-index d63c491..15fe86f 100644
---- a/lib/engine/presence/heap-impl.h
-+++ b/lib/engine/presence/heap-impl.h
-@@ -160,14 +160,14 @@ Ekiga::HeapImpl<PresentityType>::add_presentity (boost::shared_ptr<PresentityTyp
- {
-   presentity->questions.add_handler (questions.make_slot ());
--  add_object (presentity);
-+  this->add_object (presentity);
- }
- template<typename PresentityType>
- void
- Ekiga::HeapImpl<PresentityType>::remove_presentity (gmref_ptr<PresentityType> presentity)
- {
--  remove_object (presentity);
-+  this->remove_object (presentity);
- }
- #endif
diff --git a/ekiga-libnotify.patch b/ekiga-libnotify.patch
deleted file mode 100644 (file)
index b8b73f9..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
---- ekiga-3.2.7/lib/engine/components/libnotify/libnotify-main.cpp~    2010-05-30 23:58:01.000000000 +0200
-+++ ekiga-3.2.7/lib/engine/components/libnotify/libnotify-main.cpp     2011-04-07 13:22:56.466190747 +0200
-@@ -158,7 +158,11 @@
-   notif = notify_notification_new (notification->get_title ().c_str (),
-                                  notification->get_body ().c_str (),
--                                 urgency, NULL);
-+                                 urgency
-+#if !defined(NOTIFY_VERSION_MINOR) || (NOTIFY_VERSION_MAJOR == 0 && NOTIFY_VERSION_MINOR < 7)
-+                                 , NULL
-+#endif
-+                                 );
-   g_signal_connect (notif, "closed",
-                   G_CALLBACK (on_notif_closed), notification.get ());
---- ekiga-3.2.7/src/gui/main.cpp~      2010-05-30 23:58:01.000000000 +0200
-+++ ekiga-3.2.7/src/gui/main.cpp       2011-04-07 13:33:09.966210734 +0200
-@@ -2820,12 +2820,18 @@
-   body = g_strdup_printf ("%s\n%s\n%s", uri, app, account);
-   
--  notify = notify_notification_new (title, body, GM_ICON_LOGO, NULL);
-+  notify = notify_notification_new (title, body, GM_ICON_LOGO
-+#if !defined(NOTIFY_VERSION_MINOR) || (NOTIFY_VERSION_MAJOR == 0 && NOTIFY_VERSION_MINOR < 7)
-+                , NULL
-+#endif
-+                );
-   notify_notification_add_action (notify, "accept", _("Accept"), notify_action_cb, mw, NULL);
-   notify_notification_add_action (notify, "reject", _("Reject"), notify_action_cb, mw, NULL);
-   notify_notification_set_timeout (notify, NOTIFY_EXPIRES_NEVER);
-   notify_notification_set_urgency (notify, NOTIFY_URGENCY_CRITICAL);
-+#if !defined(NOTIFY_VERSION_MINOR) || (NOTIFY_VERSION_MAJOR == 0 && NOTIFY_VERSION_MINOR < 7)
-   notify_notification_attach_to_status_icon (notify, statusicon);
-+#endif
-   if (!notify_notification_show (notify, NULL)) {
-     ekiga_main_window_incoming_call_dialog_show (mw, call);
-   }
index b86b0fa5885a6cf38eeded5700f1aaba7b6b8201..9a83b491740db3b289eea6cee425a2662573dd60 100644 (file)
@@ -6,15 +6,14 @@
 Summary:       SIP and H.323 Videoconferencing
 Summary(pl.UTF-8):     Program do telekonferencji w standardzie SIP oraz H.323
 Name:          ekiga
-Version:       3.2.7
-Release:       9
+Version:       3.9.90
+Release:       1
 License:       GPL
 Group:         Applications/Communications
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/ekiga/3.2/%{name}-%{version}.tar.gz
-# Source0-md5: bdc787550c4cf5acf873788f5ea153ba
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/ekiga/3.9/%{name}-%{version}.tar.xz
+# Source0-md5: 800be31eef542e06307691c59942595a
 Patch0:                %{name}-shell.patch
-Patch1:                %{name}-libnotify.patch
-Patch2:                %{name}-gcc47.patch
+Patch1:                format-security.patch
 URL:           http://www.ekiga.org/
 BuildRequires: GConf2-devel >= 2.14.0
 BuildRequires: SDL-devel
@@ -34,10 +33,10 @@ BuildRequires:      libgnomeui-devel >= 2.14.0
 BuildRequires: libselinux-devel
 BuildRequires: libsigc++-devel
 BuildRequires: libtool
-BuildRequires: opal-devel >= 3.4.2
+BuildRequires: opal-devel >= 3.10.7
 BuildRequires: openldap-devel >= 2.4.6
 BuildRequires: pkgconfig
-BuildRequires: ptlib-devel >= 1:2.8.3
+BuildRequires: ptlib-devel >= 1:2.10.7
 BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper
 BuildRequires: speex-devel
@@ -78,14 +77,13 @@ obrazem. Ekiga była poprzednio znana jako GnomeMeeting.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 sed -i -e 's|Categories=GNOME;GTK;Network;Telephony;|Categories=GTK;GNOME;Network;InstantMessaging;|' ekiga.desktop.in.in
 
 %build
 %{__gnome_doc_common}
 %{__libtoolize}
 %{__intltoolize}
-%{__aclocal}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -124,7 +122,15 @@ rm -rf $RPM_BUILD_ROOT
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README TODO FAQ
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/ekiga
+%attr(755,root,root) %{_bindir}/ekiga-config-tool
+%attr(755,root,root) %{_bindir}/ekiga-helper
+%dir %{_libdir}/%{name}
+%dir %{_libdir}/%{name}/%{version}
+%dir %{_libdir}/%{name}/%{version}/plugins
+%attr(755,root,root) %{_libdir}/%{name}/%{version}/libekiga.so
+%attr(755,root,root) %{_libdir}/%{name}/%{version}/plugins/libgmevolution.so
+%attr(755,root,root) %{_libdir}/%{name}/%{version}/plugins/libgmldap.so
 %{_pixmapsdir}/*
 %{_desktopdir}/*.desktop
 %{_datadir}/dbus-1/services/*.service
@@ -132,4 +138,4 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/sounds/%{name}
 %{_iconsdir}/hicolor/*/*/ekiga.png
 %{_sysconfdir}/gconf/schemas/*
-%{_mandir}/*/*
+%{_mandir}/man1/ekiga.1*
diff --git a/format-security.patch b/format-security.patch
new file mode 100644 (file)
index 0000000..fdc0e80
--- /dev/null
@@ -0,0 +1,11 @@
+--- /home/users/baggins/devel/PLD/rpm/BUILD/ekiga-3.9.90/lib/engine/gui/gtk-frontend/call-window.cpp~  2012-08-21 18:27:35.000000000 +0200
++++ /home/users/baggins/devel/PLD/rpm/BUILD/ekiga-3.9.90/lib/engine/gui/gtk-frontend/call-window.cpp   2012-10-16 23:05:50.198165887 +0200
+@@ -1573,7 +1573,7 @@
+     msg = g_strdup_printf (_("A:%.1f/%.1f V:%.1f/%.1f FPS:%d/%d"),
+                            ta, ra, tv, rv, tfps, rfps);
+-  gm_statusbar_push_message (GM_STATUSBAR (cw->priv->statusbar), msg);
++  gm_statusbar_push_message (GM_STATUSBAR (cw->priv->statusbar), "%s", msg);
+   g_free (msg);
+ }
This page took 0.083472 seconds and 4 git commands to generate.