]> git.pld-linux.org Git - packages/ekg2.git/commitdiff
- fixed building with yesterday_snapshot
authorSławomir Paszkiewicz <paszczus@pld-linux.org>
Thu, 17 Jul 2008 09:00:39 +0000 (09:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added new plugins: feed, jogger, polchat
- default using sqlite3 instead of sqlite
- changes made by Adam Mikuta <adammikuta (at) gmail (dot) com>, thanks

Changed files:
    ekg2.spec -> 1.86

ekg2.spec

index f36f1cdddbaee91e2155090f20ed56d4c5eb102c..1b9f2b30c08121667981aeb3d29147407531c01c 100644 (file)
--- a/ekg2.spec
+++ b/ekg2.spec
@@ -3,6 +3,7 @@
 %bcond_with    yesterday_snapshot      # Build most current ekg2 snapshot
                                        # (must use ./builder -n5 or plain rpmbuild)
 %bcond_without aspell                  # build without spell-checking support with aspell
+%bcond_without feed                    # don't build feed plugin
 %bcond_without gadugadu                # don't build gg plugin
 %bcond_without gpg                     # don't build gpg plugin
 %bcond_without gtk                     # don't build gtk plugin
@@ -12,8 +13,8 @@
 %bcond_without perl                    # don't build Perl plugin
 %bcond_without python                  # don't build Python plugin
 %bcond_without readline                # don't build readline interface
-%bcond_without sqlite                  # don't build logsqlite plugin based on sqlite (conflicts with sqlite3)
-%bcond_with    sqlite3                 # build logsqlite plugin based on sqlite3
+%bcond_with    sqlite                  # build logsqlite plugin based on sqlite (conflicts with sqlite3)
+%bcond_without sqlite3                 # don't build logsqlite plugin based on sqlite3
 %bcond_without xosd                    # don't build xosd plugin
 
 %if %{with yesterday_snapshot}
 %undefine with_gnutls
 %endif
 
-%if %{with sqlite3}
-%undefine sqlite
+%if %{with sqlite}
+%undefine sqlite3
 %endif
 
 Summary:       Multi-protocol instant messaging and chat client
 Summary(pl.UTF-8):     Wieloprotokołowy komunikator internetowy
 Name:          ekg2
 Version:       %{_ver}
-Release:       3.1
+Release:       3.2
 Epoch:         2
 License:       GPL v2+
 Group:         Applications/Communications
@@ -48,7 +49,9 @@ URL:          http://ekg2.org/
 %{?with_aspell:BuildRequires:  aspell-devel}
 BuildRequires: autoconf
 BuildRequires: automake
-%{?with_jabber:BuildRequires:  expat-devel}
+%if %{with feed} || %{with jabber}
+BuildRequires: expat-devel
+%endif
 BuildRequires: gettext-devel
 %{?with_gadugadu:BuildRequires:        giflib-devel}
 %{?with_gnutls:BuildRequires:  gnutls-devel >= 1.2.5}
@@ -81,6 +84,7 @@ Multi-protocol instant messaging and chat client with many plugins.
 %description -l pl.UTF-8
 Wieloprotokołowy, otwarty komunikator internetowy z wieloma wtyczkami.
 
+%if %{without yesterday_snapshot}
 %package devel
 Summary:       ekg2 header files
 Summary(pl.UTF-8):     Pliki nagłówkowe ekg2
@@ -92,6 +96,21 @@ Header files for ekg2.
 
 %description devel -l pl.UTF-8
 Pliki nagłówkowe ekg2.
+%endif
+
+%if %{with yesterday_snapshot}
+%package plugin-feed
+Summary:       feed plugin for ekg2
+Summary(pl.UTF-8):     Wtyczka feed dla ekg2
+Group:         Applications/Communications
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description plugin-feed
+feed plugin for ekg2.
+
+%description plugin-feed -l pl.UTF-8
+Wtyczka feed dla ekg2.
+%endif
 
 %package plugin-gpg
 Summary:       gpg plugin for ekg2
@@ -130,6 +149,20 @@ Ioctld plugin for ekg2 (contains suid root binary!).
 %description plugin-ioctld -l pl.UTF-8
 Wtyczka ioctld dla ekg2 (zawiera program z ustawionym suid root!).
 
+%if %{with yesterday_snapshot}
+%package plugin-jogger
+Summary:       Jogger plugin for ekg2
+Summary(pl.UTF-8):     Wtyczka jogger dla ekg2
+Group:         Applications/Communications
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description plugin-jogger
+Jogger plugin for ekg2.
+
+%description plugin-jogger -l pl.UTF-8
+Wtyczka jogger dla ekg2.
+%endif
+
 %package plugin-logsqlite
 Summary:       SQLite log plugin for ekg2
 Summary(pl.UTF-8):     Wtyczka logowania do SQLite dla ekg2
@@ -195,6 +228,20 @@ Jabber protocol plugin for ekg2.
 %description plugin-protocol-jabber -l pl.UTF-8
 Wtyczka protokołu Jabber dla ekg2.
 
+%if %{with yesterday_snapshot}
+%package plugin-protocol-polchat
+Summary:       Polchat protocol plugin for ekg2
+Summary(pl.UTF-8):     Wtyczka protokołu polchat dla ekg2
+Group:         Applications/Communications
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description plugin-protocol-polchat
+Polchat protocol plugin for ekg2.
+
+%description plugin-protocol-polchat -l pl.UTF-8
+Wtyczka protokołu polchat dla ekg2.
+%endif
+
 %package plugin-readline
 Summary:       readline interface
 Summary(pl.UTF-8):     Interfejs readline
@@ -283,7 +330,11 @@ CFLAGS="%{rpmcflags} -D_GNU_SOURCE"
        %{!?with_gpg:--without-gpg} \
        --with%{!?with_gtk:out}-gtk \
        --with%{!?with_gnutls:out}-libgnutls \
-       --with%{!?with_jabber:out}-expat \
+%if %{with feed} || %{with jabber}
+        --with-expat \
+%else
+        --without-expat \
+%endif
        --with%{!?with_libgsm:out}-libgsm \
        %{!?with_perl:--without-perl} \
        --with%{!?with_python:out}-python \
@@ -340,10 +391,18 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/%{name}/scripts
 %{_datadir}/%{name}/themes
 
+%if %{without yesterday_snapshot}
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/ekg2-config
 %{_includedir}/ekg2
+%endif
+
+%if %{with yesterday_snapshot}
+%files plugin-feed
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/plugins/feed.so
+%endif
 
 %if %{with gpg}
 %files plugin-gpg
@@ -363,6 +422,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/plugins/ioctld
 %attr(4755,root,root) %{_libexecdir}/ioctld
 
+%if %{with yesterday_snapshot}
+%files plugin-jogger
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/plugins/jogger.so
+%endif
+
 %if %{with sqlite} || %{with sqlite3}
 %files plugin-logsqlite
 %defattr(644,root,root,755)
@@ -393,6 +458,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/%{name}/plugins/jabber
 %endif
 
+%if %{with yesterday_snapshot}
+%files plugin-protocol-polchat
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/plugins/polchat.so
+%endif
+
 %if %{with readline}
 %files plugin-readline
 %defattr(644,root,root,755)
This page took 0.097924 seconds and 4 git commands to generate.