]> git.pld-linux.org Git - packages/ekg.git/commitdiff
- added giflib patch (update for giflib 5.1.x) auto/th/ekg-1.7-14
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 13 Dec 2015 14:29:36 +0000 (15:29 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 13 Dec 2015 14:29:36 +0000 (15:29 +0100)
- release 14

ekg-giflib.patch [new file with mode: 0644]
ekg.spec

diff --git a/ekg-giflib.patch b/ekg-giflib.patch
new file mode 100644 (file)
index 0000000..c2b13c7
--- /dev/null
@@ -0,0 +1,46 @@
+--- ekg-1.7/src/events.c.orig  2015-12-13 14:29:18.771043146 +0100
++++ ekg-1.7/src/events.c       2015-12-13 14:50:21.057656839 +0100
+@@ -1529,6 +1529,7 @@
+       ColorMapObject *pal;
+ #endif
+       int fd;
++      int giferror;
+       fd = open(fname, O_RDONLY);
+       if (fd == -1) {
+@@ -1536,9 +1537,8 @@
+               goto err;
+       }
+-      if (!(file = DGifOpenFileHandle(fd))) {
+-              snprintf(errbuf, sizeof(errbuf), "DGifOpenFileHandle(): %d", 
+-                  GifLastError());
++      if (!(file = DGifOpenFileHandle(fd, &giferror))) {
++              snprintf(errbuf, sizeof(errbuf), "DGifOpenFileHandle(): %d", giferror);
+               goto err2;
+       }
+@@ -1548,7 +1548,7 @@
+       }
+       if (DGifSlurp(file) != GIF_OK) {
+-              snprintf(errbuf, sizeof(errbuf), "DGifSlurp(): %d", GifLastError());
++              snprintf(errbuf, sizeof(errbuf), "DGifSlurp(): %d", file->Error);
+               goto err3;
+       }
+@@ -1576,12 +1576,12 @@
+       token->data = (unsigned char *) xmalloc(token->sx * token->sy);
+       memcpy(token->data, file->SavedImages[0].RasterBits, token->sx * token->sy);
+-      DGifCloseFile(file);
++      DGifCloseFile(file, NULL);
+       return 0;
+ err3:
+-      DGifCloseFile(file);
++      DGifCloseFile(file, NULL);
+ err2:
+       close(fd);
+ err:
index cdf609be2a7a415688783ef3a0352d3099b16e77..4422461e4d1cc3348d225d68a91d5f3b73208237 100644 (file)
--- a/ekg.spec
+++ b/ekg.spec
@@ -14,7 +14,7 @@ Summary(it.UTF-8):    Un cliente compatibile con Gadu-Gadu
 Summary(pl.UTF-8):     Klient kompatybilny z Gadu-Gadu
 Name:          ekg
 Version:       1.7
-Release:       13
+Release:       14
 Epoch:         4
 License:       GPL v2
 Group:         Applications/Communications
@@ -24,11 +24,13 @@ Source1:    %{name}.conf
 Patch0:                %{name}-LDFLAGS.patch
 Patch1:                %{name}-lock_reason.patch
 Patch2:                %{name}-external_libgadu.patch
+Patch3:                %{name}-giflib.patch
 URL:           http://ekg.chmurka.net/
 BuildRequires: %{_bindir}/perl
 %{?with_aspell:BuildRequires:  aspell-devel}
 BuildRequires: autoconf
 BuildRequires: automake
+BuildRequires: giflib-devel >= 5.1
 BuildRequires: libgadu-devel >= 4:1.7.0
 %{?with_voip:BuildRequires:    libgsm-devel}
 BuildRequires: libjpeg-devel
@@ -97,6 +99,7 @@ polsku (jednak komendy są w języku angielskim).
 %patch1 -p1
 %endif
 %patch2 -p0
+%patch3 -p1
 
 %build
 %{__aclocal} -I m4
This page took 0.074037 seconds and 4 git commands to generate.